PluginProbe
User Access Manager / 0.8.0.2
User Access Manager v0.8.0.2
2.3.20 2.3.19 2.3.18 2.3.17 2.3.16 2.3.15 2.3.14 2.3.13 trunk 0.6 0.6.1 0.6.2 0.7 0.7 Beta 0.7.0.1 0.8 0.8.0.1 0.8.0.2 0.9 0.9.1 0.9.1.1 0.9.1.2 0.9.1.3 0.9.1.4 1.0 All 136 releases
← All changes | readme.txt +47 -506 2.3.200.8.0.2 View file →
@@ -1,62 +1,50 @@
1 1 === User Access Manager ===
2 2 Contributors: GM_Alex
3 3 Donate link: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=1947052
4 -Tags: member access, user access manager, user management, access
5 -Requires at least: 4.7
6 -Requires PHP: 8.0
7 -Tested up to: 7.1
8 -Stable tag: 2.3.20
9 -License: GPLv2 or later
10 -License URI: https://www.gnu.org/licenses/gpl-2.0.html
4 +Tags: admin, access, member area, members, page, pages, post, posts, private, privacy, restrict, user, user access manager, user management
5 +Requires at least: 2.6
6 +Tested up to: 2.7.1
7 +Stable tag: 0.8.0.2
11 8
12 9 With the "User Access Manager"-plugin you can manage the access to your posts, pages and files.
13 10
14 11 == Description ==
15 12
16 -The “User Access Manager”-plugin for WordPress allows you to manage the access of your content. This is useful if you need a member area, a private section at your blog, or you want that other people can write at your blog but not everywhere. Including all post type (post, pages etc.), taxonomies (categories etc.) and files by creating user groups. Just assign the content you want to restrict und and your registered users which should have access to a group. From now on the content is only accessible and writable for the specified group.
13 +With the "User Access Manager"-plugin you can manage the access to your posts, pages and files. You only create a user group, put registered users to this and set up the rights for this group. From now on the post/page is only accessible and writable for the specified group. This plugin is useful if you need a member area or a private section at your blog or you want that other people can write at your blog but not everywhere.
17 14
18 -<em>Try it out</em>
19 -
20 -You can try it out at TasteWP.com before install: [Try user access manager](https://demo.tastewp.com/user-access-manager?a=jlQ7F1va) (affiliate link)
21 -
22 15 <em>Feature list</em>
23 16
24 17 * User groups
25 -* Set separate access for readers and editors
18 +* Set seperate access for readers and editors
26 19 * Set access by user groups
27 -* Set default user groups
28 -* Set time based access
29 -* User-defined post type (posts, pages etc.) title (if no access)
30 -* User-defined post type (posts, pages etc.) text (if no access)
31 -* Optional login form (if no access)
20 +* Set access by post categories
21 +* User-defined post/page title (if no access)
22 +* User-defined post/page text (if no access)
32 23 * User-defined comment text (if no access)
33 -* Hide complete post types (posts, pages etc.)
34 -* Hide elements in the navigation
24 +* Hide complete post/page
25 +* Hide pages in navigation
35 26 * Redirecting users to other pages (if no access)
36 -* Recursive locking of content
27 +* Recursive locking of posts/pages
37 28 * Limited access to uploaded files
38 29 * Full integrated at the admin panel
39 -* Multilingual support
40 -* Also protect your rss feeds
41 -* Give access by IP-address
42 -* Plugin-Api to use the User Access Manager in your on plugins or extend other plugins
43 -* [UAMPPE](https://wordpress.org/plugins/user-access-manager-private-public-extension/) like behaviour is now build in (Expect negation like !groupName and showprivate and shownotauthorized parameter)
30 +* Multilanguage support
31 +* Also proteced your rss feeds
44 32
45 33 <em>Included languages</em>
46 34
47 -See [https://translate.wordpress.org/projects/wp-plugins/user-access-manager](https://translate.wordpress.org/projects/wp-plugins/user-access-manager)
35 +* English
36 +* German
37 +* Czech, base on 0.7.0.1. Thanks to Huska
38 +* French, thanks to macbidule
48 39
49 -The documentation can be found here: [https://github.com/GM-Alex/user-access-manager/wiki](https://github.com/GM-Alex/user-access-manager/wiki)
50 -Please report bugs and feature requests here: [https://github.com/GM-Alex/user-access-manager/issues](https://github.com/GM-Alex/user-access-manager/issues)
51 -If you are a developer and want to contribute please visit [https://github.com/GM-Alex/user-access-manager](https://github.com/GM-Alex/user-access-manager)
52 -For general questions, like how to set up, best practice and so on please use the support thread here (don't post issues here): [https://wordpress.org/support/plugin/user-access-manager](https://wordpress.org/support/plugin/user-access-manager)
53 -To stay up-to-date follow me on Twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
40 +<strong>Note</strong>: At this release you can replace one core files, because I need some hooks which are not created by the Wordpress-Team for the better integration. I've send them a diff patch and this will add in Wordpress 2.8, so you can trust this modification (see <a href="http://trac.wordpress.org/changeset/10292">http://trac.wordpress.org/changeset/10292</a>). <strong>This core modification is not needed and only optional, but it gives you more comfort.</strong>
54 41
55 -
42 +For a German description visit my page at [GMAlex](http://www.gm-alex.de/projects/wordpress/plugins/user-access-manager/ "GMAlex - deviant design and development"). If you have any problem, suggestions or make a translation please [contact me](mailto:alexanderschneider85@googlemail.com).
56 43 == Installation ==
57 -
44 +
58 45 1. Upload the full directory, with the folder, into your wp-content/plugins directory
46 +1. Replace the following files in the wp-admin dir with the files at 'core_files' or use the patches: 'includes/template.php'
59 47 1. Activate the plugin through the 'Plugins' menu in WordPress
60 48 1. Enjoy
61 49
62 50
@@ -63,492 +51,45 @@
63 51 == Changelog ==
64 52
65 53 Here you found the changes in each version.
66 54
67 - Version Date Changes
68 -
69 - 2.3.20 2026/09/09 Fix the queries failing on MariaDB 12.3, which turned to_date into a reserved word
70 - Quote the table and column names in all queries
71 - Fix the database update to version 1.0, which failed and left the group assignments unmigrated
72 - Migrate the user and role assignments in that update instead of dropping them with their tables
73 -
74 - 2.3.19 2026/08/14 Fix a reflected cross site scripting issue in the backend request parameters
75 - Fix locked documents answering with a 404 page instead of the no rights page
76 -
77 - 2.3.18 2026/08/03 Fix the missing preview images of protected documents like PDFs in the media library
78 - Rework the backend forms and the group assignment UI
79 - Fix the assignment time being discarded for users and roles added by the group search
80 - Escape the names shown in the group search results
81 -
82 - 2.3.17 2026/07/31 Fix a fatal type error in the switch_to_blog wrapper during the multisite database update
83 - 2.3.16 2026/07/27 Improve performance by loading the object assignments of all user groups with one query
84 - Improve performance by loading all user groups with one query instead of one per group
85 - Fix the never executed database update of the user group table id column
86 - Fix a fatal error on rest requests for hidden objects. Thanks to Erwan Le Rousseau (WPScan)
87 - Do not derive the admin panel context from the referer header anymore
88 - Fix an unauthenticated arbitrary file read through path traversal in the file delivery
89 -
90 - 2.3.15 2026/07/22 Fix REST API bypass for clients without an admin referer, like the official WordPress app
91 - Deny REST write requests to objects the user has no access to
92 - Deny REST requests for revisions and autosaves of restricted objects
93 - Add option to append the requested URL as "redirect_to" parameter to the redirect
94 -
95 - 2.3.14 2026/07/21 Fix REST API content restriction bypass exposing restricted posts to unauthenticated users
96 - Add "Redirect to origin" option
97 -
98 - 2.3.13 2026/07/10 Improve performance
99 - Fix security issue CVE-2026-15281
100 -
101 - 2.3.12 2026/05/20 Fix deprecation warning
102 - Add redis cache provider, improve nginx file handling and fix author access. Thanks to Erik Franzén
103 -
104 - 2.3.11 2026/01/23 Improve performance
105 - Improve styling
106 -
107 - 2.3.10 2026/01/22 Fix other possible type error
108 -
109 - 2.3.9 2026/01/19 Fix possible type error
110 -
111 - 2.3.8 2025/12/12 Adjust logic wp cli command logic to prevent errors
112 -
113 - 2.3.7 2025/12/10 Fix issue with MapPress
114 -
115 - 2.3.6 2025/12/10 Improve type compatibility again...
116 -
117 - 2.3.5 2025/12/10 Improve type compatibility again...
118 -
119 - 2.3.4 2025/12/09 Improve type compatibility again
120 -
121 - 2.3.3 2025/12/09 Improve compatibility again
122 -
123 - 2.3.2 2025/12/09 Adjust wordpress wrapper
124 -
125 - 2.3.1 2025/12/09 Fix possible type error
126 -
127 - 2.3.0 2025/12/09 Require now PHP 8.0
128 - Remove strftime
129 - Fix some issues
130 -
131 - 2.2.25 2025/04/22 Fixed problem with fix load_textdomain
132 -
133 - 2.2.24 2025/04/17 Fix deprecated warnings
134 - Fixed problem with load_textdomain Thanks to Christian Ludwig (chludwig)
135 -
136 - 2.2.23 2023/05/26 Fix typos
137 - Fix version_compare
138 -
139 - 2.2.22 2023/05/26 Minor change
140 -
141 - 2.2.21 2023/05/25 Adjust database compatibility #368
142 -
143 - 2.2.20 2023/03/08 Fix warning
144 -
145 - 2.2.19 2022/11/18 Add try out link
146 -
147 - 2.2.18 2022/11/14 Fix issue with label id. Thanks to elbakkali
148 - Add elementor support. Thanks to JboyJW
149 - Fix possible issue with PHP 8. Thanks to ollycross
150 - Fix attachment issue.
151 - Fix tags issue.
152 - Make extra IP header configurable.
153 -
154 - 2.2.17 2022/02/15 Fix issue with big picture handling. #350
155 -
156 - 2.2.16 2022/01/25 Check compatibility for WordPress 5.9.
157 -
158 - 2.2.15 2021/06/07 Fix possible type issues.
159 -
160 - 2.2.14 2021/04/21 Fix bulk edit.
161 - Fix permission issue.
162 - Fix redirect typing issue.
163 -
164 - 2.2.13 2021/04/15 Fix not logged-in user handling.
165 - Type fix for showEditLink.
166 -
167 - 2.2.12 2021/04/14 Fix warning.
168 - Fix jquery deprecation warning.
169 -
170 - 2.2.11 2021/03/15 Type fix for showEditLink.
171 - Set compatibility tag for WordPress 5.7.
172 -
173 - 2.2.10 2021/02/26 Lower minimum php version to 7.2.
174 -
175 - 2.2.9 2021/02/24 Type fixes for Yoast SEO plugin.
176 - Fix some other type issues.
177 -
178 - 2.2.8 2021/02/21 Some cleanup.
179 - Type fixes for the short controller.
180 - Fix some possible php notices and warnings.
181 -
182 - 2.2.7 2021/02/14 Fix issue with isAdmin.
183 -
184 - 2.2.6 2021/02/14 Fix more possible type errors.
185 -
186 - 2.2.5 2021/02/14 Fix more possible type errors if WordPress switches int to string.
187 -
188 - 2.2.4 2021/02/13 Fix type error for user object controller.
189 - Fix type error for the WordPress wrapper.
190 -
191 - 2.2.3 2021/02/13 Fix warning at settings page.
192 - Fix type error for user group handler.
193 -
194 - 2.2.2 2021/02/13 Fix type error with login form.
195 -
196 - 2.2.1 2021/02/13 Fix type error with registeredTaxonomy.
197 -
198 - 2.2.0 2021/02/11 Improve and update code base.
199 - Fix possible update bug.
200 -
201 - 2.1.12 2019/01/08 Fix multi-site file handling issue. #222
202 -
203 - 2.1.11 2018/03/16 Fix missing got_mod_rewrite function. #212
204 - Fix wrong media urls. #207
205 - Fix wrong post counts at the admin panel.
206 - Improve database updates/repairs.
207 -
208 -
209 - 2.1.10 2017/12/15 Fix Posts removed from WP_Query results in Ajax requests for unprivileged users #176
210 - Improve partly download handler
211 - Suppress errors on file delivery
212 - Improve error handling
213 - Change blog switch handling. fixes #194
214 - Fix wrong parameter name. fixes #191
215 - Improve user group sorting. closes #180
216 - Add new redirect type to the login page. closes #155
217 - Add dynamic user groups for exclude object calculation. closes #181
218 - Add filter for getUserUserGroupsForObjectAccess. closes #157
219 - Make it possible to set a default group for new media files.
220 -
221 - 2.1.9 2017/11/18 Add show content before <!--more--> tag option for all post types
222 - Fix js time input issue
223 - Fix small prepare query issue
224 - Don't switch to edit mode after user group creation #171
225 - Add sortable columns for user groups list #172
226 - Show no access image again instead of broken image
227 - Fix double user group form for media files
228 - Add option to hide the edit page option if the user doesn't have the right to edit this page #174
229 -
230 - 2.1.8 2017/11/07 Add getter for the user group handler fixes #160
231 - Fix multi-site file handling issue #159
232 -
233 - 2.1.7 2017/11/01 Improve database update prompt fixes #153
234 - Fix user group selection not saved when adding a new user issue fixes #154
235 - Add none read access option for user groups closes #144
236 - Extend file settings
237 - Add xsendfile support
238 -
239 - 2.1.6 2017/10/20 Fix "Inherited group membership for media attachments" issue #133
240 - Fix traits strict warning #145
241 -
242 - 2.1.5 2017/10/12 Refactor traits
243 - Fix datetime issue with not supported browsers
244 -
245 - 2.1.4 2017/10/10 Fix strict warnings #134
246 - Fix "Unable to select default user group for both page and post" issue #126
247 - Add NGINX reverse proxy handling #117
248 - Improve code
249 - Fix bulk edit issue #135
250 - Fix array filly issue #138
251 - Add database repair tool
252 -
253 - 2.1.3 2017/09/18 Possible fix for custom post types / taxonomies issues
254 - Fix .htaccess deletion issue
255 -
256 - 2.1.2 2017/09/17 Fix issue with not handled taxonomies #123
257 -
258 - 2.1.1 2017/09/16 Fix issue for users with small innodb page size #121
259 -
260 - 2.1.0 2017/09/15 Refactor code
261 - Implement content tags for partly restriction like UAMPPE #84
262 - Add default user groups
263 - Add time based access
264 - Add dynamic user groups #64
265 - Implement caching #75
266 - Allow html as no access content #63 #93
267 - Optimize settings screen #61
268 - Support of partial download #118
269 - Add option to toggle visibility of assigned groups text next to the edit link #111
270 - Fix incorrectly retrieving of an ID for attachments/media #116
271 -
272 - 2.0.13 2017/07/26 Add ipv6 support - Fix issue #97
273 - Change "Hide Comments" logic - Fix issue #100
274 - Fix rewrite base issue - Fix issue #107 and #103
275 - Fix vsprintf warning - Fix issue #105
276 - Fix Relevanssi compatibility issue
277 - Fix missing feature picture if file locking is disabled
278 -
279 - 2.0.12 2017/06/16 Fix media file group issue #74
280 - Fix broken file includes / excludes
281 - Fix WordPress filter issue
282 - Fix access to own post #95
283 -
284 - 2.0.11 2017/05/18 Fix FrontendController::postsPreQuery() expected to be a reference, value given error
285 -
286 - 2.0.10 2017/05/17 Fix issue of not saved groups #74
287 - Adjust password lost link #79
288 - Improve attachment access checks #78
289 - Fix not working redirect
290 -
291 - 2.0.9 2017/05/13 Improve security #76
292 -
293 - 2.0.8 2017/05/08 Fix missing rss feed if protection is disabled #68
294 -
295 - 2.0.7 2017/05/07 Fix category tree issues #59
296 - Fix mysql database errors on strict mode #60
297 - Fix possible path issue
298 - Remove settings for post_format post type (which is used for internal propose)
299 - Fix wrong database update prompt
300 - Fix issue with asgaros from #66
301 -
302 - 2.0.6 2017/04/28 Improve http error codes #24
303 - Fix wrong url on Windows servers #53
304 - Fix missing install routine #51
305 -
306 - 2.0.5 2017/04/27 Fix switch_to_blog issue
307 - Fix file handling issues
308 -
309 - 2.0.4 2017/04/26 Adjust code so that php version is checked before throwing a fatal error
310 - Improve login form #26
311 - Fix soliloquy slider incompatibility #31
312 - Improve performance #41
313 -
314 - 2.0.3 2017/04/25 Fix compatibility issue with CMS Tree Page View plugin #37
315 - Fix compatibility issue with SEO Redirection plugin #38
316 - Fix Error thrown: Class 'WP_Site_Query' not found issue #36
317 -
318 - 2.0.2 2017/04/24 Fix wp_get_current_user() error #34
319 - Fix custom post save issue after database update #33
320 -
321 - 2.0.1 2017/04/23 Fix dbDelta issue on activation
322 -
323 - 2.0.0 2017/04/23 Refactoring of the module
324 - Improve performance
325 - Full support for custom post and taxonomies.
326 - Use translate.wordpress.org for translations
327 - Many improvements and fixes
328 -
329 - 1.2.14 2017/01/07 Fix IP access issue.
330 - Some small optimization.
331 -
332 - 1.2.13 2017/01/04 Fix tag count issue.
333 -
334 - 1.2.12 2017/01/03 Fix tag issue.
335 - Improve usability of the setup page.
336 -
337 - 1.2.11 2017/01/02 Restore hide categories behaviour.
338 -
339 - 1.2.10 2017/01/02 Improve mysql query to prevent against possible collations issue.
340 -
341 - 1.2.9 2017/01/01 Fix wrong category count.
342 - Hide pages without access at the administration panel.
343 - Fix redirect problems.
344 -
345 - 1.2.8 2016/12/31 Fix wrong term behavior for the backend.
346 - Require at least PHP 5.3
347 -
348 - 1.2.7.6 2016/12/28 Fix ip restriction issue.
349 - Fix missing categories issue.
350 -
351 - 1.2.7.5 2016/12/27 Improve taxonomy handling.
352 - Improve performance.
353 - Add missing wp-cli.php file.
354 - Refactor config handling.
355 - Fix Yoast SEO Plugin issue.
356 - Some other small fixes.
357 -
358 - 1.2.7.4 2016/12/08 Fix some issues related to WordPress 4.7
359 -
360 - 1.2.7.3 2016/12/08 Fix empty category issue.
361 -
362 - 1.2.7.2 2016/12/07 Hot fix for WordPress 4.7
363 -
364 - 1.2.7.1 2016/12/04 Remove deprecated function get_currentuserinfo
365 -
366 - 1.2.7.0 2016/11/30 Add experimental nginx support
367 - Fix redirect issue (Thanks to Laurence Shaw for the hint and James Riordon for the fix)
368 -
369 - 1.2.6.10 2016/10/07 Again a security fix
370 -
371 - 1.2.6.9 2016/10/06 Security fix
372 -
373 - 1.2.6.8 2016/08/15 Security fix
374 - Add Yoast SEO Plugin filter. Thanks to Christian Werner
375 -
376 - 1.2.6.7 2016/03/17 Security fix
377 -
378 - 1.2.6.6 2015/03/09 Hide UAM at the backend from normal users.
379 - Change IP range logic. Thanks to Takanashi
380 - Fix issue with roles.
381 -
382 - 1.2.6.5 2015/03/02 Fix install/update missing table issue.
383 -
384 - 1.2.6.4 2015/02/26 Fix database update issue.
385 -
386 - 1.2.6.3 2015/02/25 Fix database update for multi sites.
387 - Fix array_keys warning.
388 - Fix redirect loop.
389 -
390 - 1.2.6.2 2015/02/24 Fix not removable role affiliation issue.
391 -
392 - 1.2.6.1 2015/02/24 Remove deprecated php function mysql_get_server_info().
393 - Change object_id from varchar 11 to varchar 255.
394 - Fix backslashes issue.
395 -
396 - 1.2.6.0 2015/02/11 Remove unnecessary js library.
397 - Merge changes from https://github.com/nwoetzel/user-access-manager. Thanks for contribution.
398 -
399 - 1.2.5.0 2013/12/13 Improve performance. Thanks to all testers.
400 - Add bulk edit feature.
401 -
402 - 1.2.4.3 2013/05/08 Fix redirect if page is hidden and permalink is active issue.
403 - Fix no access issue.
404 -
405 - 1.2.4.2 2013/05/08 Fix pagination issue. Thanks to arjenbreur.
406 - Fix comment issue. Thanks to jpr105.
407 - Redirect if post/page is hidden and permalink is active.
408 - Change icon.
409 -
410 - 1.2.4.1 2013/05/06 Fix broken images issue.
411 - Fix duplicated key issue.
412 - Filter file types.
413 - Use WordPress mime types instead of the config array.
414 -
415 - 1.2.4 2013/05/01 Fix add column issue.
416 - Fix install bug.
417 - Fix error if no user is logged in. Thanks to Robert Egger and akiko.pusu.
418 - Fix media file issue.
419 - Optimize code.
420 -
421 - 1.2.3.1 2013/05/01 Fix terms issue.
422 -
423 - 1.2.3 2013/04/30 Fix Fatal 'error: Call-time pass-by-reference' error.
424 - Fix 'get_userdata() is not defined' error. Thanks to ranwaldo.
425 - Refactor many variable names to fit new coding style.
426 -
427 - 1.2.2 2011/04/03 Speed improvements.
428 - Fix get_term bug.
429 - Fix category bug
55 + Version Date Changes
430 56
431 - 1.2.1 2011/10/11 Fix uninstall bug.
432 - Add capability 'manage_user_groups'. Thanks to Tim Okrongli
433 - Some small improvements.
57 + 0.8.0.2 2009/03/09 Add French language file
58 + Delete .htaccess files on deactivation/uninstall
434 59
435 - 1.2 2011/06/19 Add custom post types.
436 - Fix CSRF issue. Thanks to Luke Crouch
60 + 0.8.0.1 2009/03/06 Small fix
437 61
438 - 1.1.4 2010/10/19 Fix error on custom post types
439 - Add warning for PHP version lower than 5.0
62 + 0.8 2009/03/05 Add write access control
63 + Add support down to 2.6
64 + Better file access control
65 + Code optimization - Plugin became faster
66 + Fix the category bug
67 + Small fixes
440 68
441 - 1.1.3 2010/10/09 Add tag filter
442 - Fix media file bug for multisites
443 - Fix ip access bug
444 - Improve redirecting code
445 - Speed up
69 + 0.7.0.1 2009/02/13 Small fixes
446 70
447 - 1.1.2 2010/10/04 Fix read/write access bug
448 - Add recursive looking for posts page option
449 - Improve network activation/update
450 - Add hooks for login bar
451 - Prepare for NextGEN Gallery extension
71 + 0.7 2009/02/13 Fix: All known Bugs of the beta
72 + Add ajax for more comfort
73 + Add language support
452 74
453 - 1.1.1.2 2010/09/29 Fix bug that an usergroup for a user wasn't saved
75 + 0.7 Beta 2009/01/05 Fix: Problems with media at posts
76 + Fix: Many other small fixes
77 + Only support up to Wordpress 2.7
78 + Better integration
454 79
455 - 1.1.1.1 2010/09/29 Fix T_DNUMBER bug
80 + 0.62 2008/12/18 Fix: Fatal error: Only variables can
81 + be passed by reference. Thanks to David Thompson
456 82
457 - 1.1.1 2010/09/29 Fix custom menu bug
458 - Fix quick edit bug
459 - Fix undefined object bug
460 - Extend admin hint
461 -
462 - 1.1 2010/09/28 Add plugin api
463 - Optimized code
464 - Improve content filtering
465 - Fix bug that user groups can't be removed from element
466 - Fix empty category bug
467 - Fix pre/next post bug
468 - Fix login form bug
469 - Fix redirect bug
470 - Fix some other small bugs
471 -
472 - 1.0.2 2010/07/24 Remove debugging code
473 - Fix file download bug
474 -
475 - 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
476 - Fix bug for recursive locking for categories
477 -
478 - 1.0 2010/07/22 Fix array_merge bug at media page
479 - Reorder some admin options
480 - Add some new admin functions
481 - Speed it up
482 - Disable file locking by default
483 -
484 - 1.0 Beta 2 2010/07/13 Fix performance issues
485 - Fix media gallery issues
486 - Fix category bug
487 - Fix not loaded translation
488 - Remove some unused functions
489 -
490 - 1.0 Beta 2010/07/09 Complete rewrite
491 - Some new options to improve the functions
492 -
493 - 0.9.1.4 2010/06/23 Hotfix for WordPress 3.0
494 -
495 - 0.9.1.3 2009/07/17 Fix "header already send"-Problem with WordPress 2.8.1
496 - Add option to set level with full access
497 -
498 - 0.9.1.2 2009/03/29 Fix some path problems
499 - Add a reset function
500 - Rename menu at admin panel
501 -
502 - 0.9.1.1 2009/03/26 Fix the empty category issue
503 -
504 - 0.9.1 2009/03/26 Fix the database problem
505 - Fix feed bug. Thanks to Markus Brinkmann
506 - Fix wrong javascript path
507 -
508 - 0.9 2009/03/24 Add login form
509 - Add option to show text bevor <!--more--> tag
510 - Fix write access issues
511 - Fix file issues
512 - Small fixes
513 -
514 - 0.8.0.2 2009/03/09 Add French language file
515 - Delete .htaccess files on deactivation/uninstall
516 -
517 - 0.8.0.1 2009/03/06 Small fix
518 -
519 - 0.8 2009/03/05 Add write access control
520 - Add support down to 2.6
521 - Better file access control
522 - Code optimization - Plugin became faster
523 - Fix the category bug
524 - Small fixes
525 -
526 - 0.7.0.1 2009/02/13 Small fixes
83 + 0.61 2008/12/17 Fix: Wrong file id in Media Library.
527 84
528 - 0.7 2009/02/13 Fix: All known Bugs of the beta
529 - Add ajax for more comfort
530 - Add language support
531 -
532 - 0.7 Beta 2009/01/05 Fix: Problems with media at posts
533 - Fix: Many other small fixes
534 - Only support up to WordPress 2.7
535 - Better integration
536 -
537 - 0.62 2008/12/18 Fix: Fatal error: Only variables can
538 - be passed by reference. Thanks to David Thompson
85 + 0.6 2007/12/14 First release.
539 86
540 - 0.61 2008/12/17 Fix: Wrong file id in Media Library
541 87
542 - 0.6 2007/12/14 First release.
543 88
544 89
545 -== Frequently Asked Questions ==
546 90
547 -See: [https://github.com/GM-Alex/user-access-manager/wiki/FAQ](https://github.com/GM-Alex/user-access-manager/wiki/FAQ)
548 -
549 91 == Screenshots ==
550 92
551 -1. The group manager.
552 -2. The setting screen
553 -3. The setup screen.
554 -4. Integration into post overview.
93 +1. The group manger.
94 +2. The setting screen.
95 +3. Integration at posts.