PluginProbe
User Access Manager / 1.1.1
User Access Manager v1.1.1
2.3.20 2.3.19 2.3.18 2.3.17 2.3.16 2.3.15 2.3.14 2.3.13 trunk 0.6 0.6.1 0.6.2 0.7 0.7 Beta 0.7.0.1 0.8 0.8.0.1 0.8.0.2 0.9 0.9.1 0.9.1.1 0.9.1.2 0.9.1.3 0.9.1.4 1.0 All 136 releases
← All changes | readme.txt +120 -457 2.3.13 → 1.1.1 View file →
@@ -1,61 +1,54 @@
1 1 === User Access Manager ===
2 2 Contributors: GM_Alex
3 3 Donate link: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=1947052
4 -Tags: member access, user access manager, user management, access
5 -Requires at least: 4.7
6 -Requires PHP: 8.0
7 -Tested up to: 7.0
8 -Stable tag: 2.3.13
9 -License: GPLv2 or later
10 -License URI: https://www.gnu.org/licenses/gpl-2.0.html
4 +Tags: admin, access, member area, members, member, member access, page, pages, post, posts, private, privacy, restrict, user, user access manager, user management
5 +Requires at least: 3.0
6 +Tested up to: 3.0
7 +Stable tag: 1.1.1
11 8
12 9 With the "User Access Manager"-plugin you can manage the access to your posts, pages and files.
13 10
14 11 == Description ==
15 12
16 -The “User Access Manager”-plugin for WordPress allows you to manage the access of your content. This is useful if you need a member area, a private section at your blog, or you want that other people can write at your blog but not everywhere. Including all post type (post, pages etc.), taxonomies (categories etc.) and files by creating user groups. Just assign the content you want to restrict und and your registered users which should have access to a group. From now on the content is only accessible and writable for the specified group.
13 +With the "User Access Manager"-plugin you can manage the access to your posts, pages and files. You only create a user group, put registered users to this and set up the rights for this group. From now on the post/page is only accessible and writable for the specified group. This plugin is useful if you need a member area or a private section at your blog or you want that other people can write at your blog but not everywhere.
17 14
18 -<em>Try it out</em>
15 +Appeal: If it works click the "Works" button, if it don't works click the "Broken" button and [send me an error report](mailto:[email protected]). That is the only way to find bugs and see if the plugin works proper. Thanks.
19 16
20 -You can try it out at TasteWP.com before install: [Try user access manager](https://demo.tastewp.com/user-access-manager?a=jlQ7F1va) (affiliate link)
21 -
22 17 <em>Feature list</em>
23 18
24 19 * User groups
25 -* Set separate access for readers and editors
20 +* Set seperate access for readers and editors
26 21 * Set access by user groups
27 -* Set default user groups
28 -* Set time based access
29 -* User-defined post type (posts, pages etc.) title (if no access)
30 -* User-defined post type (posts, pages etc.) text (if no access)
22 +* Set access by post categories
23 +* User-defined post/page title (if no access)
24 +* User-defined post/page text (if no access)
31 25 * Optional login form (if no access)
32 26 * User-defined comment text (if no access)
33 -* Hide complete post types (posts, pages etc.)
34 -* Hide elements in the navigation
27 +* Hide complete post/page
28 +* Hide pages in navigation
35 29 * Redirecting users to other pages (if no access)
36 -* Recursive locking of content
30 +* Recursive locking of posts/pages
37 31 * Limited access to uploaded files
38 32 * Full integrated at the admin panel
39 -* Multilingual support
40 -* Also protect your rss feeds
33 +* Multilanguage support
34 +* Also proteced your rss feeds
41 35 * Give access by IP-address
42 36 * Plugin-Api to use the User Access Manager in your on plugins or extend other plugins
43 -* [UAMPPE](https://wordpress.org/plugins/user-access-manager-private-public-extension/) like behaviour is now build in (Expect negation like !groupName and showprivate and shownotauthorized parameter)
44 37
45 38 <em>Included languages</em>
46 39
47 -See [https://translate.wordpress.org/projects/wp-plugins/user-access-manager](https://translate.wordpress.org/projects/wp-plugins/user-access-manager)
40 +* English
41 +* German
42 +* Czech, based on 0.7.0.1. Thanks to Huska
43 +* French, based on 0.8.0.2. Thanks to macbidule
44 +* Hungary, based on 1.0.2. Thanks to Zina
48 45
49 -The documentation can be found here: [https://github.com/GM-Alex/user-access-manager/wiki](https://github.com/GM-Alex/user-access-manager/wiki)
50 -Please report bugs and feature requests here: [https://github.com/GM-Alex/user-access-manager/issues](https://github.com/GM-Alex/user-access-manager/issues)
51 -If you are a developer and want to contribute please visit [https://github.com/GM-Alex/user-access-manager](https://github.com/GM-Alex/user-access-manager)
52 -For general questions, like how to set up, best practice and so on please use the support thread here (don't post issues here): [https://wordpress.org/support/plugin/user-access-manager](https://wordpress.org/support/plugin/user-access-manager)
53 -To stay up-to-date follow me on Twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
46 +For a German description visit my page at [GMAlex](http://www.gm-alex.de/projects/wordpress/plugins/user-access-manager/ "GMAlex - deviant design and development"). If you have any problem, suggestions or make a translation please [contact me](mailto:[email protected]). To stay up-to-date follow me on twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
54 47
55 48
56 49 == Installation ==
57 -
50 +
58 51 1. Upload the full directory, with the folder, into your wp-content/plugins directory
59 52 1. Activate the plugin through the 'Plugins' menu in WordPress
60 53 1. Enjoy
61 54
@@ -63,463 +56,133 @@
63 56 == Changelog ==
64 57
65 58 Here you found the changes in each version.
66 59
67 - Version Date Changes
68 -
69 - 2.3.13 2026/07/10 Improve performance
70 - Fix security issue CVE-2026-15281
71 -
72 - 2.3.12 2026/05/20 Fix deprecation warning
73 - Add redis cache provider, improve nginx file handling and fix author access. Thanks to Erik Franzén
74 -
75 - 2.3.11 2026/01/23 Improve performance
76 - Improve styling
77 -
78 - 2.3.10 2026/01/22 Fix other possible type error
79 -
80 - 2.3.9 2026/01/19 Fix possible type error
81 -
82 - 2.3.8 2025/12/12 Adjust logic wp cli command logic to prevent errors
83 -
84 - 2.3.7 2025/12/10 Fix issue with MapPress
85 -
86 - 2.3.6 2025/12/10 Improve type compatibility again...
87 -
88 - 2.3.5 2025/12/10 Improve type compatibility again...
89 -
90 - 2.3.4 2025/12/09 Improve type compatibility again
91 -
92 - 2.3.3 2025/12/09 Improve compatibility again
93 -
94 - 2.3.2 2025/12/09 Adjust wordpress wrapper
95 -
96 - 2.3.1 2025/12/09 Fix possible type error
97 -
98 - 2.3.0 2025/12/09 Require now PHP 8.0
99 - Remove strftime
100 - Fix some issues
101 -
102 - 2.2.25 2025/04/22 Fixed problem with fix load_textdomain
103 -
104 - 2.2.24 2025/04/17 Fix deprecated warnings
105 - Fixed problem with load_textdomain Thanks to Christian Ludwig (chludwig)
106 -
107 - 2.2.23 2023/05/26 Fix typos
108 - Fix version_compare
109 -
110 - 2.2.22 2023/05/26 Minor change
111 -
112 - 2.2.21 2023/05/25 Adjust database compatibility #368
113 -
114 - 2.2.20 2023/03/08 Fix warning
115 -
116 - 2.2.19 2022/11/18 Add try out link
117 -
118 - 2.2.18 2022/11/14 Fix issue with label id. Thanks to elbakkali
119 - Add elementor support. Thanks to JboyJW
120 - Fix possible issue with PHP 8. Thanks to ollycross
121 - Fix attachment issue.
122 - Fix tags issue.
123 - Make extra IP header configurable.
124 -
125 - 2.2.17 2022/02/15 Fix issue with big picture handling. #350
126 -
127 - 2.2.16 2022/01/25 Check compatibility for WordPress 5.9.
128 -
129 - 2.2.15 2021/06/07 Fix possible type issues.
130 -
131 - 2.2.14 2021/04/21 Fix bulk edit.
132 - Fix permission issue.
133 - Fix redirect typing issue.
134 -
135 - 2.2.13 2021/04/15 Fix not logged-in user handling.
136 - Type fix for showEditLink.
137 -
138 - 2.2.12 2021/04/14 Fix warning.
139 - Fix jquery deprecation warning.
140 -
141 - 2.2.11 2021/03/15 Type fix for showEditLink.
142 - Set compatibility tag for WordPress 5.7.
143 -
144 - 2.2.10 2021/02/26 Lower minimum php version to 7.2.
145 -
146 - 2.2.9 2021/02/24 Type fixes for Yoast SEO plugin.
147 - Fix some other type issues.
148 -
149 - 2.2.8 2021/02/21 Some cleanup.
150 - Type fixes for the short controller.
151 - Fix some possible php notices and warnings.
152 -
153 - 2.2.7 2021/02/14 Fix issue with isAdmin.
154 -
155 - 2.2.6 2021/02/14 Fix more possible type errors.
156 -
157 - 2.2.5 2021/02/14 Fix more possible type errors if WordPress switches int to string.
158 -
159 - 2.2.4 2021/02/13 Fix type error for user object controller.
160 - Fix type error for the WordPress wrapper.
161 -
162 - 2.2.3 2021/02/13 Fix warning at settings page.
163 - Fix type error for user group handler.
164 -
165 - 2.2.2 2021/02/13 Fix type error with login form.
166 -
167 - 2.2.1 2021/02/13 Fix type error with registeredTaxonomy.
168 -
169 - 2.2.0 2021/02/11 Improve and update code base.
170 - Fix possible update bug.
171 -
172 - 2.1.12 2019/01/08 Fix multi-site file handling issue. #222
173 -
174 - 2.1.11 2018/03/16 Fix missing got_mod_rewrite function. #212
175 - Fix wrong media urls. #207
176 - Fix wrong post counts at the admin panel.
177 - Improve database updates/repairs.
178 -
179 -
180 - 2.1.10 2017/12/15 Fix Posts removed from WP_Query results in Ajax requests for unprivileged users #176
181 - Improve partly download handler
182 - Suppress errors on file delivery
183 - Improve error handling
184 - Change blog switch handling. fixes #194
185 - Fix wrong parameter name. fixes #191
186 - Improve user group sorting. closes #180
187 - Add new redirect type to the login page. closes #155
188 - Add dynamic user groups for exclude object calculation. closes #181
189 - Add filter for getUserUserGroupsForObjectAccess. closes #157
190 - Make it possible to set a default group for new media files.
191 -
192 - 2.1.9 2017/11/18 Add show content before <!--more--> tag option for all post types
193 - Fix js time input issue
194 - Fix small prepare query issue
195 - Don't switch to edit mode after user group creation #171
196 - Add sortable columns for user groups list #172
197 - Show no access image again instead of broken image
198 - Fix double user group form for media files
199 - Add option to hide the edit page option if the user doesn't have the right to edit this page #174
200 -
201 - 2.1.8 2017/11/07 Add getter for the user group handler fixes #160
202 - Fix multi-site file handling issue #159
203 -
204 - 2.1.7 2017/11/01 Improve database update prompt fixes #153
205 - Fix user group selection not saved when adding a new user issue fixes #154
206 - Add none read access option for user groups closes #144
207 - Extend file settings
208 - Add xsendfile support
209 -
210 - 2.1.6 2017/10/20 Fix "Inherited group membership for media attachments" issue #133
211 - Fix traits strict warning #145
212 -
213 - 2.1.5 2017/10/12 Refactor traits
214 - Fix datetime issue with not supported browsers
215 -
216 - 2.1.4 2017/10/10 Fix strict warnings #134
217 - Fix "Unable to select default user group for both page and post" issue #126
218 - Add NGINX reverse proxy handling #117
219 - Improve code
220 - Fix bulk edit issue #135
221 - Fix array filly issue #138
222 - Add database repair tool
223 -
224 - 2.1.3 2017/09/18 Possible fix for custom post types / taxonomies issues
225 - Fix .htaccess deletion issue
226 -
227 - 2.1.2 2017/09/17 Fix issue with not handled taxonomies #123
228 -
229 - 2.1.1 2017/09/16 Fix issue for users with small innodb page size #121
230 -
231 - 2.1.0 2017/09/15 Refactor code
232 - Implement content tags for partly restriction like UAMPPE #84
233 - Add default user groups
234 - Add time based access
235 - Add dynamic user groups #64
236 - Implement caching #75
237 - Allow html as no access content #63 #93
238 - Optimize settings screen #61
239 - Support of partial download #118
240 - Add option to toggle visibility of assigned groups text next to the edit link #111
241 - Fix incorrectly retrieving of an ID for attachments/media #116
242 -
243 - 2.0.13 2017/07/26 Add ipv6 support - Fix issue #97
244 - Change "Hide Comments" logic - Fix issue #100
245 - Fix rewrite base issue - Fix issue #107 and #103
246 - Fix vsprintf warning - Fix issue #105
247 - Fix Relevanssi compatibility issue
248 - Fix missing feature picture if file locking is disabled
249 -
250 - 2.0.12 2017/06/16 Fix media file group issue #74
251 - Fix broken file includes / excludes
252 - Fix WordPress filter issue
253 - Fix access to own post #95
254 -
255 - 2.0.11 2017/05/18 Fix FrontendController::postsPreQuery() expected to be a reference, value given error
256 -
257 - 2.0.10 2017/05/17 Fix issue of not saved groups #74
258 - Adjust password lost link #79
259 - Improve attachment access checks #78
260 - Fix not working redirect
261 -
262 - 2.0.9 2017/05/13 Improve security #76
263 -
264 - 2.0.8 2017/05/08 Fix missing rss feed if protection is disabled #68
265 -
266 - 2.0.7 2017/05/07 Fix category tree issues #59
267 - Fix mysql database errors on strict mode #60
268 - Fix possible path issue
269 - Remove settings for post_format post type (which is used for internal propose)
270 - Fix wrong database update prompt
271 - Fix issue with asgaros from #66
272 -
273 - 2.0.6 2017/04/28 Improve http error codes #24
274 - Fix wrong url on Windows servers #53
275 - Fix missing install routine #51
276 -
277 - 2.0.5 2017/04/27 Fix switch_to_blog issue
278 - Fix file handling issues
279 -
280 - 2.0.4 2017/04/26 Adjust code so that php version is checked before throwing a fatal error
281 - Improve login form #26
282 - Fix soliloquy slider incompatibility #31
283 - Improve performance #41
284 -
285 - 2.0.3 2017/04/25 Fix compatibility issue with CMS Tree Page View plugin #37
286 - Fix compatibility issue with SEO Redirection plugin #38
287 - Fix Error thrown: Class 'WP_Site_Query' not found issue #36
288 -
289 - 2.0.2 2017/04/24 Fix wp_get_current_user() error #34
290 - Fix custom post save issue after database update #33
291 -
292 - 2.0.1 2017/04/23 Fix dbDelta issue on activation
293 -
294 - 2.0.0 2017/04/23 Refactoring of the module
295 - Improve performance
296 - Full support for custom post and taxonomies.
297 - Use translate.wordpress.org for translations
298 - Many improvements and fixes
299 -
300 - 1.2.14 2017/01/07 Fix IP access issue.
301 - Some small optimization.
302 -
303 - 1.2.13 2017/01/04 Fix tag count issue.
304 -
305 - 1.2.12 2017/01/03 Fix tag issue.
306 - Improve usability of the setup page.
307 -
308 - 1.2.11 2017/01/02 Restore hide categories behaviour.
309 -
310 - 1.2.10 2017/01/02 Improve mysql query to prevent against possible collations issue.
311 -
312 - 1.2.9 2017/01/01 Fix wrong category count.
313 - Hide pages without access at the administration panel.
314 - Fix redirect problems.
315 -
316 - 1.2.8 2016/12/31 Fix wrong term behavior for the backend.
317 - Require at least PHP 5.3
318 -
319 - 1.2.7.6 2016/12/28 Fix ip restriction issue.
320 - Fix missing categories issue.
321 -
322 - 1.2.7.5 2016/12/27 Improve taxonomy handling.
323 - Improve performance.
324 - Add missing wp-cli.php file.
325 - Refactor config handling.
326 - Fix Yoast SEO Plugin issue.
327 - Some other small fixes.
328 -
329 - 1.2.7.4 2016/12/08 Fix some issues related to WordPress 4.7
330 -
331 - 1.2.7.3 2016/12/08 Fix empty category issue.
332 -
333 - 1.2.7.2 2016/12/07 Hot fix for WordPress 4.7
334 -
335 - 1.2.7.1 2016/12/04 Remove deprecated function get_currentuserinfo
336 -
337 - 1.2.7.0 2016/11/30 Add experimental nginx support
338 - Fix redirect issue (Thanks to Laurence Shaw for the hint and James Riordon for the fix)
339 -
340 - 1.2.6.10 2016/10/07 Again a security fix
341 -
342 - 1.2.6.9 2016/10/06 Security fix
343 -
344 - 1.2.6.8 2016/08/15 Security fix
345 - Add Yoast SEO Plugin filter. Thanks to Christian Werner
346 -
347 - 1.2.6.7 2016/03/17 Security fix
348 -
349 - 1.2.6.6 2015/03/09 Hide UAM at the backend from normal users.
350 - Change IP range logic. Thanks to Takanashi
351 - Fix issue with roles.
352 -
353 - 1.2.6.5 2015/03/02 Fix install/update missing table issue.
354 -
355 - 1.2.6.4 2015/02/26 Fix database update issue.
356 -
357 - 1.2.6.3 2015/02/25 Fix database update for multi sites.
358 - Fix array_keys warning.
359 - Fix redirect loop.
360 -
361 - 1.2.6.2 2015/02/24 Fix not removable role affiliation issue.
362 -
363 - 1.2.6.1 2015/02/24 Remove deprecated php function mysql_get_server_info().
364 - Change object_id from varchar 11 to varchar 255.
365 - Fix backslashes issue.
366 -
367 - 1.2.6.0 2015/02/11 Remove unnecessary js library.
368 - Merge changes from https://github.com/nwoetzel/user-access-manager. Thanks for contribution.
369 -
370 - 1.2.5.0 2013/12/13 Improve performance. Thanks to all testers.
371 - Add bulk edit feature.
372 -
373 - 1.2.4.3 2013/05/08 Fix redirect if page is hidden and permalink is active issue.
374 - Fix no access issue.
375 -
376 - 1.2.4.2 2013/05/08 Fix pagination issue. Thanks to arjenbreur.
377 - Fix comment issue. Thanks to jpr105.
378 - Redirect if post/page is hidden and permalink is active.
379 - Change icon.
380 -
381 - 1.2.4.1 2013/05/06 Fix broken images issue.
382 - Fix duplicated key issue.
383 - Filter file types.
384 - Use WordPress mime types instead of the config array.
385 -
386 - 1.2.4 2013/05/01 Fix add column issue.
387 - Fix install bug.
388 - Fix error if no user is logged in. Thanks to Robert Egger and akiko.pusu.
389 - Fix media file issue.
390 - Optimize code.
391 -
392 - 1.2.3.1 2013/05/01 Fix terms issue.
393 -
394 - 1.2.3 2013/04/30 Fix Fatal 'error: Call-time pass-by-reference' error.
395 - Fix 'get_userdata() is not defined' error. Thanks to ranwaldo.
396 - Refactor many variable names to fit new coding style.
397 -
398 - 1.2.2 2011/04/03 Speed improvements.
399 - Fix get_term bug.
400 - Fix category bug
60 + Version Date Changes
401 61
402 - 1.2.1 2011/10/11 Fix uninstall bug.
403 - Add capability 'manage_user_groups'. Thanks to Tim Okrongli
404 - Some small improvements.
405 -
406 - 1.2 2011/06/19 Add custom post types.
407 - Fix CSRF issue. Thanks to Luke Crouch
408 -
409 - 1.1.4 2010/10/19 Fix error on custom post types
410 - Add warning for PHP version lower than 5.0
411 -
412 - 1.1.3 2010/10/09 Add tag filter
413 - Fix media file bug for multisites
414 - Fix ip access bug
415 - Improve redirecting code
416 - Speed up
417 -
418 - 1.1.2 2010/10/04 Fix read/write access bug
419 - Add recursive looking for posts page option
420 - Improve network activation/update
421 - Add hooks for login bar
422 - Prepare for NextGEN Gallery extension
423 -
424 - 1.1.1.2 2010/09/29 Fix bug that an usergroup for a user wasn't saved
425 -
426 - 1.1.1.1 2010/09/29 Fix T_DNUMBER bug
427 -
428 62 1.1.1 2010/09/29 Fix custom menu bug
429 63 Fix quick edit bug
430 64 Fix undefined object bug
431 65 Extend admin hint
432 66
433 - 1.1 2010/09/28 Add plugin api
434 - Optimized code
435 - Improve content filtering
436 - Fix bug that user groups can't be removed from element
437 - Fix empty category bug
438 - Fix pre/next post bug
439 - Fix login form bug
440 - Fix redirect bug
441 - Fix some other small bugs
67 + 1.1 2010/09/28 Add plugin api
68 + Optimized code
69 + Improve content filtering
70 + Fix bug that user groups can't removed from element
71 + Fix empty category bug
72 + Fix pre/next post bug
73 + Fix login form bug
74 + Fix redirect bug
75 + Fix some other small bugs
442 76
443 - 1.0.2 2010/07/24 Remove debugging code
444 - Fix file download bug
77 + 1.0.2 2010/07/24 Remove debugging code
78 + Fix file download bug
445 79
446 - 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
447 - Fix bug for recursive locking for categories
80 + 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
81 + Fix bug for recursive locking for categories
448 82
449 - 1.0 2010/07/22 Fix array_merge bug at media page
450 - Reorder some admin options
451 - Add some new admin functions
452 - Speed it up
453 - Disable file locking by default
83 + 1.0 2010/07/22 Fix array_merge bug at media page
84 + Reorder some admin options
85 + Add some new admin functions
86 + Speed it up
87 + Disable file locking by default
454 88
455 - 1.0 Beta 2 2010/07/13 Fix performance issues
456 - Fix media gallery issues
457 - Fix category bug
458 - Fix not loaded translation
459 - Remove some unused functions
89 + 1.0 Beta 2 2010/07/13 Fix perforance issues
90 + Fix media gallery issues
91 + Fix category bug
92 + Fix not loaded translation
93 + Remove some unused functions
460 94
461 - 1.0 Beta 2010/07/09 Complete rewrite
462 - Some new options to improve the functions
95 + 1.0 Beta 2010/07/09 Complete rewrite
96 + Some new options to improve the functions
463 97
464 - 0.9.1.4 2010/06/23 Hotfix for WordPress 3.0
98 + 0.9.1.4 2010/06/23 Hotfix for Wordpress 3.0
465 99
466 - 0.9.1.3 2009/07/17 Fix "header already send"-Problem with WordPress 2.8.1
467 - Add option to set level with full access
100 + 0.9.1.3 2009/07/17 Fix "header already send"-Problem with Wordpress 2.8.1
101 + Add option to set level with full access
468 102
469 - 0.9.1.2 2009/03/29 Fix some path problems
470 - Add a reset function
471 - Rename menu at admin panel
103 + 0.9.1.2 2009/03/29 Fix some path problems
104 + Add a reset function
105 + Rename menu at admin panel
472 106
473 - 0.9.1.1 2009/03/26 Fix the empty category issue
107 + 0.9.1.1 2009/03/26 Fix the empty category issue
474 108
475 - 0.9.1 2009/03/26 Fix the database problem
476 - Fix feed bug. Thanks to Markus Brinkmann
477 - Fix wrong javascript path
109 + 0.9.1 2009/03/26 Fix the database problem
110 + Fix feed bug. Thanks to Markus Brinkmann
111 + Fix wrong javascript path
478 112
479 - 0.9 2009/03/24 Add login form
480 - Add option to show text bevor <!--more--> tag
481 - Fix write access issues
482 - Fix file issues
483 - Small fixes
113 + 0.9 2009/03/24 Add login form
114 + Add option to show text bevor <!--more--> tag
115 + Fix write access issues
116 + Fix file issues
117 + Small fixes
484 118
485 - 0.8.0.2 2009/03/09 Add French language file
486 - Delete .htaccess files on deactivation/uninstall
119 + 0.8.0.2 2009/03/09 Add French language file
120 + Delete .htaccess files on deactivation/uninstall
487 121
488 - 0.8.0.1 2009/03/06 Small fix
122 + 0.8.0.1 2009/03/06 Small fix
489 123
490 - 0.8 2009/03/05 Add write access control
491 - Add support down to 2.6
492 - Better file access control
493 - Code optimization - Plugin became faster
494 - Fix the category bug
495 - Small fixes
124 + 0.8 2009/03/05 Add write access control
125 + Add support down to 2.6
126 + Better file access control
127 + Code optimization - Plugin became faster
128 + Fix the category bug
129 + Small fixes
496 130
497 - 0.7.0.1 2009/02/13 Small fixes
498 -
499 - 0.7 2009/02/13 Fix: All known Bugs of the beta
500 - Add ajax for more comfort
501 - Add language support
131 + 0.7.0.1 2009/02/13 Small fixes
502 132
503 - 0.7 Beta 2009/01/05 Fix: Problems with media at posts
504 - Fix: Many other small fixes
505 - Only support up to WordPress 2.7
506 - Better integration
133 + 0.7 2009/02/13 Fix: All known Bugs of the beta
134 + Add ajax for more comfort
135 + Add language support
507 136
508 - 0.62 2008/12/18 Fix: Fatal error: Only variables can
509 - be passed by reference. Thanks to David Thompson
137 + 0.7 Beta 2009/01/05 Fix: Problems with media at posts
138 + Fix: Many other small fixes
139 + Only support up to Wordpress 2.7
140 + Better integration
141 +
142 + 0.62 2008/12/18 Fix: Fatal error: Only variables can
143 + be passed by reference. Thanks to David Thompson
144 +
145 + 0.61 2008/12/17 Fix: Wrong file id in Media Library
510 146
511 - 0.61 2008/12/17 Fix: Wrong file id in Media Library
147 + 0.6 2007/12/14 First release.
512 148
513 - 0.6 2007/12/14 First release.
514 149
150 +== Frequently Asked Questions ==
515 151
516 -== Frequently Asked Questions ==
152 +<strong>How works the User Access Manager?</strong>
517 153
518 -See: [https://github.com/GM-Alex/user-access-manager/wiki/FAQ](https://github.com/GM-Alex/user-access-manager/wiki/FAQ)
154 +All posts/pages which are not in a user access group are accessable to all users. Posts/pages can put to groupes by themselfe, categories or recursive (most by pages).
519 155
156 +<strong>How dose "Role affiliation" work?</strong>
157 +
158 +This example will give you an overview:
159 +
160 +- Posts: Post1, Post2
161 +- Users: User1 (admin), User2 (subscriber), User3 (subscriber)
162 +
163 +Groups:
164 +
165 +- Group1: Users: User2, User3 | Posts: Post1 | Role affiliation: subscriber
166 +- Group2: Users: User3 | Posts: Post2 | Role affiliation: -
167 +
168 +Access:
169 +
170 +- Post1: User1 because he is a admin, User2 because he is in the group and a subscriber, User3 he is a subscriber (to this group all subscribers has access!)
171 +- Post2: User1 because he is a admin, User3 because he is in the group (only group members has access because there is no role affiliation!)
172 +
173 +<strong>I get an login box "WP-Files", what can I do?</strong>
174 +
175 +- You can deactivate the file locking at the UAM settings.
176 +- You can replace your media files in your posts. Just delete the old link and insert it again. (A new working link will generated)
177 +
178 +
520 179 == Screenshots ==
521 180
522 -1. The group manager.
523 -2. The setting screen
524 -3. The setup screen.
525 -4. Integration into post overview.
181 +1. The group manger.
182 +2. The setting screen - Part 1.
183 +3. The setting screen - Part 2.
184 +4. The setting screen - Part 3.
185 +5. The setup screen.
186 +6. Integration into post overview.
187 +7. Integration into the post page.
188 +8. Admin hint at the blog frontend.