PluginProbe
User Access Manager / 1.1.1
User Access Manager v1.1.1
2.3.20 2.3.19 2.3.18 2.3.17 2.3.16 2.3.15 2.3.14 2.3.13 trunk 0.6 0.6.1 0.6.2 0.7 0.7 Beta 0.7.0.1 0.8 0.8.0.1 0.8.0.2 0.9 0.9.1 0.9.1.1 0.9.1.2 0.9.1.3 0.9.1.4 1.0 All 136 releases
← All changes | readme.txt +120 -472 2.3.16 → 1.1.1 View file →
@@ -1,61 +1,54 @@
1 1 === User Access Manager ===
2 2 Contributors: GM_Alex
3 3 Donate link: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=1947052
4 -Tags: member access, user access manager, user management, access
5 -Requires at least: 4.7
6 -Requires PHP: 8.0
7 -Tested up to: 7.0
8 -Stable tag: 2.3.16
9 -License: GPLv2 or later
10 -License URI: https://www.gnu.org/licenses/gpl-2.0.html
4 +Tags: admin, access, member area, members, member, member access, page, pages, post, posts, private, privacy, restrict, user, user access manager, user management
5 +Requires at least: 3.0
6 +Tested up to: 3.0
7 +Stable tag: 1.1.1
11 8
12 9 With the "User Access Manager"-plugin you can manage the access to your posts, pages and files.
13 10
14 11 == Description ==
15 12
16 -The “User Access Manager”-plugin for WordPress allows you to manage the access of your content. This is useful if you need a member area, a private section at your blog, or you want that other people can write at your blog but not everywhere. Including all post type (post, pages etc.), taxonomies (categories etc.) and files by creating user groups. Just assign the content you want to restrict und and your registered users which should have access to a group. From now on the content is only accessible and writable for the specified group.
13 +With the "User Access Manager"-plugin you can manage the access to your posts, pages and files. You only create a user group, put registered users to this and set up the rights for this group. From now on the post/page is only accessible and writable for the specified group. This plugin is useful if you need a member area or a private section at your blog or you want that other people can write at your blog but not everywhere.
17 14
18 -<em>Try it out</em>
15 +Appeal: If it works click the "Works" button, if it don't works click the "Broken" button and [send me an error report](mailto:[email protected]). That is the only way to find bugs and see if the plugin works proper. Thanks.
19 16
20 -You can try it out at TasteWP.com before install: [Try user access manager](https://demo.tastewp.com/user-access-manager?a=jlQ7F1va) (affiliate link)
21 -
22 17 <em>Feature list</em>
23 18
24 19 * User groups
25 -* Set separate access for readers and editors
20 +* Set seperate access for readers and editors
26 21 * Set access by user groups
27 -* Set default user groups
28 -* Set time based access
29 -* User-defined post type (posts, pages etc.) title (if no access)
30 -* User-defined post type (posts, pages etc.) text (if no access)
22 +* Set access by post categories
23 +* User-defined post/page title (if no access)
24 +* User-defined post/page text (if no access)
31 25 * Optional login form (if no access)
32 26 * User-defined comment text (if no access)
33 -* Hide complete post types (posts, pages etc.)
34 -* Hide elements in the navigation
27 +* Hide complete post/page
28 +* Hide pages in navigation
35 29 * Redirecting users to other pages (if no access)
36 -* Recursive locking of content
30 +* Recursive locking of posts/pages
37 31 * Limited access to uploaded files
38 32 * Full integrated at the admin panel
39 -* Multilingual support
40 -* Also protect your rss feeds
33 +* Multilanguage support
34 +* Also proteced your rss feeds
41 35 * Give access by IP-address
42 36 * Plugin-Api to use the User Access Manager in your on plugins or extend other plugins
43 -* [UAMPPE](https://wordpress.org/plugins/user-access-manager-private-public-extension/) like behaviour is now build in (Expect negation like !groupName and showprivate and shownotauthorized parameter)
44 37
45 38 <em>Included languages</em>
46 39
47 -See [https://translate.wordpress.org/projects/wp-plugins/user-access-manager](https://translate.wordpress.org/projects/wp-plugins/user-access-manager)
40 +* English
41 +* German
42 +* Czech, based on 0.7.0.1. Thanks to Huska
43 +* French, based on 0.8.0.2. Thanks to macbidule
44 +* Hungary, based on 1.0.2. Thanks to Zina
48 45
49 -The documentation can be found here: [https://github.com/GM-Alex/user-access-manager/wiki](https://github.com/GM-Alex/user-access-manager/wiki)
50 -Please report bugs and feature requests here: [https://github.com/GM-Alex/user-access-manager/issues](https://github.com/GM-Alex/user-access-manager/issues)
51 -If you are a developer and want to contribute please visit [https://github.com/GM-Alex/user-access-manager](https://github.com/GM-Alex/user-access-manager)
52 -For general questions, like how to set up, best practice and so on please use the support thread here (don't post issues here): [https://wordpress.org/support/plugin/user-access-manager](https://wordpress.org/support/plugin/user-access-manager)
53 -To stay up-to-date follow me on Twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
46 +For a German description visit my page at [GMAlex](http://www.gm-alex.de/projects/wordpress/plugins/user-access-manager/ "GMAlex - deviant design and development"). If you have any problem, suggestions or make a translation please [contact me](mailto:[email protected]). To stay up-to-date follow me on twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
54 47
55 48
56 49 == Installation ==
57 -
50 +
58 51 1. Upload the full directory, with the folder, into your wp-content/plugins directory
59 52 1. Activate the plugin through the 'Plugins' menu in WordPress
60 53 1. Enjoy
61 54
@@ -63,478 +56,133 @@
63 56 == Changelog ==
64 57
65 58 Here you found the changes in each version.
66 59
67 - Version Date Changes
68 -
69 - 2.3.16 2026/07/27 Improve performance by loading the object assignments of all user groups with one query
70 - Improve performance by loading all user groups with one query instead of one per group
71 - Fix the never executed database update of the user group table id column
72 - Fix a fatal error on rest requests for hidden objects. Thanks to Erwan Le Rousseau (WPScan)
73 - Do not derive the admin panel context from the referer header anymore
74 - Fix an unauthenticated arbitrary file read through path traversal in the file delivery
75 -
76 - 2.3.15 2026/07/22 Fix REST API bypass for clients without an admin referer, like the official WordPress app
77 - Deny REST write requests to objects the user has no access to
78 - Deny REST requests for revisions and autosaves of restricted objects
79 - Add option to append the requested URL as "redirect_to" parameter to the redirect
80 -
81 - 2.3.14 2026/07/21 Fix REST API content restriction bypass exposing restricted posts to unauthenticated users
82 - Add "Redirect to origin" option
83 -
84 - 2.3.13 2026/07/10 Improve performance
85 - Fix security issue CVE-2026-15281
86 -
87 - 2.3.12 2026/05/20 Fix deprecation warning
88 - Add redis cache provider, improve nginx file handling and fix author access. Thanks to Erik Franzén
89 -
90 - 2.3.11 2026/01/23 Improve performance
91 - Improve styling
92 -
93 - 2.3.10 2026/01/22 Fix other possible type error
94 -
95 - 2.3.9 2026/01/19 Fix possible type error
96 -
97 - 2.3.8 2025/12/12 Adjust logic wp cli command logic to prevent errors
98 -
99 - 2.3.7 2025/12/10 Fix issue with MapPress
100 -
101 - 2.3.6 2025/12/10 Improve type compatibility again...
102 -
103 - 2.3.5 2025/12/10 Improve type compatibility again...
104 -
105 - 2.3.4 2025/12/09 Improve type compatibility again
106 -
107 - 2.3.3 2025/12/09 Improve compatibility again
108 -
109 - 2.3.2 2025/12/09 Adjust wordpress wrapper
110 -
111 - 2.3.1 2025/12/09 Fix possible type error
112 -
113 - 2.3.0 2025/12/09 Require now PHP 8.0
114 - Remove strftime
115 - Fix some issues
116 -
117 - 2.2.25 2025/04/22 Fixed problem with fix load_textdomain
118 -
119 - 2.2.24 2025/04/17 Fix deprecated warnings
120 - Fixed problem with load_textdomain Thanks to Christian Ludwig (chludwig)
121 -
122 - 2.2.23 2023/05/26 Fix typos
123 - Fix version_compare
124 -
125 - 2.2.22 2023/05/26 Minor change
126 -
127 - 2.2.21 2023/05/25 Adjust database compatibility #368
128 -
129 - 2.2.20 2023/03/08 Fix warning
130 -
131 - 2.2.19 2022/11/18 Add try out link
132 -
133 - 2.2.18 2022/11/14 Fix issue with label id. Thanks to elbakkali
134 - Add elementor support. Thanks to JboyJW
135 - Fix possible issue with PHP 8. Thanks to ollycross
136 - Fix attachment issue.
137 - Fix tags issue.
138 - Make extra IP header configurable.
139 -
140 - 2.2.17 2022/02/15 Fix issue with big picture handling. #350
141 -
142 - 2.2.16 2022/01/25 Check compatibility for WordPress 5.9.
143 -
144 - 2.2.15 2021/06/07 Fix possible type issues.
145 -
146 - 2.2.14 2021/04/21 Fix bulk edit.
147 - Fix permission issue.
148 - Fix redirect typing issue.
149 -
150 - 2.2.13 2021/04/15 Fix not logged-in user handling.
151 - Type fix for showEditLink.
152 -
153 - 2.2.12 2021/04/14 Fix warning.
154 - Fix jquery deprecation warning.
155 -
156 - 2.2.11 2021/03/15 Type fix for showEditLink.
157 - Set compatibility tag for WordPress 5.7.
158 -
159 - 2.2.10 2021/02/26 Lower minimum php version to 7.2.
160 -
161 - 2.2.9 2021/02/24 Type fixes for Yoast SEO plugin.
162 - Fix some other type issues.
163 -
164 - 2.2.8 2021/02/21 Some cleanup.
165 - Type fixes for the short controller.
166 - Fix some possible php notices and warnings.
167 -
168 - 2.2.7 2021/02/14 Fix issue with isAdmin.
169 -
170 - 2.2.6 2021/02/14 Fix more possible type errors.
171 -
172 - 2.2.5 2021/02/14 Fix more possible type errors if WordPress switches int to string.
173 -
174 - 2.2.4 2021/02/13 Fix type error for user object controller.
175 - Fix type error for the WordPress wrapper.
176 -
177 - 2.2.3 2021/02/13 Fix warning at settings page.
178 - Fix type error for user group handler.
179 -
180 - 2.2.2 2021/02/13 Fix type error with login form.
181 -
182 - 2.2.1 2021/02/13 Fix type error with registeredTaxonomy.
183 -
184 - 2.2.0 2021/02/11 Improve and update code base.
185 - Fix possible update bug.
186 -
187 - 2.1.12 2019/01/08 Fix multi-site file handling issue. #222
188 -
189 - 2.1.11 2018/03/16 Fix missing got_mod_rewrite function. #212
190 - Fix wrong media urls. #207
191 - Fix wrong post counts at the admin panel.
192 - Improve database updates/repairs.
193 -
194 -
195 - 2.1.10 2017/12/15 Fix Posts removed from WP_Query results in Ajax requests for unprivileged users #176
196 - Improve partly download handler
197 - Suppress errors on file delivery
198 - Improve error handling
199 - Change blog switch handling. fixes #194
200 - Fix wrong parameter name. fixes #191
201 - Improve user group sorting. closes #180
202 - Add new redirect type to the login page. closes #155
203 - Add dynamic user groups for exclude object calculation. closes #181
204 - Add filter for getUserUserGroupsForObjectAccess. closes #157
205 - Make it possible to set a default group for new media files.
206 -
207 - 2.1.9 2017/11/18 Add show content before <!--more--> tag option for all post types
208 - Fix js time input issue
209 - Fix small prepare query issue
210 - Don't switch to edit mode after user group creation #171
211 - Add sortable columns for user groups list #172
212 - Show no access image again instead of broken image
213 - Fix double user group form for media files
214 - Add option to hide the edit page option if the user doesn't have the right to edit this page #174
215 -
216 - 2.1.8 2017/11/07 Add getter for the user group handler fixes #160
217 - Fix multi-site file handling issue #159
218 -
219 - 2.1.7 2017/11/01 Improve database update prompt fixes #153
220 - Fix user group selection not saved when adding a new user issue fixes #154
221 - Add none read access option for user groups closes #144
222 - Extend file settings
223 - Add xsendfile support
224 -
225 - 2.1.6 2017/10/20 Fix "Inherited group membership for media attachments" issue #133
226 - Fix traits strict warning #145
227 -
228 - 2.1.5 2017/10/12 Refactor traits
229 - Fix datetime issue with not supported browsers
230 -
231 - 2.1.4 2017/10/10 Fix strict warnings #134
232 - Fix "Unable to select default user group for both page and post" issue #126
233 - Add NGINX reverse proxy handling #117
234 - Improve code
235 - Fix bulk edit issue #135
236 - Fix array filly issue #138
237 - Add database repair tool
238 -
239 - 2.1.3 2017/09/18 Possible fix for custom post types / taxonomies issues
240 - Fix .htaccess deletion issue
241 -
242 - 2.1.2 2017/09/17 Fix issue with not handled taxonomies #123
243 -
244 - 2.1.1 2017/09/16 Fix issue for users with small innodb page size #121
245 -
246 - 2.1.0 2017/09/15 Refactor code
247 - Implement content tags for partly restriction like UAMPPE #84
248 - Add default user groups
249 - Add time based access
250 - Add dynamic user groups #64
251 - Implement caching #75
252 - Allow html as no access content #63 #93
253 - Optimize settings screen #61
254 - Support of partial download #118
255 - Add option to toggle visibility of assigned groups text next to the edit link #111
256 - Fix incorrectly retrieving of an ID for attachments/media #116
257 -
258 - 2.0.13 2017/07/26 Add ipv6 support - Fix issue #97
259 - Change "Hide Comments" logic - Fix issue #100
260 - Fix rewrite base issue - Fix issue #107 and #103
261 - Fix vsprintf warning - Fix issue #105
262 - Fix Relevanssi compatibility issue
263 - Fix missing feature picture if file locking is disabled
264 -
265 - 2.0.12 2017/06/16 Fix media file group issue #74
266 - Fix broken file includes / excludes
267 - Fix WordPress filter issue
268 - Fix access to own post #95
269 -
270 - 2.0.11 2017/05/18 Fix FrontendController::postsPreQuery() expected to be a reference, value given error
271 -
272 - 2.0.10 2017/05/17 Fix issue of not saved groups #74
273 - Adjust password lost link #79
274 - Improve attachment access checks #78
275 - Fix not working redirect
276 -
277 - 2.0.9 2017/05/13 Improve security #76
278 -
279 - 2.0.8 2017/05/08 Fix missing rss feed if protection is disabled #68
280 -
281 - 2.0.7 2017/05/07 Fix category tree issues #59
282 - Fix mysql database errors on strict mode #60
283 - Fix possible path issue
284 - Remove settings for post_format post type (which is used for internal propose)
285 - Fix wrong database update prompt
286 - Fix issue with asgaros from #66
287 -
288 - 2.0.6 2017/04/28 Improve http error codes #24
289 - Fix wrong url on Windows servers #53
290 - Fix missing install routine #51
291 -
292 - 2.0.5 2017/04/27 Fix switch_to_blog issue
293 - Fix file handling issues
294 -
295 - 2.0.4 2017/04/26 Adjust code so that php version is checked before throwing a fatal error
296 - Improve login form #26
297 - Fix soliloquy slider incompatibility #31
298 - Improve performance #41
299 -
300 - 2.0.3 2017/04/25 Fix compatibility issue with CMS Tree Page View plugin #37
301 - Fix compatibility issue with SEO Redirection plugin #38
302 - Fix Error thrown: Class 'WP_Site_Query' not found issue #36
303 -
304 - 2.0.2 2017/04/24 Fix wp_get_current_user() error #34
305 - Fix custom post save issue after database update #33
306 -
307 - 2.0.1 2017/04/23 Fix dbDelta issue on activation
308 -
309 - 2.0.0 2017/04/23 Refactoring of the module
310 - Improve performance
311 - Full support for custom post and taxonomies.
312 - Use translate.wordpress.org for translations
313 - Many improvements and fixes
314 -
315 - 1.2.14 2017/01/07 Fix IP access issue.
316 - Some small optimization.
317 -
318 - 1.2.13 2017/01/04 Fix tag count issue.
319 -
320 - 1.2.12 2017/01/03 Fix tag issue.
321 - Improve usability of the setup page.
322 -
323 - 1.2.11 2017/01/02 Restore hide categories behaviour.
324 -
325 - 1.2.10 2017/01/02 Improve mysql query to prevent against possible collations issue.
326 -
327 - 1.2.9 2017/01/01 Fix wrong category count.
328 - Hide pages without access at the administration panel.
329 - Fix redirect problems.
330 -
331 - 1.2.8 2016/12/31 Fix wrong term behavior for the backend.
332 - Require at least PHP 5.3
333 -
334 - 1.2.7.6 2016/12/28 Fix ip restriction issue.
335 - Fix missing categories issue.
336 -
337 - 1.2.7.5 2016/12/27 Improve taxonomy handling.
338 - Improve performance.
339 - Add missing wp-cli.php file.
340 - Refactor config handling.
341 - Fix Yoast SEO Plugin issue.
342 - Some other small fixes.
343 -
344 - 1.2.7.4 2016/12/08 Fix some issues related to WordPress 4.7
345 -
346 - 1.2.7.3 2016/12/08 Fix empty category issue.
347 -
348 - 1.2.7.2 2016/12/07 Hot fix for WordPress 4.7
349 -
350 - 1.2.7.1 2016/12/04 Remove deprecated function get_currentuserinfo
351 -
352 - 1.2.7.0 2016/11/30 Add experimental nginx support
353 - Fix redirect issue (Thanks to Laurence Shaw for the hint and James Riordon for the fix)
354 -
355 - 1.2.6.10 2016/10/07 Again a security fix
356 -
357 - 1.2.6.9 2016/10/06 Security fix
358 -
359 - 1.2.6.8 2016/08/15 Security fix
360 - Add Yoast SEO Plugin filter. Thanks to Christian Werner
361 -
362 - 1.2.6.7 2016/03/17 Security fix
363 -
364 - 1.2.6.6 2015/03/09 Hide UAM at the backend from normal users.
365 - Change IP range logic. Thanks to Takanashi
366 - Fix issue with roles.
367 -
368 - 1.2.6.5 2015/03/02 Fix install/update missing table issue.
369 -
370 - 1.2.6.4 2015/02/26 Fix database update issue.
371 -
372 - 1.2.6.3 2015/02/25 Fix database update for multi sites.
373 - Fix array_keys warning.
374 - Fix redirect loop.
375 -
376 - 1.2.6.2 2015/02/24 Fix not removable role affiliation issue.
377 -
378 - 1.2.6.1 2015/02/24 Remove deprecated php function mysql_get_server_info().
379 - Change object_id from varchar 11 to varchar 255.
380 - Fix backslashes issue.
381 -
382 - 1.2.6.0 2015/02/11 Remove unnecessary js library.
383 - Merge changes from https://github.com/nwoetzel/user-access-manager. Thanks for contribution.
384 -
385 - 1.2.5.0 2013/12/13 Improve performance. Thanks to all testers.
386 - Add bulk edit feature.
387 -
388 - 1.2.4.3 2013/05/08 Fix redirect if page is hidden and permalink is active issue.
389 - Fix no access issue.
390 -
391 - 1.2.4.2 2013/05/08 Fix pagination issue. Thanks to arjenbreur.
392 - Fix comment issue. Thanks to jpr105.
393 - Redirect if post/page is hidden and permalink is active.
394 - Change icon.
395 -
396 - 1.2.4.1 2013/05/06 Fix broken images issue.
397 - Fix duplicated key issue.
398 - Filter file types.
399 - Use WordPress mime types instead of the config array.
400 -
401 - 1.2.4 2013/05/01 Fix add column issue.
402 - Fix install bug.
403 - Fix error if no user is logged in. Thanks to Robert Egger and akiko.pusu.
404 - Fix media file issue.
405 - Optimize code.
406 -
407 - 1.2.3.1 2013/05/01 Fix terms issue.
408 -
409 - 1.2.3 2013/04/30 Fix Fatal 'error: Call-time pass-by-reference' error.
410 - Fix 'get_userdata() is not defined' error. Thanks to ranwaldo.
411 - Refactor many variable names to fit new coding style.
412 -
413 - 1.2.2 2011/04/03 Speed improvements.
414 - Fix get_term bug.
415 - Fix category bug
60 + Version Date Changes
416 61
417 - 1.2.1 2011/10/11 Fix uninstall bug.
418 - Add capability 'manage_user_groups'. Thanks to Tim Okrongli
419 - Some small improvements.
420 -
421 - 1.2 2011/06/19 Add custom post types.
422 - Fix CSRF issue. Thanks to Luke Crouch
423 -
424 - 1.1.4 2010/10/19 Fix error on custom post types
425 - Add warning for PHP version lower than 5.0
426 -
427 - 1.1.3 2010/10/09 Add tag filter
428 - Fix media file bug for multisites
429 - Fix ip access bug
430 - Improve redirecting code
431 - Speed up
432 -
433 - 1.1.2 2010/10/04 Fix read/write access bug
434 - Add recursive looking for posts page option
435 - Improve network activation/update
436 - Add hooks for login bar
437 - Prepare for NextGEN Gallery extension
438 -
439 - 1.1.1.2 2010/09/29 Fix bug that an usergroup for a user wasn't saved
440 -
441 - 1.1.1.1 2010/09/29 Fix T_DNUMBER bug
442 -
443 62 1.1.1 2010/09/29 Fix custom menu bug
444 63 Fix quick edit bug
445 64 Fix undefined object bug
446 65 Extend admin hint
447 66
448 - 1.1 2010/09/28 Add plugin api
449 - Optimized code
450 - Improve content filtering
451 - Fix bug that user groups can't be removed from element
452 - Fix empty category bug
453 - Fix pre/next post bug
454 - Fix login form bug
455 - Fix redirect bug
456 - Fix some other small bugs
67 + 1.1 2010/09/28 Add plugin api
68 + Optimized code
69 + Improve content filtering
70 + Fix bug that user groups can't removed from element
71 + Fix empty category bug
72 + Fix pre/next post bug
73 + Fix login form bug
74 + Fix redirect bug
75 + Fix some other small bugs
457 76
458 - 1.0.2 2010/07/24 Remove debugging code
459 - Fix file download bug
77 + 1.0.2 2010/07/24 Remove debugging code
78 + Fix file download bug
460 79
461 - 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
462 - Fix bug for recursive locking for categories
80 + 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
81 + Fix bug for recursive locking for categories
463 82
464 - 1.0 2010/07/22 Fix array_merge bug at media page
465 - Reorder some admin options
466 - Add some new admin functions
467 - Speed it up
468 - Disable file locking by default
83 + 1.0 2010/07/22 Fix array_merge bug at media page
84 + Reorder some admin options
85 + Add some new admin functions
86 + Speed it up
87 + Disable file locking by default
469 88
470 - 1.0 Beta 2 2010/07/13 Fix performance issues
471 - Fix media gallery issues
472 - Fix category bug
473 - Fix not loaded translation
474 - Remove some unused functions
89 + 1.0 Beta 2 2010/07/13 Fix perforance issues
90 + Fix media gallery issues
91 + Fix category bug
92 + Fix not loaded translation
93 + Remove some unused functions
475 94
476 - 1.0 Beta 2010/07/09 Complete rewrite
477 - Some new options to improve the functions
95 + 1.0 Beta 2010/07/09 Complete rewrite
96 + Some new options to improve the functions
478 97
479 - 0.9.1.4 2010/06/23 Hotfix for WordPress 3.0
98 + 0.9.1.4 2010/06/23 Hotfix for Wordpress 3.0
480 99
481 - 0.9.1.3 2009/07/17 Fix "header already send"-Problem with WordPress 2.8.1
482 - Add option to set level with full access
100 + 0.9.1.3 2009/07/17 Fix "header already send"-Problem with Wordpress 2.8.1
101 + Add option to set level with full access
483 102
484 - 0.9.1.2 2009/03/29 Fix some path problems
485 - Add a reset function
486 - Rename menu at admin panel
103 + 0.9.1.2 2009/03/29 Fix some path problems
104 + Add a reset function
105 + Rename menu at admin panel
487 106
488 - 0.9.1.1 2009/03/26 Fix the empty category issue
107 + 0.9.1.1 2009/03/26 Fix the empty category issue
489 108
490 - 0.9.1 2009/03/26 Fix the database problem
491 - Fix feed bug. Thanks to Markus Brinkmann
492 - Fix wrong javascript path
109 + 0.9.1 2009/03/26 Fix the database problem
110 + Fix feed bug. Thanks to Markus Brinkmann
111 + Fix wrong javascript path
493 112
494 - 0.9 2009/03/24 Add login form
495 - Add option to show text bevor <!--more--> tag
496 - Fix write access issues
497 - Fix file issues
498 - Small fixes
113 + 0.9 2009/03/24 Add login form
114 + Add option to show text bevor <!--more--> tag
115 + Fix write access issues
116 + Fix file issues
117 + Small fixes
499 118
500 - 0.8.0.2 2009/03/09 Add French language file
501 - Delete .htaccess files on deactivation/uninstall
119 + 0.8.0.2 2009/03/09 Add French language file
120 + Delete .htaccess files on deactivation/uninstall
502 121
503 - 0.8.0.1 2009/03/06 Small fix
122 + 0.8.0.1 2009/03/06 Small fix
504 123
505 - 0.8 2009/03/05 Add write access control
506 - Add support down to 2.6
507 - Better file access control
508 - Code optimization - Plugin became faster
509 - Fix the category bug
510 - Small fixes
124 + 0.8 2009/03/05 Add write access control
125 + Add support down to 2.6
126 + Better file access control
127 + Code optimization - Plugin became faster
128 + Fix the category bug
129 + Small fixes
511 130
512 - 0.7.0.1 2009/02/13 Small fixes
513 -
514 - 0.7 2009/02/13 Fix: All known Bugs of the beta
515 - Add ajax for more comfort
516 - Add language support
131 + 0.7.0.1 2009/02/13 Small fixes
517 132
518 - 0.7 Beta 2009/01/05 Fix: Problems with media at posts
519 - Fix: Many other small fixes
520 - Only support up to WordPress 2.7
521 - Better integration
133 + 0.7 2009/02/13 Fix: All known Bugs of the beta
134 + Add ajax for more comfort
135 + Add language support
522 136
523 - 0.62 2008/12/18 Fix: Fatal error: Only variables can
524 - be passed by reference. Thanks to David Thompson
137 + 0.7 Beta 2009/01/05 Fix: Problems with media at posts
138 + Fix: Many other small fixes
139 + Only support up to Wordpress 2.7
140 + Better integration
141 +
142 + 0.62 2008/12/18 Fix: Fatal error: Only variables can
143 + be passed by reference. Thanks to David Thompson
144 +
145 + 0.61 2008/12/17 Fix: Wrong file id in Media Library
525 146
526 - 0.61 2008/12/17 Fix: Wrong file id in Media Library
147 + 0.6 2007/12/14 First release.
527 148
528 - 0.6 2007/12/14 First release.
529 149
150 +== Frequently Asked Questions ==
530 151
531 -== Frequently Asked Questions ==
152 +<strong>How works the User Access Manager?</strong>
532 153
533 -See: [https://github.com/GM-Alex/user-access-manager/wiki/FAQ](https://github.com/GM-Alex/user-access-manager/wiki/FAQ)
154 +All posts/pages which are not in a user access group are accessable to all users. Posts/pages can put to groupes by themselfe, categories or recursive (most by pages).
534 155
156 +<strong>How dose "Role affiliation" work?</strong>
157 +
158 +This example will give you an overview:
159 +
160 +- Posts: Post1, Post2
161 +- Users: User1 (admin), User2 (subscriber), User3 (subscriber)
162 +
163 +Groups:
164 +
165 +- Group1: Users: User2, User3 | Posts: Post1 | Role affiliation: subscriber
166 +- Group2: Users: User3 | Posts: Post2 | Role affiliation: -
167 +
168 +Access:
169 +
170 +- Post1: User1 because he is a admin, User2 because he is in the group and a subscriber, User3 he is a subscriber (to this group all subscribers has access!)
171 +- Post2: User1 because he is a admin, User3 because he is in the group (only group members has access because there is no role affiliation!)
172 +
173 +<strong>I get an login box "WP-Files", what can I do?</strong>
174 +
175 +- You can deactivate the file locking at the UAM settings.
176 +- You can replace your media files in your posts. Just delete the old link and insert it again. (A new working link will generated)
177 +
178 +
535 179 == Screenshots ==
536 180
537 -1. The group manager.
538 -2. The setting screen
539 -3. The setup screen.
540 -4. Integration into post overview.
181 +1. The group manger.
182 +2. The setting screen - Part 1.
183 +3. The setting screen - Part 2.
184 +4. The setting screen - Part 3.
185 +5. The setup screen.
186 +6. Integration into post overview.
187 +7. Integration into the post page.
188 +8. Admin hint at the blog frontend.