PluginProbe
User Access Manager / 2.2.11
User Access Manager v2.2.11
2.3.20 2.3.19 2.3.18 2.3.17 2.3.16 2.3.15 2.3.14 2.3.13 trunk 0.6 0.6.1 0.6.2 0.7 0.7 Beta 0.7.0.1 0.8 0.8.0.1 0.8.0.2 0.9 0.9.1 0.9.1.1 0.9.1.2 0.9.1.3 0.9.1.4 1.0 All 136 releases
← All changes | readme.txt +412 -20 0.6.22.2.11 View file →
@@ -1,54 +1,446 @@
1 1 === User Access Manager ===
2 2 Contributors: GM_Alex
3 3 Donate link: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=1947052
4 -Tags: user access manager, access, member area, user management, private, privacy, admin
5 -Requires at least: 2.6
6 -Tested up to: 2.6
7 -Stable tag: 0.6.2
4 +Tags: admin, access, member area, members, member, member access, page, pages, post, posts, private, privacy, restrict, user, user access manager, user management
5 +Requires at least: 4.7
6 +Tested up to: 5.7
7 +Stable tag: 2.2.11
8 8
9 9 With the "User Access Manager"-plugin you can manage the access to your posts, pages and files.
10 10
11 11 == Description ==
12 12
13 -With the "User Access Manager"-plugin you can manage the access to your posts, pages and files. You only create a user group, put registered users to this and set up the rights for this group. From now on the post/page is only accessible for the specified group. This plugin is useful if you need a member area or a private section at your blog.
13 +The “User Access Manager”-plugin for Wordpress allows you to manage the access of your content. This is useful if you need a member area, a private section at your blog or you want that other people can write at your blog but not everywhere. Including all post type (post, pages etc.), taxonomies (categories etc.) and files by creating user groups. Just assign the content you want to restrict und and your registered users which should have a access to a group. From now on the content is only accessible and writable for the specified group.
14 14
15 -<h5>Feature list</h5>
15 +<em>Feature list</em>
16 +
16 17 * User groups
17 -* User-defined post/page title (if no access)
18 -* User-defined post/page text (if no access)
19 -* Hide complete post/page
20 -* Hide pages in navigation
18 +* Set separate access for readers and editors
19 +* Set access by user groups
20 +* Set default user groups
21 +* Set time based access
22 +* User-defined post type (posts, pages etc.) title (if no access)
23 +* User-defined post type (posts, pages etc.) text (if no access)
24 +* Optional login form (if no access)
25 +* User-defined comment text (if no access)
26 +* Hide complete post types (posts, pages etc.)
27 +* Hide elements in the navigation
21 28 * Redirecting users to other pages (if no access)
22 -* Recursive locking of posts/pages
29 +* Recursive locking of content
23 30 * Limited access to uploaded files
31 +* Full integrated at the admin panel
32 +* Multilingual support
33 +* Also protect your rss feeds
34 +* Give access by IP-address
35 +* Plugin-Api to use the User Access Manager in your on plugins or extend other plugins
36 +* [UAMPPE](https://wordpress.org/plugins/user-access-manager-private-public-extension/) like behaviour is now build in (Expect negation like !groupName and showprivate and shownotauthorized parameter)
24 37
25 -For a German description visit my page at [GMAlex](http://www.gm-alex.de/projects/wordpress/plugins/user-access-manager/ "GMAlex - deviant design and development"). If you have any problem or suggestions please [contact me](mailto:alexanderschneider85@googlemail.com).
38 +<em>Included languages</em>
26 39
40 +See [https://translate.wordpress.org/projects/wp-plugins/user-access-manager](https://translate.wordpress.org/projects/wp-plugins/user-access-manager)
27 41
42 +The documentation can be found here: [https://github.com/GM-Alex/user-access-manager/wiki](https://github.com/GM-Alex/user-access-manager/wiki)
43 +Please report bugs and feature requests here: [https://github.com/GM-Alex/user-access-manager/issues](https://github.com/GM-Alex/user-access-manager/issues)
44 +If you are a developer and want to contribute please visit [https://github.com/GM-Alex/user-access-manager](https://github.com/GM-Alex/user-access-manager)
45 +For general questions, like how to setup, best practice and so on please use the support thread here (don't post issues here): [https://wordpress.org/support/plugin/user-access-manager](https://wordpress.org/support/plugin/user-access-manager)
46 +To stay up-to-date follow me on twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
47 +
48 +
28 49 == Installation ==
29 -
30 -1. Upload the full directory into your wp-content/plugins directory
50 +
51 +1. Upload the full directory, with the folder, into your wp-content/plugins directory
31 52 1. Activate the plugin through the 'Plugins' menu in WordPress
32 53 1. Enjoy
33 54
34 55
35 -== Contributors/Changelog ==
56 +== Changelog ==
36 57
37 58 Here you found the changes in each version.
38 59
39 - Version Date Changes
60 + Version Date Changes
61 +
62 + 2.2.11 2021/03/15 Type fix for showEditLink.
63 + Set compatibility tag for wordpress 5.7.
64 +
65 + 2.2.10 2021/02/26 Lower minimum php version to 7.2.
66 +
67 + 2.2.9 2021/02/24 Type fixes for Yoast seo plugin.
68 + Fix some other type issues.
69 +
70 + 2.2.8 2021/02/21 Some cleanup.
71 + Type fixes for the short controller.
72 + Fix some possible php notices and warnings.
73 +
74 + 2.2.7 2021/02/14 Fix issue with isAdmin.
75 +
76 + 2.2.6 2021/02/14 Fix more possible type errors.
77 +
78 + 2.2.5 2021/02/14 Fix more possible type errors if wordpress switches int to string.
79 +
80 + 2.2.4 2021/02/13 Fix type error for user object controller.
81 + Fix type error for the wordpress wrapper.
82 +
83 + 2.2.3 2021/02/13 Fix warning at settings page.
84 + Fix type error for user group handler.
85 +
86 + 2.2.2 2021/02/13 Fix type error with login form.
87 +
88 + 2.2.1 2021/02/13 Fix type error with registeredTaxonomy.
89 +
90 + 2.2.0 2021/02/11 Improve and update code base.
91 + Fix possible update bug.
92 +
93 + 2.1.12 2019/01/08 Fix multi site file handling issue. #222
94 +
95 + 2.1.11 2018/03/16 Fix missing got_mod_rewrite function. #212
96 + Fix wrong media urls. #207
97 + Fix wrong post counts at the admin panel.
98 + Improve database updates/repairs.
99 +
100 +
101 + 2.1.10 2017/12/15 Fix Posts removed from WP_Query results in Ajax requests for unprivileged users #176
102 + Improve partly download handler
103 + Suppress errors on file delivery
104 + Improve error handling
105 + Change blog switch handling. fixes #194
106 + Fix wrong parameter name. fixes #191
107 + Improve user group sorting. closes #180
108 + Add new redirect type to the login page. closes #155
109 + Add dynamic user groups for exclude object calculation. closes #181
110 + Add filter for getUserUserGroupsForObjectAccess. closes #157
111 + Make it possible to set a default group for new media files.
112 +
113 + 2.1.9 2017/11/18 Add show content before <!--more--> tag option for all post types
114 + Fix js time input issue
115 + Fix small prepare query issue
116 + Don't switch to edit mode after user group creation #171
117 + Add sortable columns for user groups list #172
118 + Show no access image again instead of broken image
119 + Fix double user group form for media files
120 + Add option to hide the edit page option if the user doesn't have the right to edit this page #174
121 +
122 + 2.1.8 2017/11/07 Add getter for the user group handler fixes #160
123 + Fix multi site file handling issue #159
124 +
125 + 2.1.7 2017/11/01 Improve database update prompt fixes #153
126 + Fix user group selection not saved when adding a new user issue fixes #154
127 + Add none read access option for user groups closes #144
128 + Extend file settings
129 + Add xsendfile support
130 +
131 + 2.1.6 2017/10/20 Fix "Inherited group membership for media attachments" issue #133
132 + Fix traits strict warning #145
133 +
134 + 2.1.5 2017/10/12 Refactor traits
135 + Fix datetime issue with not supported browsers
136 +
137 + 2.1.4 2017/10/10 Fix strict warnings #134
138 + Fix "Unable to select default user group for both page and post" issue #126
139 + Add NGINX reverse proxy handling #117
140 + Improve code
141 + Fix bulk edit issue #135
142 + Fix array filly issue #138
143 + Add database repair tool
144 +
145 + 2.1.3 2017/09/18 Possible fix for custom post types / taxonomies issues
146 + Fix .htaccess deletion issue
147 +
148 + 2.1.2 2017/09/17 Fix issue with not handled taxonomies #123
149 +
150 + 2.1.1 2017/09/16 Fix issue for users with small innodb page size #121
151 +
152 + 2.1.0 2017/09/15 Refactor code
153 + Implement content tags for partly restriction like UAMPPE #84
154 + Add default user groups
155 + Add time based access
156 + Add dynamic user groups #64
157 + Implement caching #75
158 + Allow html as no access content #63 #93
159 + Optimize settings screen #61
160 + Support of partial download #118
161 + Add option to toggle visibility of assigned groups text next to the edit link #111
162 + Fix incorrectly retrieving of a ID for attachments/media #116
163 +
164 + 2.0.13 2017/07/26 Add ipv6 support - Fix issue #97
165 + Change "Hide Comments" logic - Fix issue #100
166 + Fix rewrite base issue - Fix issue #107 and #103
167 + Fix vsprintf warning - Fix issue #105
168 + Fix Relevanssi compatibility issue
169 + Fix missing feature picture if file locking is disabled
170 +
171 + 2.0.12 2017/06/16 Fix media file group issue #74
172 + Fix broken file includes / excludes
173 + Fix wordpress filter issue
174 + Fix access to own post #95
175 +
176 + 2.0.11 2017/05/18 Fix FrontendController::postsPreQuery() expected to be a reference, value given error
177 +
178 + 2.0.10 2017/05/17 Fix issue of not saved groups #74
179 + Adjust password lost link #79
180 + Improve attachment access checks #78
181 + Fix not working redirect
182 +
183 + 2.0.9 2017/05/13 Improve security #76
184 +
185 + 2.0.8 2017/05/08 Fix missing rss feed if protection is disabled #68
186 +
187 + 2.0.7 2017/05/07 Fix category tree issues #59
188 + Fix mysql database errors on strict mode #60
189 + Fix possible path issue
190 + Remove settings for post_format post type (which is used for internal propose)
191 + Fix wrong database update prompt
192 + Fix issue with asgaros from #66
193 +
194 + 2.0.6 2017/04/28 Improve http error codes #24
195 + Fix wrong url on windows servers #53
196 + Fix missing install routine #51
197 +
198 + 2.0.5 2017/04/27 Fix switch_to_blog issue
199 + Fix file handling issues
200 +
201 + 2.0.4 2017/04/26 Adjust code so that php version is checked before throwing a fatal error
202 + Improve login form #26
203 + Fix soliloquy slider incompatibility #31
204 + Improve performance #41
205 +
206 + 2.0.3 2017/04/25 Fix compatibility issue with CMS Tree Page View plugin #37
207 + Fix compatibility issue with SEO Redirection plugin #38
208 + Fix Error thrown: Class 'WP_Site_Query' not found issue #36
209 +
210 + 2.0.2 2017/04/24 Fix wp_get_current_user() error #34
211 + Fix custom post save issue after database update #33
212 +
213 + 2.0.1 2017/04/23 Fix dbDelta issue on activation
214 +
215 + 2.0.0 2017/04/23 Refactoring of the module
216 + Improve performance
217 + Full support for custom post and taxonomies.
218 + Use translate.wordpress.org for translations
219 + Many improvements and fixes
220 +
221 + 1.2.14 2017/01/07 Fix IP access issue.
222 + Some small optimization.
223 +
224 + 1.2.13 2017/01/04 Fix tag count issue.
225 +
226 + 1.2.12 2017/01/03 Fix tag issue.
227 + Improve usability of the setup page.
228 +
229 + 1.2.11 2017/01/02 Restore hide categories behaviour.
230 +
231 + 1.2.10 2017/01/02 Improve mysql query to prevent against possible collations issue.
232 +
233 + 1.2.9 2017/01/01 Fix wrong category count.
234 + Hide pages without access at the administration panel.
235 + Fix redirect problems.
236 +
237 + 1.2.8 2016/12/31 Fix wrong term behavior for the backend.
238 + Require at least PHP 5.3
239 +
240 + 1.2.7.6 2016/12/28 Fix ip restriction issue.
241 + Fix missing categories issue.
242 +
243 + 1.2.7.5 2016/12/27 Improve taxonomy handling.
244 + Improve performance.
245 + Add missing wp-cli.php file.
246 + Refactor config handling.
247 + Fix Yoast SEO Plugin issue.
248 + Some other small fixes.
249 +
250 + 1.2.7.4 2016/12/08 Fix some issues related to Wordpress 4.7
251 +
252 + 1.2.7.3 2016/12/08 Fix empty category issue.
253 +
254 + 1.2.7.2 2016/12/07 Hot fix for Wordpress 4.7
255 +
256 + 1.2.7.1 2016/12/04 Remove deprecated function get_currentuserinfo
257 +
258 + 1.2.7.0 2016/11/30 Add experimental nginx support
259 + Fix redirect issue (Thanks to Laurence Shaw for the hint and James Riordon for the fix)
260 +
261 + 1.2.6.10 2016/10/07 Again a security fix
262 +
263 + 1.2.6.9 2016/10/06 Security fix
264 +
265 + 1.2.6.8 2016/08/15 Security fix
266 + Add Yoast SEO Plugin filter. Thanks to Christian Werner
267 +
268 + 1.2.6.7 2016/03/17 Security fix
269 +
270 + 1.2.6.6 2015/03/09 Hide UAM at the backend from normal users.
271 + Change IP range logic. Thanks to Takanashi
272 + Fix issue with roles.
273 +
274 + 1.2.6.5 2015/03/02 Fix install/update missing table issue.
275 +
276 + 1.2.6.4 2015/02/26 Fix database update issue.
277 +
278 + 1.2.6.3 2015/02/25 Fix database update for multi sites.
279 + Fix array_keys warning.
280 + Fix redirect loop.
281 +
282 + 1.2.6.2 2015/02/24 Fix not removable role affiliation issue.
283 +
284 + 1.2.6.1 2015/02/24 Remove deprecated php function mysql_get_server_info().
285 + Change object_id from varchar 11 to varchar 255.
286 + Fix backslashes issue.
287 +
288 + 1.2.6.0 2015/02/11 Remove unnecessary js library.
289 + Merge changes from https://github.com/nwoetzel/user-access-manager. Thanks for contribution.
290 +
291 + 1.2.5.0 2013/12/13 Improve performance. Thanks to all testers.
292 + Add bulk edit feature.
293 +
294 + 1.2.4.3 2013/05/08 Fix redirect if page is hidden and permalink is active issue.
295 + Fix no access issue.
296 +
297 + 1.2.4.2 2013/05/08 Fix pagination issue. Thanks to arjenbreur.
298 + Fix comment issue. Thanks to jpr105.
299 + Redirect if post/page is hidden and permalink is active.
300 + Change icon.
301 +
302 + 1.2.4.1 2013/05/06 Fix broken images issue.
303 + Fix duplicated key issue.
304 + Filter file types.
305 + Use wordpress mime types instead of the config array.
306 +
307 + 1.2.4 2013/05/01 Fix add column issue.
308 + Fix install bug.
309 + Fix error if no user is logged in. Thanks to Robert Egger and akiko.pusu.
310 + Fix media file issue.
311 + Optimize code.
312 +
313 + 1.2.3.1 2013/05/01 Fix terms issue.
314 +
315 + 1.2.3 2013/04/30 Fix Fatal 'error: Call-time pass-by-reference' error.
316 + Fix 'get_userdata() is not defined' error. Thanks to ranwaldo.
317 + Refactor many variable names to fit new coding style.
318 +
319 + 1.2.2 2011/04/03 Speed improvements.
320 + Fix get_term bug.
321 + Fix category bug
40 322
41 - 0.62 2008/12/18 Fix: Fatal error: Only variables can be passed by reference. Thanks to David Thompson
323 + 1.2.1 2011/10/11 Fix uninstall bug.
324 + Add capability 'manage_user_groups'. Thanks to Tim Okrongli
325 + Some small improvements.
42 326
43 - 0.61 2008/12/17 Fix: Wrong file id in Media Library.
327 + 1.2 2011/06/19 Add custom post types.
328 + Fix CSRF issue. Thanks to Luke Crouch
329 +
330 + 1.1.4 2010/10/19 Fix error on custom post types
331 + Add warning for PHP version lower than 5.0
332 +
333 + 1.1.3 2010/10/09 Add tag filter
334 + Fix media file bug for multisites
335 + Fix ip access bug
336 + Improve redirecting code
337 + Speed up
338 +
339 + 1.1.2 2010/10/04 Fix read/write access bug
340 + Add recursive looking for posts page option
341 + Improve network activation/update
342 + Add hooks for login bar
343 + Prepare for NextGEN Gallery extension
344 +
345 + 1.1.1.2 2010/09/29 Fix bug that a usergroup for a user wasn't saved
346 +
347 + 1.1.1.1 2010/09/29 Fix T_DNUMBER bug
348 +
349 + 1.1.1 2010/09/29 Fix custom menu bug
350 + Fix quick edit bug
351 + Fix undefined object bug
352 + Extend admin hint
353 +
354 + 1.1 2010/09/28 Add plugin api
355 + Optimized code
356 + Improve content filtering
357 + Fix bug that user groups can't removed from element
358 + Fix empty category bug
359 + Fix pre/next post bug
360 + Fix login form bug
361 + Fix redirect bug
362 + Fix some other small bugs
363 +
364 + 1.0.2 2010/07/24 Remove debugging code
365 + Fix file download bug
366 +
367 + 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
368 + Fix bug for recursive locking for categories
369 +
370 + 1.0 2010/07/22 Fix array_merge bug at media page
371 + Reorder some admin options
372 + Add some new admin functions
373 + Speed it up
374 + Disable file locking by default
375 +
376 + 1.0 Beta 2 2010/07/13 Fix performance issues
377 + Fix media gallery issues
378 + Fix category bug
379 + Fix not loaded translation
380 + Remove some unused functions
381 +
382 + 1.0 Beta 2010/07/09 Complete rewrite
383 + Some new options to improve the functions
384 +
385 + 0.9.1.4 2010/06/23 Hotfix for Wordpress 3.0
386 +
387 + 0.9.1.3 2009/07/17 Fix "header already send"-Problem with Wordpress 2.8.1
388 + Add option to set level with full access
389 +
390 + 0.9.1.2 2009/03/29 Fix some path problems
391 + Add a reset function
392 + Rename menu at admin panel
393 +
394 + 0.9.1.1 2009/03/26 Fix the empty category issue
395 +
396 + 0.9.1 2009/03/26 Fix the database problem
397 + Fix feed bug. Thanks to Markus Brinkmann
398 + Fix wrong javascript path
399 +
400 + 0.9 2009/03/24 Add login form
401 + Add option to show text bevor <!--more--> tag
402 + Fix write access issues
403 + Fix file issues
404 + Small fixes
405 +
406 + 0.8.0.2 2009/03/09 Add French language file
407 + Delete .htaccess files on deactivation/uninstall
408 +
409 + 0.8.0.1 2009/03/06 Small fix
410 +
411 + 0.8 2009/03/05 Add write access control
412 + Add support down to 2.6
413 + Better file access control
414 + Code optimization - Plugin became faster
415 + Fix the category bug
416 + Small fixes
417 +
418 + 0.7.0.1 2009/02/13 Small fixes
44 419
45 - 0.6 2007/12/14 First release.
420 + 0.7 2009/02/13 Fix: All known Bugs of the beta
421 + Add ajax for more comfort
422 + Add language support
423 +
424 + 0.7 Beta 2009/01/05 Fix: Problems with media at posts
425 + Fix: Many other small fixes
426 + Only support up to Wordpress 2.7
427 + Better integration
428 +
429 + 0.62 2008/12/18 Fix: Fatal error: Only variables can
430 + be passed by reference. Thanks to David Thompson
46 431
432 + 0.61 2008/12/17 Fix: Wrong file id in Media Library
47 433
434 + 0.6 2007/12/14 First release.
48 435
49 436
437 +== Frequently Asked Questions ==
50 438
439 +See: [https://github.com/GM-Alex/user-access-manager/wiki/FAQ](https://github.com/GM-Alex/user-access-manager/wiki/FAQ)
440 +
51 441 == Screenshots ==
52 442
53 443 1. The group manger.
54 -
444 +2. The setting screen
445 +3. The setup screen.
446 +4. Integration into post overview.