PluginProbe
User Access Manager / 2.2.23
User Access Manager v2.2.23
2.3.20 2.3.19 2.3.18 2.3.17 2.3.16 2.3.15 2.3.14 2.3.13 trunk 0.6 0.6.1 0.6.2 0.7 0.7 Beta 0.7.0.1 0.8 0.8.0.1 0.8.0.2 0.9 0.9.1 0.9.1.1 0.9.1.2 0.9.1.3 0.9.1.4 1.0 All 136 releases
← All changes | readme.txt +428 -85 0.9.1.2 → 2.2.23 View file →
@@ -1,54 +1,59 @@
1 1 === User Access Manager ===
2 2 Contributors: GM_Alex
3 3 Donate link: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=1947052
4 -Tags: admin, access, member area, members, page, pages, post, posts, private, privacy, restrict, user, user access manager, user management
5 -Requires at least: 2.6
6 -Tested up to: 2.7.1
7 -Stable tag: 0.9.1.2
4 +Tags: admin, access, member area, members, member, member access, page, pages, post, posts, private, privacy, restrict, user, user access manager, user management
5 +Requires at least: 4.7
6 +Tested up to: 6.3
7 +Stable tag: 2.2.23
8 8
9 9 With the "User Access Manager"-plugin you can manage the access to your posts, pages and files.
10 10
11 11 == Description ==
12 12
13 -With the "User Access Manager"-plugin you can manage the access to your posts, pages and files. You only create a user group, put registered users to this and set up the rights for this group. From now on the post/page is only accessible and writable for the specified group. This plugin is useful if you need a member area or a private section at your blog or you want that other people can write at your blog but not everywhere.
13 +The “User Access Manager”-plugin for Wordpress allows you to manage the access of your content. This is useful if you need a member area, a private section at your blog or you want that other people can write at your blog but not everywhere. Including all post type (post, pages etc.), taxonomies (categories etc.) and files by creating user groups. Just assign the content you want to restrict und and your registered users which should have a access to a group. From now on the content is only accessible and writable for the specified group.
14 14
15 +<em>Try it out</em>
16 +
17 +You can try it out at TasteWP.com before install: [Try user access manager](https://demo.tastewp.com/user-access-manager?a=jlQ7F1va) (affiliate link)
18 +
15 19 <em>Feature list</em>
16 20
17 21 * User groups
18 -* Set seperate access for readers and editors
22 +* Set separate access for readers and editors
19 23 * Set access by user groups
20 -* Set access by post categories
21 -* User-defined post/page title (if no access)
22 -* User-defined post/page text (if no access)
24 +* Set default user groups
25 +* Set time based access
26 +* User-defined post type (posts, pages etc.) title (if no access)
27 +* User-defined post type (posts, pages etc.) text (if no access)
23 28 * Optional login form (if no access)
24 29 * User-defined comment text (if no access)
25 -* Hide complete post/page
26 -* Hide pages in navigation
30 +* Hide complete post types (posts, pages etc.)
31 +* Hide elements in the navigation
27 32 * Redirecting users to other pages (if no access)
28 -* Recursive locking of posts/pages
33 +* Recursive locking of content
29 34 * Limited access to uploaded files
30 35 * Full integrated at the admin panel
31 -* Multilanguage support
32 -* Also proteced your rss feeds
36 +* Multilingual support
37 +* Also protect your rss feeds
33 38 * Give access by IP-address
39 +* Plugin-Api to use the User Access Manager in your on plugins or extend other plugins
40 +* [UAMPPE](https://wordpress.org/plugins/user-access-manager-private-public-extension/) like behaviour is now build in (Expect negation like !groupName and showprivate and shownotauthorized parameter)
34 41
35 42 <em>Included languages</em>
36 43
37 -* English
38 -* German
39 -* Czech, base on 0.7.0.1. Thanks to Huska
40 -* French, base on 0.8.0.2. Thanks to macbidule
44 +See [https://translate.wordpress.org/projects/wp-plugins/user-access-manager](https://translate.wordpress.org/projects/wp-plugins/user-access-manager)
41 45
42 -<strong>Note</strong>: At this release you can replace one core files, because I need some hooks which are not created by the Wordpress-Team for the better integration. I've send them a diff patch and this will add in Wordpress 2.8, so you can trust this modification (see <a href="http://trac.wordpress.org/changeset/10292">http://trac.wordpress.org/changeset/10292</a>). <strong>This core modification is not needed and only optional, but it gives you more comfort.</strong>
46 +The documentation can be found here: [https://github.com/GM-Alex/user-access-manager/wiki](https://github.com/GM-Alex/user-access-manager/wiki)
47 +Please report bugs and feature requests here: [https://github.com/GM-Alex/user-access-manager/issues](https://github.com/GM-Alex/user-access-manager/issues)
48 +If you are a developer and want to contribute please visit [https://github.com/GM-Alex/user-access-manager](https://github.com/GM-Alex/user-access-manager)
49 +For general questions, like how to setup, best practice and so on please use the support thread here (don't post issues here): [https://wordpress.org/support/plugin/user-access-manager](https://wordpress.org/support/plugin/user-access-manager)
50 +To stay up-to-date follow me on twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
43 51
44 -For a German description visit my page at [GMAlex](http://www.gm-alex.de/projects/wordpress/plugins/user-access-manager/ "GMAlex - deviant design and development"). If you have any problem, suggestions or make a translation please [contact me](mailto:[email protected]).
45 52
53 +== Installation ==
46 54
47 -== Installation ==
48 -
49 55 1. Upload the full directory, with the folder, into your wp-content/plugins directory
50 -1. Replace the following files in the wp-admin dir with the files at 'core_files' or use the patches: 'includes/template.php'
51 56 1. Activate the plugin through the 'Plugins' menu in WordPress
52 57 1. Enjoy
53 58
54 59
@@ -55,87 +60,425 @@
55 60 == Changelog ==
56 61
57 62 Here you found the changes in each version.
58 63
59 - Version Date Changes
64 + Version Date Changes
65 +
66 + 2.2.23 2023/05/26 Fix typos
67 + Fix version_compare
68 +
69 + 2.2.22 2023/05/26 Minor change
70 +
71 + 2.2.21 2023/05/25 Adjust database compatibility #368
72 +
73 + 2.2.20 2023/03/08 Fix warning
74 +
75 + 2.2.19 2022/11/18 Add try out link
76 +
77 + 2.2.18 2022/11/14 Fix issue with label id. Thanks to elbakkali
78 + Add elementor support. Thanks to JboyJW
79 + Fix possible issue with PHP 8. Thanks to ollycross
80 + Fix attachment issue.
81 + Fix tags issue.
82 + Make extra IP header configurable.
83 +
84 + 2.2.17 2022/02/15 Fix issue with big picture handling. #350
85 +
86 + 2.2.16 2022/01/25 Check compatibility for Wordpress 5.9.
87 +
88 + 2.2.15 2021/06/07 Fix possible type issues.
89 +
90 + 2.2.14 2021/04/21 Fix bulk edit.
91 + Fix permission issue.
92 + Fix redirect typing issue.
93 +
94 + 2.2.13 2021/04/15 Fix not logged in user handling.
95 + Type fix for showEditLink.
96 +
97 + 2.2.12 2021/04/14 Fix warning.
98 + Fix jquery deprecation warning.
99 +
100 + 2.2.11 2021/03/15 Type fix for showEditLink.
101 + Set compatibility tag for wordpress 5.7.
102 +
103 + 2.2.10 2021/02/26 Lower minimum php version to 7.2.
104 +
105 + 2.2.9 2021/02/24 Type fixes for Yoast seo plugin.
106 + Fix some other type issues.
107 +
108 + 2.2.8 2021/02/21 Some cleanup.
109 + Type fixes for the short controller.
110 + Fix some possible php notices and warnings.
111 +
112 + 2.2.7 2021/02/14 Fix issue with isAdmin.
113 +
114 + 2.2.6 2021/02/14 Fix more possible type errors.
115 +
116 + 2.2.5 2021/02/14 Fix more possible type errors if wordpress switches int to string.
117 +
118 + 2.2.4 2021/02/13 Fix type error for user object controller.
119 + Fix type error for the wordpress wrapper.
120 +
121 + 2.2.3 2021/02/13 Fix warning at settings page.
122 + Fix type error for user group handler.
123 +
124 + 2.2.2 2021/02/13 Fix type error with login form.
125 +
126 + 2.2.1 2021/02/13 Fix type error with registeredTaxonomy.
127 +
128 + 2.2.0 2021/02/11 Improve and update code base.
129 + Fix possible update bug.
130 +
131 + 2.1.12 2019/01/08 Fix multi site file handling issue. #222
132 +
133 + 2.1.11 2018/03/16 Fix missing got_mod_rewrite function. #212
134 + Fix wrong media urls. #207
135 + Fix wrong post counts at the admin panel.
136 + Improve database updates/repairs.
137 +
138 +
139 + 2.1.10 2017/12/15 Fix Posts removed from WP_Query results in Ajax requests for unprivileged users #176
140 + Improve partly download handler
141 + Suppress errors on file delivery
142 + Improve error handling
143 + Change blog switch handling. fixes #194
144 + Fix wrong parameter name. fixes #191
145 + Improve user group sorting. closes #180
146 + Add new redirect type to the login page. closes #155
147 + Add dynamic user groups for exclude object calculation. closes #181
148 + Add filter for getUserUserGroupsForObjectAccess. closes #157
149 + Make it possible to set a default group for new media files.
150 +
151 + 2.1.9 2017/11/18 Add show content before <!--more--> tag option for all post types
152 + Fix js time input issue
153 + Fix small prepare query issue
154 + Don't switch to edit mode after user group creation #171
155 + Add sortable columns for user groups list #172
156 + Show no access image again instead of broken image
157 + Fix double user group form for media files
158 + Add option to hide the edit page option if the user doesn't have the right to edit this page #174
159 +
160 + 2.1.8 2017/11/07 Add getter for the user group handler fixes #160
161 + Fix multi site file handling issue #159
162 +
163 + 2.1.7 2017/11/01 Improve database update prompt fixes #153
164 + Fix user group selection not saved when adding a new user issue fixes #154
165 + Add none read access option for user groups closes #144
166 + Extend file settings
167 + Add xsendfile support
168 +
169 + 2.1.6 2017/10/20 Fix "Inherited group membership for media attachments" issue #133
170 + Fix traits strict warning #145
171 +
172 + 2.1.5 2017/10/12 Refactor traits
173 + Fix datetime issue with not supported browsers
174 +
175 + 2.1.4 2017/10/10 Fix strict warnings #134
176 + Fix "Unable to select default user group for both page and post" issue #126
177 + Add NGINX reverse proxy handling #117
178 + Improve code
179 + Fix bulk edit issue #135
180 + Fix array filly issue #138
181 + Add database repair tool
182 +
183 + 2.1.3 2017/09/18 Possible fix for custom post types / taxonomies issues
184 + Fix .htaccess deletion issue
185 +
186 + 2.1.2 2017/09/17 Fix issue with not handled taxonomies #123
187 +
188 + 2.1.1 2017/09/16 Fix issue for users with small innodb page size #121
189 +
190 + 2.1.0 2017/09/15 Refactor code
191 + Implement content tags for partly restriction like UAMPPE #84
192 + Add default user groups
193 + Add time based access
194 + Add dynamic user groups #64
195 + Implement caching #75
196 + Allow html as no access content #63 #93
197 + Optimize settings screen #61
198 + Support of partial download #118
199 + Add option to toggle visibility of assigned groups text next to the edit link #111
200 + Fix incorrectly retrieving of a ID for attachments/media #116
201 +
202 + 2.0.13 2017/07/26 Add ipv6 support - Fix issue #97
203 + Change "Hide Comments" logic - Fix issue #100
204 + Fix rewrite base issue - Fix issue #107 and #103
205 + Fix vsprintf warning - Fix issue #105
206 + Fix Relevanssi compatibility issue
207 + Fix missing feature picture if file locking is disabled
208 +
209 + 2.0.12 2017/06/16 Fix media file group issue #74
210 + Fix broken file includes / excludes
211 + Fix wordpress filter issue
212 + Fix access to own post #95
213 +
214 + 2.0.11 2017/05/18 Fix FrontendController::postsPreQuery() expected to be a reference, value given error
215 +
216 + 2.0.10 2017/05/17 Fix issue of not saved groups #74
217 + Adjust password lost link #79
218 + Improve attachment access checks #78
219 + Fix not working redirect
220 +
221 + 2.0.9 2017/05/13 Improve security #76
222 +
223 + 2.0.8 2017/05/08 Fix missing rss feed if protection is disabled #68
224 +
225 + 2.0.7 2017/05/07 Fix category tree issues #59
226 + Fix mysql database errors on strict mode #60
227 + Fix possible path issue
228 + Remove settings for post_format post type (which is used for internal propose)
229 + Fix wrong database update prompt
230 + Fix issue with asgaros from #66
231 +
232 + 2.0.6 2017/04/28 Improve http error codes #24
233 + Fix wrong url on windows servers #53
234 + Fix missing install routine #51
235 +
236 + 2.0.5 2017/04/27 Fix switch_to_blog issue
237 + Fix file handling issues
238 +
239 + 2.0.4 2017/04/26 Adjust code so that php version is checked before throwing a fatal error
240 + Improve login form #26
241 + Fix soliloquy slider incompatibility #31
242 + Improve performance #41
243 +
244 + 2.0.3 2017/04/25 Fix compatibility issue with CMS Tree Page View plugin #37
245 + Fix compatibility issue with SEO Redirection plugin #38
246 + Fix Error thrown: Class 'WP_Site_Query' not found issue #36
247 +
248 + 2.0.2 2017/04/24 Fix wp_get_current_user() error #34
249 + Fix custom post save issue after database update #33
250 +
251 + 2.0.1 2017/04/23 Fix dbDelta issue on activation
252 +
253 + 2.0.0 2017/04/23 Refactoring of the module
254 + Improve performance
255 + Full support for custom post and taxonomies.
256 + Use translate.wordpress.org for translations
257 + Many improvements and fixes
258 +
259 + 1.2.14 2017/01/07 Fix IP access issue.
260 + Some small optimization.
261 +
262 + 1.2.13 2017/01/04 Fix tag count issue.
263 +
264 + 1.2.12 2017/01/03 Fix tag issue.
265 + Improve usability of the setup page.
266 +
267 + 1.2.11 2017/01/02 Restore hide categories behaviour.
268 +
269 + 1.2.10 2017/01/02 Improve mysql query to prevent against possible collations issue.
270 +
271 + 1.2.9 2017/01/01 Fix wrong category count.
272 + Hide pages without access at the administration panel.
273 + Fix redirect problems.
274 +
275 + 1.2.8 2016/12/31 Fix wrong term behavior for the backend.
276 + Require at least PHP 5.3
277 +
278 + 1.2.7.6 2016/12/28 Fix ip restriction issue.
279 + Fix missing categories issue.
280 +
281 + 1.2.7.5 2016/12/27 Improve taxonomy handling.
282 + Improve performance.
283 + Add missing wp-cli.php file.
284 + Refactor config handling.
285 + Fix Yoast SEO Plugin issue.
286 + Some other small fixes.
287 +
288 + 1.2.7.4 2016/12/08 Fix some issues related to Wordpress 4.7
289 +
290 + 1.2.7.3 2016/12/08 Fix empty category issue.
291 +
292 + 1.2.7.2 2016/12/07 Hot fix for Wordpress 4.7
293 +
294 + 1.2.7.1 2016/12/04 Remove deprecated function get_currentuserinfo
295 +
296 + 1.2.7.0 2016/11/30 Add experimental nginx support
297 + Fix redirect issue (Thanks to Laurence Shaw for the hint and James Riordon for the fix)
298 +
299 + 1.2.6.10 2016/10/07 Again a security fix
300 +
301 + 1.2.6.9 2016/10/06 Security fix
302 +
303 + 1.2.6.8 2016/08/15 Security fix
304 + Add Yoast SEO Plugin filter. Thanks to Christian Werner
305 +
306 + 1.2.6.7 2016/03/17 Security fix
307 +
308 + 1.2.6.6 2015/03/09 Hide UAM at the backend from normal users.
309 + Change IP range logic. Thanks to Takanashi
310 + Fix issue with roles.
311 +
312 + 1.2.6.5 2015/03/02 Fix install/update missing table issue.
313 +
314 + 1.2.6.4 2015/02/26 Fix database update issue.
315 +
316 + 1.2.6.3 2015/02/25 Fix database update for multi sites.
317 + Fix array_keys warning.
318 + Fix redirect loop.
319 +
320 + 1.2.6.2 2015/02/24 Fix not removable role affiliation issue.
321 +
322 + 1.2.6.1 2015/02/24 Remove deprecated php function mysql_get_server_info().
323 + Change object_id from varchar 11 to varchar 255.
324 + Fix backslashes issue.
325 +
326 + 1.2.6.0 2015/02/11 Remove unnecessary js library.
327 + Merge changes from https://github.com/nwoetzel/user-access-manager. Thanks for contribution.
328 +
329 + 1.2.5.0 2013/12/13 Improve performance. Thanks to all testers.
330 + Add bulk edit feature.
331 +
332 + 1.2.4.3 2013/05/08 Fix redirect if page is hidden and permalink is active issue.
333 + Fix no access issue.
334 +
335 + 1.2.4.2 2013/05/08 Fix pagination issue. Thanks to arjenbreur.
336 + Fix comment issue. Thanks to jpr105.
337 + Redirect if post/page is hidden and permalink is active.
338 + Change icon.
339 +
340 + 1.2.4.1 2013/05/06 Fix broken images issue.
341 + Fix duplicated key issue.
342 + Filter file types.
343 + Use wordpress mime types instead of the config array.
344 +
345 + 1.2.4 2013/05/01 Fix add column issue.
346 + Fix install bug.
347 + Fix error if no user is logged in. Thanks to Robert Egger and akiko.pusu.
348 + Fix media file issue.
349 + Optimize code.
350 +
351 + 1.2.3.1 2013/05/01 Fix terms issue.
352 +
353 + 1.2.3 2013/04/30 Fix Fatal 'error: Call-time pass-by-reference' error.
354 + Fix 'get_userdata() is not defined' error. Thanks to ranwaldo.
355 + Refactor many variable names to fit new coding style.
356 +
357 + 1.2.2 2011/04/03 Speed improvements.
358 + Fix get_term bug.
359 + Fix category bug
60 360
61 - 0.9.1.2 2009/03/29 Fix some path problems
62 - Add a reset function
63 - Rename menu at admin panel
361 + 1.2.1 2011/10/11 Fix uninstall bug.
362 + Add capability 'manage_user_groups'. Thanks to Tim Okrongli
363 + Some small improvements.
64 364
65 - 0.9.1.1 2009/03/26 Fix the empty category issue
365 + 1.2 2011/06/19 Add custom post types.
366 + Fix CSRF issue. Thanks to Luke Crouch
66 367
67 - 0.9.1 2009/03/26 Fix the database problem
68 - Fix feed bug. Thanks to Markus Brinkmann
69 - Fix wrong javascript path
368 + 1.1.4 2010/10/19 Fix error on custom post types
369 + Add warning for PHP version lower than 5.0
70 370
71 - 0.9 2009/03/24 Add login form
72 - Add option to show text bevor <!--more--> tag
73 - Fix write access issues
74 - Fix file issues
75 - Small fixes
371 + 1.1.3 2010/10/09 Add tag filter
372 + Fix media file bug for multisites
373 + Fix ip access bug
374 + Improve redirecting code
375 + Speed up
76 376
77 - 0.8.0.2 2009/03/09 Add French language file
78 - Delete .htaccess files on deactivation/uninstall
377 + 1.1.2 2010/10/04 Fix read/write access bug
378 + Add recursive looking for posts page option
379 + Improve network activation/update
380 + Add hooks for login bar
381 + Prepare for NextGEN Gallery extension
79 382
80 - 0.8.0.1 2009/03/06 Small fix
383 + 1.1.1.2 2010/09/29 Fix bug that a usergroup for a user wasn't saved
81 384
82 - 0.8 2009/03/05 Add write access control
83 - Add support down to 2.6
84 - Better file access control
85 - Code optimization - Plugin became faster
86 - Fix the category bug
87 - Small fixes
385 + 1.1.1.1 2010/09/29 Fix T_DNUMBER bug
88 386
89 - 0.7.0.1 2009/02/13 Small fixes
387 + 1.1.1 2010/09/29 Fix custom menu bug
388 + Fix quick edit bug
389 + Fix undefined object bug
390 + Extend admin hint
90 391
91 - 0.7 2009/02/13 Fix: All known Bugs of the beta
92 - Add ajax for more comfort
93 - Add language support
392 + 1.1 2010/09/28 Add plugin api
393 + Optimized code
394 + Improve content filtering
395 + Fix bug that user groups can't removed from element
396 + Fix empty category bug
397 + Fix pre/next post bug
398 + Fix login form bug
399 + Fix redirect bug
400 + Fix some other small bugs
94 401
95 - 0.7 Beta 2009/01/05 Fix: Problems with media at posts
96 - Fix: Many other small fixes
97 - Only support up to Wordpress 2.7
98 - Better integration
402 + 1.0.2 2010/07/24 Remove debugging code
403 + Fix file download bug
99 404
100 - 0.62 2008/12/18 Fix: Fatal error: Only variables can
101 - be passed by reference. Thanks to David Thompson
405 + 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
406 + Fix bug for recursive locking for categories
102 407
103 - 0.61 2008/12/17 Fix: Wrong file id in Media Library.
408 + 1.0 2010/07/22 Fix array_merge bug at media page
409 + Reorder some admin options
410 + Add some new admin functions
411 + Speed it up
412 + Disable file locking by default
413 +
414 + 1.0 Beta 2 2010/07/13 Fix performance issues
415 + Fix media gallery issues
416 + Fix category bug
417 + Fix not loaded translation
418 + Remove some unused functions
419 +
420 + 1.0 Beta 2010/07/09 Complete rewrite
421 + Some new options to improve the functions
422 +
423 + 0.9.1.4 2010/06/23 Hotfix for Wordpress 3.0
424 +
425 + 0.9.1.3 2009/07/17 Fix "header already send"-Problem with Wordpress 2.8.1
426 + Add option to set level with full access
427 +
428 + 0.9.1.2 2009/03/29 Fix some path problems
429 + Add a reset function
430 + Rename menu at admin panel
431 +
432 + 0.9.1.1 2009/03/26 Fix the empty category issue
433 +
434 + 0.9.1 2009/03/26 Fix the database problem
435 + Fix feed bug. Thanks to Markus Brinkmann
436 + Fix wrong javascript path
437 +
438 + 0.9 2009/03/24 Add login form
439 + Add option to show text bevor <!--more--> tag
440 + Fix write access issues
441 + Fix file issues
442 + Small fixes
443 +
444 + 0.8.0.2 2009/03/09 Add French language file
445 + Delete .htaccess files on deactivation/uninstall
446 +
447 + 0.8.0.1 2009/03/06 Small fix
448 +
449 + 0.8 2009/03/05 Add write access control
450 + Add support down to 2.6
451 + Better file access control
452 + Code optimization - Plugin became faster
453 + Fix the category bug
454 + Small fixes
455 +
456 + 0.7.0.1 2009/02/13 Small fixes
104 457
105 - 0.6 2007/12/14 First release.
458 + 0.7 2009/02/13 Fix: All known Bugs of the beta
459 + Add ajax for more comfort
460 + Add language support
461 +
462 + 0.7 Beta 2009/01/05 Fix: Problems with media at posts
463 + Fix: Many other small fixes
464 + Only support up to Wordpress 2.7
465 + Better integration
466 +
467 + 0.62 2008/12/18 Fix: Fatal error: Only variables can
468 + be passed by reference. Thanks to David Thompson
106 469
470 + 0.61 2008/12/17 Fix: Wrong file id in Media Library
107 471
108 -== Frequently Asked Questions ==
472 + 0.6 2007/12/14 First release.
109 473
110 -<strong>How works the User Access Manager?</strong>
111 474
112 -All posts/pages which are not in a user access group are accessable to all users. Posts/pages can put to groupes by themselfe, categories or recursive (most by pages).
475 +== Frequently Asked Questions ==
113 476
114 -<strong>How dose "Role affiliation" work?</strong>
477 +See: [https://github.com/GM-Alex/user-access-manager/wiki/FAQ](https://github.com/GM-Alex/user-access-manager/wiki/FAQ)
115 478
116 -This example will give you an overview:
117 -
118 -- Posts: Post1, Post2
119 -- Users: User1 (admin), User2 (subscriber), User3 (subscriber)
120 -
121 -Groups:
122 -
123 -- Group1: Users: User2, User3 | Posts: Post1 | Role affiliation: subscriber
124 -- Group2: Users: User3 | Posts: Post2 | Role affiliation: -
125 -
126 -Access:
127 -
128 -- Post1: User1 because he is a admin, User2 because he is in the group and a subscriber, User3 he is a subscriber (to this group all subscribers has access!)
129 -- Post2: User1 because he is a admin, User3 because he is in the group (only group members has access because there is no role affiliation!)
130 -
131 -<strong>I get an login box "WP-Files", what can I do?</strong>
132 -
133 -- You can deactivate the file locking at the UAM settings.
134 -- You can replace your media files in your posts. Just delete the old link and insert it again. (A new working link will generated)
135 -
136 -
137 479 == Screenshots ==
138 480
139 -1. The group manger.
140 -2. The setting screen.
141 -3. Integration at posts.
481 +1. The group manager.
482 +2. The setting screen
483 +3. The setup screen.
484 +4. Integration into post overview.