PluginProbe
User Access Manager / 2.2.9
User Access Manager v2.2.9
2.3.20 2.3.19 2.3.18 2.3.17 2.3.16 2.3.15 2.3.14 2.3.13 trunk 0.6 0.6.1 0.6.2 0.7 0.7 Beta 0.7.0.1 0.8 0.8.0.1 0.8.0.2 0.9 0.9.1 0.9.1.1 0.9.1.2 0.9.1.3 0.9.1.4 1.0 All 136 releases
← All changes | readme.txt +407 -19 0.6.1 → 2.2.9 View file →
@@ -1,53 +1,441 @@
1 1 === User Access Manager ===
2 2 Contributors: GM_Alex
3 3 Donate link: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=1947052
4 -Tags: user access manager, access, member area, user management, private, privacy, admin
5 -Requires at least: 2.6
6 -Tested up to: 2.6
7 -Stable tag: 0.6.1
4 +Tags: admin, access, member area, members, member, member access, page, pages, post, posts, private, privacy, restrict, user, user access manager, user management
5 +Requires at least: 4.7
6 +Tested up to: 5.6
7 +Stable tag: 2.2.9
8 8
9 9 With the "User Access Manager"-plugin you can manage the access to your posts, pages and files.
10 10
11 11 == Description ==
12 12
13 -With the "User Access Manager"-plugin you can manage the access to your posts, pages and files. You only create a user group, put registered users to this and set up the rights for this group. From now the post/page is only accessible for the specified group. This plugin is useful if you need a member area or a private section at your blog.
13 +The “User Access Manager”-plugin for Wordpress allows you to manage the access of your content. This is useful if you need a member area, a private section at your blog or you want that other people can write at your blog but not everywhere. Including all post type (post, pages etc.), taxonomies (categories etc.) and files by creating user groups. Just assign the content you want to restrict und and your registered users which should have a access to a group. From now on the content is only accessible and writable for the specified group.
14 14
15 -Feature list
15 +<em>Feature list</em>
16 16
17 17 * User groups
18 -* User-defined post/page title (if no access)
19 -* User-defined post/page text (if no access)
20 -* Hide complete post/page
21 -* Hide pages in navigation
18 +* Set separate access for readers and editors
19 +* Set access by user groups
20 +* Set default user groups
21 +* Set time based access
22 +* User-defined post type (posts, pages etc.) title (if no access)
23 +* User-defined post type (posts, pages etc.) text (if no access)
24 +* Optional login form (if no access)
25 +* User-defined comment text (if no access)
26 +* Hide complete post types (posts, pages etc.)
27 +* Hide elements in the navigation
22 28 * Redirecting users to other pages (if no access)
23 -* Recursive locking of posts/pages
29 +* Recursive locking of content
24 30 * Limited access to uploaded files
31 +* Full integrated at the admin panel
32 +* Multilingual support
33 +* Also protect your rss feeds
34 +* Give access by IP-address
35 +* Plugin-Api to use the User Access Manager in your on plugins or extend other plugins
36 +* [UAMPPE](https://wordpress.org/plugins/user-access-manager-private-public-extension/) like behaviour is now build in (Expect negation like !groupName and showprivate and shownotauthorized parameter)
25 37
26 -For a German description visit my page at [GMAlex](http://www.gm-alex.de/projects/wordpress/plugins/user-access-manager/ "GMAlex - deviant design and development"). If you have any problem or suggestions please [contact me](mailto:[email protected]).
38 +<em>Included languages</em>
27 39
40 +See [https://translate.wordpress.org/projects/wp-plugins/user-access-manager](https://translate.wordpress.org/projects/wp-plugins/user-access-manager)
28 41
42 +The documentation can be found here: [https://github.com/GM-Alex/user-access-manager/wiki](https://github.com/GM-Alex/user-access-manager/wiki)
43 +Please report bugs and feature requests here: [https://github.com/GM-Alex/user-access-manager/issues](https://github.com/GM-Alex/user-access-manager/issues)
44 +If you are a developer and want to contribute please visit [https://github.com/GM-Alex/user-access-manager](https://github.com/GM-Alex/user-access-manager)
45 +For general questions, like how to setup, best practice and so on please use the support thread here (don't post issues here): [https://wordpress.org/support/plugin/user-access-manager](https://wordpress.org/support/plugin/user-access-manager)
46 +To stay up-to-date follow me on twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
47 +
48 +
29 49 == Installation ==
30 -
31 -1. Upload the full directory into your wp-content/plugins directory
50 +
51 +1. Upload the full directory, with the folder, into your wp-content/plugins directory
32 52 1. Activate the plugin through the 'Plugins' menu in WordPress
33 53 1. Enjoy
34 54
35 55
36 -== Contributors/Changelog ==
56 +== Changelog ==
37 57
38 58 Here you found the changes in each version.
39 59
40 - Version Date Changes
60 + Version Date Changes
61 +
62 + 2.2.9 2021/02/24 Type fixes for Yoast seo plugin.
63 + Fix some other type issues.
64 +
65 + 2.2.8 2021/02/21 Some cleanup.
66 + Type fixes for the short controller.
67 + Fix some possible php notices and warnings.
68 +
69 + 2.2.7 2021/02/14 Fix issue with isAdmin.
70 +
71 + 2.2.6 2021/02/14 Fix more possible type errors.
72 +
73 + 2.2.5 2021/02/14 Fix more possible type errors if wordpress switches int to string.
74 +
75 + 2.2.4 2021/02/13 Fix type error for user object controller.
76 + Fix type error for the wordpress wrapper.
77 +
78 + 2.2.3 2021/02/13 Fix warning at settings page.
79 + Fix type error for user group handler.
80 +
81 + 2.2.2 2021/02/13 Fix type error with login form.
82 +
83 + 2.2.1 2021/02/13 Fix type error with registeredTaxonomy.
84 +
85 + 2.2.0 2021/02/11 Improve and update code base.
86 + Fix possible update bug.
87 +
88 + 2.1.12 2019/01/08 Fix multi site file handling issue. #222
89 +
90 + 2.1.11 2018/03/16 Fix missing got_mod_rewrite function. #212
91 + Fix wrong media urls. #207
92 + Fix wrong post counts at the admin panel.
93 + Improve database updates/repairs.
94 +
95 +
96 + 2.1.10 2017/12/15 Fix Posts removed from WP_Query results in Ajax requests for unprivileged users #176
97 + Improve partly download handler
98 + Suppress errors on file delivery
99 + Improve error handling
100 + Change blog switch handling. fixes #194
101 + Fix wrong parameter name. fixes #191
102 + Improve user group sorting. closes #180
103 + Add new redirect type to the login page. closes #155
104 + Add dynamic user groups for exclude object calculation. closes #181
105 + Add filter for getUserUserGroupsForObjectAccess. closes #157
106 + Make it possible to set a default group for new media files.
107 +
108 + 2.1.9 2017/11/18 Add show content before <!--more--> tag option for all post types
109 + Fix js time input issue
110 + Fix small prepare query issue
111 + Don't switch to edit mode after user group creation #171
112 + Add sortable columns for user groups list #172
113 + Show no access image again instead of broken image
114 + Fix double user group form for media files
115 + Add option to hide the edit page option if the user doesn't have the right to edit this page #174
116 +
117 + 2.1.8 2017/11/07 Add getter for the user group handler fixes #160
118 + Fix multi site file handling issue #159
119 +
120 + 2.1.7 2017/11/01 Improve database update prompt fixes #153
121 + Fix user group selection not saved when adding a new user issue fixes #154
122 + Add none read access option for user groups closes #144
123 + Extend file settings
124 + Add xsendfile support
125 +
126 + 2.1.6 2017/10/20 Fix "Inherited group membership for media attachments" issue #133
127 + Fix traits strict warning #145
128 +
129 + 2.1.5 2017/10/12 Refactor traits
130 + Fix datetime issue with not supported browsers
131 +
132 + 2.1.4 2017/10/10 Fix strict warnings #134
133 + Fix "Unable to select default user group for both page and post" issue #126
134 + Add NGINX reverse proxy handling #117
135 + Improve code
136 + Fix bulk edit issue #135
137 + Fix array filly issue #138
138 + Add database repair tool
139 +
140 + 2.1.3 2017/09/18 Possible fix for custom post types / taxonomies issues
141 + Fix .htaccess deletion issue
142 +
143 + 2.1.2 2017/09/17 Fix issue with not handled taxonomies #123
144 +
145 + 2.1.1 2017/09/16 Fix issue for users with small innodb page size #121
146 +
147 + 2.1.0 2017/09/15 Refactor code
148 + Implement content tags for partly restriction like UAMPPE #84
149 + Add default user groups
150 + Add time based access
151 + Add dynamic user groups #64
152 + Implement caching #75
153 + Allow html as no access content #63 #93
154 + Optimize settings screen #61
155 + Support of partial download #118
156 + Add option to toggle visibility of assigned groups text next to the edit link #111
157 + Fix incorrectly retrieving of a ID for attachments/media #116
158 +
159 + 2.0.13 2017/07/26 Add ipv6 support - Fix issue #97
160 + Change "Hide Comments" logic - Fix issue #100
161 + Fix rewrite base issue - Fix issue #107 and #103
162 + Fix vsprintf warning - Fix issue #105
163 + Fix Relevanssi compatibility issue
164 + Fix missing feature picture if file locking is disabled
165 +
166 + 2.0.12 2017/06/16 Fix media file group issue #74
167 + Fix broken file includes / excludes
168 + Fix wordpress filter issue
169 + Fix access to own post #95
170 +
171 + 2.0.11 2017/05/18 Fix FrontendController::postsPreQuery() expected to be a reference, value given error
172 +
173 + 2.0.10 2017/05/17 Fix issue of not saved groups #74
174 + Adjust password lost link #79
175 + Improve attachment access checks #78
176 + Fix not working redirect
177 +
178 + 2.0.9 2017/05/13 Improve security #76
179 +
180 + 2.0.8 2017/05/08 Fix missing rss feed if protection is disabled #68
181 +
182 + 2.0.7 2017/05/07 Fix category tree issues #59
183 + Fix mysql database errors on strict mode #60
184 + Fix possible path issue
185 + Remove settings for post_format post type (which is used for internal propose)
186 + Fix wrong database update prompt
187 + Fix issue with asgaros from #66
188 +
189 + 2.0.6 2017/04/28 Improve http error codes #24
190 + Fix wrong url on windows servers #53
191 + Fix missing install routine #51
192 +
193 + 2.0.5 2017/04/27 Fix switch_to_blog issue
194 + Fix file handling issues
195 +
196 + 2.0.4 2017/04/26 Adjust code so that php version is checked before throwing a fatal error
197 + Improve login form #26
198 + Fix soliloquy slider incompatibility #31
199 + Improve performance #41
200 +
201 + 2.0.3 2017/04/25 Fix compatibility issue with CMS Tree Page View plugin #37
202 + Fix compatibility issue with SEO Redirection plugin #38
203 + Fix Error thrown: Class 'WP_Site_Query' not found issue #36
204 +
205 + 2.0.2 2017/04/24 Fix wp_get_current_user() error #34
206 + Fix custom post save issue after database update #33
207 +
208 + 2.0.1 2017/04/23 Fix dbDelta issue on activation
209 +
210 + 2.0.0 2017/04/23 Refactoring of the module
211 + Improve performance
212 + Full support for custom post and taxonomies.
213 + Use translate.wordpress.org for translations
214 + Many improvements and fixes
215 +
216 + 1.2.14 2017/01/07 Fix IP access issue.
217 + Some small optimization.
218 +
219 + 1.2.13 2017/01/04 Fix tag count issue.
220 +
221 + 1.2.12 2017/01/03 Fix tag issue.
222 + Improve usability of the setup page.
223 +
224 + 1.2.11 2017/01/02 Restore hide categories behaviour.
225 +
226 + 1.2.10 2017/01/02 Improve mysql query to prevent against possible collations issue.
227 +
228 + 1.2.9 2017/01/01 Fix wrong category count.
229 + Hide pages without access at the administration panel.
230 + Fix redirect problems.
231 +
232 + 1.2.8 2016/12/31 Fix wrong term behavior for the backend.
233 + Require at least PHP 5.3
234 +
235 + 1.2.7.6 2016/12/28 Fix ip restriction issue.
236 + Fix missing categories issue.
237 +
238 + 1.2.7.5 2016/12/27 Improve taxonomy handling.
239 + Improve performance.
240 + Add missing wp-cli.php file.
241 + Refactor config handling.
242 + Fix Yoast SEO Plugin issue.
243 + Some other small fixes.
244 +
245 + 1.2.7.4 2016/12/08 Fix some issues related to Wordpress 4.7
246 +
247 + 1.2.7.3 2016/12/08 Fix empty category issue.
248 +
249 + 1.2.7.2 2016/12/07 Hot fix for Wordpress 4.7
250 +
251 + 1.2.7.1 2016/12/04 Remove deprecated function get_currentuserinfo
252 +
253 + 1.2.7.0 2016/11/30 Add experimental nginx support
254 + Fix redirect issue (Thanks to Laurence Shaw for the hint and James Riordon for the fix)
255 +
256 + 1.2.6.10 2016/10/07 Again a security fix
257 +
258 + 1.2.6.9 2016/10/06 Security fix
259 +
260 + 1.2.6.8 2016/08/15 Security fix
261 + Add Yoast SEO Plugin filter. Thanks to Christian Werner
262 +
263 + 1.2.6.7 2016/03/17 Security fix
264 +
265 + 1.2.6.6 2015/03/09 Hide UAM at the backend from normal users.
266 + Change IP range logic. Thanks to Takanashi
267 + Fix issue with roles.
268 +
269 + 1.2.6.5 2015/03/02 Fix install/update missing table issue.
270 +
271 + 1.2.6.4 2015/02/26 Fix database update issue.
272 +
273 + 1.2.6.3 2015/02/25 Fix database update for multi sites.
274 + Fix array_keys warning.
275 + Fix redirect loop.
276 +
277 + 1.2.6.2 2015/02/24 Fix not removable role affiliation issue.
278 +
279 + 1.2.6.1 2015/02/24 Remove deprecated php function mysql_get_server_info().
280 + Change object_id from varchar 11 to varchar 255.
281 + Fix backslashes issue.
282 +
283 + 1.2.6.0 2015/02/11 Remove unnecessary js library.
284 + Merge changes from https://github.com/nwoetzel/user-access-manager. Thanks for contribution.
285 +
286 + 1.2.5.0 2013/12/13 Improve performance. Thanks to all testers.
287 + Add bulk edit feature.
288 +
289 + 1.2.4.3 2013/05/08 Fix redirect if page is hidden and permalink is active issue.
290 + Fix no access issue.
291 +
292 + 1.2.4.2 2013/05/08 Fix pagination issue. Thanks to arjenbreur.
293 + Fix comment issue. Thanks to jpr105.
294 + Redirect if post/page is hidden and permalink is active.
295 + Change icon.
296 +
297 + 1.2.4.1 2013/05/06 Fix broken images issue.
298 + Fix duplicated key issue.
299 + Filter file types.
300 + Use wordpress mime types instead of the config array.
301 +
302 + 1.2.4 2013/05/01 Fix add column issue.
303 + Fix install bug.
304 + Fix error if no user is logged in. Thanks to Robert Egger and akiko.pusu.
305 + Fix media file issue.
306 + Optimize code.
307 +
308 + 1.2.3.1 2013/05/01 Fix terms issue.
309 +
310 + 1.2.3 2013/04/30 Fix Fatal 'error: Call-time pass-by-reference' error.
311 + Fix 'get_userdata() is not defined' error. Thanks to ranwaldo.
312 + Refactor many variable names to fit new coding style.
313 +
314 + 1.2.2 2011/04/03 Speed improvements.
315 + Fix get_term bug.
316 + Fix category bug
41 317
42 - 0.61 2008/12/17 Fix: Wrong file id in Media Library.
318 + 1.2.1 2011/10/11 Fix uninstall bug.
319 + Add capability 'manage_user_groups'. Thanks to Tim Okrongli
320 + Some small improvements.
321 +
322 + 1.2 2011/06/19 Add custom post types.
323 + Fix CSRF issue. Thanks to Luke Crouch
324 +
325 + 1.1.4 2010/10/19 Fix error on custom post types
326 + Add warning for PHP version lower than 5.0
327 +
328 + 1.1.3 2010/10/09 Add tag filter
329 + Fix media file bug for multisites
330 + Fix ip access bug
331 + Improve redirecting code
332 + Speed up
333 +
334 + 1.1.2 2010/10/04 Fix read/write access bug
335 + Add recursive looking for posts page option
336 + Improve network activation/update
337 + Add hooks for login bar
338 + Prepare for NextGEN Gallery extension
339 +
340 + 1.1.1.2 2010/09/29 Fix bug that a usergroup for a user wasn't saved
341 +
342 + 1.1.1.1 2010/09/29 Fix T_DNUMBER bug
343 +
344 + 1.1.1 2010/09/29 Fix custom menu bug
345 + Fix quick edit bug
346 + Fix undefined object bug
347 + Extend admin hint
348 +
349 + 1.1 2010/09/28 Add plugin api
350 + Optimized code
351 + Improve content filtering
352 + Fix bug that user groups can't removed from element
353 + Fix empty category bug
354 + Fix pre/next post bug
355 + Fix login form bug
356 + Fix redirect bug
357 + Fix some other small bugs
358 +
359 + 1.0.2 2010/07/24 Remove debugging code
360 + Fix file download bug
361 +
362 + 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
363 + Fix bug for recursive locking for categories
364 +
365 + 1.0 2010/07/22 Fix array_merge bug at media page
366 + Reorder some admin options
367 + Add some new admin functions
368 + Speed it up
369 + Disable file locking by default
370 +
371 + 1.0 Beta 2 2010/07/13 Fix performance issues
372 + Fix media gallery issues
373 + Fix category bug
374 + Fix not loaded translation
375 + Remove some unused functions
376 +
377 + 1.0 Beta 2010/07/09 Complete rewrite
378 + Some new options to improve the functions
379 +
380 + 0.9.1.4 2010/06/23 Hotfix for Wordpress 3.0
381 +
382 + 0.9.1.3 2009/07/17 Fix "header already send"-Problem with Wordpress 2.8.1
383 + Add option to set level with full access
384 +
385 + 0.9.1.2 2009/03/29 Fix some path problems
386 + Add a reset function
387 + Rename menu at admin panel
388 +
389 + 0.9.1.1 2009/03/26 Fix the empty category issue
390 +
391 + 0.9.1 2009/03/26 Fix the database problem
392 + Fix feed bug. Thanks to Markus Brinkmann
393 + Fix wrong javascript path
394 +
395 + 0.9 2009/03/24 Add login form
396 + Add option to show text bevor <!--more--> tag
397 + Fix write access issues
398 + Fix file issues
399 + Small fixes
400 +
401 + 0.8.0.2 2009/03/09 Add French language file
402 + Delete .htaccess files on deactivation/uninstall
403 +
404 + 0.8.0.1 2009/03/06 Small fix
405 +
406 + 0.8 2009/03/05 Add write access control
407 + Add support down to 2.6
408 + Better file access control
409 + Code optimization - Plugin became faster
410 + Fix the category bug
411 + Small fixes
412 +
413 + 0.7.0.1 2009/02/13 Small fixes
43 414
44 - 0.6 2007/12/14 First release.
415 + 0.7 2009/02/13 Fix: All known Bugs of the beta
416 + Add ajax for more comfort
417 + Add language support
418 +
419 + 0.7 Beta 2009/01/05 Fix: Problems with media at posts
420 + Fix: Many other small fixes
421 + Only support up to Wordpress 2.7
422 + Better integration
423 +
424 + 0.62 2008/12/18 Fix: Fatal error: Only variables can
425 + be passed by reference. Thanks to David Thompson
45 426
427 + 0.61 2008/12/17 Fix: Wrong file id in Media Library
46 428
429 + 0.6 2007/12/14 First release.
47 430
48 431
432 +== Frequently Asked Questions ==
49 433
434 +See: [https://github.com/GM-Alex/user-access-manager/wiki/FAQ](https://github.com/GM-Alex/user-access-manager/wiki/FAQ)
435 +
50 436 == Screenshots ==
51 437
52 438 1. The group manger.
53 -
439 +2. The setting screen
440 +3. The setup screen.
441 +4. Integration into post overview.