PluginProbe
User Access Manager / 2.3.4
User Access Manager v2.3.4
2.3.20 2.3.19 2.3.18 2.3.17 2.3.16 2.3.15 2.3.14 2.3.13 trunk 0.6 0.6.1 0.6.2 0.7 0.7 Beta 0.7.0.1 0.8 0.8.0.1 0.8.0.2 0.9 0.9.1 0.9.1.1 0.9.1.2 0.9.1.3 0.9.1.4 1.0 All 136 releases
← All changes | readme.txt +451 -73 0.9 → 2.3.4 View file →
@@ -1,54 +1,62 @@
1 1 === User Access Manager ===
2 2 Contributors: GM_Alex
3 3 Donate link: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=1947052
4 -Tags: admin, access, member area, members, page, pages, post, posts, private, privacy, restrict, user, user access manager, user management
5 -Requires at least: 2.6
6 -Tested up to: 2.7.1
7 -Stable tag: 0.9
4 +Tags: member access, user access manager, user management, access
5 +Requires at least: 4.7
6 +Requires PHP: 8.0
7 +Tested up to: 6.9
8 +Stable tag: 2.3.4
9 +License: GPLv2 or later
10 +License URI: https://www.gnu.org/licenses/gpl-2.0.html
8 11
9 12 With the "User Access Manager"-plugin you can manage the access to your posts, pages and files.
10 13
11 14 == Description ==
12 15
13 -With the "User Access Manager"-plugin you can manage the access to your posts, pages and files. You only create a user group, put registered users to this and set up the rights for this group. From now on the post/page is only accessible and writable for the specified group. This plugin is useful if you need a member area or a private section at your blog or you want that other people can write at your blog but not everywhere.
16 +The “User Access Manager”-plugin for WordPress allows you to manage the access of your content. This is useful if you need a member area, a private section at your blog, or you want that other people can write at your blog but not everywhere. Including all post type (post, pages etc.), taxonomies (categories etc.) and files by creating user groups. Just assign the content you want to restrict und and your registered users which should have access to a group. From now on the content is only accessible and writable for the specified group.
14 17
18 +<em>Try it out</em>
19 +
20 +You can try it out at TasteWP.com before install: [Try user access manager](https://demo.tastewp.com/user-access-manager?a=jlQ7F1va) (affiliate link)
21 +
15 22 <em>Feature list</em>
16 23
17 24 * User groups
18 -* Set seperate access for readers and editors
25 +* Set separate access for readers and editors
19 26 * Set access by user groups
20 -* Set access by post categories
21 -* User-defined post/page title (if no access)
22 -* User-defined post/page text (if no access)
27 +* Set default user groups
28 +* Set time based access
29 +* User-defined post type (posts, pages etc.) title (if no access)
30 +* User-defined post type (posts, pages etc.) text (if no access)
23 31 * Optional login form (if no access)
24 32 * User-defined comment text (if no access)
25 -* Hide complete post/page
26 -* Hide pages in navigation
33 +* Hide complete post types (posts, pages etc.)
34 +* Hide elements in the navigation
27 35 * Redirecting users to other pages (if no access)
28 -* Recursive locking of posts/pages
36 +* Recursive locking of content
29 37 * Limited access to uploaded files
30 38 * Full integrated at the admin panel
31 -* Multilanguage support
32 -* Also proteced your rss feeds
39 +* Multilingual support
40 +* Also protect your rss feeds
33 41 * Give access by IP-address
42 +* Plugin-Api to use the User Access Manager in your on plugins or extend other plugins
43 +* [UAMPPE](https://wordpress.org/plugins/user-access-manager-private-public-extension/) like behaviour is now build in (Expect negation like !groupName and showprivate and shownotauthorized parameter)
34 44
35 45 <em>Included languages</em>
36 46
37 -* English
38 -* German
39 -* Czech, base on 0.7.0.1. Thanks to Huska
40 -* French, base on 0.8.0.2. Thanks to macbidule
47 +See [https://translate.wordpress.org/projects/wp-plugins/user-access-manager](https://translate.wordpress.org/projects/wp-plugins/user-access-manager)
41 48
42 -<strong>Note</strong>: At this release you can replace one core files, because I need some hooks which are not created by the Wordpress-Team for the better integration. I've send them a diff patch and this will add in Wordpress 2.8, so you can trust this modification (see <a href="http://trac.wordpress.org/changeset/10292">http://trac.wordpress.org/changeset/10292</a>). <strong>This core modification is not needed and only optional, but it gives you more comfort.</strong>
49 +The documentation can be found here: [https://github.com/GM-Alex/user-access-manager/wiki](https://github.com/GM-Alex/user-access-manager/wiki)
50 +Please report bugs and feature requests here: [https://github.com/GM-Alex/user-access-manager/issues](https://github.com/GM-Alex/user-access-manager/issues)
51 +If you are a developer and want to contribute please visit [https://github.com/GM-Alex/user-access-manager](https://github.com/GM-Alex/user-access-manager)
52 +For general questions, like how to set up, best practice and so on please use the support thread here (don't post issues here): [https://wordpress.org/support/plugin/user-access-manager](https://wordpress.org/support/plugin/user-access-manager)
53 +To stay up-to-date follow me on Twitter: [GMAlex on Twitter](http://twitter.com/GM_Alex)
43 54
44 -For a German description visit my page at [GMAlex](http://www.gm-alex.de/projects/wordpress/plugins/user-access-manager/ "GMAlex - deviant design and development"). If you have any problem, suggestions or make a translation please [contact me](mailto:[email protected]).
45 55
56 +== Installation ==
46 57
47 -== Installation ==
48 -
49 58 1. Upload the full directory, with the folder, into your wp-content/plugins directory
50 -1. Replace the following files in the wp-admin dir with the files at 'core_files' or use the patches: 'includes/template.php'
51 59 1. Activate the plugin through the 'Plugins' menu in WordPress
52 60 1. Enjoy
53 61
54 62
@@ -55,72 +63,442 @@
55 63 == Changelog ==
56 64
57 65 Here you found the changes in each version.
58 66
59 - Version Date Changes
67 + Version Date Changes
68 +
69 + 2.3.4 2025/12/09 Improve type compatibility again
70 +
71 + 2.3.3 2025/12/09 Improve compatibility again
72 +
73 + 2.3.2 2025/12/09 Adjust wordpress wrapper
74 +
75 + 2.3.1 2025/12/09 Fix possible type error
76 +
77 + 2.3.0 2025/12/09 Require now PHP 8.0
78 + Remove strftime
79 + Fix some issues
80 +
81 + 2.2.25 2025/04/22 Fixed problem with fix load_textdomain
82 +
83 + 2.2.24 2025/04/17 Fix deprecated warnings
84 + Fixed problem with load_textdomain Thanks to Christian Ludwig (chludwig)
85 +
86 + 2.2.23 2023/05/26 Fix typos
87 + Fix version_compare
88 +
89 + 2.2.22 2023/05/26 Minor change
90 +
91 + 2.2.21 2023/05/25 Adjust database compatibility #368
92 +
93 + 2.2.20 2023/03/08 Fix warning
94 +
95 + 2.2.19 2022/11/18 Add try out link
96 +
97 + 2.2.18 2022/11/14 Fix issue with label id. Thanks to elbakkali
98 + Add elementor support. Thanks to JboyJW
99 + Fix possible issue with PHP 8. Thanks to ollycross
100 + Fix attachment issue.
101 + Fix tags issue.
102 + Make extra IP header configurable.
103 +
104 + 2.2.17 2022/02/15 Fix issue with big picture handling. #350
105 +
106 + 2.2.16 2022/01/25 Check compatibility for WordPress 5.9.
107 +
108 + 2.2.15 2021/06/07 Fix possible type issues.
109 +
110 + 2.2.14 2021/04/21 Fix bulk edit.
111 + Fix permission issue.
112 + Fix redirect typing issue.
113 +
114 + 2.2.13 2021/04/15 Fix not logged-in user handling.
115 + Type fix for showEditLink.
116 +
117 + 2.2.12 2021/04/14 Fix warning.
118 + Fix jquery deprecation warning.
119 +
120 + 2.2.11 2021/03/15 Type fix for showEditLink.
121 + Set compatibility tag for WordPress 5.7.
122 +
123 + 2.2.10 2021/02/26 Lower minimum php version to 7.2.
124 +
125 + 2.2.9 2021/02/24 Type fixes for Yoast SEO plugin.
126 + Fix some other type issues.
127 +
128 + 2.2.8 2021/02/21 Some cleanup.
129 + Type fixes for the short controller.
130 + Fix some possible php notices and warnings.
131 +
132 + 2.2.7 2021/02/14 Fix issue with isAdmin.
133 +
134 + 2.2.6 2021/02/14 Fix more possible type errors.
135 +
136 + 2.2.5 2021/02/14 Fix more possible type errors if WordPress switches int to string.
137 +
138 + 2.2.4 2021/02/13 Fix type error for user object controller.
139 + Fix type error for the WordPress wrapper.
140 +
141 + 2.2.3 2021/02/13 Fix warning at settings page.
142 + Fix type error for user group handler.
143 +
144 + 2.2.2 2021/02/13 Fix type error with login form.
145 +
146 + 2.2.1 2021/02/13 Fix type error with registeredTaxonomy.
147 +
148 + 2.2.0 2021/02/11 Improve and update code base.
149 + Fix possible update bug.
150 +
151 + 2.1.12 2019/01/08 Fix multi-site file handling issue. #222
152 +
153 + 2.1.11 2018/03/16 Fix missing got_mod_rewrite function. #212
154 + Fix wrong media urls. #207
155 + Fix wrong post counts at the admin panel.
156 + Improve database updates/repairs.
157 +
158 +
159 + 2.1.10 2017/12/15 Fix Posts removed from WP_Query results in Ajax requests for unprivileged users #176
160 + Improve partly download handler
161 + Suppress errors on file delivery
162 + Improve error handling
163 + Change blog switch handling. fixes #194
164 + Fix wrong parameter name. fixes #191
165 + Improve user group sorting. closes #180
166 + Add new redirect type to the login page. closes #155
167 + Add dynamic user groups for exclude object calculation. closes #181
168 + Add filter for getUserUserGroupsForObjectAccess. closes #157
169 + Make it possible to set a default group for new media files.
170 +
171 + 2.1.9 2017/11/18 Add show content before <!--more--> tag option for all post types
172 + Fix js time input issue
173 + Fix small prepare query issue
174 + Don't switch to edit mode after user group creation #171
175 + Add sortable columns for user groups list #172
176 + Show no access image again instead of broken image
177 + Fix double user group form for media files
178 + Add option to hide the edit page option if the user doesn't have the right to edit this page #174
179 +
180 + 2.1.8 2017/11/07 Add getter for the user group handler fixes #160
181 + Fix multi-site file handling issue #159
182 +
183 + 2.1.7 2017/11/01 Improve database update prompt fixes #153
184 + Fix user group selection not saved when adding a new user issue fixes #154
185 + Add none read access option for user groups closes #144
186 + Extend file settings
187 + Add xsendfile support
188 +
189 + 2.1.6 2017/10/20 Fix "Inherited group membership for media attachments" issue #133
190 + Fix traits strict warning #145
191 +
192 + 2.1.5 2017/10/12 Refactor traits
193 + Fix datetime issue with not supported browsers
194 +
195 + 2.1.4 2017/10/10 Fix strict warnings #134
196 + Fix "Unable to select default user group for both page and post" issue #126
197 + Add NGINX reverse proxy handling #117
198 + Improve code
199 + Fix bulk edit issue #135
200 + Fix array filly issue #138
201 + Add database repair tool
202 +
203 + 2.1.3 2017/09/18 Possible fix for custom post types / taxonomies issues
204 + Fix .htaccess deletion issue
205 +
206 + 2.1.2 2017/09/17 Fix issue with not handled taxonomies #123
207 +
208 + 2.1.1 2017/09/16 Fix issue for users with small innodb page size #121
209 +
210 + 2.1.0 2017/09/15 Refactor code
211 + Implement content tags for partly restriction like UAMPPE #84
212 + Add default user groups
213 + Add time based access
214 + Add dynamic user groups #64
215 + Implement caching #75
216 + Allow html as no access content #63 #93
217 + Optimize settings screen #61
218 + Support of partial download #118
219 + Add option to toggle visibility of assigned groups text next to the edit link #111
220 + Fix incorrectly retrieving of an ID for attachments/media #116
221 +
222 + 2.0.13 2017/07/26 Add ipv6 support - Fix issue #97
223 + Change "Hide Comments" logic - Fix issue #100
224 + Fix rewrite base issue - Fix issue #107 and #103
225 + Fix vsprintf warning - Fix issue #105
226 + Fix Relevanssi compatibility issue
227 + Fix missing feature picture if file locking is disabled
228 +
229 + 2.0.12 2017/06/16 Fix media file group issue #74
230 + Fix broken file includes / excludes
231 + Fix WordPress filter issue
232 + Fix access to own post #95
233 +
234 + 2.0.11 2017/05/18 Fix FrontendController::postsPreQuery() expected to be a reference, value given error
235 +
236 + 2.0.10 2017/05/17 Fix issue of not saved groups #74
237 + Adjust password lost link #79
238 + Improve attachment access checks #78
239 + Fix not working redirect
240 +
241 + 2.0.9 2017/05/13 Improve security #76
242 +
243 + 2.0.8 2017/05/08 Fix missing rss feed if protection is disabled #68
244 +
245 + 2.0.7 2017/05/07 Fix category tree issues #59
246 + Fix mysql database errors on strict mode #60
247 + Fix possible path issue
248 + Remove settings for post_format post type (which is used for internal propose)
249 + Fix wrong database update prompt
250 + Fix issue with asgaros from #66
251 +
252 + 2.0.6 2017/04/28 Improve http error codes #24
253 + Fix wrong url on Windows servers #53
254 + Fix missing install routine #51
255 +
256 + 2.0.5 2017/04/27 Fix switch_to_blog issue
257 + Fix file handling issues
258 +
259 + 2.0.4 2017/04/26 Adjust code so that php version is checked before throwing a fatal error
260 + Improve login form #26
261 + Fix soliloquy slider incompatibility #31
262 + Improve performance #41
263 +
264 + 2.0.3 2017/04/25 Fix compatibility issue with CMS Tree Page View plugin #37
265 + Fix compatibility issue with SEO Redirection plugin #38
266 + Fix Error thrown: Class 'WP_Site_Query' not found issue #36
267 +
268 + 2.0.2 2017/04/24 Fix wp_get_current_user() error #34
269 + Fix custom post save issue after database update #33
270 +
271 + 2.0.1 2017/04/23 Fix dbDelta issue on activation
272 +
273 + 2.0.0 2017/04/23 Refactoring of the module
274 + Improve performance
275 + Full support for custom post and taxonomies.
276 + Use translate.wordpress.org for translations
277 + Many improvements and fixes
278 +
279 + 1.2.14 2017/01/07 Fix IP access issue.
280 + Some small optimization.
281 +
282 + 1.2.13 2017/01/04 Fix tag count issue.
283 +
284 + 1.2.12 2017/01/03 Fix tag issue.
285 + Improve usability of the setup page.
286 +
287 + 1.2.11 2017/01/02 Restore hide categories behaviour.
288 +
289 + 1.2.10 2017/01/02 Improve mysql query to prevent against possible collations issue.
290 +
291 + 1.2.9 2017/01/01 Fix wrong category count.
292 + Hide pages without access at the administration panel.
293 + Fix redirect problems.
294 +
295 + 1.2.8 2016/12/31 Fix wrong term behavior for the backend.
296 + Require at least PHP 5.3
297 +
298 + 1.2.7.6 2016/12/28 Fix ip restriction issue.
299 + Fix missing categories issue.
300 +
301 + 1.2.7.5 2016/12/27 Improve taxonomy handling.
302 + Improve performance.
303 + Add missing wp-cli.php file.
304 + Refactor config handling.
305 + Fix Yoast SEO Plugin issue.
306 + Some other small fixes.
307 +
308 + 1.2.7.4 2016/12/08 Fix some issues related to WordPress 4.7
309 +
310 + 1.2.7.3 2016/12/08 Fix empty category issue.
311 +
312 + 1.2.7.2 2016/12/07 Hot fix for WordPress 4.7
313 +
314 + 1.2.7.1 2016/12/04 Remove deprecated function get_currentuserinfo
315 +
316 + 1.2.7.0 2016/11/30 Add experimental nginx support
317 + Fix redirect issue (Thanks to Laurence Shaw for the hint and James Riordon for the fix)
318 +
319 + 1.2.6.10 2016/10/07 Again a security fix
320 +
321 + 1.2.6.9 2016/10/06 Security fix
322 +
323 + 1.2.6.8 2016/08/15 Security fix
324 + Add Yoast SEO Plugin filter. Thanks to Christian Werner
325 +
326 + 1.2.6.7 2016/03/17 Security fix
327 +
328 + 1.2.6.6 2015/03/09 Hide UAM at the backend from normal users.
329 + Change IP range logic. Thanks to Takanashi
330 + Fix issue with roles.
331 +
332 + 1.2.6.5 2015/03/02 Fix install/update missing table issue.
333 +
334 + 1.2.6.4 2015/02/26 Fix database update issue.
335 +
336 + 1.2.6.3 2015/02/25 Fix database update for multi sites.
337 + Fix array_keys warning.
338 + Fix redirect loop.
339 +
340 + 1.2.6.2 2015/02/24 Fix not removable role affiliation issue.
341 +
342 + 1.2.6.1 2015/02/24 Remove deprecated php function mysql_get_server_info().
343 + Change object_id from varchar 11 to varchar 255.
344 + Fix backslashes issue.
345 +
346 + 1.2.6.0 2015/02/11 Remove unnecessary js library.
347 + Merge changes from https://github.com/nwoetzel/user-access-manager. Thanks for contribution.
348 +
349 + 1.2.5.0 2013/12/13 Improve performance. Thanks to all testers.
350 + Add bulk edit feature.
351 +
352 + 1.2.4.3 2013/05/08 Fix redirect if page is hidden and permalink is active issue.
353 + Fix no access issue.
354 +
355 + 1.2.4.2 2013/05/08 Fix pagination issue. Thanks to arjenbreur.
356 + Fix comment issue. Thanks to jpr105.
357 + Redirect if post/page is hidden and permalink is active.
358 + Change icon.
359 +
360 + 1.2.4.1 2013/05/06 Fix broken images issue.
361 + Fix duplicated key issue.
362 + Filter file types.
363 + Use WordPress mime types instead of the config array.
364 +
365 + 1.2.4 2013/05/01 Fix add column issue.
366 + Fix install bug.
367 + Fix error if no user is logged in. Thanks to Robert Egger and akiko.pusu.
368 + Fix media file issue.
369 + Optimize code.
370 +
371 + 1.2.3.1 2013/05/01 Fix terms issue.
372 +
373 + 1.2.3 2013/04/30 Fix Fatal 'error: Call-time pass-by-reference' error.
374 + Fix 'get_userdata() is not defined' error. Thanks to ranwaldo.
375 + Refactor many variable names to fit new coding style.
376 +
377 + 1.2.2 2011/04/03 Speed improvements.
378 + Fix get_term bug.
379 + Fix category bug
60 380
61 - 0.9 2009/03/24 Add login form
62 - Add option to show text bevor <!--more--> tag
63 - Fix write access issues
64 - Fix file issues
65 - Small fixes
381 + 1.2.1 2011/10/11 Fix uninstall bug.
382 + Add capability 'manage_user_groups'. Thanks to Tim Okrongli
383 + Some small improvements.
66 384
67 - 0.8.0.2 2009/03/09 Add French language file
68 - Delete .htaccess files on deactivation/uninstall
385 + 1.2 2011/06/19 Add custom post types.
386 + Fix CSRF issue. Thanks to Luke Crouch
69 387
70 - 0.8.0.1 2009/03/06 Small fix
388 + 1.1.4 2010/10/19 Fix error on custom post types
389 + Add warning for PHP version lower than 5.0
71 390
72 - 0.8 2009/03/05 Add write access control
73 - Add support down to 2.6
74 - Better file access control
75 - Code optimization - Plugin became faster
76 - Fix the category bug
77 - Small fixes
391 + 1.1.3 2010/10/09 Add tag filter
392 + Fix media file bug for multisites
393 + Fix ip access bug
394 + Improve redirecting code
395 + Speed up
78 396
79 - 0.7.0.1 2009/02/13 Small fixes
397 + 1.1.2 2010/10/04 Fix read/write access bug
398 + Add recursive looking for posts page option
399 + Improve network activation/update
400 + Add hooks for login bar
401 + Prepare for NextGEN Gallery extension
80 402
81 - 0.7 2009/02/13 Fix: All known Bugs of the beta
82 - Add ajax for more comfort
83 - Add language support
403 + 1.1.1.2 2010/09/29 Fix bug that an usergroup for a user wasn't saved
84 404
85 - 0.7 Beta 2009/01/05 Fix: Problems with media at posts
86 - Fix: Many other small fixes
87 - Only support up to Wordpress 2.7
88 - Better integration
405 + 1.1.1.1 2010/09/29 Fix T_DNUMBER bug
89 406
90 - 0.62 2008/12/18 Fix: Fatal error: Only variables can
91 - be passed by reference. Thanks to David Thompson
407 + 1.1.1 2010/09/29 Fix custom menu bug
408 + Fix quick edit bug
409 + Fix undefined object bug
410 + Extend admin hint
92 411
93 - 0.61 2008/12/17 Fix: Wrong file id in Media Library.
412 + 1.1 2010/09/28 Add plugin api
413 + Optimized code
414 + Improve content filtering
415 + Fix bug that user groups can't be removed from element
416 + Fix empty category bug
417 + Fix pre/next post bug
418 + Fix login form bug
419 + Fix redirect bug
420 + Fix some other small bugs
421 +
422 + 1.0.2 2010/07/24 Remove debugging code
423 + Fix file download bug
424 +
425 + 1.0.1 2010/07/24 Fix bug that only one user can be a member of a user group
426 + Fix bug for recursive locking for categories
427 +
428 + 1.0 2010/07/22 Fix array_merge bug at media page
429 + Reorder some admin options
430 + Add some new admin functions
431 + Speed it up
432 + Disable file locking by default
433 +
434 + 1.0 Beta 2 2010/07/13 Fix performance issues
435 + Fix media gallery issues
436 + Fix category bug
437 + Fix not loaded translation
438 + Remove some unused functions
439 +
440 + 1.0 Beta 2010/07/09 Complete rewrite
441 + Some new options to improve the functions
442 +
443 + 0.9.1.4 2010/06/23 Hotfix for WordPress 3.0
444 +
445 + 0.9.1.3 2009/07/17 Fix "header already send"-Problem with WordPress 2.8.1
446 + Add option to set level with full access
447 +
448 + 0.9.1.2 2009/03/29 Fix some path problems
449 + Add a reset function
450 + Rename menu at admin panel
451 +
452 + 0.9.1.1 2009/03/26 Fix the empty category issue
453 +
454 + 0.9.1 2009/03/26 Fix the database problem
455 + Fix feed bug. Thanks to Markus Brinkmann
456 + Fix wrong javascript path
457 +
458 + 0.9 2009/03/24 Add login form
459 + Add option to show text bevor <!--more--> tag
460 + Fix write access issues
461 + Fix file issues
462 + Small fixes
463 +
464 + 0.8.0.2 2009/03/09 Add French language file
465 + Delete .htaccess files on deactivation/uninstall
466 +
467 + 0.8.0.1 2009/03/06 Small fix
468 +
469 + 0.8 2009/03/05 Add write access control
470 + Add support down to 2.6
471 + Better file access control
472 + Code optimization - Plugin became faster
473 + Fix the category bug
474 + Small fixes
475 +
476 + 0.7.0.1 2009/02/13 Small fixes
94 477
95 - 0.6 2007/12/14 First release.
478 + 0.7 2009/02/13 Fix: All known Bugs of the beta
479 + Add ajax for more comfort
480 + Add language support
481 +
482 + 0.7 Beta 2009/01/05 Fix: Problems with media at posts
483 + Fix: Many other small fixes
484 + Only support up to WordPress 2.7
485 + Better integration
486 +
487 + 0.62 2008/12/18 Fix: Fatal error: Only variables can
488 + be passed by reference. Thanks to David Thompson
96 489
490 + 0.61 2008/12/17 Fix: Wrong file id in Media Library
97 491
98 -== Frequently Asked Questions ==
492 + 0.6 2007/12/14 First release.
99 493
100 -<strong>How works the User Access Manager?</strong>
101 494
102 -All posts/pages which are not in a user access group are accessable to all users. Posts/pages can put to groupes by themselfe, categories or recursive (most by pages).
495 +== Frequently Asked Questions ==
103 496
104 -<strong>How dose "Role affiliation" work?</strong>
497 +See: [https://github.com/GM-Alex/user-access-manager/wiki/FAQ](https://github.com/GM-Alex/user-access-manager/wiki/FAQ)
105 498
106 -This example will give you an overview:
107 -
108 -- Posts: Post1, Post2
109 -- Users: User1 (admin), User2 (subscriber), User3 (subscriber)
110 -
111 -Groups:
112 -
113 -- Group1: Users: User2, User3 | Posts: Post1 | Role affiliation: subscriber
114 -- Group2: Users: User3 | Posts: Post2 | Role affiliation: -
115 -
116 -Access:
117 -
118 -- Post1: User1 because he is a admin, User2 because he is in the group and a subscriber, User3 he is a subscriber (to this group all subscribers has access!)
119 -- Post2: User1 because he is a admin, User3 because he is in the group (only group members has access because there is no role affiliation!)
120 -
121 -
122 499 == Screenshots ==
123 500
124 -1. The group manger.
125 -2. The setting screen.
126 -3. Integration at posts.
501 +1. The group manager.
502 +2. The setting screen
503 +3. The setup screen.
504 +4. Integration into post overview.