PluginProbe
Defender Security – Malware Scanner, Login Security & Firewall / 3.1.0
Defender Security – Malware Scanner, Login Security & Firewall v3.1.0
6.3.0 6.2.3 6.2.4 6.2.0 6.2.1 6.2.2 6.1.0 5.3.1 5.4.0 5.4.1 5.5.0 5.5.1 5.6.0 5.6.1 5.6.2 5.7.0 5.7.1 5.7.2 5.8.0 5.8.1 5.9.0 6.0.0 6.0.1 3.0.1 3.1.0 All 141 releases
defender-security / vendor / composer / installed.json

installed.json in Defender Security – Malware Scanner, Login Security & Firewall 3.1.0, at vendor/composer/installed.json

2,346 lines 74.8 KB
No matching file
Up and down to move Enter to open Esc to close
Raw Download Zip
1 [
2 {
3 "name": "beberlei/assert",
4 "version": "v3.3.2",
5 "version_normalized": "3.3.2.0",
6 "source": {
7 "type": "git",
8 "url": "https://github.com/beberlei/assert.git",
9 "reference": "cb70015c04be1baee6f5f5c953703347c0ac1655"
10 },
11 "dist": {
12 "type": "zip",
13 "url": "https://api.github.com/repos/beberlei/assert/zipball/cb70015c04be1baee6f5f5c953703347c0ac1655",
14 "reference": "cb70015c04be1baee6f5f5c953703347c0ac1655",
15 "shasum": ""
16 },
17 "require": {
18 "ext-ctype": "*",
19 "ext-json": "*",
20 "ext-mbstring": "*",
21 "ext-simplexml": "*",
22 "php": "^7.0 || ^8.0"
23 },
24 "require-dev": {
25 "friendsofphp/php-cs-fixer": "*",
26 "phpstan/phpstan": "*",
27 "phpunit/phpunit": ">=6.0.0",
28 "yoast/phpunit-polyfills": "^0.1.0"
29 },
30 "suggest": {
31 "ext-intl": "Needed to allow Assertion::count(), Assertion::isCountable(), Assertion::minCount(), and Assertion::maxCount() to operate on ResourceBundles"
32 },
33 "time": "2021-12-16T21:41:27+00:00",
34 "type": "library",
35 "installation-source": "dist",
36 "autoload": {
37 "files": [
38 "lib/Assert/functions.php"
39 ],
40 "psr-4": {
41 "Assert\\": "lib/Assert"
42 }
43 },
44 "notification-url": "https://packagist.org/downloads/",
45 "license": [
46 "BSD-2-Clause"
47 ],
48 "authors": [
49 {
50 "name": "Benjamin Eberlei",
51 "email": "[email protected]",
52 "role": "Lead Developer"
53 },
54 {
55 "name": "Richard Quadling",
56 "email": "[email protected]",
57 "role": "Collaborator"
58 }
59 ],
60 "description": "Thin assertion library for input validation in business models.",
61 "keywords": [
62 "assert",
63 "assertion",
64 "validation"
65 ]
66 },
67 {
68 "name": "brick/math",
69 "version": "0.8.17",
70 "version_normalized": "0.8.17.0",
71 "source": {
72 "type": "git",
73 "url": "https://github.com/brick/math.git",
74 "reference": "e6f8e7d04346a95be89580f8c2c22d6c3fa65556"
75 },
76 "dist": {
77 "type": "zip",
78 "url": "https://api.github.com/repos/brick/math/zipball/e6f8e7d04346a95be89580f8c2c22d6c3fa65556",
79 "reference": "e6f8e7d04346a95be89580f8c2c22d6c3fa65556",
80 "shasum": ""
81 },
82 "require": {
83 "ext-json": "*",
84 "php": "^7.1|^8.0"
85 },
86 "require-dev": {
87 "php-coveralls/php-coveralls": "^2.2",
88 "phpunit/phpunit": "^7.5.15|^8.5",
89 "vimeo/psalm": "^3.5"
90 },
91 "time": "2020-08-18T23:41:20+00:00",
92 "type": "library",
93 "installation-source": "dist",
94 "autoload": {
95 "psr-4": {
96 "Brick\\Math\\": "src/"
97 }
98 },
99 "notification-url": "https://packagist.org/downloads/",
100 "license": [
101 "MIT"
102 ],
103 "description": "Arbitrary-precision arithmetic library",
104 "keywords": [
105 "Arbitrary-precision",
106 "BigInteger",
107 "BigRational",
108 "arithmetic",
109 "bigdecimal",
110 "bignum",
111 "brick",
112 "math"
113 ]
114 },
115 {
116 "name": "fgrosse/phpasn1",
117 "version": "v2.4.0",
118 "version_normalized": "2.4.0.0",
119 "source": {
120 "type": "git",
121 "url": "https://github.com/fgrosse/PHPASN1.git",
122 "reference": "eef488991d53e58e60c9554b09b1201ca5ba9296"
123 },
124 "dist": {
125 "type": "zip",
126 "url": "https://api.github.com/repos/fgrosse/PHPASN1/zipball/eef488991d53e58e60c9554b09b1201ca5ba9296",
127 "reference": "eef488991d53e58e60c9554b09b1201ca5ba9296",
128 "shasum": ""
129 },
130 "require": {
131 "php": "~7.1.0 || ~7.2.0 || ~7.3.0 || ~7.4.0 || ~8.0.0 || ~8.1.0"
132 },
133 "require-dev": {
134 "php-coveralls/php-coveralls": "~2.0",
135 "phpunit/phpunit": "^6.3 || ^7.0 || ^8.0"
136 },
137 "suggest": {
138 "ext-bcmath": "BCmath is the fallback extension for big integer calculations",
139 "ext-curl": "For loading OID information from the web if they have not bee defined statically",
140 "ext-gmp": "GMP is the preferred extension for big integer calculations",
141 "phpseclib/bcmath_compat": "BCmath polyfill for servers where neither GMP nor BCmath is available"
142 },
143 "time": "2021-12-11T12:41:06+00:00",
144 "type": "library",
145 "extra": {
146 "branch-alias": {
147 "dev-master": "2.0.x-dev"
148 }
149 },
150 "installation-source": "dist",
151 "autoload": {
152 "psr-4": {
153 "FG\\": "lib/"
154 }
155 },
156 "notification-url": "https://packagist.org/downloads/",
157 "license": [
158 "MIT"
159 ],
160 "authors": [
161 {
162 "name": "Friedrich Große",
163 "email": "[email protected]",
164 "homepage": "https://github.com/FGrosse",
165 "role": "Author"
166 },
167 {
168 "name": "All contributors",
169 "homepage": "https://github.com/FGrosse/PHPASN1/contributors"
170 }
171 ],
172 "description": "A PHP Framework that allows you to encode and decode arbitrary ASN.1 structures using the ITU-T X.690 Encoding Rules.",
173 "homepage": "https://github.com/FGrosse/PHPASN1",
174 "keywords": [
175 "DER",
176 "asn.1",
177 "asn1",
178 "ber",
179 "binary",
180 "decoding",
181 "encoding",
182 "x.509",
183 "x.690",
184 "x509",
185 "x690"
186 ]
187 },
188 {
189 "name": "gettext/gettext",
190 "version": "v5.5.2",
191 "version_normalized": "5.5.2.0",
192 "source": {
193 "type": "git",
194 "url": "https://github.com/php-gettext/Gettext.git",
195 "reference": "86f1f4f1e433ae46ba5b91b898b8438216adb96c"
196 },
197 "dist": {
198 "type": "zip",
199 "url": "https://api.github.com/repos/php-gettext/Gettext/zipball/86f1f4f1e433ae46ba5b91b898b8438216adb96c",
200 "reference": "86f1f4f1e433ae46ba5b91b898b8438216adb96c",
201 "shasum": ""
202 },
203 "require": {
204 "gettext/languages": "^2.3",
205 "php": "^7.2"
206 },
207 "require-dev": {
208 "brick/varexporter": "^0.2.1",
209 "friendsofphp/php-cs-fixer": "^2.15",
210 "oscarotero/php-cs-fixer-config": "^1.0",
211 "phpunit/phpunit": "^8.0",
212 "squizlabs/php_codesniffer": "^3.0"
213 },
214 "time": "2020-11-17T22:48:20+00:00",
215 "type": "library",
216 "installation-source": "dist",
217 "autoload": {
218 "psr-4": {
219 "Gettext\\": "src"
220 }
221 },
222 "notification-url": "https://packagist.org/downloads/",
223 "license": [
224 "MIT"
225 ],
226 "authors": [
227 {
228 "name": "Oscar Otero",
229 "email": "[email protected]",
230 "homepage": "http://oscarotero.com",
231 "role": "Developer"
232 }
233 ],
234 "description": "PHP gettext manager",
235 "homepage": "https://github.com/php-gettext/Gettext",
236 "keywords": [
237 "JS",
238 "gettext",
239 "i18n",
240 "mo",
241 "po",
242 "translation"
243 ]
244 },
245 {
246 "name": "gettext/languages",
247 "version": "2.9.0",
248 "version_normalized": "2.9.0.0",
249 "source": {
250 "type": "git",
251 "url": "https://github.com/php-gettext/Languages.git",
252 "reference": "ed56dd2c7f4024cc953ed180d25f02f2640e3ffa"
253 },
254 "dist": {
255 "type": "zip",
256 "url": "https://api.github.com/repos/php-gettext/Languages/zipball/ed56dd2c7f4024cc953ed180d25f02f2640e3ffa",
257 "reference": "ed56dd2c7f4024cc953ed180d25f02f2640e3ffa",
258 "shasum": ""
259 },
260 "require": {
261 "php": ">=5.3"
262 },
263 "require-dev": {
264 "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.5 || ^8.4"
265 },
266 "time": "2021-11-11T17:30:39+00:00",
267 "bin": [
268 "bin/export-plural-rules"
269 ],
270 "type": "library",
271 "installation-source": "dist",
272 "autoload": {
273 "psr-4": {
274 "Gettext\\Languages\\": "src/"
275 }
276 },
277 "notification-url": "https://packagist.org/downloads/",
278 "license": [
279 "MIT"
280 ],
281 "authors": [
282 {
283 "name": "Michele Locati",
284 "email": "[email protected]",
285 "role": "Developer"
286 }
287 ],
288 "description": "gettext languages with plural rules",
289 "homepage": "https://github.com/php-gettext/Languages",
290 "keywords": [
291 "cldr",
292 "i18n",
293 "internationalization",
294 "l10n",
295 "language",
296 "languages",
297 "localization",
298 "php",
299 "plural",
300 "plural rules",
301 "plurals",
302 "translate",
303 "translations",
304 "unicode"
305 ]
306 },
307 {
308 "name": "league/uri",
309 "version": "6.4.0",
310 "version_normalized": "6.4.0.0",
311 "source": {
312 "type": "git",
313 "url": "https://github.com/thephpleague/uri.git",
314 "reference": "09da64118eaf4c5d52f9923a1e6a5be1da52fd9a"
315 },
316 "dist": {
317 "type": "zip",
318 "url": "https://api.github.com/repos/thephpleague/uri/zipball/09da64118eaf4c5d52f9923a1e6a5be1da52fd9a",
319 "reference": "09da64118eaf4c5d52f9923a1e6a5be1da52fd9a",
320 "shasum": ""
321 },
322 "require": {
323 "ext-json": "*",
324 "league/uri-interfaces": "^2.1",
325 "php": ">=7.2",
326 "psr/http-message": "^1.0"
327 },
328 "conflict": {
329 "league/uri-schemes": "^1.0"
330 },
331 "require-dev": {
332 "friendsofphp/php-cs-fixer": "^2.16",
333 "phpstan/phpstan": "^0.12",
334 "phpstan/phpstan-phpunit": "^0.12",
335 "phpstan/phpstan-strict-rules": "^0.12",
336 "phpunit/phpunit": "^8.0 || ^9.0",
337 "psr/http-factory": "^1.0"
338 },
339 "suggest": {
340 "ext-fileinfo": "Needed to create Data URI from a filepath",
341 "ext-intl": "Needed to improve host validation",
342 "league/uri-components": "Needed to easily manipulate URI objects",
343 "psr/http-factory": "Needed to use the URI factory"
344 },
345 "time": "2020-11-22T14:29:11+00:00",
346 "type": "library",
347 "extra": {
348 "branch-alias": {
349 "dev-master": "6.x-dev"
350 }
351 },
352 "installation-source": "dist",
353 "autoload": {
354 "psr-4": {
355 "League\\Uri\\": "src"
356 }
357 },
358 "notification-url": "https://packagist.org/downloads/",
359 "license": [
360 "MIT"
361 ],
362 "authors": [
363 {
364 "name": "Ignace Nyamagana Butera",
365 "email": "[email protected]",
366 "homepage": "https://nyamsprod.com"
367 }
368 ],
369 "description": "URI manipulation library",
370 "homepage": "http://uri.thephpleague.com",
371 "keywords": [
372 "data-uri",
373 "file-uri",
374 "ftp",
375 "hostname",
376 "http",
377 "https",
378 "middleware",
379 "parse_str",
380 "parse_url",
381 "psr-7",
382 "query-string",
383 "querystring",
384 "rfc3986",
385 "rfc3987",
386 "rfc6570",
387 "uri",
388 "uri-template",
389 "url",
390 "ws"
391 ]
392 },
393 {
394 "name": "league/uri-interfaces",
395 "version": "2.3.0",
396 "version_normalized": "2.3.0.0",
397 "source": {
398 "type": "git",
399 "url": "https://github.com/thephpleague/uri-interfaces.git",
400 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383"
401 },
402 "dist": {
403 "type": "zip",
404 "url": "https://api.github.com/repos/thephpleague/uri-interfaces/zipball/00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
405 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
406 "shasum": ""
407 },
408 "require": {
409 "ext-json": "*",
410 "php": "^7.2 || ^8.0"
411 },
412 "require-dev": {
413 "friendsofphp/php-cs-fixer": "^2.19",
414 "phpstan/phpstan": "^0.12.90",
415 "phpstan/phpstan-phpunit": "^0.12.19",
416 "phpstan/phpstan-strict-rules": "^0.12.9",
417 "phpunit/phpunit": "^8.5.15 || ^9.5"
418 },
419 "suggest": {
420 "ext-intl": "to use the IDNA feature",
421 "symfony/intl": "to use the IDNA feature via Symfony Polyfill"
422 },
423 "time": "2021-06-28T04:27:21+00:00",
424 "type": "library",
425 "extra": {
426 "branch-alias": {
427 "dev-master": "2.x-dev"
428 }
429 },
430 "installation-source": "dist",
431 "autoload": {
432 "psr-4": {
433 "League\\Uri\\": "src/"
434 }
435 },
436 "notification-url": "https://packagist.org/downloads/",
437 "license": [
438 "MIT"
439 ],
440 "authors": [
441 {
442 "name": "Ignace Nyamagana Butera",
443 "email": "[email protected]",
444 "homepage": "https://nyamsprod.com"
445 }
446 ],
447 "description": "Common interface for URI representation",
448 "homepage": "http://github.com/thephpleague/uri-interfaces",
449 "keywords": [
450 "rfc3986",
451 "rfc3987",
452 "uri",
453 "url"
454 ]
455 },
456 {
457 "name": "nyholm/psr7",
458 "version": "1.5.0",
459 "version_normalized": "1.5.0.0",
460 "source": {
461 "type": "git",
462 "url": "https://github.com/Nyholm/psr7.git",
463 "reference": "1461e07a0f2a975a52082ca3b769ca912b816226"
464 },
465 "dist": {
466 "type": "zip",
467 "url": "https://api.github.com/repos/Nyholm/psr7/zipball/1461e07a0f2a975a52082ca3b769ca912b816226",
468 "reference": "1461e07a0f2a975a52082ca3b769ca912b816226",
469 "shasum": ""
470 },
471 "require": {
472 "php": ">=7.1",
473 "php-http/message-factory": "^1.0",
474 "psr/http-factory": "^1.0",
475 "psr/http-message": "^1.0"
476 },
477 "provide": {
478 "psr/http-factory-implementation": "1.0",
479 "psr/http-message-implementation": "1.0"
480 },
481 "require-dev": {
482 "http-interop/http-factory-tests": "^0.9",
483 "php-http/psr7-integration-tests": "^1.0",
484 "phpunit/phpunit": "^7.5 || 8.5 || 9.4",
485 "symfony/error-handler": "^4.4"
486 },
487 "time": "2022-02-02T18:37:57+00:00",
488 "type": "library",
489 "extra": {
490 "branch-alias": {
491 "dev-master": "1.4-dev"
492 }
493 },
494 "installation-source": "dist",
495 "autoload": {
496 "psr-4": {
497 "Nyholm\\Psr7\\": "src/"
498 }
499 },
500 "notification-url": "https://packagist.org/downloads/",
501 "license": [
502 "MIT"
503 ],
504 "authors": [
505 {
506 "name": "Tobias Nyholm",
507 "email": "[email protected]"
508 },
509 {
510 "name": "Martijn van der Ven",
511 "email": "[email protected]"
512 }
513 ],
514 "description": "A fast PHP7 implementation of PSR-7",
515 "homepage": "https://tnyholm.se",
516 "keywords": [
517 "psr-17",
518 "psr-7"
519 ]
520 },
521 {
522 "name": "nyholm/psr7-server",
523 "version": "1.0.2",
524 "version_normalized": "1.0.2.0",
525 "source": {
526 "type": "git",
527 "url": "https://github.com/Nyholm/psr7-server.git",
528 "reference": "b846a689844cef114e8079d8c80f0afd96745ae3"
529 },
530 "dist": {
531 "type": "zip",
532 "url": "https://api.github.com/repos/Nyholm/psr7-server/zipball/b846a689844cef114e8079d8c80f0afd96745ae3",
533 "reference": "b846a689844cef114e8079d8c80f0afd96745ae3",
534 "shasum": ""
535 },
536 "require": {
537 "php": "^7.1 || ^8.0",
538 "psr/http-factory": "^1.0",
539 "psr/http-message": "^1.0"
540 },
541 "require-dev": {
542 "nyholm/nsa": "^1.1",
543 "nyholm/psr7": "^1.3",
544 "phpunit/phpunit": "^7.0 || ^8.5 || ^9.3"
545 },
546 "time": "2021-05-12T11:11:27+00:00",
547 "type": "library",
548 "installation-source": "dist",
549 "autoload": {
550 "psr-4": {
551 "Nyholm\\Psr7Server\\": "src/"
552 }
553 },
554 "notification-url": "https://packagist.org/downloads/",
555 "license": [
556 "MIT"
557 ],
558 "authors": [
559 {
560 "name": "Tobias Nyholm",
561 "email": "[email protected]"
562 },
563 {
564 "name": "Martijn van der Ven",
565 "email": "[email protected]"
566 }
567 ],
568 "description": "Helper classes to handle PSR-7 server requests",
569 "homepage": "http://tnyholm.se",
570 "keywords": [
571 "psr-17",
572 "psr-7"
573 ]
574 },
575 {
576 "name": "opis/closure",
577 "version": "3.6.3",
578 "version_normalized": "3.6.3.0",
579 "source": {
580 "type": "git",
581 "url": "https://github.com/opis/closure.git",
582 "reference": "3d81e4309d2a927abbe66df935f4bb60082805ad"
583 },
584 "dist": {
585 "type": "zip",
586 "url": "https://api.github.com/repos/opis/closure/zipball/3d81e4309d2a927abbe66df935f4bb60082805ad",
587 "reference": "3d81e4309d2a927abbe66df935f4bb60082805ad",
588 "shasum": ""
589 },
590 "require": {
591 "php": "^5.4 || ^7.0 || ^8.0"
592 },
593 "require-dev": {
594 "jeremeamia/superclosure": "^2.0",
595 "phpunit/phpunit": "^4.0 || ^5.0 || ^6.0 || ^7.0 || ^8.0 || ^9.0"
596 },
597 "time": "2022-01-27T09:35:39+00:00",
598 "type": "library",
599 "extra": {
600 "branch-alias": {
601 "dev-master": "3.6.x-dev"
602 }
603 },
604 "installation-source": "dist",
605 "autoload": {
606 "files": [
607 "functions.php"
608 ],
609 "psr-4": {
610 "Opis\\Closure\\": "src/"
611 }
612 },
613 "notification-url": "https://packagist.org/downloads/",
614 "license": [
615 "MIT"
616 ],
617 "authors": [
618 {
619 "name": "Marius Sarca",
620 "email": "[email protected]"
621 },
622 {
623 "name": "Sorin Sarca",
624 "email": "[email protected]"
625 }
626 ],
627 "description": "A library that can be used to serialize closures (anonymous functions) and arbitrary objects.",
628 "homepage": "https://opis.io/closure",
629 "keywords": [
630 "anonymous functions",
631 "closure",
632 "function",
633 "serializable",
634 "serialization",
635 "serialize"
636 ]
637 },
638 {
639 "name": "php-di/invoker",
640 "version": "2.0.0",
641 "version_normalized": "2.0.0.0",
642 "source": {
643 "type": "git",
644 "url": "https://github.com/PHP-DI/Invoker.git",
645 "reference": "540c27c86f663e20fe39a24cd72fa76cdb21d41a"
646 },
647 "dist": {
648 "type": "zip",
649 "url": "https://api.github.com/repos/PHP-DI/Invoker/zipball/540c27c86f663e20fe39a24cd72fa76cdb21d41a",
650 "reference": "540c27c86f663e20fe39a24cd72fa76cdb21d41a",
651 "shasum": ""
652 },
653 "require": {
654 "psr/container": "~1.0"
655 },
656 "require-dev": {
657 "athletic/athletic": "~0.1.8",
658 "phpunit/phpunit": "~4.5"
659 },
660 "time": "2017-03-20T19:28:22+00:00",
661 "type": "library",
662 "installation-source": "dist",
663 "autoload": {
664 "psr-4": {
665 "Invoker\\": "src/"
666 }
667 },
668 "notification-url": "https://packagist.org/downloads/",
669 "license": [
670 "MIT"
671 ],
672 "description": "Generic and extensible callable invoker",
673 "homepage": "https://github.com/PHP-DI/Invoker",
674 "keywords": [
675 "callable",
676 "dependency",
677 "dependency-injection",
678 "injection",
679 "invoke",
680 "invoker"
681 ]
682 },
683 {
684 "name": "php-di/php-di",
685 "version": "6.3.5",
686 "version_normalized": "6.3.5.0",
687 "source": {
688 "type": "git",
689 "url": "https://github.com/PHP-DI/PHP-DI.git",
690 "reference": "b8126d066ce144765300ee0ab040c1ed6c9ef588"
691 },
692 "dist": {
693 "type": "zip",
694 "url": "https://api.github.com/repos/PHP-DI/PHP-DI/zipball/b8126d066ce144765300ee0ab040c1ed6c9ef588",
695 "reference": "b8126d066ce144765300ee0ab040c1ed6c9ef588",
696 "shasum": ""
697 },
698 "require": {
699 "opis/closure": "^3.5.5",
700 "php": ">=7.2.0",
701 "php-di/invoker": "^2.0",
702 "php-di/phpdoc-reader": "^2.0.1",
703 "psr/container": "^1.0"
704 },
705 "provide": {
706 "psr/container-implementation": "^1.0"
707 },
708 "require-dev": {
709 "doctrine/annotations": "~1.2",
710 "friendsofphp/php-cs-fixer": "^2.4",
711 "mnapoli/phpunit-easymock": "^1.2",
712 "ocramius/proxy-manager": "^2.0.2",
713 "phpstan/phpstan": "^0.12",
714 "phpunit/phpunit": "^8.5|^9.0"
715 },
716 "suggest": {
717 "doctrine/annotations": "Install it if you want to use annotations (version ~1.2)",
718 "ocramius/proxy-manager": "Install it if you want to use lazy injection (version ~2.0)"
719 },
720 "time": "2021-09-02T09:49:58+00:00",
721 "type": "library",
722 "installation-source": "dist",
723 "autoload": {
724 "files": [
725 "src/functions.php"
726 ],
727 "psr-4": {
728 "DI\\": "src/"
729 }
730 },
731 "notification-url": "https://packagist.org/downloads/",
732 "license": [
733 "MIT"
734 ],
735 "description": "The dependency injection container for humans",
736 "homepage": "https://php-di.org/",
737 "keywords": [
738 "PSR-11",
739 "container",
740 "container-interop",
741 "dependency injection",
742 "di",
743 "ioc",
744 "psr11"
745 ]
746 },
747 {
748 "name": "php-di/phpdoc-reader",
749 "version": "2.2.1",
750 "version_normalized": "2.2.1.0",
751 "source": {
752 "type": "git",
753 "url": "https://github.com/PHP-DI/PhpDocReader.git",
754 "reference": "66daff34cbd2627740ffec9469ffbac9f8c8185c"
755 },
756 "dist": {
757 "type": "zip",
758 "url": "https://api.github.com/repos/PHP-DI/PhpDocReader/zipball/66daff34cbd2627740ffec9469ffbac9f8c8185c",
759 "reference": "66daff34cbd2627740ffec9469ffbac9f8c8185c",
760 "shasum": ""
761 },
762 "require": {
763 "php": ">=7.2.0"
764 },
765 "require-dev": {
766 "mnapoli/hard-mode": "~0.3.0",
767 "phpunit/phpunit": "^8.5|^9.0"
768 },
769 "time": "2020-10-12T12:39:22+00:00",
770 "type": "library",
771 "installation-source": "dist",
772 "autoload": {
773 "psr-4": {
774 "PhpDocReader\\": "src/PhpDocReader"
775 }
776 },
777 "notification-url": "https://packagist.org/downloads/",
778 "license": [
779 "MIT"
780 ],
781 "description": "PhpDocReader parses @var and @param values in PHP docblocks (supports namespaced class names with the same resolution rules as PHP)",
782 "keywords": [
783 "phpdoc",
784 "reflection"
785 ]
786 },
787 {
788 "name": "php-http/message-factory",
789 "version": "v1.0.2",
790 "version_normalized": "1.0.2.0",
791 "source": {
792 "type": "git",
793 "url": "https://github.com/php-http/message-factory.git",
794 "reference": "a478cb11f66a6ac48d8954216cfed9aa06a501a1"
795 },
796 "dist": {
797 "type": "zip",
798 "url": "https://api.github.com/repos/php-http/message-factory/zipball/a478cb11f66a6ac48d8954216cfed9aa06a501a1",
799 "reference": "a478cb11f66a6ac48d8954216cfed9aa06a501a1",
800 "shasum": ""
801 },
802 "require": {
803 "php": ">=5.4",
804 "psr/http-message": "^1.0"
805 },
806 "time": "2015-12-19T14:08:53+00:00",
807 "type": "library",
808 "extra": {
809 "branch-alias": {
810 "dev-master": "1.0-dev"
811 }
812 },
813 "installation-source": "dist",
814 "autoload": {
815 "psr-4": {
816 "Http\\Message\\": "src/"
817 }
818 },
819 "notification-url": "https://packagist.org/downloads/",
820 "license": [
821 "MIT"
822 ],
823 "authors": [
824 {
825 "name": "Márk Sági-Kazár",
826 "email": "[email protected]"
827 }
828 ],
829 "description": "Factory interfaces for PSR-7 HTTP Message",
830 "homepage": "http://php-http.org",
831 "keywords": [
832 "factory",
833 "http",
834 "message",
835 "stream",
836 "uri"
837 ]
838 },
839 {
840 "name": "psr/container",
841 "version": "1.1.1",
842 "version_normalized": "1.1.1.0",
843 "source": {
844 "type": "git",
845 "url": "https://github.com/php-fig/container.git",
846 "reference": "8622567409010282b7aeebe4bb841fe98b58dcaf"
847 },
848 "dist": {
849 "type": "zip",
850 "url": "https://api.github.com/repos/php-fig/container/zipball/8622567409010282b7aeebe4bb841fe98b58dcaf",
851 "reference": "8622567409010282b7aeebe4bb841fe98b58dcaf",
852 "shasum": ""
853 },
854 "require": {
855 "php": ">=7.2.0"
856 },
857 "time": "2021-03-05T17:36:06+00:00",
858 "type": "library",
859 "installation-source": "dist",
860 "autoload": {
861 "psr-4": {
862 "Psr\\Container\\": "src/"
863 }
864 },
865 "notification-url": "https://packagist.org/downloads/",
866 "license": [
867 "MIT"
868 ],
869 "authors": [
870 {
871 "name": "PHP-FIG",
872 "homepage": "https://www.php-fig.org/"
873 }
874 ],
875 "description": "Common Container Interface (PHP FIG PSR-11)",
876 "homepage": "https://github.com/php-fig/container",
877 "keywords": [
878 "PSR-11",
879 "container",
880 "container-interface",
881 "container-interop",
882 "psr"
883 ]
884 },
885 {
886 "name": "psr/http-client",
887 "version": "1.0.1",
888 "version_normalized": "1.0.1.0",
889 "source": {
890 "type": "git",
891 "url": "https://github.com/php-fig/http-client.git",
892 "reference": "2dfb5f6c5eff0e91e20e913f8c5452ed95b86621"
893 },
894 "dist": {
895 "type": "zip",
896 "url": "https://api.github.com/repos/php-fig/http-client/zipball/2dfb5f6c5eff0e91e20e913f8c5452ed95b86621",
897 "reference": "2dfb5f6c5eff0e91e20e913f8c5452ed95b86621",
898 "shasum": ""
899 },
900 "require": {
901 "php": "^7.0 || ^8.0",
902 "psr/http-message": "^1.0"
903 },
904 "time": "2020-06-29T06:28:15+00:00",
905 "type": "library",
906 "extra": {
907 "branch-alias": {
908 "dev-master": "1.0.x-dev"
909 }
910 },
911 "installation-source": "dist",
912 "autoload": {
913 "psr-4": {
914 "Psr\\Http\\Client\\": "src/"
915 }
916 },
917 "notification-url": "https://packagist.org/downloads/",
918 "license": [
919 "MIT"
920 ],
921 "authors": [
922 {
923 "name": "PHP-FIG",
924 "homepage": "http://www.php-fig.org/"
925 }
926 ],
927 "description": "Common interface for HTTP clients",
928 "homepage": "https://github.com/php-fig/http-client",
929 "keywords": [
930 "http",
931 "http-client",
932 "psr",
933 "psr-18"
934 ]
935 },
936 {
937 "name": "psr/http-factory",
938 "version": "1.0.1",
939 "version_normalized": "1.0.1.0",
940 "source": {
941 "type": "git",
942 "url": "https://github.com/php-fig/http-factory.git",
943 "reference": "12ac7fcd07e5b077433f5f2bee95b3a771bf61be"
944 },
945 "dist": {
946 "type": "zip",
947 "url": "https://api.github.com/repos/php-fig/http-factory/zipball/12ac7fcd07e5b077433f5f2bee95b3a771bf61be",
948 "reference": "12ac7fcd07e5b077433f5f2bee95b3a771bf61be",
949 "shasum": ""
950 },
951 "require": {
952 "php": ">=7.0.0",
953 "psr/http-message": "^1.0"
954 },
955 "time": "2019-04-30T12:38:16+00:00",
956 "type": "library",
957 "extra": {
958 "branch-alias": {
959 "dev-master": "1.0.x-dev"
960 }
961 },
962 "installation-source": "dist",
963 "autoload": {
964 "psr-4": {
965 "Psr\\Http\\Message\\": "src/"
966 }
967 },
968 "notification-url": "https://packagist.org/downloads/",
969 "license": [
970 "MIT"
971 ],
972 "authors": [
973 {
974 "name": "PHP-FIG",
975 "homepage": "http://www.php-fig.org/"
976 }
977 ],
978 "description": "Common interfaces for PSR-7 HTTP message factories",
979 "keywords": [
980 "factory",
981 "http",
982 "message",
983 "psr",
984 "psr-17",
985 "psr-7",
986 "request",
987 "response"
988 ]
989 },
990 {
991 "name": "psr/http-message",
992 "version": "1.0.1",
993 "version_normalized": "1.0.1.0",
994 "source": {
995 "type": "git",
996 "url": "https://github.com/php-fig/http-message.git",
997 "reference": "f6561bf28d520154e4b0ec72be95418abe6d9363"
998 },
999 "dist": {
1000 "type": "zip",
1001 "url": "https://api.github.com/repos/php-fig/http-message/zipball/f6561bf28d520154e4b0ec72be95418abe6d9363",
1002 "reference": "f6561bf28d520154e4b0ec72be95418abe6d9363",
1003 "shasum": ""
1004 },
1005 "require": {
1006 "php": ">=5.3.0"
1007 },
1008 "time": "2016-08-06T14:39:51+00:00",
1009 "type": "library",
1010 "extra": {
1011 "branch-alias": {
1012 "dev-master": "1.0.x-dev"
1013 }
1014 },
1015 "installation-source": "dist",
1016 "autoload": {
1017 "psr-4": {
1018 "Psr\\Http\\Message\\": "src/"
1019 }
1020 },
1021 "notification-url": "https://packagist.org/downloads/",
1022 "license": [
1023 "MIT"
1024 ],
1025 "authors": [
1026 {
1027 "name": "PHP-FIG",
1028 "homepage": "http://www.php-fig.org/"
1029 }
1030 ],
1031 "description": "Common interface for HTTP messages",
1032 "homepage": "https://github.com/php-fig/http-message",
1033 "keywords": [
1034 "http",
1035 "http-message",
1036 "psr",
1037 "psr-7",
1038 "request",
1039 "response"
1040 ]
1041 },
1042 {
1043 "name": "psr/log",
1044 "version": "1.1.4",
1045 "version_normalized": "1.1.4.0",
1046 "source": {
1047 "type": "git",
1048 "url": "https://github.com/php-fig/log.git",
1049 "reference": "d49695b909c3b7628b6289db5479a1c204601f11"
1050 },
1051 "dist": {
1052 "type": "zip",
1053 "url": "https://api.github.com/repos/php-fig/log/zipball/d49695b909c3b7628b6289db5479a1c204601f11",
1054 "reference": "d49695b909c3b7628b6289db5479a1c204601f11",
1055 "shasum": ""
1056 },
1057 "require": {
1058 "php": ">=5.3.0"
1059 },
1060 "time": "2021-05-03T11:20:27+00:00",
1061 "type": "library",
1062 "extra": {
1063 "branch-alias": {
1064 "dev-master": "1.1.x-dev"
1065 }
1066 },
1067 "installation-source": "dist",
1068 "autoload": {
1069 "psr-4": {
1070 "Psr\\Log\\": "Psr/Log/"
1071 }
1072 },
1073 "notification-url": "https://packagist.org/downloads/",
1074 "license": [
1075 "MIT"
1076 ],
1077 "authors": [
1078 {
1079 "name": "PHP-FIG",
1080 "homepage": "https://www.php-fig.org/"
1081 }
1082 ],
1083 "description": "Common interface for logging libraries",
1084 "homepage": "https://github.com/php-fig/log",
1085 "keywords": [
1086 "log",
1087 "psr",
1088 "psr-3"
1089 ]
1090 },
1091 {
1092 "name": "ramsey/collection",
1093 "version": "1.1.4",
1094 "version_normalized": "1.1.4.0",
1095 "source": {
1096 "type": "git",
1097 "url": "https://github.com/ramsey/collection.git",
1098 "reference": "ab2237657ad99667a5143e32ba2683c8029563d4"
1099 },
1100 "dist": {
1101 "type": "zip",
1102 "url": "https://api.github.com/repos/ramsey/collection/zipball/ab2237657ad99667a5143e32ba2683c8029563d4",
1103 "reference": "ab2237657ad99667a5143e32ba2683c8029563d4",
1104 "shasum": ""
1105 },
1106 "require": {
1107 "php": "^7.2 || ^8"
1108 },
1109 "require-dev": {
1110 "captainhook/captainhook": "^5.3",
1111 "dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
1112 "ergebnis/composer-normalize": "^2.6",
1113 "fakerphp/faker": "^1.5",
1114 "hamcrest/hamcrest-php": "^2",
1115 "jangregor/phpstan-prophecy": "^0.8",
1116 "mockery/mockery": "^1.3",
1117 "phpstan/extension-installer": "^1",
1118 "phpstan/phpstan": "^0.12.32",
1119 "phpstan/phpstan-mockery": "^0.12.5",
1120 "phpstan/phpstan-phpunit": "^0.12.11",
1121 "phpunit/phpunit": "^8.5 || ^9",
1122 "psy/psysh": "^0.10.4",
1123 "slevomat/coding-standard": "^6.3",
1124 "squizlabs/php_codesniffer": "^3.5",
1125 "vimeo/psalm": "^4.4"
1126 },
1127 "time": "2021-07-30T00:58:27+00:00",
1128 "type": "library",
1129 "installation-source": "dist",
1130 "autoload": {
1131 "psr-4": {
1132 "Ramsey\\Collection\\": "src/"
1133 }
1134 },
1135 "notification-url": "https://packagist.org/downloads/",
1136 "license": [
1137 "MIT"
1138 ],
1139 "authors": [
1140 {
1141 "name": "Ben Ramsey",
1142 "email": "[email protected]",
1143 "homepage": "https://benramsey.com"
1144 }
1145 ],
1146 "description": "A PHP 7.2+ library for representing and manipulating collections.",
1147 "keywords": [
1148 "array",
1149 "collection",
1150 "hash",
1151 "map",
1152 "queue",
1153 "set"
1154 ]
1155 },
1156 {
1157 "name": "ramsey/uuid",
1158 "version": "4.2.3",
1159 "version_normalized": "4.2.3.0",
1160 "source": {
1161 "type": "git",
1162 "url": "https://github.com/ramsey/uuid.git",
1163 "reference": "fc9bb7fb5388691fd7373cd44dcb4d63bbcf24df"
1164 },
1165 "dist": {
1166 "type": "zip",
1167 "url": "https://api.github.com/repos/ramsey/uuid/zipball/fc9bb7fb5388691fd7373cd44dcb4d63bbcf24df",
1168 "reference": "fc9bb7fb5388691fd7373cd44dcb4d63bbcf24df",
1169 "shasum": ""
1170 },
1171 "require": {
1172 "brick/math": "^0.8 || ^0.9",
1173 "ext-json": "*",
1174 "php": "^7.2 || ^8.0",
1175 "ramsey/collection": "^1.0",
1176 "symfony/polyfill-ctype": "^1.8",
1177 "symfony/polyfill-php80": "^1.14"
1178 },
1179 "replace": {
1180 "rhumsaa/uuid": "self.version"
1181 },
1182 "require-dev": {
1183 "captainhook/captainhook": "^5.10",
1184 "captainhook/plugin-composer": "^5.3",
1185 "dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
1186 "doctrine/annotations": "^1.8",
1187 "ergebnis/composer-normalize": "^2.15",
1188 "mockery/mockery": "^1.3",
1189 "moontoast/math": "^1.1",
1190 "paragonie/random-lib": "^2",
1191 "php-mock/php-mock": "^2.2",
1192 "php-mock/php-mock-mockery": "^1.3",
1193 "php-parallel-lint/php-parallel-lint": "^1.1",
1194 "phpbench/phpbench": "^1.0",
1195 "phpstan/extension-installer": "^1.0",
1196 "phpstan/phpstan": "^0.12",
1197 "phpstan/phpstan-mockery": "^0.12",
1198 "phpstan/phpstan-phpunit": "^0.12",
1199 "phpunit/phpunit": "^8.5 || ^9",
1200 "slevomat/coding-standard": "^7.0",
1201 "squizlabs/php_codesniffer": "^3.5",
1202 "vimeo/psalm": "^4.9"
1203 },
1204 "suggest": {
1205 "ext-bcmath": "Enables faster math with arbitrary-precision integers using BCMath.",
1206 "ext-ctype": "Enables faster processing of character classification using ctype functions.",
1207 "ext-gmp": "Enables faster math with arbitrary-precision integers using GMP.",
1208 "ext-uuid": "Enables the use of PeclUuidTimeGenerator and PeclUuidRandomGenerator.",
1209 "paragonie/random-lib": "Provides RandomLib for use with the RandomLibAdapter",
1210 "ramsey/uuid-doctrine": "Allows the use of Ramsey\\Uuid\\Uuid as Doctrine field type."
1211 },
1212 "time": "2021-09-25T23:10:38+00:00",
1213 "type": "library",
1214 "extra": {
1215 "branch-alias": {
1216 "dev-main": "4.x-dev"
1217 },
1218 "captainhook": {
1219 "force-install": true
1220 }
1221 },
1222 "installation-source": "dist",
1223 "autoload": {
1224 "files": [
1225 "src/functions.php"
1226 ],
1227 "psr-4": {
1228 "Ramsey\\Uuid\\": "src/"
1229 }
1230 },
1231 "notification-url": "https://packagist.org/downloads/",
1232 "license": [
1233 "MIT"
1234 ],
1235 "description": "A PHP library for generating and working with universally unique identifiers (UUIDs).",
1236 "keywords": [
1237 "guid",
1238 "identifier",
1239 "uuid"
1240 ]
1241 },
1242 {
1243 "name": "spomky-labs/base64url",
1244 "version": "v2.0.4",
1245 "version_normalized": "2.0.4.0",
1246 "source": {
1247 "type": "git",
1248 "url": "https://github.com/Spomky-Labs/base64url.git",
1249 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d"
1250 },
1251 "dist": {
1252 "type": "zip",
1253 "url": "https://api.github.com/repos/Spomky-Labs/base64url/zipball/7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1254 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1255 "shasum": ""
1256 },
1257 "require": {
1258 "php": ">=7.1"
1259 },
1260 "require-dev": {
1261 "phpstan/extension-installer": "^1.0",
1262 "phpstan/phpstan": "^0.11|^0.12",
1263 "phpstan/phpstan-beberlei-assert": "^0.11|^0.12",
1264 "phpstan/phpstan-deprecation-rules": "^0.11|^0.12",
1265 "phpstan/phpstan-phpunit": "^0.11|^0.12",
1266 "phpstan/phpstan-strict-rules": "^0.11|^0.12"
1267 },
1268 "time": "2020-11-03T09:10:25+00:00",
1269 "type": "library",
1270 "installation-source": "dist",
1271 "autoload": {
1272 "psr-4": {
1273 "Base64Url\\": "src/"
1274 }
1275 },
1276 "notification-url": "https://packagist.org/downloads/",
1277 "license": [
1278 "MIT"
1279 ],
1280 "authors": [
1281 {
1282 "name": "Florent Morselli",
1283 "homepage": "https://github.com/Spomky-Labs/base64url/contributors"
1284 }
1285 ],
1286 "description": "Base 64 URL Safe Encoding/Decoding PHP Library",
1287 "homepage": "https://github.com/Spomky-Labs/base64url",
1288 "keywords": [
1289 "base64",
1290 "rfc4648",
1291 "safe",
1292 "url"
1293 ]
1294 },
1295 {
1296 "name": "spomky-labs/cbor-php",
1297 "version": "v1.1.1",
1298 "version_normalized": "1.1.1.0",
1299 "source": {
1300 "type": "git",
1301 "url": "https://github.com/Spomky-Labs/cbor-php.git",
1302 "reference": "b8e51e6a13606ab1dd8a64aa295651d8ad57ccd1"
1303 },
1304 "dist": {
1305 "type": "zip",
1306 "url": "https://api.github.com/repos/Spomky-Labs/cbor-php/zipball/b8e51e6a13606ab1dd8a64aa295651d8ad57ccd1",
1307 "reference": "b8e51e6a13606ab1dd8a64aa295651d8ad57ccd1",
1308 "shasum": ""
1309 },
1310 "require": {
1311 "beberlei/assert": "^3.2",
1312 "brick/math": "^0.8.15",
1313 "php": ">=7.1",
1314 "spomky-labs/base64url": "^1.0|^2.0"
1315 },
1316 "require-dev": {
1317 "php-coveralls/php-coveralls": "^2.0",
1318 "phpstan/phpstan": "^0.12",
1319 "phpstan/phpstan-beberlei-assert": "^0.12",
1320 "phpstan/phpstan-deprecation-rules": "^0.12",
1321 "phpstan/phpstan-phpunit": "^0.12",
1322 "phpstan/phpstan-strict-rules": "^0.12",
1323 "phpunit/phpunit": "^7.5|^8.0"
1324 },
1325 "suggest": {
1326 "ext-bcmath": "GMP or BCMath extensions will drastically improve the library performance. BCMath extension needed to handle the Big Float and Decimal Fraction Tags",
1327 "ext-gmp": "GMP or BCMath extensions will drastically improve the library performance"
1328 },
1329 "time": "2020-07-12T22:25:05+00:00",
1330 "type": "library",
1331 "installation-source": "dist",
1332 "autoload": {
1333 "psr-4": {
1334 "CBOR\\": "src/"
1335 }
1336 },
1337 "notification-url": "https://packagist.org/downloads/",
1338 "license": [
1339 "MIT"
1340 ],
1341 "authors": [
1342 {
1343 "name": "Florent Morselli",
1344 "homepage": "https://github.com/Spomky"
1345 },
1346 {
1347 "name": "All contributors",
1348 "homepage": "https://github.com/Spomky-Labs/cbor-php/contributors"
1349 }
1350 ],
1351 "description": "CBOR Encoder/Decoder for PHP",
1352 "keywords": [
1353 "Concise Binary Object Representation",
1354 "RFC7049",
1355 "cbor"
1356 ]
1357 },
1358 {
1359 "name": "symfony/polyfill-ctype",
1360 "version": "v1.26.0",
1361 "version_normalized": "1.26.0.0",
1362 "source": {
1363 "type": "git",
1364 "url": "https://github.com/symfony/polyfill-ctype.git",
1365 "reference": "6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4"
1366 },
1367 "dist": {
1368 "type": "zip",
1369 "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4",
1370 "reference": "6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4",
1371 "shasum": ""
1372 },
1373 "require": {
1374 "php": ">=7.1"
1375 },
1376 "provide": {
1377 "ext-ctype": "*"
1378 },
1379 "suggest": {
1380 "ext-ctype": "For best performance"
1381 },
1382 "time": "2022-05-24T11:49:31+00:00",
1383 "type": "library",
1384 "extra": {
1385 "branch-alias": {
1386 "dev-main": "1.26-dev"
1387 },
1388 "thanks": {
1389 "name": "symfony/polyfill",
1390 "url": "https://github.com/symfony/polyfill"
1391 }
1392 },
1393 "installation-source": "dist",
1394 "autoload": {
1395 "files": [
1396 "bootstrap.php"
1397 ],
1398 "psr-4": {
1399 "Symfony\\Polyfill\\Ctype\\": ""
1400 }
1401 },
1402 "notification-url": "https://packagist.org/downloads/",
1403 "license": [
1404 "MIT"
1405 ],
1406 "authors": [
1407 {
1408 "name": "Gert de Pagter",
1409 "email": "[email protected]"
1410 },
1411 {
1412 "name": "Symfony Community",
1413 "homepage": "https://symfony.com/contributors"
1414 }
1415 ],
1416 "description": "Symfony polyfill for ctype functions",
1417 "homepage": "https://symfony.com",
1418 "keywords": [
1419 "compatibility",
1420 "ctype",
1421 "polyfill",
1422 "portable"
1423 ]
1424 },
1425 {
1426 "name": "symfony/polyfill-php80",
1427 "version": "v1.26.0",
1428 "version_normalized": "1.26.0.0",
1429 "source": {
1430 "type": "git",
1431 "url": "https://github.com/symfony/polyfill-php80.git",
1432 "reference": "cfa0ae98841b9e461207c13ab093d76b0fa7bace"
1433 },
1434 "dist": {
1435 "type": "zip",
1436 "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/cfa0ae98841b9e461207c13ab093d76b0fa7bace",
1437 "reference": "cfa0ae98841b9e461207c13ab093d76b0fa7bace",
1438 "shasum": ""
1439 },
1440 "require": {
1441 "php": ">=7.1"
1442 },
1443 "time": "2022-05-10T07:21:04+00:00",
1444 "type": "library",
1445 "extra": {
1446 "branch-alias": {
1447 "dev-main": "1.26-dev"
1448 },
1449 "thanks": {
1450 "name": "symfony/polyfill",
1451 "url": "https://github.com/symfony/polyfill"
1452 }
1453 },
1454 "installation-source": "dist",
1455 "autoload": {
1456 "files": [
1457 "bootstrap.php"
1458 ],
1459 "psr-4": {
1460 "Symfony\\Polyfill\\Php80\\": ""
1461 },
1462 "classmap": [
1463 "Resources/stubs"
1464 ]
1465 },
1466 "notification-url": "https://packagist.org/downloads/",
1467 "license": [
1468 "MIT"
1469 ],
1470 "authors": [
1471 {
1472 "name": "Ion Bazan",
1473 "email": "[email protected]"
1474 },
1475 {
1476 "name": "Nicolas Grekas",
1477 "email": "[email protected]"
1478 },
1479 {
1480 "name": "Symfony Community",
1481 "homepage": "https://symfony.com/contributors"
1482 }
1483 ],
1484 "description": "Symfony polyfill backporting some PHP 8.0+ features to lower PHP versions",
1485 "homepage": "https://symfony.com",
1486 "keywords": [
1487 "compatibility",
1488 "polyfill",
1489 "portable",
1490 "shim"
1491 ]
1492 },
1493 {
1494 "name": "symfony/process",
1495 "version": "v4.4.41",
1496 "version_normalized": "4.4.41.0",
1497 "source": {
1498 "type": "git",
1499 "url": "https://github.com/symfony/process.git",
1500 "reference": "9eedd60225506d56e42210a70c21bb80ca8456ce"
1501 },
1502 "dist": {
1503 "type": "zip",
1504 "url": "https://api.github.com/repos/symfony/process/zipball/9eedd60225506d56e42210a70c21bb80ca8456ce",
1505 "reference": "9eedd60225506d56e42210a70c21bb80ca8456ce",
1506 "shasum": ""
1507 },
1508 "require": {
1509 "php": ">=7.1.3",
1510 "symfony/polyfill-php80": "^1.16"
1511 },
1512 "time": "2022-04-04T10:19:07+00:00",
1513 "type": "library",
1514 "installation-source": "dist",
1515 "autoload": {
1516 "psr-4": {
1517 "Symfony\\Component\\Process\\": ""
1518 },
1519 "exclude-from-classmap": [
1520 "/Tests/"
1521 ]
1522 },
1523 "notification-url": "https://packagist.org/downloads/",
1524 "license": [
1525 "MIT"
1526 ],
1527 "authors": [
1528 {
1529 "name": "Fabien Potencier",
1530 "email": "[email protected]"
1531 },
1532 {
1533 "name": "Symfony Community",
1534 "homepage": "https://symfony.com/contributors"
1535 }
1536 ],
1537 "description": "Executes commands in sub-processes",
1538 "homepage": "https://symfony.com"
1539 },
1540 {
1541 "name": "thecodingmachine/safe",
1542 "version": "v1.3.3",
1543 "version_normalized": "1.3.3.0",
1544 "source": {
1545 "type": "git",
1546 "url": "https://github.com/thecodingmachine/safe.git",
1547 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc"
1548 },
1549 "dist": {
1550 "type": "zip",
1551 "url": "https://api.github.com/repos/thecodingmachine/safe/zipball/a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1552 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1553 "shasum": ""
1554 },
1555 "require": {
1556 "php": ">=7.2"
1557 },
1558 "require-dev": {
1559 "phpstan/phpstan": "^0.12",
1560 "squizlabs/php_codesniffer": "^3.2",
1561 "thecodingmachine/phpstan-strict-rules": "^0.12"
1562 },
1563 "time": "2020-10-28T17:51:34+00:00",
1564 "type": "library",
1565 "extra": {
1566 "branch-alias": {
1567 "dev-master": "0.1-dev"
1568 }
1569 },
1570 "installation-source": "dist",
1571 "autoload": {
1572 "files": [
1573 "deprecated/apc.php",
1574 "deprecated/libevent.php",
1575 "deprecated/mssql.php",
1576 "deprecated/stats.php",
1577 "lib/special_cases.php",
1578 "generated/apache.php",
1579 "generated/apcu.php",
1580 "generated/array.php",
1581 "generated/bzip2.php",
1582 "generated/calendar.php",
1583 "generated/classobj.php",
1584 "generated/com.php",
1585 "generated/cubrid.php",
1586 "generated/curl.php",
1587 "generated/datetime.php",
1588 "generated/dir.php",
1589 "generated/eio.php",
1590 "generated/errorfunc.php",
1591 "generated/exec.php",
1592 "generated/fileinfo.php",
1593 "generated/filesystem.php",
1594 "generated/filter.php",
1595 "generated/fpm.php",
1596 "generated/ftp.php",
1597 "generated/funchand.php",
1598 "generated/gmp.php",
1599 "generated/gnupg.php",
1600 "generated/hash.php",
1601 "generated/ibase.php",
1602 "generated/ibmDb2.php",
1603 "generated/iconv.php",
1604 "generated/image.php",
1605 "generated/imap.php",
1606 "generated/info.php",
1607 "generated/ingres-ii.php",
1608 "generated/inotify.php",
1609 "generated/json.php",
1610 "generated/ldap.php",
1611 "generated/libxml.php",
1612 "generated/lzf.php",
1613 "generated/mailparse.php",
1614 "generated/mbstring.php",
1615 "generated/misc.php",
1616 "generated/msql.php",
1617 "generated/mysql.php",
1618 "generated/mysqli.php",
1619 "generated/mysqlndMs.php",
1620 "generated/mysqlndQc.php",
1621 "generated/network.php",
1622 "generated/oci8.php",
1623 "generated/opcache.php",
1624 "generated/openssl.php",
1625 "generated/outcontrol.php",
1626 "generated/password.php",
1627 "generated/pcntl.php",
1628 "generated/pcre.php",
1629 "generated/pdf.php",
1630 "generated/pgsql.php",
1631 "generated/posix.php",
1632 "generated/ps.php",
1633 "generated/pspell.php",
1634 "generated/readline.php",
1635 "generated/rpminfo.php",
1636 "generated/rrd.php",
1637 "generated/sem.php",
1638 "generated/session.php",
1639 "generated/shmop.php",
1640 "generated/simplexml.php",
1641 "generated/sockets.php",
1642 "generated/sodium.php",
1643 "generated/solr.php",
1644 "generated/spl.php",
1645 "generated/sqlsrv.php",
1646 "generated/ssdeep.php",
1647 "generated/ssh2.php",
1648 "generated/stream.php",
1649 "generated/strings.php",
1650 "generated/swoole.php",
1651 "generated/uodbc.php",
1652 "generated/uopz.php",
1653 "generated/url.php",
1654 "generated/var.php",
1655 "generated/xdiff.php",
1656 "generated/xml.php",
1657 "generated/xmlrpc.php",
1658 "generated/yaml.php",
1659 "generated/yaz.php",
1660 "generated/zip.php",
1661 "generated/zlib.php"
1662 ],
1663 "psr-4": {
1664 "Safe\\": [
1665 "lib/",
1666 "deprecated/",
1667 "generated/"
1668 ]
1669 }
1670 },
1671 "notification-url": "https://packagist.org/downloads/",
1672 "license": [
1673 "MIT"
1674 ],
1675 "description": "PHP core functions that throw exceptions instead of returning FALSE on error"
1676 },
1677 {
1678 "name": "vlucas/valitron",
1679 "version": "v1.4.10",
1680 "version_normalized": "1.4.10.0",
1681 "source": {
1682 "type": "git",
1683 "url": "https://github.com/vlucas/valitron.git",
1684 "reference": "5ebd5d7af82cc0a9d798e816a2ecad63f1b59ceb"
1685 },
1686 "dist": {
1687 "type": "zip",
1688 "url": "https://api.github.com/repos/vlucas/valitron/zipball/5ebd5d7af82cc0a9d798e816a2ecad63f1b59ceb",
1689 "reference": "5ebd5d7af82cc0a9d798e816a2ecad63f1b59ceb",
1690 "shasum": ""
1691 },
1692 "require": {
1693 "php": ">=5.3.2"
1694 },
1695 "require-dev": {
1696 "phpunit/phpunit": ">=4.8.35"
1697 },
1698 "suggest": {
1699 "ext-mbstring": "It can support the multiple bytes string length."
1700 },
1701 "time": "2021-07-08T16:18:03+00:00",
1702 "type": "library",
1703 "installation-source": "dist",
1704 "autoload": {
1705 "psr-4": {
1706 "Valitron\\": "src/Valitron"
1707 }
1708 },
1709 "notification-url": "https://packagist.org/downloads/",
1710 "license": [
1711 "BSD-3-Clause"
1712 ],
1713 "authors": [
1714 {
1715 "name": "Vance Lucas",
1716 "email": "[email protected]",
1717 "homepage": "https://www.vancelucas.com"
1718 }
1719 ],
1720 "description": "Simple, elegant, stand-alone validation library with NO dependencies",
1721 "homepage": "https://github.com/vlucas/valitron",
1722 "keywords": [
1723 "valid",
1724 "validation",
1725 "validator"
1726 ]
1727 },
1728 {
1729 "name": "web-auth/cose-lib",
1730 "version": "v3.3.12",
1731 "version_normalized": "3.3.12.0",
1732 "source": {
1733 "type": "git",
1734 "url": "https://github.com/web-auth/cose-lib.git",
1735 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb"
1736 },
1737 "dist": {
1738 "type": "zip",
1739 "url": "https://api.github.com/repos/web-auth/cose-lib/zipball/efa6ec2ba4e840bc1316a493973c9916028afeeb",
1740 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb",
1741 "shasum": ""
1742 },
1743 "require": {
1744 "beberlei/assert": "^3.2",
1745 "ext-json": "*",
1746 "ext-mbstring": "*",
1747 "ext-openssl": "*",
1748 "fgrosse/phpasn1": "^2.1",
1749 "php": ">=7.2"
1750 },
1751 "time": "2021-12-04T12:13:35+00:00",
1752 "type": "library",
1753 "installation-source": "dist",
1754 "autoload": {
1755 "psr-4": {
1756 "Cose\\": "src/"
1757 }
1758 },
1759 "notification-url": "https://packagist.org/downloads/",
1760 "license": [
1761 "MIT"
1762 ],
1763 "authors": [
1764 {
1765 "name": "Florent Morselli",
1766 "homepage": "https://github.com/Spomky"
1767 },
1768 {
1769 "name": "All contributors",
1770 "homepage": "https://github.com/web-auth/cose/contributors"
1771 }
1772 ],
1773 "description": "CBOR Object Signing and Encryption (COSE) For PHP",
1774 "homepage": "https://github.com/web-auth",
1775 "keywords": [
1776 "COSE",
1777 "RFC8152"
1778 ]
1779 },
1780 {
1781 "name": "web-auth/metadata-service",
1782 "version": "v3.3.12",
1783 "version_normalized": "3.3.12.0",
1784 "source": {
1785 "type": "git",
1786 "url": "https://github.com/web-auth/webauthn-metadata-service.git",
1787 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246"
1788 },
1789 "dist": {
1790 "type": "zip",
1791 "url": "https://api.github.com/repos/web-auth/webauthn-metadata-service/zipball/ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1792 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1793 "shasum": ""
1794 },
1795 "require": {
1796 "beberlei/assert": "^3.2",
1797 "ext-json": "*",
1798 "league/uri": "^6.0",
1799 "php": ">=7.2",
1800 "psr/http-client": "^1.0",
1801 "psr/http-factory": "^1.0",
1802 "psr/log": "^1.1"
1803 },
1804 "suggest": {
1805 "web-token/jwt-key-mgmt": "Mandatory for fetching Metadata Statement from distant sources",
1806 "web-token/jwt-signature-algorithm-ecdsa": "Mandatory for fetching Metadata Statement from distant sources"
1807 },
1808 "time": "2021-11-21T11:14:31+00:00",
1809 "type": "library",
1810 "installation-source": "dist",
1811 "autoload": {
1812 "psr-4": {
1813 "Webauthn\\MetadataService\\": "src/"
1814 }
1815 },
1816 "notification-url": "https://packagist.org/downloads/",
1817 "license": [
1818 "MIT"
1819 ],
1820 "authors": [
1821 {
1822 "name": "Florent Morselli",
1823 "homepage": "https://github.com/Spomky"
1824 },
1825 {
1826 "name": "All contributors",
1827 "homepage": "https://github.com/web-auth/metadata-service/contributors"
1828 }
1829 ],
1830 "description": "Metadata Service for FIDO2/Webauthn",
1831 "homepage": "https://github.com/web-auth",
1832 "keywords": [
1833 "FIDO2",
1834 "fido",
1835 "webauthn"
1836 ]
1837 },
1838 {
1839 "name": "web-auth/webauthn-lib",
1840 "version": "v3.3.12",
1841 "version_normalized": "3.3.12.0",
1842 "source": {
1843 "type": "git",
1844 "url": "https://github.com/web-auth/webauthn-lib.git",
1845 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33"
1846 },
1847 "dist": {
1848 "type": "zip",
1849 "url": "https://api.github.com/repos/web-auth/webauthn-lib/zipball/5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
1850 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
1851 "shasum": ""
1852 },
1853 "require": {
1854 "beberlei/assert": "^3.2",
1855 "ext-json": "*",
1856 "ext-mbstring": "*",
1857 "ext-openssl": "*",
1858 "fgrosse/phpasn1": "^2.1",
1859 "php": ">=7.2",
1860 "psr/http-client": "^1.0",
1861 "psr/http-factory": "^1.0",
1862 "psr/http-message": "^1.0",
1863 "psr/log": "^1.1",
1864 "ramsey/uuid": "^3.8|^4.0",
1865 "spomky-labs/base64url": "^2.0",
1866 "spomky-labs/cbor-php": "^1.0|^2.0",
1867 "symfony/process": "^3.0|^4.0|^5.0",
1868 "thecodingmachine/safe": "^1.1",
1869 "web-auth/cose-lib": "self.version",
1870 "web-auth/metadata-service": "self.version"
1871 },
1872 "suggest": {
1873 "psr/log-implementation": "Recommended to receive logs from the library",
1874 "web-token/jwt-key-mgmt": "Mandatory for the AndroidSafetyNet Attestation Statement support",
1875 "web-token/jwt-signature-algorithm-ecdsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
1876 "web-token/jwt-signature-algorithm-eddsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
1877 "web-token/jwt-signature-algorithm-rsa": "Mandatory for the AndroidSafetyNet Attestation Statement support"
1878 },
1879 "time": "2022-02-18T07:13:44+00:00",
1880 "type": "library",
1881 "installation-source": "dist",
1882 "autoload": {
1883 "psr-4": {
1884 "Webauthn\\": "src/"
1885 }
1886 },
1887 "notification-url": "https://packagist.org/downloads/",
1888 "license": [
1889 "MIT"
1890 ],
1891 "authors": [
1892 {
1893 "name": "Florent Morselli",
1894 "homepage": "https://github.com/Spomky"
1895 },
1896 {
1897 "name": "All contributors",
1898 "homepage": "https://github.com/web-auth/webauthn-library/contributors"
1899 }
1900 ],
1901 "description": "FIDO2/Webauthn Support For PHP",
1902 "homepage": "https://github.com/web-auth",
1903 "keywords": [
1904 "FIDO2",
1905 "fido",
1906 "webauthn"
1907 ]
1908 },
1909 {
1910 "name": "web-token/jwt-core",
1911 "version": "v2.2.11",
1912 "version_normalized": "2.2.11.0",
1913 "source": {
1914 "type": "git",
1915 "url": "https://github.com/web-token/jwt-core.git",
1916 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678"
1917 },
1918 "dist": {
1919 "type": "zip",
1920 "url": "https://api.github.com/repos/web-token/jwt-core/zipball/53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
1921 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
1922 "shasum": ""
1923 },
1924 "require": {
1925 "brick/math": "^0.8.17|^0.9",
1926 "ext-json": "*",
1927 "ext-mbstring": "*",
1928 "fgrosse/phpasn1": "^2.0",
1929 "php": ">=7.2",
1930 "spomky-labs/base64url": "^1.0|^2.0"
1931 },
1932 "conflict": {
1933 "spomky-labs/jose": "*"
1934 },
1935 "time": "2021-03-17T14:55:52+00:00",
1936 "type": "library",
1937 "installation-source": "dist",
1938 "autoload": {
1939 "psr-4": {
1940 "Jose\\Component\\Core\\": ""
1941 }
1942 },
1943 "notification-url": "https://packagist.org/downloads/",
1944 "license": [
1945 "MIT"
1946 ],
1947 "authors": [
1948 {
1949 "name": "Florent Morselli",
1950 "homepage": "https://github.com/Spomky"
1951 },
1952 {
1953 "name": "All contributors",
1954 "homepage": "https://github.com/web-token/jwt-framework/contributors"
1955 }
1956 ],
1957 "description": "Core component of the JWT Framework.",
1958 "homepage": "https://github.com/web-token",
1959 "keywords": [
1960 "JOSE",
1961 "JWE",
1962 "JWK",
1963 "JWKSet",
1964 "JWS",
1965 "Jot",
1966 "RFC7515",
1967 "RFC7516",
1968 "RFC7517",
1969 "RFC7518",
1970 "RFC7519",
1971 "RFC7520",
1972 "bundle",
1973 "jwa",
1974 "jwt",
1975 "symfony"
1976 ]
1977 },
1978 {
1979 "name": "web-token/jwt-key-mgmt",
1980 "version": "v2.2.11",
1981 "version_normalized": "2.2.11.0",
1982 "source": {
1983 "type": "git",
1984 "url": "https://github.com/web-token/jwt-key-mgmt.git",
1985 "reference": "0b116379515700d237b4e5de86879078ccb09d8a"
1986 },
1987 "dist": {
1988 "type": "zip",
1989 "url": "https://api.github.com/repos/web-token/jwt-key-mgmt/zipball/0b116379515700d237b4e5de86879078ccb09d8a",
1990 "reference": "0b116379515700d237b4e5de86879078ccb09d8a",
1991 "shasum": ""
1992 },
1993 "require": {
1994 "ext-openssl": "*",
1995 "psr/http-client": "^1.0",
1996 "psr/http-factory": "^1.0",
1997 "web-token/jwt-core": "^2.0"
1998 },
1999 "suggest": {
2000 "ext-sodium": "Sodium is required for OKP key creation, EdDSA signature algorithm and ECDH-ES key encryption with OKP keys",
2001 "php-http/httplug": "To enable JKU/X5U support.",
2002 "php-http/message-factory": "To enable JKU/X5U support.",
2003 "web-token/jwt-util-ecc": "To use EC key analyzers."
2004 },
2005 "time": "2021-03-17T14:55:52+00:00",
2006 "type": "library",
2007 "installation-source": "dist",
2008 "autoload": {
2009 "psr-4": {
2010 "Jose\\Component\\KeyManagement\\": ""
2011 }
2012 },
2013 "notification-url": "https://packagist.org/downloads/",
2014 "license": [
2015 "MIT"
2016 ],
2017 "authors": [
2018 {
2019 "name": "Florent Morselli",
2020 "homepage": "https://github.com/Spomky"
2021 },
2022 {
2023 "name": "All contributors",
2024 "homepage": "https://github.com/web-token/jwt-key-mgmt/contributors"
2025 }
2026 ],
2027 "description": "Key Management component of the JWT Framework.",
2028 "homepage": "https://github.com/web-token",
2029 "keywords": [
2030 "JOSE",
2031 "JWE",
2032 "JWK",
2033 "JWKSet",
2034 "JWS",
2035 "Jot",
2036 "RFC7515",
2037 "RFC7516",
2038 "RFC7517",
2039 "RFC7518",
2040 "RFC7519",
2041 "RFC7520",
2042 "bundle",
2043 "jwa",
2044 "jwt",
2045 "symfony"
2046 ]
2047 },
2048 {
2049 "name": "web-token/jwt-signature",
2050 "version": "v2.2.11",
2051 "version_normalized": "2.2.11.0",
2052 "source": {
2053 "type": "git",
2054 "url": "https://github.com/web-token/jwt-signature.git",
2055 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103"
2056 },
2057 "dist": {
2058 "type": "zip",
2059 "url": "https://api.github.com/repos/web-token/jwt-signature/zipball/015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2060 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2061 "shasum": ""
2062 },
2063 "require": {
2064 "web-token/jwt-core": "^2.1"
2065 },
2066 "suggest": {
2067 "web-token/jwt-signature-algorithm-ecdsa": "ECDSA Based Signature Algorithms",
2068 "web-token/jwt-signature-algorithm-eddsa": "EdDSA Based Signature Algorithms",
2069 "web-token/jwt-signature-algorithm-experimental": "Experimental Signature Algorithms",
2070 "web-token/jwt-signature-algorithm-hmac": "HMAC Based Signature Algorithms",
2071 "web-token/jwt-signature-algorithm-none": "None Signature Algorithm",
2072 "web-token/jwt-signature-algorithm-rsa": "RSA Based Signature Algorithms"
2073 },
2074 "time": "2021-03-01T19:55:28+00:00",
2075 "type": "library",
2076 "installation-source": "dist",
2077 "autoload": {
2078 "psr-4": {
2079 "Jose\\Component\\Signature\\": ""
2080 }
2081 },
2082 "notification-url": "https://packagist.org/downloads/",
2083 "license": [
2084 "MIT"
2085 ],
2086 "authors": [
2087 {
2088 "name": "Florent Morselli",
2089 "homepage": "https://github.com/Spomky"
2090 },
2091 {
2092 "name": "All contributors",
2093 "homepage": "https://github.com/web-token/jwt-signature/contributors"
2094 }
2095 ],
2096 "description": "Signature component of the JWT Framework.",
2097 "homepage": "https://github.com/web-token",
2098 "keywords": [
2099 "JOSE",
2100 "JWE",
2101 "JWK",
2102 "JWKSet",
2103 "JWS",
2104 "Jot",
2105 "RFC7515",
2106 "RFC7516",
2107 "RFC7517",
2108 "RFC7518",
2109 "RFC7519",
2110 "RFC7520",
2111 "bundle",
2112 "jwa",
2113 "jwt",
2114 "symfony"
2115 ]
2116 },
2117 {
2118 "name": "web-token/jwt-signature-algorithm-ecdsa",
2119 "version": "v2.2.11",
2120 "version_normalized": "2.2.11.0",
2121 "source": {
2122 "type": "git",
2123 "url": "https://github.com/web-token/jwt-signature-algorithm-ecdsa.git",
2124 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591"
2125 },
2126 "dist": {
2127 "type": "zip",
2128 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-ecdsa/zipball/44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2129 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2130 "shasum": ""
2131 },
2132 "require": {
2133 "ext-openssl": "*",
2134 "web-token/jwt-signature": "^2.0"
2135 },
2136 "time": "2021-01-21T19:18:03+00:00",
2137 "type": "library",
2138 "installation-source": "dist",
2139 "autoload": {
2140 "psr-4": {
2141 "Jose\\Component\\Signature\\Algorithm\\": ""
2142 }
2143 },
2144 "notification-url": "https://packagist.org/downloads/",
2145 "license": [
2146 "MIT"
2147 ],
2148 "authors": [
2149 {
2150 "name": "Florent Morselli",
2151 "homepage": "https://github.com/Spomky"
2152 },
2153 {
2154 "name": "All contributors",
2155 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2156 }
2157 ],
2158 "description": "ECDSA Based Signature Algorithms the JWT Framework.",
2159 "homepage": "https://github.com/web-token",
2160 "keywords": [
2161 "JOSE",
2162 "JWE",
2163 "JWK",
2164 "JWKSet",
2165 "JWS",
2166 "Jot",
2167 "RFC7515",
2168 "RFC7516",
2169 "RFC7517",
2170 "RFC7518",
2171 "RFC7519",
2172 "RFC7520",
2173 "bundle",
2174 "jwa",
2175 "jwt",
2176 "symfony"
2177 ]
2178 },
2179 {
2180 "name": "web-token/jwt-signature-algorithm-eddsa",
2181 "version": "v2.2.11",
2182 "version_normalized": "2.2.11.0",
2183 "source": {
2184 "type": "git",
2185 "url": "https://github.com/web-token/jwt-signature-algorithm-eddsa.git",
2186 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6"
2187 },
2188 "dist": {
2189 "type": "zip",
2190 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-eddsa/zipball/b805ecca593c56e60e0463bd2cacc9b1341910f6",
2191 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6",
2192 "shasum": ""
2193 },
2194 "require": {
2195 "ext-sodium": "*",
2196 "web-token/jwt-signature": "^2.1"
2197 },
2198 "time": "2021-01-21T19:18:03+00:00",
2199 "type": "library",
2200 "installation-source": "dist",
2201 "autoload": {
2202 "psr-4": {
2203 "Jose\\Component\\Signature\\Algorithm\\": ""
2204 }
2205 },
2206 "notification-url": "https://packagist.org/downloads/",
2207 "license": [
2208 "MIT"
2209 ],
2210 "authors": [
2211 {
2212 "name": "Florent Morselli",
2213 "homepage": "https://github.com/Spomky"
2214 },
2215 {
2216 "name": "All contributors",
2217 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2218 }
2219 ],
2220 "description": "EdDSA Signature Algorithm the JWT Framework.",
2221 "homepage": "https://github.com/web-token",
2222 "keywords": [
2223 "JOSE",
2224 "JWE",
2225 "JWK",
2226 "JWKSet",
2227 "JWS",
2228 "Jot",
2229 "RFC7515",
2230 "RFC7516",
2231 "RFC7517",
2232 "RFC7518",
2233 "RFC7519",
2234 "RFC7520",
2235 "bundle",
2236 "jwa",
2237 "jwt",
2238 "symfony"
2239 ]
2240 },
2241 {
2242 "name": "web-token/jwt-signature-algorithm-rsa",
2243 "version": "v2.2.11",
2244 "version_normalized": "2.2.11.0",
2245 "source": {
2246 "type": "git",
2247 "url": "https://github.com/web-token/jwt-signature-algorithm-rsa.git",
2248 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0"
2249 },
2250 "dist": {
2251 "type": "zip",
2252 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-rsa/zipball/513ad90eb5ef1886ff176727a769bda4618141b0",
2253 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0",
2254 "shasum": ""
2255 },
2256 "require": {
2257 "brick/math": "^0.8.17|^0.9",
2258 "ext-openssl": "*",
2259 "web-token/jwt-signature": "^2.1"
2260 },
2261 "suggest": {
2262 "ext-bcmath": "GMP or BCMath is highly recommended to improve the library performance",
2263 "ext-gmp": "GMP or BCMath is highly recommended to improve the library performance"
2264 },
2265 "time": "2021-01-21T19:18:03+00:00",
2266 "type": "library",
2267 "installation-source": "dist",
2268 "autoload": {
2269 "psr-4": {
2270 "Jose\\Component\\Signature\\Algorithm\\": ""
2271 }
2272 },
2273 "notification-url": "https://packagist.org/downloads/",
2274 "license": [
2275 "MIT"
2276 ],
2277 "authors": [
2278 {
2279 "name": "Florent Morselli",
2280 "homepage": "https://github.com/Spomky"
2281 },
2282 {
2283 "name": "All contributors",
2284 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2285 }
2286 ],
2287 "description": "RSA Based Signature Algorithms the JWT Framework.",
2288 "homepage": "https://github.com/web-token",
2289 "keywords": [
2290 "JOSE",
2291 "JWE",
2292 "JWK",
2293 "JWKSet",
2294 "JWS",
2295 "Jot",
2296 "RFC7515",
2297 "RFC7516",
2298 "RFC7517",
2299 "RFC7518",
2300 "RFC7519",
2301 "RFC7520",
2302 "bundle",
2303 "jwa",
2304 "jwt",
2305 "symfony"
2306 ]
2307 },
2308 {
2309 "name": "woocommerce/action-scheduler",
2310 "version": "3.3.0",
2311 "version_normalized": "3.3.0.0",
2312 "source": {
2313 "type": "git",
2314 "url": "https://github.com/woocommerce/action-scheduler.git",
2315 "reference": "5588a831cd2453ecf7d4803f3a81063e13cde93d"
2316 },
2317 "dist": {
2318 "type": "zip",
2319 "url": "https://api.github.com/repos/woocommerce/action-scheduler/zipball/5588a831cd2453ecf7d4803f3a81063e13cde93d",
2320 "reference": "5588a831cd2453ecf7d4803f3a81063e13cde93d",
2321 "shasum": ""
2322 },
2323 "require-dev": {
2324 "phpunit/phpunit": "^7.5",
2325 "woocommerce/woocommerce-sniffs": "0.1.0",
2326 "wp-cli/wp-cli": "~2.5.0"
2327 },
2328 "time": "2021-09-15T21:08:48+00:00",
2329 "type": "wordpress-plugin",
2330 "extra": {
2331 "scripts-description": {
2332 "test": "Run unit tests",
2333 "phpcs": "Analyze code against the WordPress coding standards with PHP_CodeSniffer",
2334 "phpcbf": "Fix coding standards warnings/errors automatically with PHP Code Beautifier"
2335 }
2336 },
2337 "installation-source": "dist",
2338 "notification-url": "https://packagist.org/downloads/",
2339 "license": [
2340 "GPL-3.0-or-later"
2341 ],
2342 "description": "Action Scheduler for WordPress and WooCommerce",
2343 "homepage": "https://actionscheduler.org/"
2344 }
2345 ]
2346