PluginProbe
Defender Security – Malware Scanner, Login Security & Firewall / 5.6.0
Defender Security – Malware Scanner, Login Security & Firewall v5.6.0
6.3.0 6.2.3 6.2.4 6.2.0 6.2.1 6.2.2 6.1.0 5.3.1 5.4.0 5.4.1 5.5.0 5.5.1 5.6.0 5.6.1 5.6.2 5.7.0 5.7.1 5.7.2 5.8.0 5.8.1 5.9.0 6.0.0 6.0.1 3.0.1 3.1.0 All 141 releases
defender-security / vendor / composer / installed.json

installed.json in Defender Security – Malware Scanner, Login Security & Firewall 5.6.0, at vendor/composer/installed.json

2,560 lines 92.5 KB
No matching file
Up and down to move Enter to open Esc to close
Raw Download Zip
1 {
2 "packages": [
3 {
4 "name": "altcha-org/altcha",
5 "version": "v0.1.4",
6 "version_normalized": "0.1.4.0",
7 "source": {
8 "type": "git",
9 "url": "https://github.com/altcha-org/altcha-lib-php.git",
10 "reference": "0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6"
11 },
12 "dist": {
13 "type": "zip",
14 "url": "https://api.github.com/repos/altcha-org/altcha-lib-php/zipball/0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6",
15 "reference": "0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6",
16 "shasum": ""
17 },
18 "require": {
19 "php": ">=7.4"
20 },
21 "require-dev": {
22 "phpunit/phpunit": "^11.5"
23 },
24 "time": "2025-02-28T05:17:34+00:00",
25 "type": "library",
26 "installation-source": "dist",
27 "autoload": {
28 "psr-4": {
29 "AltchaOrg\\Altcha\\": "src/"
30 }
31 },
32 "notification-url": "https://packagist.org/downloads/",
33 "license": [
34 "MIT"
35 ],
36 "authors": [
37 {
38 "name": "Daniel Regeci",
39 "email": "[email protected]"
40 }
41 ],
42 "support": {
43 "issues": "https://github.com/altcha-org/altcha-lib-php/issues",
44 "source": "https://github.com/altcha-org/altcha-lib-php/tree/v0.1.4"
45 },
46 "install-path": "../altcha-org/altcha"
47 },
48 {
49 "name": "beberlei/assert",
50 "version": "v3.3.3",
51 "version_normalized": "3.3.3.0",
52 "source": {
53 "type": "git",
54 "url": "https://github.com/beberlei/assert.git",
55 "reference": "b5fd8eacd8915a1b627b8bfc027803f1939734dd"
56 },
57 "dist": {
58 "type": "zip",
59 "url": "https://api.github.com/repos/beberlei/assert/zipball/b5fd8eacd8915a1b627b8bfc027803f1939734dd",
60 "reference": "b5fd8eacd8915a1b627b8bfc027803f1939734dd",
61 "shasum": ""
62 },
63 "require": {
64 "ext-ctype": "*",
65 "ext-json": "*",
66 "ext-mbstring": "*",
67 "ext-simplexml": "*",
68 "php": "^7.1 || ^8.0"
69 },
70 "require-dev": {
71 "friendsofphp/php-cs-fixer": "*",
72 "phpstan/phpstan": "*",
73 "phpunit/phpunit": ">=6.0.0",
74 "yoast/phpunit-polyfills": "^0.1.0"
75 },
76 "suggest": {
77 "ext-intl": "Needed to allow Assertion::count(), Assertion::isCountable(), Assertion::minCount(), and Assertion::maxCount() to operate on ResourceBundles"
78 },
79 "time": "2024-07-15T13:18:35+00:00",
80 "type": "library",
81 "installation-source": "dist",
82 "autoload": {
83 "files": [
84 "lib/Assert/functions.php"
85 ],
86 "psr-4": {
87 "Assert\\": "lib/Assert"
88 }
89 },
90 "notification-url": "https://packagist.org/downloads/",
91 "license": [
92 "BSD-2-Clause"
93 ],
94 "authors": [
95 {
96 "name": "Benjamin Eberlei",
97 "email": "[email protected]",
98 "role": "Lead Developer"
99 },
100 {
101 "name": "Richard Quadling",
102 "email": "[email protected]",
103 "role": "Collaborator"
104 }
105 ],
106 "description": "Thin assertion library for input validation in business models.",
107 "keywords": [
108 "assert",
109 "assertion",
110 "validation"
111 ],
112 "support": {
113 "issues": "https://github.com/beberlei/assert/issues",
114 "source": "https://github.com/beberlei/assert/tree/v3.3.3"
115 },
116 "install-path": "../beberlei/assert"
117 },
118 {
119 "name": "brick/math",
120 "version": "0.9.3",
121 "version_normalized": "0.9.3.0",
122 "source": {
123 "type": "git",
124 "url": "https://github.com/brick/math.git",
125 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae"
126 },
127 "dist": {
128 "type": "zip",
129 "url": "https://api.github.com/repos/brick/math/zipball/ca57d18f028f84f777b2168cd1911b0dee2343ae",
130 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae",
131 "shasum": ""
132 },
133 "require": {
134 "ext-json": "*",
135 "php": "^7.1 || ^8.0"
136 },
137 "require-dev": {
138 "php-coveralls/php-coveralls": "^2.2",
139 "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
140 "vimeo/psalm": "4.9.2"
141 },
142 "time": "2021-08-15T20:50:18+00:00",
143 "type": "library",
144 "installation-source": "dist",
145 "autoload": {
146 "psr-4": {
147 "Brick\\Math\\": "src/"
148 }
149 },
150 "notification-url": "https://packagist.org/downloads/",
151 "license": [
152 "MIT"
153 ],
154 "description": "Arbitrary-precision arithmetic library",
155 "keywords": [
156 "Arbitrary-precision",
157 "BigInteger",
158 "BigRational",
159 "arithmetic",
160 "bigdecimal",
161 "bignum",
162 "brick",
163 "math"
164 ],
165 "support": {
166 "issues": "https://github.com/brick/math/issues",
167 "source": "https://github.com/brick/math/tree/0.9.3"
168 },
169 "funding": [
170 {
171 "url": "https://github.com/BenMorel",
172 "type": "github"
173 },
174 {
175 "url": "https://tidelift.com/funding/github/packagist/brick/math",
176 "type": "tidelift"
177 }
178 ],
179 "install-path": "../brick/math"
180 },
181 {
182 "name": "fgrosse/phpasn1",
183 "version": "v2.5.0",
184 "version_normalized": "2.5.0.0",
185 "source": {
186 "type": "git",
187 "url": "https://github.com/fgrosse/PHPASN1.git",
188 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b"
189 },
190 "dist": {
191 "type": "zip",
192 "url": "https://api.github.com/repos/fgrosse/PHPASN1/zipball/42060ed45344789fb9f21f9f1864fc47b9e3507b",
193 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b",
194 "shasum": ""
195 },
196 "require": {
197 "php": "^7.1 || ^8.0"
198 },
199 "require-dev": {
200 "php-coveralls/php-coveralls": "~2.0",
201 "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
202 },
203 "suggest": {
204 "ext-bcmath": "BCmath is the fallback extension for big integer calculations",
205 "ext-curl": "For loading OID information from the web if they have not bee defined statically",
206 "ext-gmp": "GMP is the preferred extension for big integer calculations",
207 "phpseclib/bcmath_compat": "BCmath polyfill for servers where neither GMP nor BCmath is available"
208 },
209 "time": "2022-12-19T11:08:26+00:00",
210 "type": "library",
211 "extra": {
212 "branch-alias": {
213 "dev-master": "2.0.x-dev"
214 }
215 },
216 "installation-source": "dist",
217 "autoload": {
218 "psr-4": {
219 "FG\\": "lib/"
220 }
221 },
222 "notification-url": "https://packagist.org/downloads/",
223 "license": [
224 "MIT"
225 ],
226 "authors": [
227 {
228 "name": "Friedrich Große",
229 "email": "[email protected]",
230 "homepage": "https://github.com/FGrosse",
231 "role": "Author"
232 },
233 {
234 "name": "All contributors",
235 "homepage": "https://github.com/FGrosse/PHPASN1/contributors"
236 }
237 ],
238 "description": "A PHP Framework that allows you to encode and decode arbitrary ASN.1 structures using the ITU-T X.690 Encoding Rules.",
239 "homepage": "https://github.com/FGrosse/PHPASN1",
240 "keywords": [
241 "DER",
242 "asn.1",
243 "asn1",
244 "ber",
245 "binary",
246 "decoding",
247 "encoding",
248 "x.509",
249 "x.690",
250 "x509",
251 "x690"
252 ],
253 "support": {
254 "issues": "https://github.com/fgrosse/PHPASN1/issues",
255 "source": "https://github.com/fgrosse/PHPASN1/tree/v2.5.0"
256 },
257 "abandoned": true,
258 "install-path": "../fgrosse/phpasn1"
259 },
260 {
261 "name": "gettext/gettext",
262 "version": "v5.7.3",
263 "version_normalized": "5.7.3.0",
264 "source": {
265 "type": "git",
266 "url": "https://github.com/php-gettext/Gettext.git",
267 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1"
268 },
269 "dist": {
270 "type": "zip",
271 "url": "https://api.github.com/repos/php-gettext/Gettext/zipball/95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
272 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
273 "shasum": ""
274 },
275 "require": {
276 "gettext/languages": "^2.3",
277 "php": "^7.2|^8.0"
278 },
279 "require-dev": {
280 "brick/varexporter": "^0.3.5",
281 "friendsofphp/php-cs-fixer": "^3.2",
282 "oscarotero/php-cs-fixer-config": "^2.0",
283 "phpunit/phpunit": "^8.0|^9.0",
284 "squizlabs/php_codesniffer": "^3.0"
285 },
286 "time": "2024-12-01T10:18:08+00:00",
287 "type": "library",
288 "installation-source": "dist",
289 "autoload": {
290 "psr-4": {
291 "Gettext\\": "src"
292 }
293 },
294 "notification-url": "https://packagist.org/downloads/",
295 "license": [
296 "MIT"
297 ],
298 "authors": [
299 {
300 "name": "Oscar Otero",
301 "email": "[email protected]",
302 "homepage": "http://oscarotero.com",
303 "role": "Developer"
304 }
305 ],
306 "description": "PHP gettext manager",
307 "homepage": "https://github.com/php-gettext/Gettext",
308 "keywords": [
309 "JS",
310 "gettext",
311 "i18n",
312 "mo",
313 "po",
314 "translation"
315 ],
316 "support": {
317 "email": "[email protected]",
318 "issues": "https://github.com/php-gettext/Gettext/issues",
319 "source": "https://github.com/php-gettext/Gettext/tree/v5.7.3"
320 },
321 "funding": [
322 {
323 "url": "https://paypal.me/oscarotero",
324 "type": "custom"
325 },
326 {
327 "url": "https://github.com/oscarotero",
328 "type": "github"
329 },
330 {
331 "url": "https://www.patreon.com/misteroom",
332 "type": "patreon"
333 }
334 ],
335 "install-path": "../gettext/gettext"
336 },
337 {
338 "name": "gettext/languages",
339 "version": "2.12.1",
340 "version_normalized": "2.12.1.0",
341 "source": {
342 "type": "git",
343 "url": "https://github.com/php-gettext/Languages.git",
344 "reference": "0b0b0851c55168e1dfb14305735c64019732b5f1"
345 },
346 "dist": {
347 "type": "zip",
348 "url": "https://api.github.com/repos/php-gettext/Languages/zipball/0b0b0851c55168e1dfb14305735c64019732b5f1",
349 "reference": "0b0b0851c55168e1dfb14305735c64019732b5f1",
350 "shasum": ""
351 },
352 "require": {
353 "php": ">=5.3"
354 },
355 "require-dev": {
356 "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.5 || ^8.4"
357 },
358 "time": "2025-03-19T11:14:02+00:00",
359 "bin": [
360 "bin/export-plural-rules",
361 "bin/import-cldr-data"
362 ],
363 "type": "library",
364 "installation-source": "dist",
365 "autoload": {
366 "psr-4": {
367 "Gettext\\Languages\\": "src/"
368 }
369 },
370 "notification-url": "https://packagist.org/downloads/",
371 "license": [
372 "MIT"
373 ],
374 "authors": [
375 {
376 "name": "Michele Locati",
377 "email": "[email protected]",
378 "role": "Developer"
379 }
380 ],
381 "description": "gettext languages with plural rules",
382 "homepage": "https://github.com/php-gettext/Languages",
383 "keywords": [
384 "cldr",
385 "i18n",
386 "internationalization",
387 "l10n",
388 "language",
389 "languages",
390 "localization",
391 "php",
392 "plural",
393 "plural rules",
394 "plurals",
395 "translate",
396 "translations",
397 "unicode"
398 ],
399 "support": {
400 "issues": "https://github.com/php-gettext/Languages/issues",
401 "source": "https://github.com/php-gettext/Languages/tree/2.12.1"
402 },
403 "funding": [
404 {
405 "url": "https://paypal.me/mlocati",
406 "type": "custom"
407 },
408 {
409 "url": "https://github.com/mlocati",
410 "type": "github"
411 }
412 ],
413 "install-path": "../gettext/languages"
414 },
415 {
416 "name": "league/uri",
417 "version": "6.7.2",
418 "version_normalized": "6.7.2.0",
419 "source": {
420 "type": "git",
421 "url": "https://github.com/thephpleague/uri.git",
422 "reference": "d3b50812dd51f3fbf176344cc2981db03d10fe06"
423 },
424 "dist": {
425 "type": "zip",
426 "url": "https://api.github.com/repos/thephpleague/uri/zipball/d3b50812dd51f3fbf176344cc2981db03d10fe06",
427 "reference": "d3b50812dd51f3fbf176344cc2981db03d10fe06",
428 "shasum": ""
429 },
430 "require": {
431 "ext-json": "*",
432 "league/uri-interfaces": "^2.3",
433 "php": "^7.4 || ^8.0",
434 "psr/http-message": "^1.0"
435 },
436 "conflict": {
437 "league/uri-schemes": "^1.0"
438 },
439 "require-dev": {
440 "friendsofphp/php-cs-fixer": "^v3.3.2",
441 "nyholm/psr7": "^1.5",
442 "php-http/psr7-integration-tests": "^1.1",
443 "phpstan/phpstan": "^1.2.0",
444 "phpstan/phpstan-deprecation-rules": "^1.0",
445 "phpstan/phpstan-phpunit": "^1.0.0",
446 "phpstan/phpstan-strict-rules": "^1.1.0",
447 "phpunit/phpunit": "^9.5.10",
448 "psr/http-factory": "^1.0"
449 },
450 "suggest": {
451 "ext-fileinfo": "Needed to create Data URI from a filepath",
452 "ext-intl": "Needed to improve host validation",
453 "league/uri-components": "Needed to easily manipulate URI objects",
454 "psr/http-factory": "Needed to use the URI factory"
455 },
456 "time": "2022-09-13T19:50:42+00:00",
457 "type": "library",
458 "extra": {
459 "branch-alias": {
460 "dev-master": "6.x-dev"
461 }
462 },
463 "installation-source": "dist",
464 "autoload": {
465 "psr-4": {
466 "League\\Uri\\": "src"
467 }
468 },
469 "notification-url": "https://packagist.org/downloads/",
470 "license": [
471 "MIT"
472 ],
473 "authors": [
474 {
475 "name": "Ignace Nyamagana Butera",
476 "email": "[email protected]",
477 "homepage": "https://nyamsprod.com"
478 }
479 ],
480 "description": "URI manipulation library",
481 "homepage": "https://uri.thephpleague.com",
482 "keywords": [
483 "data-uri",
484 "file-uri",
485 "ftp",
486 "hostname",
487 "http",
488 "https",
489 "middleware",
490 "parse_str",
491 "parse_url",
492 "psr-7",
493 "query-string",
494 "querystring",
495 "rfc3986",
496 "rfc3987",
497 "rfc6570",
498 "uri",
499 "uri-template",
500 "url",
501 "ws"
502 ],
503 "support": {
504 "docs": "https://uri.thephpleague.com",
505 "forum": "https://thephpleague.slack.com",
506 "issues": "https://github.com/thephpleague/uri/issues",
507 "source": "https://github.com/thephpleague/uri/tree/6.7.2"
508 },
509 "funding": [
510 {
511 "url": "https://github.com/sponsors/nyamsprod",
512 "type": "github"
513 }
514 ],
515 "install-path": "../league/uri"
516 },
517 {
518 "name": "league/uri-interfaces",
519 "version": "2.3.0",
520 "version_normalized": "2.3.0.0",
521 "source": {
522 "type": "git",
523 "url": "https://github.com/thephpleague/uri-interfaces.git",
524 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383"
525 },
526 "dist": {
527 "type": "zip",
528 "url": "https://api.github.com/repos/thephpleague/uri-interfaces/zipball/00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
529 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
530 "shasum": ""
531 },
532 "require": {
533 "ext-json": "*",
534 "php": "^7.2 || ^8.0"
535 },
536 "require-dev": {
537 "friendsofphp/php-cs-fixer": "^2.19",
538 "phpstan/phpstan": "^0.12.90",
539 "phpstan/phpstan-phpunit": "^0.12.19",
540 "phpstan/phpstan-strict-rules": "^0.12.9",
541 "phpunit/phpunit": "^8.5.15 || ^9.5"
542 },
543 "suggest": {
544 "ext-intl": "to use the IDNA feature",
545 "symfony/intl": "to use the IDNA feature via Symfony Polyfill"
546 },
547 "time": "2021-06-28T04:27:21+00:00",
548 "type": "library",
549 "extra": {
550 "branch-alias": {
551 "dev-master": "2.x-dev"
552 }
553 },
554 "installation-source": "dist",
555 "autoload": {
556 "psr-4": {
557 "League\\Uri\\": "src/"
558 }
559 },
560 "notification-url": "https://packagist.org/downloads/",
561 "license": [
562 "MIT"
563 ],
564 "authors": [
565 {
566 "name": "Ignace Nyamagana Butera",
567 "email": "[email protected]",
568 "homepage": "https://nyamsprod.com"
569 }
570 ],
571 "description": "Common interface for URI representation",
572 "homepage": "http://github.com/thephpleague/uri-interfaces",
573 "keywords": [
574 "rfc3986",
575 "rfc3987",
576 "uri",
577 "url"
578 ],
579 "support": {
580 "issues": "https://github.com/thephpleague/uri-interfaces/issues",
581 "source": "https://github.com/thephpleague/uri-interfaces/tree/2.3.0"
582 },
583 "funding": [
584 {
585 "url": "https://github.com/sponsors/nyamsprod",
586 "type": "github"
587 }
588 ],
589 "install-path": "../league/uri-interfaces"
590 },
591 {
592 "name": "nyholm/psr7",
593 "version": "1.8.2",
594 "version_normalized": "1.8.2.0",
595 "source": {
596 "type": "git",
597 "url": "https://github.com/Nyholm/psr7.git",
598 "reference": "a71f2b11690f4b24d099d6b16690a90ae14fc6f3"
599 },
600 "dist": {
601 "type": "zip",
602 "url": "https://api.github.com/repos/Nyholm/psr7/zipball/a71f2b11690f4b24d099d6b16690a90ae14fc6f3",
603 "reference": "a71f2b11690f4b24d099d6b16690a90ae14fc6f3",
604 "shasum": ""
605 },
606 "require": {
607 "php": ">=7.2",
608 "psr/http-factory": "^1.0",
609 "psr/http-message": "^1.1 || ^2.0"
610 },
611 "provide": {
612 "php-http/message-factory-implementation": "1.0",
613 "psr/http-factory-implementation": "1.0",
614 "psr/http-message-implementation": "1.0"
615 },
616 "require-dev": {
617 "http-interop/http-factory-tests": "^0.9",
618 "php-http/message-factory": "^1.0",
619 "php-http/psr7-integration-tests": "^1.0",
620 "phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
621 "symfony/error-handler": "^4.4"
622 },
623 "time": "2024-09-09T07:06:30+00:00",
624 "type": "library",
625 "extra": {
626 "branch-alias": {
627 "dev-master": "1.8-dev"
628 }
629 },
630 "installation-source": "dist",
631 "autoload": {
632 "psr-4": {
633 "Nyholm\\Psr7\\": "src/"
634 }
635 },
636 "notification-url": "https://packagist.org/downloads/",
637 "license": [
638 "MIT"
639 ],
640 "authors": [
641 {
642 "name": "Tobias Nyholm",
643 "email": "[email protected]"
644 },
645 {
646 "name": "Martijn van der Ven",
647 "email": "[email protected]"
648 }
649 ],
650 "description": "A fast PHP7 implementation of PSR-7",
651 "homepage": "https://tnyholm.se",
652 "keywords": [
653 "psr-17",
654 "psr-7"
655 ],
656 "support": {
657 "issues": "https://github.com/Nyholm/psr7/issues",
658 "source": "https://github.com/Nyholm/psr7/tree/1.8.2"
659 },
660 "funding": [
661 {
662 "url": "https://github.com/Zegnat",
663 "type": "github"
664 },
665 {
666 "url": "https://github.com/nyholm",
667 "type": "github"
668 }
669 ],
670 "install-path": "../nyholm/psr7"
671 },
672 {
673 "name": "nyholm/psr7-server",
674 "version": "1.1.0",
675 "version_normalized": "1.1.0.0",
676 "source": {
677 "type": "git",
678 "url": "https://github.com/Nyholm/psr7-server.git",
679 "reference": "4335801d851f554ca43fa6e7d2602141538854dc"
680 },
681 "dist": {
682 "type": "zip",
683 "url": "https://api.github.com/repos/Nyholm/psr7-server/zipball/4335801d851f554ca43fa6e7d2602141538854dc",
684 "reference": "4335801d851f554ca43fa6e7d2602141538854dc",
685 "shasum": ""
686 },
687 "require": {
688 "php": "^7.1 || ^8.0",
689 "psr/http-factory": "^1.0",
690 "psr/http-message": "^1.0 || ^2.0"
691 },
692 "require-dev": {
693 "nyholm/nsa": "^1.1",
694 "nyholm/psr7": "^1.3",
695 "phpunit/phpunit": "^7.0 || ^8.5 || ^9.3"
696 },
697 "time": "2023-11-08T09:30:43+00:00",
698 "type": "library",
699 "installation-source": "dist",
700 "autoload": {
701 "psr-4": {
702 "Nyholm\\Psr7Server\\": "src/"
703 }
704 },
705 "notification-url": "https://packagist.org/downloads/",
706 "license": [
707 "MIT"
708 ],
709 "authors": [
710 {
711 "name": "Tobias Nyholm",
712 "email": "[email protected]"
713 },
714 {
715 "name": "Martijn van der Ven",
716 "email": "[email protected]"
717 }
718 ],
719 "description": "Helper classes to handle PSR-7 server requests",
720 "homepage": "http://tnyholm.se",
721 "keywords": [
722 "psr-17",
723 "psr-7"
724 ],
725 "support": {
726 "issues": "https://github.com/Nyholm/psr7-server/issues",
727 "source": "https://github.com/Nyholm/psr7-server/tree/1.1.0"
728 },
729 "funding": [
730 {
731 "url": "https://github.com/Zegnat",
732 "type": "github"
733 },
734 {
735 "url": "https://github.com/nyholm",
736 "type": "github"
737 }
738 ],
739 "install-path": "../nyholm/psr7-server"
740 },
741 {
742 "name": "psr/http-client",
743 "version": "1.0.3",
744 "version_normalized": "1.0.3.0",
745 "source": {
746 "type": "git",
747 "url": "https://github.com/php-fig/http-client.git",
748 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90"
749 },
750 "dist": {
751 "type": "zip",
752 "url": "https://api.github.com/repos/php-fig/http-client/zipball/bb5906edc1c324c9a05aa0873d40117941e5fa90",
753 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90",
754 "shasum": ""
755 },
756 "require": {
757 "php": "^7.0 || ^8.0",
758 "psr/http-message": "^1.0 || ^2.0"
759 },
760 "time": "2023-09-23T14:17:50+00:00",
761 "type": "library",
762 "extra": {
763 "branch-alias": {
764 "dev-master": "1.0.x-dev"
765 }
766 },
767 "installation-source": "dist",
768 "autoload": {
769 "psr-4": {
770 "Psr\\Http\\Client\\": "src/"
771 }
772 },
773 "notification-url": "https://packagist.org/downloads/",
774 "license": [
775 "MIT"
776 ],
777 "authors": [
778 {
779 "name": "PHP-FIG",
780 "homepage": "https://www.php-fig.org/"
781 }
782 ],
783 "description": "Common interface for HTTP clients",
784 "homepage": "https://github.com/php-fig/http-client",
785 "keywords": [
786 "http",
787 "http-client",
788 "psr",
789 "psr-18"
790 ],
791 "support": {
792 "source": "https://github.com/php-fig/http-client"
793 },
794 "install-path": "../psr/http-client"
795 },
796 {
797 "name": "psr/http-factory",
798 "version": "1.1.0",
799 "version_normalized": "1.1.0.0",
800 "source": {
801 "type": "git",
802 "url": "https://github.com/php-fig/http-factory.git",
803 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a"
804 },
805 "dist": {
806 "type": "zip",
807 "url": "https://api.github.com/repos/php-fig/http-factory/zipball/2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
808 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
809 "shasum": ""
810 },
811 "require": {
812 "php": ">=7.1",
813 "psr/http-message": "^1.0 || ^2.0"
814 },
815 "time": "2024-04-15T12:06:14+00:00",
816 "type": "library",
817 "extra": {
818 "branch-alias": {
819 "dev-master": "1.0.x-dev"
820 }
821 },
822 "installation-source": "dist",
823 "autoload": {
824 "psr-4": {
825 "Psr\\Http\\Message\\": "src/"
826 }
827 },
828 "notification-url": "https://packagist.org/downloads/",
829 "license": [
830 "MIT"
831 ],
832 "authors": [
833 {
834 "name": "PHP-FIG",
835 "homepage": "https://www.php-fig.org/"
836 }
837 ],
838 "description": "PSR-17: Common interfaces for PSR-7 HTTP message factories",
839 "keywords": [
840 "factory",
841 "http",
842 "message",
843 "psr",
844 "psr-17",
845 "psr-7",
846 "request",
847 "response"
848 ],
849 "support": {
850 "source": "https://github.com/php-fig/http-factory"
851 },
852 "install-path": "../psr/http-factory"
853 },
854 {
855 "name": "psr/http-message",
856 "version": "1.1",
857 "version_normalized": "1.1.0.0",
858 "source": {
859 "type": "git",
860 "url": "https://github.com/php-fig/http-message.git",
861 "reference": "cb6ce4845ce34a8ad9e68117c10ee90a29919eba"
862 },
863 "dist": {
864 "type": "zip",
865 "url": "https://api.github.com/repos/php-fig/http-message/zipball/cb6ce4845ce34a8ad9e68117c10ee90a29919eba",
866 "reference": "cb6ce4845ce34a8ad9e68117c10ee90a29919eba",
867 "shasum": ""
868 },
869 "require": {
870 "php": "^7.2 || ^8.0"
871 },
872 "time": "2023-04-04T09:50:52+00:00",
873 "type": "library",
874 "extra": {
875 "branch-alias": {
876 "dev-master": "1.1.x-dev"
877 }
878 },
879 "installation-source": "dist",
880 "autoload": {
881 "psr-4": {
882 "Psr\\Http\\Message\\": "src/"
883 }
884 },
885 "notification-url": "https://packagist.org/downloads/",
886 "license": [
887 "MIT"
888 ],
889 "authors": [
890 {
891 "name": "PHP-FIG",
892 "homepage": "http://www.php-fig.org/"
893 }
894 ],
895 "description": "Common interface for HTTP messages",
896 "homepage": "https://github.com/php-fig/http-message",
897 "keywords": [
898 "http",
899 "http-message",
900 "psr",
901 "psr-7",
902 "request",
903 "response"
904 ],
905 "support": {
906 "source": "https://github.com/php-fig/http-message/tree/1.1"
907 },
908 "install-path": "../psr/http-message"
909 },
910 {
911 "name": "psr/log",
912 "version": "1.1.4",
913 "version_normalized": "1.1.4.0",
914 "source": {
915 "type": "git",
916 "url": "https://github.com/php-fig/log.git",
917 "reference": "d49695b909c3b7628b6289db5479a1c204601f11"
918 },
919 "dist": {
920 "type": "zip",
921 "url": "https://api.github.com/repos/php-fig/log/zipball/d49695b909c3b7628b6289db5479a1c204601f11",
922 "reference": "d49695b909c3b7628b6289db5479a1c204601f11",
923 "shasum": ""
924 },
925 "require": {
926 "php": ">=5.3.0"
927 },
928 "time": "2021-05-03T11:20:27+00:00",
929 "type": "library",
930 "extra": {
931 "branch-alias": {
932 "dev-master": "1.1.x-dev"
933 }
934 },
935 "installation-source": "dist",
936 "autoload": {
937 "psr-4": {
938 "Psr\\Log\\": "Psr/Log/"
939 }
940 },
941 "notification-url": "https://packagist.org/downloads/",
942 "license": [
943 "MIT"
944 ],
945 "authors": [
946 {
947 "name": "PHP-FIG",
948 "homepage": "https://www.php-fig.org/"
949 }
950 ],
951 "description": "Common interface for logging libraries",
952 "homepage": "https://github.com/php-fig/log",
953 "keywords": [
954 "log",
955 "psr",
956 "psr-3"
957 ],
958 "support": {
959 "source": "https://github.com/php-fig/log/tree/1.1.4"
960 },
961 "install-path": "../psr/log"
962 },
963 {
964 "name": "ramsey/collection",
965 "version": "1.3.0",
966 "version_normalized": "1.3.0.0",
967 "source": {
968 "type": "git",
969 "url": "https://github.com/ramsey/collection.git",
970 "reference": "ad7475d1c9e70b190ecffc58f2d989416af339b4"
971 },
972 "dist": {
973 "type": "zip",
974 "url": "https://api.github.com/repos/ramsey/collection/zipball/ad7475d1c9e70b190ecffc58f2d989416af339b4",
975 "reference": "ad7475d1c9e70b190ecffc58f2d989416af339b4",
976 "shasum": ""
977 },
978 "require": {
979 "php": "^7.4 || ^8.0",
980 "symfony/polyfill-php81": "^1.23"
981 },
982 "require-dev": {
983 "captainhook/plugin-composer": "^5.3",
984 "ergebnis/composer-normalize": "^2.28.3",
985 "fakerphp/faker": "^1.21",
986 "hamcrest/hamcrest-php": "^2.0",
987 "jangregor/phpstan-prophecy": "^1.0",
988 "mockery/mockery": "^1.5",
989 "php-parallel-lint/php-console-highlighter": "^1.0",
990 "php-parallel-lint/php-parallel-lint": "^1.3",
991 "phpcsstandards/phpcsutils": "^1.0.0-rc1",
992 "phpspec/prophecy-phpunit": "^2.0",
993 "phpstan/extension-installer": "^1.2",
994 "phpstan/phpstan": "^1.9",
995 "phpstan/phpstan-mockery": "^1.1",
996 "phpstan/phpstan-phpunit": "^1.3",
997 "phpunit/phpunit": "^9.5",
998 "psalm/plugin-mockery": "^1.1",
999 "psalm/plugin-phpunit": "^0.18.4",
1000 "ramsey/coding-standard": "^2.0.3",
1001 "ramsey/conventional-commits": "^1.3",
1002 "vimeo/psalm": "^5.4"
1003 },
1004 "time": "2022-12-27T19:12:24+00:00",
1005 "type": "library",
1006 "extra": {
1007 "captainhook": {
1008 "force-install": true
1009 },
1010 "ramsey/conventional-commits": {
1011 "configFile": "conventional-commits.json"
1012 }
1013 },
1014 "installation-source": "dist",
1015 "autoload": {
1016 "psr-4": {
1017 "Ramsey\\Collection\\": "src/"
1018 }
1019 },
1020 "notification-url": "https://packagist.org/downloads/",
1021 "license": [
1022 "MIT"
1023 ],
1024 "authors": [
1025 {
1026 "name": "Ben Ramsey",
1027 "email": "[email protected]",
1028 "homepage": "https://benramsey.com"
1029 }
1030 ],
1031 "description": "A PHP library for representing and manipulating collections.",
1032 "keywords": [
1033 "array",
1034 "collection",
1035 "hash",
1036 "map",
1037 "queue",
1038 "set"
1039 ],
1040 "support": {
1041 "issues": "https://github.com/ramsey/collection/issues",
1042 "source": "https://github.com/ramsey/collection/tree/1.3.0"
1043 },
1044 "funding": [
1045 {
1046 "url": "https://github.com/ramsey",
1047 "type": "github"
1048 },
1049 {
1050 "url": "https://tidelift.com/funding/github/packagist/ramsey/collection",
1051 "type": "tidelift"
1052 }
1053 ],
1054 "install-path": "../ramsey/collection"
1055 },
1056 {
1057 "name": "ramsey/uuid",
1058 "version": "4.2.3",
1059 "version_normalized": "4.2.3.0",
1060 "source": {
1061 "type": "git",
1062 "url": "https://github.com/ramsey/uuid.git",
1063 "reference": "fc9bb7fb5388691fd7373cd44dcb4d63bbcf24df"
1064 },
1065 "dist": {
1066 "type": "zip",
1067 "url": "https://api.github.com/repos/ramsey/uuid/zipball/fc9bb7fb5388691fd7373cd44dcb4d63bbcf24df",
1068 "reference": "fc9bb7fb5388691fd7373cd44dcb4d63bbcf24df",
1069 "shasum": ""
1070 },
1071 "require": {
1072 "brick/math": "^0.8 || ^0.9",
1073 "ext-json": "*",
1074 "php": "^7.2 || ^8.0",
1075 "ramsey/collection": "^1.0",
1076 "symfony/polyfill-ctype": "^1.8",
1077 "symfony/polyfill-php80": "^1.14"
1078 },
1079 "replace": {
1080 "rhumsaa/uuid": "self.version"
1081 },
1082 "require-dev": {
1083 "captainhook/captainhook": "^5.10",
1084 "captainhook/plugin-composer": "^5.3",
1085 "dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
1086 "doctrine/annotations": "^1.8",
1087 "ergebnis/composer-normalize": "^2.15",
1088 "mockery/mockery": "^1.3",
1089 "moontoast/math": "^1.1",
1090 "paragonie/random-lib": "^2",
1091 "php-mock/php-mock": "^2.2",
1092 "php-mock/php-mock-mockery": "^1.3",
1093 "php-parallel-lint/php-parallel-lint": "^1.1",
1094 "phpbench/phpbench": "^1.0",
1095 "phpstan/extension-installer": "^1.0",
1096 "phpstan/phpstan": "^0.12",
1097 "phpstan/phpstan-mockery": "^0.12",
1098 "phpstan/phpstan-phpunit": "^0.12",
1099 "phpunit/phpunit": "^8.5 || ^9",
1100 "slevomat/coding-standard": "^7.0",
1101 "squizlabs/php_codesniffer": "^3.5",
1102 "vimeo/psalm": "^4.9"
1103 },
1104 "suggest": {
1105 "ext-bcmath": "Enables faster math with arbitrary-precision integers using BCMath.",
1106 "ext-ctype": "Enables faster processing of character classification using ctype functions.",
1107 "ext-gmp": "Enables faster math with arbitrary-precision integers using GMP.",
1108 "ext-uuid": "Enables the use of PeclUuidTimeGenerator and PeclUuidRandomGenerator.",
1109 "paragonie/random-lib": "Provides RandomLib for use with the RandomLibAdapter",
1110 "ramsey/uuid-doctrine": "Allows the use of Ramsey\\Uuid\\Uuid as Doctrine field type."
1111 },
1112 "time": "2021-09-25T23:10:38+00:00",
1113 "type": "library",
1114 "extra": {
1115 "captainhook": {
1116 "force-install": true
1117 },
1118 "branch-alias": {
1119 "dev-main": "4.x-dev"
1120 }
1121 },
1122 "installation-source": "dist",
1123 "autoload": {
1124 "files": [
1125 "src/functions.php"
1126 ],
1127 "psr-4": {
1128 "Ramsey\\Uuid\\": "src/"
1129 }
1130 },
1131 "notification-url": "https://packagist.org/downloads/",
1132 "license": [
1133 "MIT"
1134 ],
1135 "description": "A PHP library for generating and working with universally unique identifiers (UUIDs).",
1136 "keywords": [
1137 "guid",
1138 "identifier",
1139 "uuid"
1140 ],
1141 "support": {
1142 "issues": "https://github.com/ramsey/uuid/issues",
1143 "source": "https://github.com/ramsey/uuid/tree/4.2.3"
1144 },
1145 "funding": [
1146 {
1147 "url": "https://github.com/ramsey",
1148 "type": "github"
1149 },
1150 {
1151 "url": "https://tidelift.com/funding/github/packagist/ramsey/uuid",
1152 "type": "tidelift"
1153 }
1154 ],
1155 "install-path": "../ramsey/uuid"
1156 },
1157 {
1158 "name": "spomky-labs/base64url",
1159 "version": "v2.0.4",
1160 "version_normalized": "2.0.4.0",
1161 "source": {
1162 "type": "git",
1163 "url": "https://github.com/Spomky-Labs/base64url.git",
1164 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d"
1165 },
1166 "dist": {
1167 "type": "zip",
1168 "url": "https://api.github.com/repos/Spomky-Labs/base64url/zipball/7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1169 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1170 "shasum": ""
1171 },
1172 "require": {
1173 "php": ">=7.1"
1174 },
1175 "require-dev": {
1176 "phpstan/extension-installer": "^1.0",
1177 "phpstan/phpstan": "^0.11|^0.12",
1178 "phpstan/phpstan-beberlei-assert": "^0.11|^0.12",
1179 "phpstan/phpstan-deprecation-rules": "^0.11|^0.12",
1180 "phpstan/phpstan-phpunit": "^0.11|^0.12",
1181 "phpstan/phpstan-strict-rules": "^0.11|^0.12"
1182 },
1183 "time": "2020-11-03T09:10:25+00:00",
1184 "type": "library",
1185 "installation-source": "dist",
1186 "autoload": {
1187 "psr-4": {
1188 "Base64Url\\": "src/"
1189 }
1190 },
1191 "notification-url": "https://packagist.org/downloads/",
1192 "license": [
1193 "MIT"
1194 ],
1195 "authors": [
1196 {
1197 "name": "Florent Morselli",
1198 "homepage": "https://github.com/Spomky-Labs/base64url/contributors"
1199 }
1200 ],
1201 "description": "Base 64 URL Safe Encoding/Decoding PHP Library",
1202 "homepage": "https://github.com/Spomky-Labs/base64url",
1203 "keywords": [
1204 "base64",
1205 "rfc4648",
1206 "safe",
1207 "url"
1208 ],
1209 "support": {
1210 "issues": "https://github.com/Spomky-Labs/base64url/issues",
1211 "source": "https://github.com/Spomky-Labs/base64url/tree/v2.0.4"
1212 },
1213 "funding": [
1214 {
1215 "url": "https://github.com/Spomky",
1216 "type": "github"
1217 },
1218 {
1219 "url": "https://www.patreon.com/FlorentMorselli",
1220 "type": "patreon"
1221 }
1222 ],
1223 "install-path": "../spomky-labs/base64url"
1224 },
1225 {
1226 "name": "spomky-labs/cbor-php",
1227 "version": "v2.1.0",
1228 "version_normalized": "2.1.0.0",
1229 "source": {
1230 "type": "git",
1231 "url": "https://github.com/Spomky-Labs/cbor-php.git",
1232 "reference": "28e2712cfc0b48fae661a48ffc6896d7abe83684"
1233 },
1234 "dist": {
1235 "type": "zip",
1236 "url": "https://api.github.com/repos/Spomky-Labs/cbor-php/zipball/28e2712cfc0b48fae661a48ffc6896d7abe83684",
1237 "reference": "28e2712cfc0b48fae661a48ffc6896d7abe83684",
1238 "shasum": ""
1239 },
1240 "require": {
1241 "brick/math": "^0.8.15|^0.9.0",
1242 "ext-mbstring": "*",
1243 "php": ">=7.3"
1244 },
1245 "require-dev": {
1246 "ekino/phpstan-banned-code": "^1.0",
1247 "ext-json": "*",
1248 "infection/infection": "^0.18|^0.25",
1249 "phpstan/extension-installer": "^1.1",
1250 "phpstan/phpstan": "^1.0",
1251 "phpstan/phpstan-beberlei-assert": "^1.0",
1252 "phpstan/phpstan-deprecation-rules": "^1.0",
1253 "phpstan/phpstan-phpunit": "^1.0",
1254 "phpstan/phpstan-strict-rules": "^1.0",
1255 "phpunit/phpunit": "^9.5",
1256 "rector/rector": "^0.12",
1257 "roave/security-advisories": "dev-latest",
1258 "symplify/easy-coding-standard": "^10.0"
1259 },
1260 "suggest": {
1261 "ext-bcmath": "GMP or BCMath extensions will drastically improve the library performance. BCMath extension needed to handle the Big Float and Decimal Fraction Tags",
1262 "ext-gmp": "GMP or BCMath extensions will drastically improve the library performance"
1263 },
1264 "time": "2021-12-13T12:46:26+00:00",
1265 "type": "library",
1266 "installation-source": "dist",
1267 "autoload": {
1268 "psr-4": {
1269 "CBOR\\": "src/"
1270 }
1271 },
1272 "notification-url": "https://packagist.org/downloads/",
1273 "license": [
1274 "MIT"
1275 ],
1276 "authors": [
1277 {
1278 "name": "Florent Morselli",
1279 "homepage": "https://github.com/Spomky"
1280 },
1281 {
1282 "name": "All contributors",
1283 "homepage": "https://github.com/Spomky-Labs/cbor-php/contributors"
1284 }
1285 ],
1286 "description": "CBOR Encoder/Decoder for PHP",
1287 "keywords": [
1288 "Concise Binary Object Representation",
1289 "RFC7049",
1290 "cbor"
1291 ],
1292 "support": {
1293 "issues": "https://github.com/Spomky-Labs/cbor-php/issues",
1294 "source": "https://github.com/Spomky-Labs/cbor-php/tree/v2.1.0"
1295 },
1296 "funding": [
1297 {
1298 "url": "https://github.com/Spomky",
1299 "type": "github"
1300 },
1301 {
1302 "url": "https://www.patreon.com/FlorentMorselli",
1303 "type": "patreon"
1304 }
1305 ],
1306 "install-path": "../spomky-labs/cbor-php"
1307 },
1308 {
1309 "name": "symfony/polyfill-ctype",
1310 "version": "v1.31.0",
1311 "version_normalized": "1.31.0.0",
1312 "source": {
1313 "type": "git",
1314 "url": "https://github.com/symfony/polyfill-ctype.git",
1315 "reference": "a3cc8b044a6ea513310cbd48ef7333b384945638"
1316 },
1317 "dist": {
1318 "type": "zip",
1319 "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/a3cc8b044a6ea513310cbd48ef7333b384945638",
1320 "reference": "a3cc8b044a6ea513310cbd48ef7333b384945638",
1321 "shasum": ""
1322 },
1323 "require": {
1324 "php": ">=7.2"
1325 },
1326 "provide": {
1327 "ext-ctype": "*"
1328 },
1329 "suggest": {
1330 "ext-ctype": "For best performance"
1331 },
1332 "time": "2024-09-09T11:45:10+00:00",
1333 "type": "library",
1334 "extra": {
1335 "thanks": {
1336 "url": "https://github.com/symfony/polyfill",
1337 "name": "symfony/polyfill"
1338 }
1339 },
1340 "installation-source": "dist",
1341 "autoload": {
1342 "files": [
1343 "bootstrap.php"
1344 ],
1345 "psr-4": {
1346 "Symfony\\Polyfill\\Ctype\\": ""
1347 }
1348 },
1349 "notification-url": "https://packagist.org/downloads/",
1350 "license": [
1351 "MIT"
1352 ],
1353 "authors": [
1354 {
1355 "name": "Gert de Pagter",
1356 "email": "[email protected]"
1357 },
1358 {
1359 "name": "Symfony Community",
1360 "homepage": "https://symfony.com/contributors"
1361 }
1362 ],
1363 "description": "Symfony polyfill for ctype functions",
1364 "homepage": "https://symfony.com",
1365 "keywords": [
1366 "compatibility",
1367 "ctype",
1368 "polyfill",
1369 "portable"
1370 ],
1371 "support": {
1372 "source": "https://github.com/symfony/polyfill-ctype/tree/v1.31.0"
1373 },
1374 "funding": [
1375 {
1376 "url": "https://symfony.com/sponsor",
1377 "type": "custom"
1378 },
1379 {
1380 "url": "https://github.com/fabpot",
1381 "type": "github"
1382 },
1383 {
1384 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1385 "type": "tidelift"
1386 }
1387 ],
1388 "install-path": "../symfony/polyfill-ctype"
1389 },
1390 {
1391 "name": "symfony/polyfill-php80",
1392 "version": "v1.31.0",
1393 "version_normalized": "1.31.0.0",
1394 "source": {
1395 "type": "git",
1396 "url": "https://github.com/symfony/polyfill-php80.git",
1397 "reference": "60328e362d4c2c802a54fcbf04f9d3fb892b4cf8"
1398 },
1399 "dist": {
1400 "type": "zip",
1401 "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/60328e362d4c2c802a54fcbf04f9d3fb892b4cf8",
1402 "reference": "60328e362d4c2c802a54fcbf04f9d3fb892b4cf8",
1403 "shasum": ""
1404 },
1405 "require": {
1406 "php": ">=7.2"
1407 },
1408 "time": "2024-09-09T11:45:10+00:00",
1409 "type": "library",
1410 "extra": {
1411 "thanks": {
1412 "url": "https://github.com/symfony/polyfill",
1413 "name": "symfony/polyfill"
1414 }
1415 },
1416 "installation-source": "dist",
1417 "autoload": {
1418 "files": [
1419 "bootstrap.php"
1420 ],
1421 "psr-4": {
1422 "Symfony\\Polyfill\\Php80\\": ""
1423 },
1424 "classmap": [
1425 "Resources/stubs"
1426 ]
1427 },
1428 "notification-url": "https://packagist.org/downloads/",
1429 "license": [
1430 "MIT"
1431 ],
1432 "authors": [
1433 {
1434 "name": "Ion Bazan",
1435 "email": "[email protected]"
1436 },
1437 {
1438 "name": "Nicolas Grekas",
1439 "email": "[email protected]"
1440 },
1441 {
1442 "name": "Symfony Community",
1443 "homepage": "https://symfony.com/contributors"
1444 }
1445 ],
1446 "description": "Symfony polyfill backporting some PHP 8.0+ features to lower PHP versions",
1447 "homepage": "https://symfony.com",
1448 "keywords": [
1449 "compatibility",
1450 "polyfill",
1451 "portable",
1452 "shim"
1453 ],
1454 "support": {
1455 "source": "https://github.com/symfony/polyfill-php80/tree/v1.31.0"
1456 },
1457 "funding": [
1458 {
1459 "url": "https://symfony.com/sponsor",
1460 "type": "custom"
1461 },
1462 {
1463 "url": "https://github.com/fabpot",
1464 "type": "github"
1465 },
1466 {
1467 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1468 "type": "tidelift"
1469 }
1470 ],
1471 "install-path": "../symfony/polyfill-php80"
1472 },
1473 {
1474 "name": "symfony/polyfill-php81",
1475 "version": "v1.31.0",
1476 "version_normalized": "1.31.0.0",
1477 "source": {
1478 "type": "git",
1479 "url": "https://github.com/symfony/polyfill-php81.git",
1480 "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c"
1481 },
1482 "dist": {
1483 "type": "zip",
1484 "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
1485 "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
1486 "shasum": ""
1487 },
1488 "require": {
1489 "php": ">=7.2"
1490 },
1491 "time": "2024-09-09T11:45:10+00:00",
1492 "type": "library",
1493 "extra": {
1494 "thanks": {
1495 "url": "https://github.com/symfony/polyfill",
1496 "name": "symfony/polyfill"
1497 }
1498 },
1499 "installation-source": "dist",
1500 "autoload": {
1501 "files": [
1502 "bootstrap.php"
1503 ],
1504 "psr-4": {
1505 "Symfony\\Polyfill\\Php81\\": ""
1506 },
1507 "classmap": [
1508 "Resources/stubs"
1509 ]
1510 },
1511 "notification-url": "https://packagist.org/downloads/",
1512 "license": [
1513 "MIT"
1514 ],
1515 "authors": [
1516 {
1517 "name": "Nicolas Grekas",
1518 "email": "[email protected]"
1519 },
1520 {
1521 "name": "Symfony Community",
1522 "homepage": "https://symfony.com/contributors"
1523 }
1524 ],
1525 "description": "Symfony polyfill backporting some PHP 8.1+ features to lower PHP versions",
1526 "homepage": "https://symfony.com",
1527 "keywords": [
1528 "compatibility",
1529 "polyfill",
1530 "portable",
1531 "shim"
1532 ],
1533 "support": {
1534 "source": "https://github.com/symfony/polyfill-php81/tree/v1.31.0"
1535 },
1536 "funding": [
1537 {
1538 "url": "https://symfony.com/sponsor",
1539 "type": "custom"
1540 },
1541 {
1542 "url": "https://github.com/fabpot",
1543 "type": "github"
1544 },
1545 {
1546 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1547 "type": "tidelift"
1548 }
1549 ],
1550 "install-path": "../symfony/polyfill-php81"
1551 },
1552 {
1553 "name": "symfony/process",
1554 "version": "v5.4.47",
1555 "version_normalized": "5.4.47.0",
1556 "source": {
1557 "type": "git",
1558 "url": "https://github.com/symfony/process.git",
1559 "reference": "5d1662fb32ebc94f17ddb8d635454a776066733d"
1560 },
1561 "dist": {
1562 "type": "zip",
1563 "url": "https://api.github.com/repos/symfony/process/zipball/5d1662fb32ebc94f17ddb8d635454a776066733d",
1564 "reference": "5d1662fb32ebc94f17ddb8d635454a776066733d",
1565 "shasum": ""
1566 },
1567 "require": {
1568 "php": ">=7.2.5",
1569 "symfony/polyfill-php80": "^1.16"
1570 },
1571 "time": "2024-11-06T11:36:42+00:00",
1572 "type": "library",
1573 "installation-source": "dist",
1574 "autoload": {
1575 "psr-4": {
1576 "Symfony\\Component\\Process\\": ""
1577 },
1578 "exclude-from-classmap": [
1579 "/Tests/"
1580 ]
1581 },
1582 "notification-url": "https://packagist.org/downloads/",
1583 "license": [
1584 "MIT"
1585 ],
1586 "authors": [
1587 {
1588 "name": "Fabien Potencier",
1589 "email": "[email protected]"
1590 },
1591 {
1592 "name": "Symfony Community",
1593 "homepage": "https://symfony.com/contributors"
1594 }
1595 ],
1596 "description": "Executes commands in sub-processes",
1597 "homepage": "https://symfony.com",
1598 "support": {
1599 "source": "https://github.com/symfony/process/tree/v5.4.47"
1600 },
1601 "funding": [
1602 {
1603 "url": "https://symfony.com/sponsor",
1604 "type": "custom"
1605 },
1606 {
1607 "url": "https://github.com/fabpot",
1608 "type": "github"
1609 },
1610 {
1611 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1612 "type": "tidelift"
1613 }
1614 ],
1615 "install-path": "../symfony/process"
1616 },
1617 {
1618 "name": "thecodingmachine/safe",
1619 "version": "v1.3.3",
1620 "version_normalized": "1.3.3.0",
1621 "source": {
1622 "type": "git",
1623 "url": "https://github.com/thecodingmachine/safe.git",
1624 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc"
1625 },
1626 "dist": {
1627 "type": "zip",
1628 "url": "https://api.github.com/repos/thecodingmachine/safe/zipball/a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1629 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1630 "shasum": ""
1631 },
1632 "require": {
1633 "php": ">=7.2"
1634 },
1635 "require-dev": {
1636 "phpstan/phpstan": "^0.12",
1637 "squizlabs/php_codesniffer": "^3.2",
1638 "thecodingmachine/phpstan-strict-rules": "^0.12"
1639 },
1640 "time": "2020-10-28T17:51:34+00:00",
1641 "type": "library",
1642 "extra": {
1643 "branch-alias": {
1644 "dev-master": "0.1-dev"
1645 }
1646 },
1647 "installation-source": "dist",
1648 "autoload": {
1649 "files": [
1650 "deprecated/apc.php",
1651 "deprecated/libevent.php",
1652 "deprecated/mssql.php",
1653 "deprecated/stats.php",
1654 "lib/special_cases.php",
1655 "generated/apache.php",
1656 "generated/apcu.php",
1657 "generated/array.php",
1658 "generated/bzip2.php",
1659 "generated/calendar.php",
1660 "generated/classobj.php",
1661 "generated/com.php",
1662 "generated/cubrid.php",
1663 "generated/curl.php",
1664 "generated/datetime.php",
1665 "generated/dir.php",
1666 "generated/eio.php",
1667 "generated/errorfunc.php",
1668 "generated/exec.php",
1669 "generated/fileinfo.php",
1670 "generated/filesystem.php",
1671 "generated/filter.php",
1672 "generated/fpm.php",
1673 "generated/ftp.php",
1674 "generated/funchand.php",
1675 "generated/gmp.php",
1676 "generated/gnupg.php",
1677 "generated/hash.php",
1678 "generated/ibase.php",
1679 "generated/ibmDb2.php",
1680 "generated/iconv.php",
1681 "generated/image.php",
1682 "generated/imap.php",
1683 "generated/info.php",
1684 "generated/ingres-ii.php",
1685 "generated/inotify.php",
1686 "generated/json.php",
1687 "generated/ldap.php",
1688 "generated/libxml.php",
1689 "generated/lzf.php",
1690 "generated/mailparse.php",
1691 "generated/mbstring.php",
1692 "generated/misc.php",
1693 "generated/msql.php",
1694 "generated/mysql.php",
1695 "generated/mysqli.php",
1696 "generated/mysqlndMs.php",
1697 "generated/mysqlndQc.php",
1698 "generated/network.php",
1699 "generated/oci8.php",
1700 "generated/opcache.php",
1701 "generated/openssl.php",
1702 "generated/outcontrol.php",
1703 "generated/password.php",
1704 "generated/pcntl.php",
1705 "generated/pcre.php",
1706 "generated/pdf.php",
1707 "generated/pgsql.php",
1708 "generated/posix.php",
1709 "generated/ps.php",
1710 "generated/pspell.php",
1711 "generated/readline.php",
1712 "generated/rpminfo.php",
1713 "generated/rrd.php",
1714 "generated/sem.php",
1715 "generated/session.php",
1716 "generated/shmop.php",
1717 "generated/simplexml.php",
1718 "generated/sockets.php",
1719 "generated/sodium.php",
1720 "generated/solr.php",
1721 "generated/spl.php",
1722 "generated/sqlsrv.php",
1723 "generated/ssdeep.php",
1724 "generated/ssh2.php",
1725 "generated/stream.php",
1726 "generated/strings.php",
1727 "generated/swoole.php",
1728 "generated/uodbc.php",
1729 "generated/uopz.php",
1730 "generated/url.php",
1731 "generated/var.php",
1732 "generated/xdiff.php",
1733 "generated/xml.php",
1734 "generated/xmlrpc.php",
1735 "generated/yaml.php",
1736 "generated/yaz.php",
1737 "generated/zip.php",
1738 "generated/zlib.php"
1739 ],
1740 "psr-4": {
1741 "Safe\\": [
1742 "lib/",
1743 "deprecated/",
1744 "generated/"
1745 ]
1746 }
1747 },
1748 "notification-url": "https://packagist.org/downloads/",
1749 "license": [
1750 "MIT"
1751 ],
1752 "description": "PHP core functions that throw exceptions instead of returning FALSE on error",
1753 "support": {
1754 "issues": "https://github.com/thecodingmachine/safe/issues",
1755 "source": "https://github.com/thecodingmachine/safe/tree/v1.3.3"
1756 },
1757 "install-path": "../thecodingmachine/safe"
1758 },
1759 {
1760 "name": "vlucas/valitron",
1761 "version": "v1.4.11",
1762 "version_normalized": "1.4.11.0",
1763 "source": {
1764 "type": "git",
1765 "url": "https://github.com/vlucas/valitron.git",
1766 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f"
1767 },
1768 "dist": {
1769 "type": "zip",
1770 "url": "https://api.github.com/repos/vlucas/valitron/zipball/fadce39f5f235755bb9794b2573af2d5bfcba85f",
1771 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f",
1772 "shasum": ""
1773 },
1774 "require": {
1775 "php": ">=5.3.2"
1776 },
1777 "require-dev": {
1778 "phpunit/phpunit": ">=4.8.35"
1779 },
1780 "suggest": {
1781 "ext-mbstring": "It can support the multiple bytes string length."
1782 },
1783 "time": "2022-10-14T11:54:24+00:00",
1784 "type": "library",
1785 "installation-source": "dist",
1786 "autoload": {
1787 "psr-4": {
1788 "Valitron\\": "src/Valitron"
1789 }
1790 },
1791 "notification-url": "https://packagist.org/downloads/",
1792 "license": [
1793 "BSD-3-Clause"
1794 ],
1795 "authors": [
1796 {
1797 "name": "Vance Lucas",
1798 "email": "[email protected]",
1799 "homepage": "https://www.vancelucas.com"
1800 }
1801 ],
1802 "description": "Simple, elegant, stand-alone validation library with NO dependencies",
1803 "homepage": "https://github.com/vlucas/valitron",
1804 "keywords": [
1805 "valid",
1806 "validation",
1807 "validator"
1808 ],
1809 "support": {
1810 "issues": "https://github.com/vlucas/valitron/issues",
1811 "source": "https://github.com/vlucas/valitron/tree/v1.4.11"
1812 },
1813 "funding": [
1814 {
1815 "url": "https://tidelift.com/funding/github/packagist/vlucas/valitron",
1816 "type": "tidelift"
1817 }
1818 ],
1819 "install-path": "../vlucas/valitron"
1820 },
1821 {
1822 "name": "web-auth/cose-lib",
1823 "version": "v3.3.12",
1824 "version_normalized": "3.3.12.0",
1825 "source": {
1826 "type": "git",
1827 "url": "https://github.com/web-auth/cose-lib.git",
1828 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb"
1829 },
1830 "dist": {
1831 "type": "zip",
1832 "url": "https://api.github.com/repos/web-auth/cose-lib/zipball/efa6ec2ba4e840bc1316a493973c9916028afeeb",
1833 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb",
1834 "shasum": ""
1835 },
1836 "require": {
1837 "beberlei/assert": "^3.2",
1838 "ext-json": "*",
1839 "ext-mbstring": "*",
1840 "ext-openssl": "*",
1841 "fgrosse/phpasn1": "^2.1",
1842 "php": ">=7.2"
1843 },
1844 "time": "2021-12-04T12:13:35+00:00",
1845 "type": "library",
1846 "installation-source": "dist",
1847 "autoload": {
1848 "psr-4": {
1849 "Cose\\": "src/"
1850 }
1851 },
1852 "notification-url": "https://packagist.org/downloads/",
1853 "license": [
1854 "MIT"
1855 ],
1856 "authors": [
1857 {
1858 "name": "Florent Morselli",
1859 "homepage": "https://github.com/Spomky"
1860 },
1861 {
1862 "name": "All contributors",
1863 "homepage": "https://github.com/web-auth/cose/contributors"
1864 }
1865 ],
1866 "description": "CBOR Object Signing and Encryption (COSE) For PHP",
1867 "homepage": "https://github.com/web-auth",
1868 "keywords": [
1869 "COSE",
1870 "RFC8152"
1871 ],
1872 "support": {
1873 "source": "https://github.com/web-auth/cose-lib/tree/v3.3.12"
1874 },
1875 "funding": [
1876 {
1877 "url": "https://github.com/Spomky",
1878 "type": "github"
1879 },
1880 {
1881 "url": "https://www.patreon.com/FlorentMorselli",
1882 "type": "patreon"
1883 }
1884 ],
1885 "install-path": "../web-auth/cose-lib"
1886 },
1887 {
1888 "name": "web-auth/metadata-service",
1889 "version": "v3.3.12",
1890 "version_normalized": "3.3.12.0",
1891 "source": {
1892 "type": "git",
1893 "url": "https://github.com/web-auth/webauthn-metadata-service.git",
1894 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246"
1895 },
1896 "dist": {
1897 "type": "zip",
1898 "url": "https://api.github.com/repos/web-auth/webauthn-metadata-service/zipball/ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1899 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1900 "shasum": ""
1901 },
1902 "require": {
1903 "beberlei/assert": "^3.2",
1904 "ext-json": "*",
1905 "league/uri": "^6.0",
1906 "php": ">=7.2",
1907 "psr/http-client": "^1.0",
1908 "psr/http-factory": "^1.0",
1909 "psr/log": "^1.1"
1910 },
1911 "suggest": {
1912 "web-token/jwt-key-mgmt": "Mandatory for fetching Metadata Statement from distant sources",
1913 "web-token/jwt-signature-algorithm-ecdsa": "Mandatory for fetching Metadata Statement from distant sources"
1914 },
1915 "time": "2021-11-21T11:14:31+00:00",
1916 "type": "library",
1917 "installation-source": "dist",
1918 "autoload": {
1919 "psr-4": {
1920 "Webauthn\\MetadataService\\": "src/"
1921 }
1922 },
1923 "notification-url": "https://packagist.org/downloads/",
1924 "license": [
1925 "MIT"
1926 ],
1927 "authors": [
1928 {
1929 "name": "Florent Morselli",
1930 "homepage": "https://github.com/Spomky"
1931 },
1932 {
1933 "name": "All contributors",
1934 "homepage": "https://github.com/web-auth/metadata-service/contributors"
1935 }
1936 ],
1937 "description": "Metadata Service for FIDO2/Webauthn",
1938 "homepage": "https://github.com/web-auth",
1939 "keywords": [
1940 "FIDO2",
1941 "fido",
1942 "webauthn"
1943 ],
1944 "support": {
1945 "source": "https://github.com/web-auth/webauthn-metadata-service/tree/v3.3.12"
1946 },
1947 "funding": [
1948 {
1949 "url": "https://github.com/Spomky",
1950 "type": "github"
1951 },
1952 {
1953 "url": "https://www.patreon.com/FlorentMorselli",
1954 "type": "patreon"
1955 }
1956 ],
1957 "abandoned": "web-auth/webauthn-lib",
1958 "install-path": "../web-auth/metadata-service"
1959 },
1960 {
1961 "name": "web-auth/webauthn-lib",
1962 "version": "v3.3.12",
1963 "version_normalized": "3.3.12.0",
1964 "source": {
1965 "type": "git",
1966 "url": "https://github.com/web-auth/webauthn-lib.git",
1967 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33"
1968 },
1969 "dist": {
1970 "type": "zip",
1971 "url": "https://api.github.com/repos/web-auth/webauthn-lib/zipball/5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
1972 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
1973 "shasum": ""
1974 },
1975 "require": {
1976 "beberlei/assert": "^3.2",
1977 "ext-json": "*",
1978 "ext-mbstring": "*",
1979 "ext-openssl": "*",
1980 "fgrosse/phpasn1": "^2.1",
1981 "php": ">=7.2",
1982 "psr/http-client": "^1.0",
1983 "psr/http-factory": "^1.0",
1984 "psr/http-message": "^1.0",
1985 "psr/log": "^1.1",
1986 "ramsey/uuid": "^3.8|^4.0",
1987 "spomky-labs/base64url": "^2.0",
1988 "spomky-labs/cbor-php": "^1.0|^2.0",
1989 "symfony/process": "^3.0|^4.0|^5.0",
1990 "thecodingmachine/safe": "^1.1",
1991 "web-auth/cose-lib": "self.version",
1992 "web-auth/metadata-service": "self.version"
1993 },
1994 "suggest": {
1995 "psr/log-implementation": "Recommended to receive logs from the library",
1996 "web-token/jwt-key-mgmt": "Mandatory for the AndroidSafetyNet Attestation Statement support",
1997 "web-token/jwt-signature-algorithm-ecdsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
1998 "web-token/jwt-signature-algorithm-eddsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
1999 "web-token/jwt-signature-algorithm-rsa": "Mandatory for the AndroidSafetyNet Attestation Statement support"
2000 },
2001 "time": "2022-02-18T07:13:44+00:00",
2002 "type": "library",
2003 "installation-source": "dist",
2004 "autoload": {
2005 "psr-4": {
2006 "Webauthn\\": "src/"
2007 }
2008 },
2009 "notification-url": "https://packagist.org/downloads/",
2010 "license": [
2011 "MIT"
2012 ],
2013 "authors": [
2014 {
2015 "name": "Florent Morselli",
2016 "homepage": "https://github.com/Spomky"
2017 },
2018 {
2019 "name": "All contributors",
2020 "homepage": "https://github.com/web-auth/webauthn-library/contributors"
2021 }
2022 ],
2023 "description": "FIDO2/Webauthn Support For PHP",
2024 "homepage": "https://github.com/web-auth",
2025 "keywords": [
2026 "FIDO2",
2027 "fido",
2028 "webauthn"
2029 ],
2030 "support": {
2031 "source": "https://github.com/web-auth/webauthn-lib/tree/v3.3.12"
2032 },
2033 "funding": [
2034 {
2035 "url": "https://github.com/Spomky",
2036 "type": "github"
2037 },
2038 {
2039 "url": "https://www.patreon.com/FlorentMorselli",
2040 "type": "patreon"
2041 }
2042 ],
2043 "install-path": "../web-auth/webauthn-lib"
2044 },
2045 {
2046 "name": "web-token/jwt-core",
2047 "version": "v2.2.11",
2048 "version_normalized": "2.2.11.0",
2049 "source": {
2050 "type": "git",
2051 "url": "https://github.com/web-token/jwt-core.git",
2052 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678"
2053 },
2054 "dist": {
2055 "type": "zip",
2056 "url": "https://api.github.com/repos/web-token/jwt-core/zipball/53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
2057 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
2058 "shasum": ""
2059 },
2060 "require": {
2061 "brick/math": "^0.8.17|^0.9",
2062 "ext-json": "*",
2063 "ext-mbstring": "*",
2064 "fgrosse/phpasn1": "^2.0",
2065 "php": ">=7.2",
2066 "spomky-labs/base64url": "^1.0|^2.0"
2067 },
2068 "conflict": {
2069 "spomky-labs/jose": "*"
2070 },
2071 "time": "2021-03-17T14:55:52+00:00",
2072 "type": "library",
2073 "installation-source": "dist",
2074 "autoload": {
2075 "psr-4": {
2076 "Jose\\Component\\Core\\": ""
2077 }
2078 },
2079 "notification-url": "https://packagist.org/downloads/",
2080 "license": [
2081 "MIT"
2082 ],
2083 "authors": [
2084 {
2085 "name": "Florent Morselli",
2086 "homepage": "https://github.com/Spomky"
2087 },
2088 {
2089 "name": "All contributors",
2090 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2091 }
2092 ],
2093 "description": "Core component of the JWT Framework.",
2094 "homepage": "https://github.com/web-token",
2095 "keywords": [
2096 "JOSE",
2097 "JWE",
2098 "JWK",
2099 "JWKSet",
2100 "JWS",
2101 "Jot",
2102 "RFC7515",
2103 "RFC7516",
2104 "RFC7517",
2105 "RFC7518",
2106 "RFC7519",
2107 "RFC7520",
2108 "bundle",
2109 "jwa",
2110 "jwt",
2111 "symfony"
2112 ],
2113 "support": {
2114 "source": "https://github.com/web-token/jwt-core/tree/v2.2.11"
2115 },
2116 "funding": [
2117 {
2118 "url": "https://www.patreon.com/FlorentMorselli",
2119 "type": "patreon"
2120 }
2121 ],
2122 "abandoned": "web-token/jwt-library",
2123 "install-path": "../web-token/jwt-core"
2124 },
2125 {
2126 "name": "web-token/jwt-key-mgmt",
2127 "version": "v2.2.11",
2128 "version_normalized": "2.2.11.0",
2129 "source": {
2130 "type": "git",
2131 "url": "https://github.com/web-token/jwt-key-mgmt.git",
2132 "reference": "0b116379515700d237b4e5de86879078ccb09d8a"
2133 },
2134 "dist": {
2135 "type": "zip",
2136 "url": "https://api.github.com/repos/web-token/jwt-key-mgmt/zipball/0b116379515700d237b4e5de86879078ccb09d8a",
2137 "reference": "0b116379515700d237b4e5de86879078ccb09d8a",
2138 "shasum": ""
2139 },
2140 "require": {
2141 "ext-openssl": "*",
2142 "psr/http-client": "^1.0",
2143 "psr/http-factory": "^1.0",
2144 "web-token/jwt-core": "^2.0"
2145 },
2146 "suggest": {
2147 "ext-sodium": "Sodium is required for OKP key creation, EdDSA signature algorithm and ECDH-ES key encryption with OKP keys",
2148 "php-http/httplug": "To enable JKU/X5U support.",
2149 "php-http/message-factory": "To enable JKU/X5U support.",
2150 "web-token/jwt-util-ecc": "To use EC key analyzers."
2151 },
2152 "time": "2021-03-17T14:55:52+00:00",
2153 "type": "library",
2154 "installation-source": "dist",
2155 "autoload": {
2156 "psr-4": {
2157 "Jose\\Component\\KeyManagement\\": ""
2158 }
2159 },
2160 "notification-url": "https://packagist.org/downloads/",
2161 "license": [
2162 "MIT"
2163 ],
2164 "authors": [
2165 {
2166 "name": "Florent Morselli",
2167 "homepage": "https://github.com/Spomky"
2168 },
2169 {
2170 "name": "All contributors",
2171 "homepage": "https://github.com/web-token/jwt-key-mgmt/contributors"
2172 }
2173 ],
2174 "description": "Key Management component of the JWT Framework.",
2175 "homepage": "https://github.com/web-token",
2176 "keywords": [
2177 "JOSE",
2178 "JWE",
2179 "JWK",
2180 "JWKSet",
2181 "JWS",
2182 "Jot",
2183 "RFC7515",
2184 "RFC7516",
2185 "RFC7517",
2186 "RFC7518",
2187 "RFC7519",
2188 "RFC7520",
2189 "bundle",
2190 "jwa",
2191 "jwt",
2192 "symfony"
2193 ],
2194 "support": {
2195 "source": "https://github.com/web-token/jwt-key-mgmt/tree/v2.2.11"
2196 },
2197 "funding": [
2198 {
2199 "url": "https://www.patreon.com/FlorentMorselli",
2200 "type": "patreon"
2201 }
2202 ],
2203 "abandoned": "web-token/jwt-library",
2204 "install-path": "../web-token/jwt-key-mgmt"
2205 },
2206 {
2207 "name": "web-token/jwt-signature",
2208 "version": "v2.2.11",
2209 "version_normalized": "2.2.11.0",
2210 "source": {
2211 "type": "git",
2212 "url": "https://github.com/web-token/jwt-signature.git",
2213 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103"
2214 },
2215 "dist": {
2216 "type": "zip",
2217 "url": "https://api.github.com/repos/web-token/jwt-signature/zipball/015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2218 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2219 "shasum": ""
2220 },
2221 "require": {
2222 "web-token/jwt-core": "^2.1"
2223 },
2224 "suggest": {
2225 "web-token/jwt-signature-algorithm-ecdsa": "ECDSA Based Signature Algorithms",
2226 "web-token/jwt-signature-algorithm-eddsa": "EdDSA Based Signature Algorithms",
2227 "web-token/jwt-signature-algorithm-experimental": "Experimental Signature Algorithms",
2228 "web-token/jwt-signature-algorithm-hmac": "HMAC Based Signature Algorithms",
2229 "web-token/jwt-signature-algorithm-none": "None Signature Algorithm",
2230 "web-token/jwt-signature-algorithm-rsa": "RSA Based Signature Algorithms"
2231 },
2232 "time": "2021-03-01T19:55:28+00:00",
2233 "type": "library",
2234 "installation-source": "dist",
2235 "autoload": {
2236 "psr-4": {
2237 "Jose\\Component\\Signature\\": ""
2238 }
2239 },
2240 "notification-url": "https://packagist.org/downloads/",
2241 "license": [
2242 "MIT"
2243 ],
2244 "authors": [
2245 {
2246 "name": "Florent Morselli",
2247 "homepage": "https://github.com/Spomky"
2248 },
2249 {
2250 "name": "All contributors",
2251 "homepage": "https://github.com/web-token/jwt-signature/contributors"
2252 }
2253 ],
2254 "description": "Signature component of the JWT Framework.",
2255 "homepage": "https://github.com/web-token",
2256 "keywords": [
2257 "JOSE",
2258 "JWE",
2259 "JWK",
2260 "JWKSet",
2261 "JWS",
2262 "Jot",
2263 "RFC7515",
2264 "RFC7516",
2265 "RFC7517",
2266 "RFC7518",
2267 "RFC7519",
2268 "RFC7520",
2269 "bundle",
2270 "jwa",
2271 "jwt",
2272 "symfony"
2273 ],
2274 "support": {
2275 "source": "https://github.com/web-token/jwt-signature/tree/v2.2.11"
2276 },
2277 "funding": [
2278 {
2279 "url": "https://www.patreon.com/FlorentMorselli",
2280 "type": "patreon"
2281 }
2282 ],
2283 "abandoned": "web-token/jwt-library",
2284 "install-path": "../web-token/jwt-signature"
2285 },
2286 {
2287 "name": "web-token/jwt-signature-algorithm-ecdsa",
2288 "version": "v2.2.11",
2289 "version_normalized": "2.2.11.0",
2290 "source": {
2291 "type": "git",
2292 "url": "https://github.com/web-token/jwt-signature-algorithm-ecdsa.git",
2293 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591"
2294 },
2295 "dist": {
2296 "type": "zip",
2297 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-ecdsa/zipball/44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2298 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2299 "shasum": ""
2300 },
2301 "require": {
2302 "ext-openssl": "*",
2303 "web-token/jwt-signature": "^2.0"
2304 },
2305 "time": "2021-01-21T19:18:03+00:00",
2306 "type": "library",
2307 "installation-source": "dist",
2308 "autoload": {
2309 "psr-4": {
2310 "Jose\\Component\\Signature\\Algorithm\\": ""
2311 }
2312 },
2313 "notification-url": "https://packagist.org/downloads/",
2314 "license": [
2315 "MIT"
2316 ],
2317 "authors": [
2318 {
2319 "name": "Florent Morselli",
2320 "homepage": "https://github.com/Spomky"
2321 },
2322 {
2323 "name": "All contributors",
2324 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2325 }
2326 ],
2327 "description": "ECDSA Based Signature Algorithms the JWT Framework.",
2328 "homepage": "https://github.com/web-token",
2329 "keywords": [
2330 "JOSE",
2331 "JWE",
2332 "JWK",
2333 "JWKSet",
2334 "JWS",
2335 "Jot",
2336 "RFC7515",
2337 "RFC7516",
2338 "RFC7517",
2339 "RFC7518",
2340 "RFC7519",
2341 "RFC7520",
2342 "bundle",
2343 "jwa",
2344 "jwt",
2345 "symfony"
2346 ],
2347 "support": {
2348 "source": "https://github.com/web-token/jwt-signature-algorithm-ecdsa/tree/v2.2.11"
2349 },
2350 "funding": [
2351 {
2352 "url": "https://www.patreon.com/FlorentMorselli",
2353 "type": "patreon"
2354 }
2355 ],
2356 "abandoned": "web-token/jwt-library",
2357 "install-path": "../web-token/jwt-signature-algorithm-ecdsa"
2358 },
2359 {
2360 "name": "web-token/jwt-signature-algorithm-eddsa",
2361 "version": "v2.2.11",
2362 "version_normalized": "2.2.11.0",
2363 "source": {
2364 "type": "git",
2365 "url": "https://github.com/web-token/jwt-signature-algorithm-eddsa.git",
2366 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6"
2367 },
2368 "dist": {
2369 "type": "zip",
2370 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-eddsa/zipball/b805ecca593c56e60e0463bd2cacc9b1341910f6",
2371 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6",
2372 "shasum": ""
2373 },
2374 "require": {
2375 "ext-sodium": "*",
2376 "web-token/jwt-signature": "^2.1"
2377 },
2378 "time": "2021-01-21T19:18:03+00:00",
2379 "type": "library",
2380 "installation-source": "dist",
2381 "autoload": {
2382 "psr-4": {
2383 "Jose\\Component\\Signature\\Algorithm\\": ""
2384 }
2385 },
2386 "notification-url": "https://packagist.org/downloads/",
2387 "license": [
2388 "MIT"
2389 ],
2390 "authors": [
2391 {
2392 "name": "Florent Morselli",
2393 "homepage": "https://github.com/Spomky"
2394 },
2395 {
2396 "name": "All contributors",
2397 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2398 }
2399 ],
2400 "description": "EdDSA Signature Algorithm the JWT Framework.",
2401 "homepage": "https://github.com/web-token",
2402 "keywords": [
2403 "JOSE",
2404 "JWE",
2405 "JWK",
2406 "JWKSet",
2407 "JWS",
2408 "Jot",
2409 "RFC7515",
2410 "RFC7516",
2411 "RFC7517",
2412 "RFC7518",
2413 "RFC7519",
2414 "RFC7520",
2415 "bundle",
2416 "jwa",
2417 "jwt",
2418 "symfony"
2419 ],
2420 "support": {
2421 "source": "https://github.com/web-token/jwt-signature-algorithm-eddsa/tree/v2.2.11"
2422 },
2423 "funding": [
2424 {
2425 "url": "https://www.patreon.com/FlorentMorselli",
2426 "type": "patreon"
2427 }
2428 ],
2429 "abandoned": "web-token/jwt-library",
2430 "install-path": "../web-token/jwt-signature-algorithm-eddsa"
2431 },
2432 {
2433 "name": "web-token/jwt-signature-algorithm-rsa",
2434 "version": "v2.2.11",
2435 "version_normalized": "2.2.11.0",
2436 "source": {
2437 "type": "git",
2438 "url": "https://github.com/web-token/jwt-signature-algorithm-rsa.git",
2439 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0"
2440 },
2441 "dist": {
2442 "type": "zip",
2443 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-rsa/zipball/513ad90eb5ef1886ff176727a769bda4618141b0",
2444 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0",
2445 "shasum": ""
2446 },
2447 "require": {
2448 "brick/math": "^0.8.17|^0.9",
2449 "ext-openssl": "*",
2450 "web-token/jwt-signature": "^2.1"
2451 },
2452 "suggest": {
2453 "ext-bcmath": "GMP or BCMath is highly recommended to improve the library performance",
2454 "ext-gmp": "GMP or BCMath is highly recommended to improve the library performance"
2455 },
2456 "time": "2021-01-21T19:18:03+00:00",
2457 "type": "library",
2458 "installation-source": "dist",
2459 "autoload": {
2460 "psr-4": {
2461 "Jose\\Component\\Signature\\Algorithm\\": ""
2462 }
2463 },
2464 "notification-url": "https://packagist.org/downloads/",
2465 "license": [
2466 "MIT"
2467 ],
2468 "authors": [
2469 {
2470 "name": "Florent Morselli",
2471 "homepage": "https://github.com/Spomky"
2472 },
2473 {
2474 "name": "All contributors",
2475 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2476 }
2477 ],
2478 "description": "RSA Based Signature Algorithms the JWT Framework.",
2479 "homepage": "https://github.com/web-token",
2480 "keywords": [
2481 "JOSE",
2482 "JWE",
2483 "JWK",
2484 "JWKSet",
2485 "JWS",
2486 "Jot",
2487 "RFC7515",
2488 "RFC7516",
2489 "RFC7517",
2490 "RFC7518",
2491 "RFC7519",
2492 "RFC7520",
2493 "bundle",
2494 "jwa",
2495 "jwt",
2496 "symfony"
2497 ],
2498 "support": {
2499 "source": "https://github.com/web-token/jwt-signature-algorithm-rsa/tree/v2.2.11"
2500 },
2501 "funding": [
2502 {
2503 "url": "https://www.patreon.com/FlorentMorselli",
2504 "type": "patreon"
2505 }
2506 ],
2507 "abandoned": "web-token/jwt-library",
2508 "install-path": "../web-token/jwt-signature-algorithm-rsa"
2509 },
2510 {
2511 "name": "woocommerce/action-scheduler",
2512 "version": "3.9.2",
2513 "version_normalized": "3.9.2.0",
2514 "source": {
2515 "type": "git",
2516 "url": "https://github.com/woocommerce/action-scheduler.git",
2517 "reference": "efbb7953f72a433086335b249292f280dd43ddfe"
2518 },
2519 "dist": {
2520 "type": "zip",
2521 "url": "https://api.github.com/repos/woocommerce/action-scheduler/zipball/efbb7953f72a433086335b249292f280dd43ddfe",
2522 "reference": "efbb7953f72a433086335b249292f280dd43ddfe",
2523 "shasum": ""
2524 },
2525 "require": {
2526 "php": ">=7.1"
2527 },
2528 "require-dev": {
2529 "phpunit/phpunit": "^7.5",
2530 "woocommerce/woocommerce-sniffs": "0.1.0",
2531 "wp-cli/wp-cli": "~2.5.0",
2532 "yoast/phpunit-polyfills": "^2.0"
2533 },
2534 "time": "2025-02-03T09:09:30+00:00",
2535 "type": "wordpress-plugin",
2536 "extra": {
2537 "scripts-description": {
2538 "test": "Run unit tests",
2539 "phpcs": "Analyze code against the WordPress coding standards with PHP_CodeSniffer",
2540 "phpcbf": "Fix coding standards warnings/errors automatically with PHP Code Beautifier"
2541 }
2542 },
2543 "installation-source": "dist",
2544 "notification-url": "https://packagist.org/downloads/",
2545 "license": [
2546 "GPL-3.0-or-later"
2547 ],
2548 "description": "Action Scheduler for WordPress and WooCommerce",
2549 "homepage": "https://actionscheduler.org/",
2550 "support": {
2551 "issues": "https://github.com/woocommerce/action-scheduler/issues",
2552 "source": "https://github.com/woocommerce/action-scheduler/tree/3.9.2"
2553 },
2554 "install-path": "../woocommerce/action-scheduler"
2555 }
2556 ],
2557 "dev": false,
2558 "dev-package-names": []
2559 }
2560