PluginProbe
Defender Security – Malware Scanner, Login Security & Firewall / 5.7.0
Defender Security – Malware Scanner, Login Security & Firewall v5.7.0
6.3.0 6.2.3 6.2.4 6.2.0 6.2.1 6.2.2 6.1.0 5.3.1 5.4.0 5.4.1 5.5.0 5.5.1 5.6.0 5.6.1 5.6.2 5.7.0 5.7.1 5.7.2 5.8.0 5.8.1 5.9.0 6.0.0 6.0.1 3.0.1 3.1.0 All 141 releases
defender-security / vendor / composer / installed.json

installed.json in Defender Security – Malware Scanner, Login Security & Firewall 5.7.0, at vendor/composer/installed.json

2,466 lines 89.3 KB
No matching file
Up and down to move Enter to open Esc to close
Raw Download Zip
1 {
2 "packages": [
3 {
4 "name": "altcha-org/altcha",
5 "version": "v0.1.4",
6 "version_normalized": "0.1.4.0",
7 "source": {
8 "type": "git",
9 "url": "https://github.com/altcha-org/altcha-lib-php.git",
10 "reference": "0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6"
11 },
12 "dist": {
13 "type": "zip",
14 "url": "https://api.github.com/repos/altcha-org/altcha-lib-php/zipball/0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6",
15 "reference": "0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6",
16 "shasum": ""
17 },
18 "require": {
19 "php": ">=7.4"
20 },
21 "require-dev": {
22 "phpunit/phpunit": "^11.5"
23 },
24 "time": "2025-02-28T05:17:34+00:00",
25 "type": "library",
26 "installation-source": "dist",
27 "autoload": {
28 "psr-4": {
29 "AltchaOrg\\Altcha\\": "src/"
30 }
31 },
32 "notification-url": "https://packagist.org/downloads/",
33 "license": [
34 "MIT"
35 ],
36 "authors": [
37 {
38 "name": "Daniel Regeci",
39 "email": "[email protected]"
40 }
41 ],
42 "support": {
43 "issues": "https://github.com/altcha-org/altcha-lib-php/issues",
44 "source": "https://github.com/altcha-org/altcha-lib-php/tree/v0.1.4"
45 },
46 "install-path": "../altcha-org/altcha"
47 },
48 {
49 "name": "beberlei/assert",
50 "version": "v3.3.3",
51 "version_normalized": "3.3.3.0",
52 "source": {
53 "type": "git",
54 "url": "https://github.com/beberlei/assert.git",
55 "reference": "b5fd8eacd8915a1b627b8bfc027803f1939734dd"
56 },
57 "dist": {
58 "type": "zip",
59 "url": "https://api.github.com/repos/beberlei/assert/zipball/b5fd8eacd8915a1b627b8bfc027803f1939734dd",
60 "reference": "b5fd8eacd8915a1b627b8bfc027803f1939734dd",
61 "shasum": ""
62 },
63 "require": {
64 "ext-ctype": "*",
65 "ext-json": "*",
66 "ext-mbstring": "*",
67 "ext-simplexml": "*",
68 "php": "^7.1 || ^8.0"
69 },
70 "require-dev": {
71 "friendsofphp/php-cs-fixer": "*",
72 "phpstan/phpstan": "*",
73 "phpunit/phpunit": ">=6.0.0",
74 "yoast/phpunit-polyfills": "^0.1.0"
75 },
76 "suggest": {
77 "ext-intl": "Needed to allow Assertion::count(), Assertion::isCountable(), Assertion::minCount(), and Assertion::maxCount() to operate on ResourceBundles"
78 },
79 "time": "2024-07-15T13:18:35+00:00",
80 "type": "library",
81 "installation-source": "dist",
82 "autoload": {
83 "files": [
84 "lib/Assert/functions.php"
85 ],
86 "psr-4": {
87 "Assert\\": "lib/Assert"
88 }
89 },
90 "notification-url": "https://packagist.org/downloads/",
91 "license": [
92 "BSD-2-Clause"
93 ],
94 "authors": [
95 {
96 "name": "Benjamin Eberlei",
97 "email": "[email protected]",
98 "role": "Lead Developer"
99 },
100 {
101 "name": "Richard Quadling",
102 "email": "[email protected]",
103 "role": "Collaborator"
104 }
105 ],
106 "description": "Thin assertion library for input validation in business models.",
107 "keywords": [
108 "assert",
109 "assertion",
110 "validation"
111 ],
112 "support": {
113 "issues": "https://github.com/beberlei/assert/issues",
114 "source": "https://github.com/beberlei/assert/tree/v3.3.3"
115 },
116 "install-path": "../beberlei/assert"
117 },
118 {
119 "name": "brick/math",
120 "version": "0.9.3",
121 "version_normalized": "0.9.3.0",
122 "source": {
123 "type": "git",
124 "url": "https://github.com/brick/math.git",
125 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae"
126 },
127 "dist": {
128 "type": "zip",
129 "url": "https://api.github.com/repos/brick/math/zipball/ca57d18f028f84f777b2168cd1911b0dee2343ae",
130 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae",
131 "shasum": ""
132 },
133 "require": {
134 "ext-json": "*",
135 "php": "^7.1 || ^8.0"
136 },
137 "require-dev": {
138 "php-coveralls/php-coveralls": "^2.2",
139 "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
140 "vimeo/psalm": "4.9.2"
141 },
142 "time": "2021-08-15T20:50:18+00:00",
143 "type": "library",
144 "installation-source": "dist",
145 "autoload": {
146 "psr-4": {
147 "Brick\\Math\\": "src/"
148 }
149 },
150 "notification-url": "https://packagist.org/downloads/",
151 "license": [
152 "MIT"
153 ],
154 "description": "Arbitrary-precision arithmetic library",
155 "keywords": [
156 "Arbitrary-precision",
157 "BigInteger",
158 "BigRational",
159 "arithmetic",
160 "bigdecimal",
161 "bignum",
162 "brick",
163 "math"
164 ],
165 "support": {
166 "issues": "https://github.com/brick/math/issues",
167 "source": "https://github.com/brick/math/tree/0.9.3"
168 },
169 "funding": [
170 {
171 "url": "https://github.com/BenMorel",
172 "type": "github"
173 },
174 {
175 "url": "https://tidelift.com/funding/github/packagist/brick/math",
176 "type": "tidelift"
177 }
178 ],
179 "install-path": "../brick/math"
180 },
181 {
182 "name": "fgrosse/phpasn1",
183 "version": "v2.5.0",
184 "version_normalized": "2.5.0.0",
185 "source": {
186 "type": "git",
187 "url": "https://github.com/fgrosse/PHPASN1.git",
188 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b"
189 },
190 "dist": {
191 "type": "zip",
192 "url": "https://api.github.com/repos/fgrosse/PHPASN1/zipball/42060ed45344789fb9f21f9f1864fc47b9e3507b",
193 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b",
194 "shasum": ""
195 },
196 "require": {
197 "php": "^7.1 || ^8.0"
198 },
199 "require-dev": {
200 "php-coveralls/php-coveralls": "~2.0",
201 "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
202 },
203 "suggest": {
204 "ext-bcmath": "BCmath is the fallback extension for big integer calculations",
205 "ext-curl": "For loading OID information from the web if they have not bee defined statically",
206 "ext-gmp": "GMP is the preferred extension for big integer calculations",
207 "phpseclib/bcmath_compat": "BCmath polyfill for servers where neither GMP nor BCmath is available"
208 },
209 "time": "2022-12-19T11:08:26+00:00",
210 "type": "library",
211 "extra": {
212 "branch-alias": {
213 "dev-master": "2.0.x-dev"
214 }
215 },
216 "installation-source": "dist",
217 "autoload": {
218 "psr-4": {
219 "FG\\": "lib/"
220 }
221 },
222 "notification-url": "https://packagist.org/downloads/",
223 "license": [
224 "MIT"
225 ],
226 "authors": [
227 {
228 "name": "Friedrich Große",
229 "email": "[email protected]",
230 "homepage": "https://github.com/FGrosse",
231 "role": "Author"
232 },
233 {
234 "name": "All contributors",
235 "homepage": "https://github.com/FGrosse/PHPASN1/contributors"
236 }
237 ],
238 "description": "A PHP Framework that allows you to encode and decode arbitrary ASN.1 structures using the ITU-T X.690 Encoding Rules.",
239 "homepage": "https://github.com/FGrosse/PHPASN1",
240 "keywords": [
241 "DER",
242 "asn.1",
243 "asn1",
244 "ber",
245 "binary",
246 "decoding",
247 "encoding",
248 "x.509",
249 "x.690",
250 "x509",
251 "x690"
252 ],
253 "support": {
254 "issues": "https://github.com/fgrosse/PHPASN1/issues",
255 "source": "https://github.com/fgrosse/PHPASN1/tree/v2.5.0"
256 },
257 "abandoned": true,
258 "install-path": "../fgrosse/phpasn1"
259 },
260 {
261 "name": "gettext/gettext",
262 "version": "v5.7.3",
263 "version_normalized": "5.7.3.0",
264 "source": {
265 "type": "git",
266 "url": "https://github.com/php-gettext/Gettext.git",
267 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1"
268 },
269 "dist": {
270 "type": "zip",
271 "url": "https://api.github.com/repos/php-gettext/Gettext/zipball/95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
272 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
273 "shasum": ""
274 },
275 "require": {
276 "gettext/languages": "^2.3",
277 "php": "^7.2|^8.0"
278 },
279 "require-dev": {
280 "brick/varexporter": "^0.3.5",
281 "friendsofphp/php-cs-fixer": "^3.2",
282 "oscarotero/php-cs-fixer-config": "^2.0",
283 "phpunit/phpunit": "^8.0|^9.0",
284 "squizlabs/php_codesniffer": "^3.0"
285 },
286 "time": "2024-12-01T10:18:08+00:00",
287 "type": "library",
288 "installation-source": "dist",
289 "autoload": {
290 "psr-4": {
291 "Gettext\\": "src"
292 }
293 },
294 "notification-url": "https://packagist.org/downloads/",
295 "license": [
296 "MIT"
297 ],
298 "authors": [
299 {
300 "name": "Oscar Otero",
301 "email": "[email protected]",
302 "homepage": "http://oscarotero.com",
303 "role": "Developer"
304 }
305 ],
306 "description": "PHP gettext manager",
307 "homepage": "https://github.com/php-gettext/Gettext",
308 "keywords": [
309 "JS",
310 "gettext",
311 "i18n",
312 "mo",
313 "po",
314 "translation"
315 ],
316 "support": {
317 "email": "[email protected]",
318 "issues": "https://github.com/php-gettext/Gettext/issues",
319 "source": "https://github.com/php-gettext/Gettext/tree/v5.7.3"
320 },
321 "funding": [
322 {
323 "url": "https://paypal.me/oscarotero",
324 "type": "custom"
325 },
326 {
327 "url": "https://github.com/oscarotero",
328 "type": "github"
329 },
330 {
331 "url": "https://www.patreon.com/misteroom",
332 "type": "patreon"
333 }
334 ],
335 "install-path": "../gettext/gettext"
336 },
337 {
338 "name": "gettext/languages",
339 "version": "2.12.1",
340 "version_normalized": "2.12.1.0",
341 "source": {
342 "type": "git",
343 "url": "https://github.com/php-gettext/Languages.git",
344 "reference": "0b0b0851c55168e1dfb14305735c64019732b5f1"
345 },
346 "dist": {
347 "type": "zip",
348 "url": "https://api.github.com/repos/php-gettext/Languages/zipball/0b0b0851c55168e1dfb14305735c64019732b5f1",
349 "reference": "0b0b0851c55168e1dfb14305735c64019732b5f1",
350 "shasum": ""
351 },
352 "require": {
353 "php": ">=5.3"
354 },
355 "require-dev": {
356 "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.5 || ^8.4"
357 },
358 "time": "2025-03-19T11:14:02+00:00",
359 "bin": [
360 "bin/export-plural-rules",
361 "bin/import-cldr-data"
362 ],
363 "type": "library",
364 "installation-source": "dist",
365 "autoload": {
366 "psr-4": {
367 "Gettext\\Languages\\": "src/"
368 }
369 },
370 "notification-url": "https://packagist.org/downloads/",
371 "license": [
372 "MIT"
373 ],
374 "authors": [
375 {
376 "name": "Michele Locati",
377 "email": "[email protected]",
378 "role": "Developer"
379 }
380 ],
381 "description": "gettext languages with plural rules",
382 "homepage": "https://github.com/php-gettext/Languages",
383 "keywords": [
384 "cldr",
385 "i18n",
386 "internationalization",
387 "l10n",
388 "language",
389 "languages",
390 "localization",
391 "php",
392 "plural",
393 "plural rules",
394 "plurals",
395 "translate",
396 "translations",
397 "unicode"
398 ],
399 "support": {
400 "issues": "https://github.com/php-gettext/Languages/issues",
401 "source": "https://github.com/php-gettext/Languages/tree/2.12.1"
402 },
403 "funding": [
404 {
405 "url": "https://paypal.me/mlocati",
406 "type": "custom"
407 },
408 {
409 "url": "https://github.com/mlocati",
410 "type": "github"
411 }
412 ],
413 "install-path": "../gettext/languages"
414 },
415 {
416 "name": "league/uri",
417 "version": "6.7.2",
418 "version_normalized": "6.7.2.0",
419 "source": {
420 "type": "git",
421 "url": "https://github.com/thephpleague/uri.git",
422 "reference": "d3b50812dd51f3fbf176344cc2981db03d10fe06"
423 },
424 "dist": {
425 "type": "zip",
426 "url": "https://api.github.com/repos/thephpleague/uri/zipball/d3b50812dd51f3fbf176344cc2981db03d10fe06",
427 "reference": "d3b50812dd51f3fbf176344cc2981db03d10fe06",
428 "shasum": ""
429 },
430 "require": {
431 "ext-json": "*",
432 "league/uri-interfaces": "^2.3",
433 "php": "^7.4 || ^8.0",
434 "psr/http-message": "^1.0"
435 },
436 "conflict": {
437 "league/uri-schemes": "^1.0"
438 },
439 "require-dev": {
440 "friendsofphp/php-cs-fixer": "^v3.3.2",
441 "nyholm/psr7": "^1.5",
442 "php-http/psr7-integration-tests": "^1.1",
443 "phpstan/phpstan": "^1.2.0",
444 "phpstan/phpstan-deprecation-rules": "^1.0",
445 "phpstan/phpstan-phpunit": "^1.0.0",
446 "phpstan/phpstan-strict-rules": "^1.1.0",
447 "phpunit/phpunit": "^9.5.10",
448 "psr/http-factory": "^1.0"
449 },
450 "suggest": {
451 "ext-fileinfo": "Needed to create Data URI from a filepath",
452 "ext-intl": "Needed to improve host validation",
453 "league/uri-components": "Needed to easily manipulate URI objects",
454 "psr/http-factory": "Needed to use the URI factory"
455 },
456 "time": "2022-09-13T19:50:42+00:00",
457 "type": "library",
458 "extra": {
459 "branch-alias": {
460 "dev-master": "6.x-dev"
461 }
462 },
463 "installation-source": "dist",
464 "autoload": {
465 "psr-4": {
466 "League\\Uri\\": "src"
467 }
468 },
469 "notification-url": "https://packagist.org/downloads/",
470 "license": [
471 "MIT"
472 ],
473 "authors": [
474 {
475 "name": "Ignace Nyamagana Butera",
476 "email": "[email protected]",
477 "homepage": "https://nyamsprod.com"
478 }
479 ],
480 "description": "URI manipulation library",
481 "homepage": "https://uri.thephpleague.com",
482 "keywords": [
483 "data-uri",
484 "file-uri",
485 "ftp",
486 "hostname",
487 "http",
488 "https",
489 "middleware",
490 "parse_str",
491 "parse_url",
492 "psr-7",
493 "query-string",
494 "querystring",
495 "rfc3986",
496 "rfc3987",
497 "rfc6570",
498 "uri",
499 "uri-template",
500 "url",
501 "ws"
502 ],
503 "support": {
504 "docs": "https://uri.thephpleague.com",
505 "forum": "https://thephpleague.slack.com",
506 "issues": "https://github.com/thephpleague/uri/issues",
507 "source": "https://github.com/thephpleague/uri/tree/6.7.2"
508 },
509 "funding": [
510 {
511 "url": "https://github.com/sponsors/nyamsprod",
512 "type": "github"
513 }
514 ],
515 "install-path": "../league/uri"
516 },
517 {
518 "name": "league/uri-interfaces",
519 "version": "2.3.0",
520 "version_normalized": "2.3.0.0",
521 "source": {
522 "type": "git",
523 "url": "https://github.com/thephpleague/uri-interfaces.git",
524 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383"
525 },
526 "dist": {
527 "type": "zip",
528 "url": "https://api.github.com/repos/thephpleague/uri-interfaces/zipball/00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
529 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
530 "shasum": ""
531 },
532 "require": {
533 "ext-json": "*",
534 "php": "^7.2 || ^8.0"
535 },
536 "require-dev": {
537 "friendsofphp/php-cs-fixer": "^2.19",
538 "phpstan/phpstan": "^0.12.90",
539 "phpstan/phpstan-phpunit": "^0.12.19",
540 "phpstan/phpstan-strict-rules": "^0.12.9",
541 "phpunit/phpunit": "^8.5.15 || ^9.5"
542 },
543 "suggest": {
544 "ext-intl": "to use the IDNA feature",
545 "symfony/intl": "to use the IDNA feature via Symfony Polyfill"
546 },
547 "time": "2021-06-28T04:27:21+00:00",
548 "type": "library",
549 "extra": {
550 "branch-alias": {
551 "dev-master": "2.x-dev"
552 }
553 },
554 "installation-source": "dist",
555 "autoload": {
556 "psr-4": {
557 "League\\Uri\\": "src/"
558 }
559 },
560 "notification-url": "https://packagist.org/downloads/",
561 "license": [
562 "MIT"
563 ],
564 "authors": [
565 {
566 "name": "Ignace Nyamagana Butera",
567 "email": "[email protected]",
568 "homepage": "https://nyamsprod.com"
569 }
570 ],
571 "description": "Common interface for URI representation",
572 "homepage": "http://github.com/thephpleague/uri-interfaces",
573 "keywords": [
574 "rfc3986",
575 "rfc3987",
576 "uri",
577 "url"
578 ],
579 "support": {
580 "issues": "https://github.com/thephpleague/uri-interfaces/issues",
581 "source": "https://github.com/thephpleague/uri-interfaces/tree/2.3.0"
582 },
583 "funding": [
584 {
585 "url": "https://github.com/sponsors/nyamsprod",
586 "type": "github"
587 }
588 ],
589 "install-path": "../league/uri-interfaces"
590 },
591 {
592 "name": "nyholm/psr7",
593 "version": "1.8.2",
594 "version_normalized": "1.8.2.0",
595 "source": {
596 "type": "git",
597 "url": "https://github.com/Nyholm/psr7.git",
598 "reference": "a71f2b11690f4b24d099d6b16690a90ae14fc6f3"
599 },
600 "dist": {
601 "type": "zip",
602 "url": "https://api.github.com/repos/Nyholm/psr7/zipball/a71f2b11690f4b24d099d6b16690a90ae14fc6f3",
603 "reference": "a71f2b11690f4b24d099d6b16690a90ae14fc6f3",
604 "shasum": ""
605 },
606 "require": {
607 "php": ">=7.2",
608 "psr/http-factory": "^1.0",
609 "psr/http-message": "^1.1 || ^2.0"
610 },
611 "provide": {
612 "php-http/message-factory-implementation": "1.0",
613 "psr/http-factory-implementation": "1.0",
614 "psr/http-message-implementation": "1.0"
615 },
616 "require-dev": {
617 "http-interop/http-factory-tests": "^0.9",
618 "php-http/message-factory": "^1.0",
619 "php-http/psr7-integration-tests": "^1.0",
620 "phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
621 "symfony/error-handler": "^4.4"
622 },
623 "time": "2024-09-09T07:06:30+00:00",
624 "type": "library",
625 "extra": {
626 "branch-alias": {
627 "dev-master": "1.8-dev"
628 }
629 },
630 "installation-source": "dist",
631 "autoload": {
632 "psr-4": {
633 "Nyholm\\Psr7\\": "src/"
634 }
635 },
636 "notification-url": "https://packagist.org/downloads/",
637 "license": [
638 "MIT"
639 ],
640 "authors": [
641 {
642 "name": "Tobias Nyholm",
643 "email": "[email protected]"
644 },
645 {
646 "name": "Martijn van der Ven",
647 "email": "[email protected]"
648 }
649 ],
650 "description": "A fast PHP7 implementation of PSR-7",
651 "homepage": "https://tnyholm.se",
652 "keywords": [
653 "psr-17",
654 "psr-7"
655 ],
656 "support": {
657 "issues": "https://github.com/Nyholm/psr7/issues",
658 "source": "https://github.com/Nyholm/psr7/tree/1.8.2"
659 },
660 "funding": [
661 {
662 "url": "https://github.com/Zegnat",
663 "type": "github"
664 },
665 {
666 "url": "https://github.com/nyholm",
667 "type": "github"
668 }
669 ],
670 "install-path": "../nyholm/psr7"
671 },
672 {
673 "name": "nyholm/psr7-server",
674 "version": "1.1.0",
675 "version_normalized": "1.1.0.0",
676 "source": {
677 "type": "git",
678 "url": "https://github.com/Nyholm/psr7-server.git",
679 "reference": "4335801d851f554ca43fa6e7d2602141538854dc"
680 },
681 "dist": {
682 "type": "zip",
683 "url": "https://api.github.com/repos/Nyholm/psr7-server/zipball/4335801d851f554ca43fa6e7d2602141538854dc",
684 "reference": "4335801d851f554ca43fa6e7d2602141538854dc",
685 "shasum": ""
686 },
687 "require": {
688 "php": "^7.1 || ^8.0",
689 "psr/http-factory": "^1.0",
690 "psr/http-message": "^1.0 || ^2.0"
691 },
692 "require-dev": {
693 "nyholm/nsa": "^1.1",
694 "nyholm/psr7": "^1.3",
695 "phpunit/phpunit": "^7.0 || ^8.5 || ^9.3"
696 },
697 "time": "2023-11-08T09:30:43+00:00",
698 "type": "library",
699 "installation-source": "dist",
700 "autoload": {
701 "psr-4": {
702 "Nyholm\\Psr7Server\\": "src/"
703 }
704 },
705 "notification-url": "https://packagist.org/downloads/",
706 "license": [
707 "MIT"
708 ],
709 "authors": [
710 {
711 "name": "Tobias Nyholm",
712 "email": "[email protected]"
713 },
714 {
715 "name": "Martijn van der Ven",
716 "email": "[email protected]"
717 }
718 ],
719 "description": "Helper classes to handle PSR-7 server requests",
720 "homepage": "http://tnyholm.se",
721 "keywords": [
722 "psr-17",
723 "psr-7"
724 ],
725 "support": {
726 "issues": "https://github.com/Nyholm/psr7-server/issues",
727 "source": "https://github.com/Nyholm/psr7-server/tree/1.1.0"
728 },
729 "funding": [
730 {
731 "url": "https://github.com/Zegnat",
732 "type": "github"
733 },
734 {
735 "url": "https://github.com/nyholm",
736 "type": "github"
737 }
738 ],
739 "install-path": "../nyholm/psr7-server"
740 },
741 {
742 "name": "psr/http-client",
743 "version": "1.0.3",
744 "version_normalized": "1.0.3.0",
745 "source": {
746 "type": "git",
747 "url": "https://github.com/php-fig/http-client.git",
748 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90"
749 },
750 "dist": {
751 "type": "zip",
752 "url": "https://api.github.com/repos/php-fig/http-client/zipball/bb5906edc1c324c9a05aa0873d40117941e5fa90",
753 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90",
754 "shasum": ""
755 },
756 "require": {
757 "php": "^7.0 || ^8.0",
758 "psr/http-message": "^1.0 || ^2.0"
759 },
760 "time": "2023-09-23T14:17:50+00:00",
761 "type": "library",
762 "extra": {
763 "branch-alias": {
764 "dev-master": "1.0.x-dev"
765 }
766 },
767 "installation-source": "dist",
768 "autoload": {
769 "psr-4": {
770 "Psr\\Http\\Client\\": "src/"
771 }
772 },
773 "notification-url": "https://packagist.org/downloads/",
774 "license": [
775 "MIT"
776 ],
777 "authors": [
778 {
779 "name": "PHP-FIG",
780 "homepage": "https://www.php-fig.org/"
781 }
782 ],
783 "description": "Common interface for HTTP clients",
784 "homepage": "https://github.com/php-fig/http-client",
785 "keywords": [
786 "http",
787 "http-client",
788 "psr",
789 "psr-18"
790 ],
791 "support": {
792 "source": "https://github.com/php-fig/http-client"
793 },
794 "install-path": "../psr/http-client"
795 },
796 {
797 "name": "psr/http-factory",
798 "version": "1.1.0",
799 "version_normalized": "1.1.0.0",
800 "source": {
801 "type": "git",
802 "url": "https://github.com/php-fig/http-factory.git",
803 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a"
804 },
805 "dist": {
806 "type": "zip",
807 "url": "https://api.github.com/repos/php-fig/http-factory/zipball/2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
808 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
809 "shasum": ""
810 },
811 "require": {
812 "php": ">=7.1",
813 "psr/http-message": "^1.0 || ^2.0"
814 },
815 "time": "2024-04-15T12:06:14+00:00",
816 "type": "library",
817 "extra": {
818 "branch-alias": {
819 "dev-master": "1.0.x-dev"
820 }
821 },
822 "installation-source": "dist",
823 "autoload": {
824 "psr-4": {
825 "Psr\\Http\\Message\\": "src/"
826 }
827 },
828 "notification-url": "https://packagist.org/downloads/",
829 "license": [
830 "MIT"
831 ],
832 "authors": [
833 {
834 "name": "PHP-FIG",
835 "homepage": "https://www.php-fig.org/"
836 }
837 ],
838 "description": "PSR-17: Common interfaces for PSR-7 HTTP message factories",
839 "keywords": [
840 "factory",
841 "http",
842 "message",
843 "psr",
844 "psr-17",
845 "psr-7",
846 "request",
847 "response"
848 ],
849 "support": {
850 "source": "https://github.com/php-fig/http-factory"
851 },
852 "install-path": "../psr/http-factory"
853 },
854 {
855 "name": "psr/http-message",
856 "version": "1.1",
857 "version_normalized": "1.1.0.0",
858 "source": {
859 "type": "git",
860 "url": "https://github.com/php-fig/http-message.git",
861 "reference": "cb6ce4845ce34a8ad9e68117c10ee90a29919eba"
862 },
863 "dist": {
864 "type": "zip",
865 "url": "https://api.github.com/repos/php-fig/http-message/zipball/cb6ce4845ce34a8ad9e68117c10ee90a29919eba",
866 "reference": "cb6ce4845ce34a8ad9e68117c10ee90a29919eba",
867 "shasum": ""
868 },
869 "require": {
870 "php": "^7.2 || ^8.0"
871 },
872 "time": "2023-04-04T09:50:52+00:00",
873 "type": "library",
874 "extra": {
875 "branch-alias": {
876 "dev-master": "1.1.x-dev"
877 }
878 },
879 "installation-source": "dist",
880 "autoload": {
881 "psr-4": {
882 "Psr\\Http\\Message\\": "src/"
883 }
884 },
885 "notification-url": "https://packagist.org/downloads/",
886 "license": [
887 "MIT"
888 ],
889 "authors": [
890 {
891 "name": "PHP-FIG",
892 "homepage": "http://www.php-fig.org/"
893 }
894 ],
895 "description": "Common interface for HTTP messages",
896 "homepage": "https://github.com/php-fig/http-message",
897 "keywords": [
898 "http",
899 "http-message",
900 "psr",
901 "psr-7",
902 "request",
903 "response"
904 ],
905 "support": {
906 "source": "https://github.com/php-fig/http-message/tree/1.1"
907 },
908 "install-path": "../psr/http-message"
909 },
910 {
911 "name": "psr/log",
912 "version": "1.1.4",
913 "version_normalized": "1.1.4.0",
914 "source": {
915 "type": "git",
916 "url": "https://github.com/php-fig/log.git",
917 "reference": "d49695b909c3b7628b6289db5479a1c204601f11"
918 },
919 "dist": {
920 "type": "zip",
921 "url": "https://api.github.com/repos/php-fig/log/zipball/d49695b909c3b7628b6289db5479a1c204601f11",
922 "reference": "d49695b909c3b7628b6289db5479a1c204601f11",
923 "shasum": ""
924 },
925 "require": {
926 "php": ">=5.3.0"
927 },
928 "time": "2021-05-03T11:20:27+00:00",
929 "type": "library",
930 "extra": {
931 "branch-alias": {
932 "dev-master": "1.1.x-dev"
933 }
934 },
935 "installation-source": "dist",
936 "autoload": {
937 "psr-4": {
938 "Psr\\Log\\": "Psr/Log/"
939 }
940 },
941 "notification-url": "https://packagist.org/downloads/",
942 "license": [
943 "MIT"
944 ],
945 "authors": [
946 {
947 "name": "PHP-FIG",
948 "homepage": "https://www.php-fig.org/"
949 }
950 ],
951 "description": "Common interface for logging libraries",
952 "homepage": "https://github.com/php-fig/log",
953 "keywords": [
954 "log",
955 "psr",
956 "psr-3"
957 ],
958 "support": {
959 "source": "https://github.com/php-fig/log/tree/1.1.4"
960 },
961 "install-path": "../psr/log"
962 },
963 {
964 "name": "ramsey/collection",
965 "version": "1.3.0",
966 "version_normalized": "1.3.0.0",
967 "source": {
968 "type": "git",
969 "url": "https://github.com/ramsey/collection.git",
970 "reference": "ad7475d1c9e70b190ecffc58f2d989416af339b4"
971 },
972 "dist": {
973 "type": "zip",
974 "url": "https://api.github.com/repos/ramsey/collection/zipball/ad7475d1c9e70b190ecffc58f2d989416af339b4",
975 "reference": "ad7475d1c9e70b190ecffc58f2d989416af339b4",
976 "shasum": ""
977 },
978 "require": {
979 "php": "^7.4 || ^8.0",
980 "symfony/polyfill-php81": "^1.23"
981 },
982 "require-dev": {
983 "captainhook/plugin-composer": "^5.3",
984 "ergebnis/composer-normalize": "^2.28.3",
985 "fakerphp/faker": "^1.21",
986 "hamcrest/hamcrest-php": "^2.0",
987 "jangregor/phpstan-prophecy": "^1.0",
988 "mockery/mockery": "^1.5",
989 "php-parallel-lint/php-console-highlighter": "^1.0",
990 "php-parallel-lint/php-parallel-lint": "^1.3",
991 "phpcsstandards/phpcsutils": "^1.0.0-rc1",
992 "phpspec/prophecy-phpunit": "^2.0",
993 "phpstan/extension-installer": "^1.2",
994 "phpstan/phpstan": "^1.9",
995 "phpstan/phpstan-mockery": "^1.1",
996 "phpstan/phpstan-phpunit": "^1.3",
997 "phpunit/phpunit": "^9.5",
998 "psalm/plugin-mockery": "^1.1",
999 "psalm/plugin-phpunit": "^0.18.4",
1000 "ramsey/coding-standard": "^2.0.3",
1001 "ramsey/conventional-commits": "^1.3",
1002 "vimeo/psalm": "^5.4"
1003 },
1004 "time": "2022-12-27T19:12:24+00:00",
1005 "type": "library",
1006 "extra": {
1007 "captainhook": {
1008 "force-install": true
1009 },
1010 "ramsey/conventional-commits": {
1011 "configFile": "conventional-commits.json"
1012 }
1013 },
1014 "installation-source": "dist",
1015 "autoload": {
1016 "psr-4": {
1017 "Ramsey\\Collection\\": "src/"
1018 }
1019 },
1020 "notification-url": "https://packagist.org/downloads/",
1021 "license": [
1022 "MIT"
1023 ],
1024 "authors": [
1025 {
1026 "name": "Ben Ramsey",
1027 "email": "[email protected]",
1028 "homepage": "https://benramsey.com"
1029 }
1030 ],
1031 "description": "A PHP library for representing and manipulating collections.",
1032 "keywords": [
1033 "array",
1034 "collection",
1035 "hash",
1036 "map",
1037 "queue",
1038 "set"
1039 ],
1040 "support": {
1041 "issues": "https://github.com/ramsey/collection/issues",
1042 "source": "https://github.com/ramsey/collection/tree/1.3.0"
1043 },
1044 "funding": [
1045 {
1046 "url": "https://github.com/ramsey",
1047 "type": "github"
1048 },
1049 {
1050 "url": "https://tidelift.com/funding/github/packagist/ramsey/collection",
1051 "type": "tidelift"
1052 }
1053 ],
1054 "install-path": "../ramsey/collection"
1055 },
1056 {
1057 "name": "ramsey/uuid",
1058 "version": "4.9.1",
1059 "version_normalized": "4.9.1.0",
1060 "source": {
1061 "type": "git",
1062 "url": "https://github.com/ramsey/uuid.git",
1063 "reference": "81f941f6f729b1e3ceea61d9d014f8b6c6800440"
1064 },
1065 "dist": {
1066 "type": "zip",
1067 "url": "https://api.github.com/repos/ramsey/uuid/zipball/81f941f6f729b1e3ceea61d9d014f8b6c6800440",
1068 "reference": "81f941f6f729b1e3ceea61d9d014f8b6c6800440",
1069 "shasum": ""
1070 },
1071 "require": {
1072 "brick/math": "^0.8.8 || ^0.9 || ^0.10 || ^0.11 || ^0.12 || ^0.13 || ^0.14",
1073 "php": "^8.0",
1074 "ramsey/collection": "^1.2 || ^2.0"
1075 },
1076 "replace": {
1077 "rhumsaa/uuid": "self.version"
1078 },
1079 "require-dev": {
1080 "captainhook/captainhook": "^5.25",
1081 "captainhook/plugin-composer": "^5.3",
1082 "dealerdirect/phpcodesniffer-composer-installer": "^1.0",
1083 "ergebnis/composer-normalize": "^2.47",
1084 "mockery/mockery": "^1.6",
1085 "paragonie/random-lib": "^2",
1086 "php-mock/php-mock": "^2.6",
1087 "php-mock/php-mock-mockery": "^1.5",
1088 "php-parallel-lint/php-parallel-lint": "^1.4.0",
1089 "phpbench/phpbench": "^1.2.14",
1090 "phpstan/extension-installer": "^1.4",
1091 "phpstan/phpstan": "^2.1",
1092 "phpstan/phpstan-mockery": "^2.0",
1093 "phpstan/phpstan-phpunit": "^2.0",
1094 "phpunit/phpunit": "^9.6",
1095 "slevomat/coding-standard": "^8.18",
1096 "squizlabs/php_codesniffer": "^3.13"
1097 },
1098 "suggest": {
1099 "ext-bcmath": "Enables faster math with arbitrary-precision integers using BCMath.",
1100 "ext-gmp": "Enables faster math with arbitrary-precision integers using GMP.",
1101 "ext-uuid": "Enables the use of PeclUuidTimeGenerator and PeclUuidRandomGenerator.",
1102 "paragonie/random-lib": "Provides RandomLib for use with the RandomLibAdapter",
1103 "ramsey/uuid-doctrine": "Allows the use of Ramsey\\Uuid\\Uuid as Doctrine field type."
1104 },
1105 "time": "2025-09-04T20:59:21+00:00",
1106 "type": "library",
1107 "extra": {
1108 "captainhook": {
1109 "force-install": true
1110 }
1111 },
1112 "installation-source": "dist",
1113 "autoload": {
1114 "files": [
1115 "src/functions.php"
1116 ],
1117 "psr-4": {
1118 "Ramsey\\Uuid\\": "src/"
1119 }
1120 },
1121 "notification-url": "https://packagist.org/downloads/",
1122 "license": [
1123 "MIT"
1124 ],
1125 "description": "A PHP library for generating and working with universally unique identifiers (UUIDs).",
1126 "keywords": [
1127 "guid",
1128 "identifier",
1129 "uuid"
1130 ],
1131 "support": {
1132 "issues": "https://github.com/ramsey/uuid/issues",
1133 "source": "https://github.com/ramsey/uuid/tree/4.9.1"
1134 },
1135 "install-path": "../ramsey/uuid"
1136 },
1137 {
1138 "name": "spomky-labs/base64url",
1139 "version": "v2.0.4",
1140 "version_normalized": "2.0.4.0",
1141 "source": {
1142 "type": "git",
1143 "url": "https://github.com/Spomky-Labs/base64url.git",
1144 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d"
1145 },
1146 "dist": {
1147 "type": "zip",
1148 "url": "https://api.github.com/repos/Spomky-Labs/base64url/zipball/7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1149 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1150 "shasum": ""
1151 },
1152 "require": {
1153 "php": ">=7.1"
1154 },
1155 "require-dev": {
1156 "phpstan/extension-installer": "^1.0",
1157 "phpstan/phpstan": "^0.11|^0.12",
1158 "phpstan/phpstan-beberlei-assert": "^0.11|^0.12",
1159 "phpstan/phpstan-deprecation-rules": "^0.11|^0.12",
1160 "phpstan/phpstan-phpunit": "^0.11|^0.12",
1161 "phpstan/phpstan-strict-rules": "^0.11|^0.12"
1162 },
1163 "time": "2020-11-03T09:10:25+00:00",
1164 "type": "library",
1165 "installation-source": "dist",
1166 "autoload": {
1167 "psr-4": {
1168 "Base64Url\\": "src/"
1169 }
1170 },
1171 "notification-url": "https://packagist.org/downloads/",
1172 "license": [
1173 "MIT"
1174 ],
1175 "authors": [
1176 {
1177 "name": "Florent Morselli",
1178 "homepage": "https://github.com/Spomky-Labs/base64url/contributors"
1179 }
1180 ],
1181 "description": "Base 64 URL Safe Encoding/Decoding PHP Library",
1182 "homepage": "https://github.com/Spomky-Labs/base64url",
1183 "keywords": [
1184 "base64",
1185 "rfc4648",
1186 "safe",
1187 "url"
1188 ],
1189 "support": {
1190 "issues": "https://github.com/Spomky-Labs/base64url/issues",
1191 "source": "https://github.com/Spomky-Labs/base64url/tree/v2.0.4"
1192 },
1193 "funding": [
1194 {
1195 "url": "https://github.com/Spomky",
1196 "type": "github"
1197 },
1198 {
1199 "url": "https://www.patreon.com/FlorentMorselli",
1200 "type": "patreon"
1201 }
1202 ],
1203 "install-path": "../spomky-labs/base64url"
1204 },
1205 {
1206 "name": "spomky-labs/cbor-php",
1207 "version": "v2.1.0",
1208 "version_normalized": "2.1.0.0",
1209 "source": {
1210 "type": "git",
1211 "url": "https://github.com/Spomky-Labs/cbor-php.git",
1212 "reference": "28e2712cfc0b48fae661a48ffc6896d7abe83684"
1213 },
1214 "dist": {
1215 "type": "zip",
1216 "url": "https://api.github.com/repos/Spomky-Labs/cbor-php/zipball/28e2712cfc0b48fae661a48ffc6896d7abe83684",
1217 "reference": "28e2712cfc0b48fae661a48ffc6896d7abe83684",
1218 "shasum": ""
1219 },
1220 "require": {
1221 "brick/math": "^0.8.15|^0.9.0",
1222 "ext-mbstring": "*",
1223 "php": ">=7.3"
1224 },
1225 "require-dev": {
1226 "ekino/phpstan-banned-code": "^1.0",
1227 "ext-json": "*",
1228 "infection/infection": "^0.18|^0.25",
1229 "phpstan/extension-installer": "^1.1",
1230 "phpstan/phpstan": "^1.0",
1231 "phpstan/phpstan-beberlei-assert": "^1.0",
1232 "phpstan/phpstan-deprecation-rules": "^1.0",
1233 "phpstan/phpstan-phpunit": "^1.0",
1234 "phpstan/phpstan-strict-rules": "^1.0",
1235 "phpunit/phpunit": "^9.5",
1236 "rector/rector": "^0.12",
1237 "roave/security-advisories": "dev-latest",
1238 "symplify/easy-coding-standard": "^10.0"
1239 },
1240 "suggest": {
1241 "ext-bcmath": "GMP or BCMath extensions will drastically improve the library performance. BCMath extension needed to handle the Big Float and Decimal Fraction Tags",
1242 "ext-gmp": "GMP or BCMath extensions will drastically improve the library performance"
1243 },
1244 "time": "2021-12-13T12:46:26+00:00",
1245 "type": "library",
1246 "installation-source": "dist",
1247 "autoload": {
1248 "psr-4": {
1249 "CBOR\\": "src/"
1250 }
1251 },
1252 "notification-url": "https://packagist.org/downloads/",
1253 "license": [
1254 "MIT"
1255 ],
1256 "authors": [
1257 {
1258 "name": "Florent Morselli",
1259 "homepage": "https://github.com/Spomky"
1260 },
1261 {
1262 "name": "All contributors",
1263 "homepage": "https://github.com/Spomky-Labs/cbor-php/contributors"
1264 }
1265 ],
1266 "description": "CBOR Encoder/Decoder for PHP",
1267 "keywords": [
1268 "Concise Binary Object Representation",
1269 "RFC7049",
1270 "cbor"
1271 ],
1272 "support": {
1273 "issues": "https://github.com/Spomky-Labs/cbor-php/issues",
1274 "source": "https://github.com/Spomky-Labs/cbor-php/tree/v2.1.0"
1275 },
1276 "funding": [
1277 {
1278 "url": "https://github.com/Spomky",
1279 "type": "github"
1280 },
1281 {
1282 "url": "https://www.patreon.com/FlorentMorselli",
1283 "type": "patreon"
1284 }
1285 ],
1286 "install-path": "../spomky-labs/cbor-php"
1287 },
1288 {
1289 "name": "symfony/polyfill-php80",
1290 "version": "v1.33.0",
1291 "version_normalized": "1.33.0.0",
1292 "source": {
1293 "type": "git",
1294 "url": "https://github.com/symfony/polyfill-php80.git",
1295 "reference": "0cc9dd0f17f61d8131e7df6b84bd344899fe2608"
1296 },
1297 "dist": {
1298 "type": "zip",
1299 "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/0cc9dd0f17f61d8131e7df6b84bd344899fe2608",
1300 "reference": "0cc9dd0f17f61d8131e7df6b84bd344899fe2608",
1301 "shasum": ""
1302 },
1303 "require": {
1304 "php": ">=7.2"
1305 },
1306 "time": "2025-01-02T08:10:11+00:00",
1307 "type": "library",
1308 "extra": {
1309 "thanks": {
1310 "url": "https://github.com/symfony/polyfill",
1311 "name": "symfony/polyfill"
1312 }
1313 },
1314 "installation-source": "dist",
1315 "autoload": {
1316 "files": [
1317 "bootstrap.php"
1318 ],
1319 "psr-4": {
1320 "Symfony\\Polyfill\\Php80\\": ""
1321 },
1322 "classmap": [
1323 "Resources/stubs"
1324 ]
1325 },
1326 "notification-url": "https://packagist.org/downloads/",
1327 "license": [
1328 "MIT"
1329 ],
1330 "authors": [
1331 {
1332 "name": "Ion Bazan",
1333 "email": "[email protected]"
1334 },
1335 {
1336 "name": "Nicolas Grekas",
1337 "email": "[email protected]"
1338 },
1339 {
1340 "name": "Symfony Community",
1341 "homepage": "https://symfony.com/contributors"
1342 }
1343 ],
1344 "description": "Symfony polyfill backporting some PHP 8.0+ features to lower PHP versions",
1345 "homepage": "https://symfony.com",
1346 "keywords": [
1347 "compatibility",
1348 "polyfill",
1349 "portable",
1350 "shim"
1351 ],
1352 "support": {
1353 "source": "https://github.com/symfony/polyfill-php80/tree/v1.33.0"
1354 },
1355 "funding": [
1356 {
1357 "url": "https://symfony.com/sponsor",
1358 "type": "custom"
1359 },
1360 {
1361 "url": "https://github.com/fabpot",
1362 "type": "github"
1363 },
1364 {
1365 "url": "https://github.com/nicolas-grekas",
1366 "type": "github"
1367 },
1368 {
1369 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1370 "type": "tidelift"
1371 }
1372 ],
1373 "install-path": "../symfony/polyfill-php80"
1374 },
1375 {
1376 "name": "symfony/polyfill-php81",
1377 "version": "v1.33.0",
1378 "version_normalized": "1.33.0.0",
1379 "source": {
1380 "type": "git",
1381 "url": "https://github.com/symfony/polyfill-php81.git",
1382 "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c"
1383 },
1384 "dist": {
1385 "type": "zip",
1386 "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
1387 "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
1388 "shasum": ""
1389 },
1390 "require": {
1391 "php": ">=7.2"
1392 },
1393 "time": "2024-09-09T11:45:10+00:00",
1394 "type": "library",
1395 "extra": {
1396 "thanks": {
1397 "url": "https://github.com/symfony/polyfill",
1398 "name": "symfony/polyfill"
1399 }
1400 },
1401 "installation-source": "dist",
1402 "autoload": {
1403 "files": [
1404 "bootstrap.php"
1405 ],
1406 "psr-4": {
1407 "Symfony\\Polyfill\\Php81\\": ""
1408 },
1409 "classmap": [
1410 "Resources/stubs"
1411 ]
1412 },
1413 "notification-url": "https://packagist.org/downloads/",
1414 "license": [
1415 "MIT"
1416 ],
1417 "authors": [
1418 {
1419 "name": "Nicolas Grekas",
1420 "email": "[email protected]"
1421 },
1422 {
1423 "name": "Symfony Community",
1424 "homepage": "https://symfony.com/contributors"
1425 }
1426 ],
1427 "description": "Symfony polyfill backporting some PHP 8.1+ features to lower PHP versions",
1428 "homepage": "https://symfony.com",
1429 "keywords": [
1430 "compatibility",
1431 "polyfill",
1432 "portable",
1433 "shim"
1434 ],
1435 "support": {
1436 "source": "https://github.com/symfony/polyfill-php81/tree/v1.33.0"
1437 },
1438 "funding": [
1439 {
1440 "url": "https://symfony.com/sponsor",
1441 "type": "custom"
1442 },
1443 {
1444 "url": "https://github.com/fabpot",
1445 "type": "github"
1446 },
1447 {
1448 "url": "https://github.com/nicolas-grekas",
1449 "type": "github"
1450 },
1451 {
1452 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1453 "type": "tidelift"
1454 }
1455 ],
1456 "install-path": "../symfony/polyfill-php81"
1457 },
1458 {
1459 "name": "symfony/process",
1460 "version": "v5.4.47",
1461 "version_normalized": "5.4.47.0",
1462 "source": {
1463 "type": "git",
1464 "url": "https://github.com/symfony/process.git",
1465 "reference": "5d1662fb32ebc94f17ddb8d635454a776066733d"
1466 },
1467 "dist": {
1468 "type": "zip",
1469 "url": "https://api.github.com/repos/symfony/process/zipball/5d1662fb32ebc94f17ddb8d635454a776066733d",
1470 "reference": "5d1662fb32ebc94f17ddb8d635454a776066733d",
1471 "shasum": ""
1472 },
1473 "require": {
1474 "php": ">=7.2.5",
1475 "symfony/polyfill-php80": "^1.16"
1476 },
1477 "time": "2024-11-06T11:36:42+00:00",
1478 "type": "library",
1479 "installation-source": "dist",
1480 "autoload": {
1481 "psr-4": {
1482 "Symfony\\Component\\Process\\": ""
1483 },
1484 "exclude-from-classmap": [
1485 "/Tests/"
1486 ]
1487 },
1488 "notification-url": "https://packagist.org/downloads/",
1489 "license": [
1490 "MIT"
1491 ],
1492 "authors": [
1493 {
1494 "name": "Fabien Potencier",
1495 "email": "[email protected]"
1496 },
1497 {
1498 "name": "Symfony Community",
1499 "homepage": "https://symfony.com/contributors"
1500 }
1501 ],
1502 "description": "Executes commands in sub-processes",
1503 "homepage": "https://symfony.com",
1504 "support": {
1505 "source": "https://github.com/symfony/process/tree/v5.4.47"
1506 },
1507 "funding": [
1508 {
1509 "url": "https://symfony.com/sponsor",
1510 "type": "custom"
1511 },
1512 {
1513 "url": "https://github.com/fabpot",
1514 "type": "github"
1515 },
1516 {
1517 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1518 "type": "tidelift"
1519 }
1520 ],
1521 "install-path": "../symfony/process"
1522 },
1523 {
1524 "name": "thecodingmachine/safe",
1525 "version": "v1.3.3",
1526 "version_normalized": "1.3.3.0",
1527 "source": {
1528 "type": "git",
1529 "url": "https://github.com/thecodingmachine/safe.git",
1530 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc"
1531 },
1532 "dist": {
1533 "type": "zip",
1534 "url": "https://api.github.com/repos/thecodingmachine/safe/zipball/a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1535 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1536 "shasum": ""
1537 },
1538 "require": {
1539 "php": ">=7.2"
1540 },
1541 "require-dev": {
1542 "phpstan/phpstan": "^0.12",
1543 "squizlabs/php_codesniffer": "^3.2",
1544 "thecodingmachine/phpstan-strict-rules": "^0.12"
1545 },
1546 "time": "2020-10-28T17:51:34+00:00",
1547 "type": "library",
1548 "extra": {
1549 "branch-alias": {
1550 "dev-master": "0.1-dev"
1551 }
1552 },
1553 "installation-source": "dist",
1554 "autoload": {
1555 "files": [
1556 "deprecated/apc.php",
1557 "deprecated/libevent.php",
1558 "deprecated/mssql.php",
1559 "deprecated/stats.php",
1560 "lib/special_cases.php",
1561 "generated/apache.php",
1562 "generated/apcu.php",
1563 "generated/array.php",
1564 "generated/bzip2.php",
1565 "generated/calendar.php",
1566 "generated/classobj.php",
1567 "generated/com.php",
1568 "generated/cubrid.php",
1569 "generated/curl.php",
1570 "generated/datetime.php",
1571 "generated/dir.php",
1572 "generated/eio.php",
1573 "generated/errorfunc.php",
1574 "generated/exec.php",
1575 "generated/fileinfo.php",
1576 "generated/filesystem.php",
1577 "generated/filter.php",
1578 "generated/fpm.php",
1579 "generated/ftp.php",
1580 "generated/funchand.php",
1581 "generated/gmp.php",
1582 "generated/gnupg.php",
1583 "generated/hash.php",
1584 "generated/ibase.php",
1585 "generated/ibmDb2.php",
1586 "generated/iconv.php",
1587 "generated/image.php",
1588 "generated/imap.php",
1589 "generated/info.php",
1590 "generated/ingres-ii.php",
1591 "generated/inotify.php",
1592 "generated/json.php",
1593 "generated/ldap.php",
1594 "generated/libxml.php",
1595 "generated/lzf.php",
1596 "generated/mailparse.php",
1597 "generated/mbstring.php",
1598 "generated/misc.php",
1599 "generated/msql.php",
1600 "generated/mysql.php",
1601 "generated/mysqli.php",
1602 "generated/mysqlndMs.php",
1603 "generated/mysqlndQc.php",
1604 "generated/network.php",
1605 "generated/oci8.php",
1606 "generated/opcache.php",
1607 "generated/openssl.php",
1608 "generated/outcontrol.php",
1609 "generated/password.php",
1610 "generated/pcntl.php",
1611 "generated/pcre.php",
1612 "generated/pdf.php",
1613 "generated/pgsql.php",
1614 "generated/posix.php",
1615 "generated/ps.php",
1616 "generated/pspell.php",
1617 "generated/readline.php",
1618 "generated/rpminfo.php",
1619 "generated/rrd.php",
1620 "generated/sem.php",
1621 "generated/session.php",
1622 "generated/shmop.php",
1623 "generated/simplexml.php",
1624 "generated/sockets.php",
1625 "generated/sodium.php",
1626 "generated/solr.php",
1627 "generated/spl.php",
1628 "generated/sqlsrv.php",
1629 "generated/ssdeep.php",
1630 "generated/ssh2.php",
1631 "generated/stream.php",
1632 "generated/strings.php",
1633 "generated/swoole.php",
1634 "generated/uodbc.php",
1635 "generated/uopz.php",
1636 "generated/url.php",
1637 "generated/var.php",
1638 "generated/xdiff.php",
1639 "generated/xml.php",
1640 "generated/xmlrpc.php",
1641 "generated/yaml.php",
1642 "generated/yaz.php",
1643 "generated/zip.php",
1644 "generated/zlib.php"
1645 ],
1646 "psr-4": {
1647 "Safe\\": [
1648 "lib/",
1649 "deprecated/",
1650 "generated/"
1651 ]
1652 }
1653 },
1654 "notification-url": "https://packagist.org/downloads/",
1655 "license": [
1656 "MIT"
1657 ],
1658 "description": "PHP core functions that throw exceptions instead of returning FALSE on error",
1659 "support": {
1660 "issues": "https://github.com/thecodingmachine/safe/issues",
1661 "source": "https://github.com/thecodingmachine/safe/tree/v1.3.3"
1662 },
1663 "install-path": "../thecodingmachine/safe"
1664 },
1665 {
1666 "name": "vlucas/valitron",
1667 "version": "v1.4.11",
1668 "version_normalized": "1.4.11.0",
1669 "source": {
1670 "type": "git",
1671 "url": "https://github.com/vlucas/valitron.git",
1672 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f"
1673 },
1674 "dist": {
1675 "type": "zip",
1676 "url": "https://api.github.com/repos/vlucas/valitron/zipball/fadce39f5f235755bb9794b2573af2d5bfcba85f",
1677 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f",
1678 "shasum": ""
1679 },
1680 "require": {
1681 "php": ">=5.3.2"
1682 },
1683 "require-dev": {
1684 "phpunit/phpunit": ">=4.8.35"
1685 },
1686 "suggest": {
1687 "ext-mbstring": "It can support the multiple bytes string length."
1688 },
1689 "time": "2022-10-14T11:54:24+00:00",
1690 "type": "library",
1691 "installation-source": "dist",
1692 "autoload": {
1693 "psr-4": {
1694 "Valitron\\": "src/Valitron"
1695 }
1696 },
1697 "notification-url": "https://packagist.org/downloads/",
1698 "license": [
1699 "BSD-3-Clause"
1700 ],
1701 "authors": [
1702 {
1703 "name": "Vance Lucas",
1704 "email": "[email protected]",
1705 "homepage": "https://www.vancelucas.com"
1706 }
1707 ],
1708 "description": "Simple, elegant, stand-alone validation library with NO dependencies",
1709 "homepage": "https://github.com/vlucas/valitron",
1710 "keywords": [
1711 "valid",
1712 "validation",
1713 "validator"
1714 ],
1715 "support": {
1716 "issues": "https://github.com/vlucas/valitron/issues",
1717 "source": "https://github.com/vlucas/valitron/tree/v1.4.11"
1718 },
1719 "funding": [
1720 {
1721 "url": "https://tidelift.com/funding/github/packagist/vlucas/valitron",
1722 "type": "tidelift"
1723 }
1724 ],
1725 "install-path": "../vlucas/valitron"
1726 },
1727 {
1728 "name": "web-auth/cose-lib",
1729 "version": "v3.3.12",
1730 "version_normalized": "3.3.12.0",
1731 "source": {
1732 "type": "git",
1733 "url": "https://github.com/web-auth/cose-lib.git",
1734 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb"
1735 },
1736 "dist": {
1737 "type": "zip",
1738 "url": "https://api.github.com/repos/web-auth/cose-lib/zipball/efa6ec2ba4e840bc1316a493973c9916028afeeb",
1739 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb",
1740 "shasum": ""
1741 },
1742 "require": {
1743 "beberlei/assert": "^3.2",
1744 "ext-json": "*",
1745 "ext-mbstring": "*",
1746 "ext-openssl": "*",
1747 "fgrosse/phpasn1": "^2.1",
1748 "php": ">=7.2"
1749 },
1750 "time": "2021-12-04T12:13:35+00:00",
1751 "type": "library",
1752 "installation-source": "dist",
1753 "autoload": {
1754 "psr-4": {
1755 "Cose\\": "src/"
1756 }
1757 },
1758 "notification-url": "https://packagist.org/downloads/",
1759 "license": [
1760 "MIT"
1761 ],
1762 "authors": [
1763 {
1764 "name": "Florent Morselli",
1765 "homepage": "https://github.com/Spomky"
1766 },
1767 {
1768 "name": "All contributors",
1769 "homepage": "https://github.com/web-auth/cose/contributors"
1770 }
1771 ],
1772 "description": "CBOR Object Signing and Encryption (COSE) For PHP",
1773 "homepage": "https://github.com/web-auth",
1774 "keywords": [
1775 "COSE",
1776 "RFC8152"
1777 ],
1778 "support": {
1779 "source": "https://github.com/web-auth/cose-lib/tree/v3.3.12"
1780 },
1781 "funding": [
1782 {
1783 "url": "https://github.com/Spomky",
1784 "type": "github"
1785 },
1786 {
1787 "url": "https://www.patreon.com/FlorentMorselli",
1788 "type": "patreon"
1789 }
1790 ],
1791 "install-path": "../web-auth/cose-lib"
1792 },
1793 {
1794 "name": "web-auth/metadata-service",
1795 "version": "v3.3.12",
1796 "version_normalized": "3.3.12.0",
1797 "source": {
1798 "type": "git",
1799 "url": "https://github.com/web-auth/webauthn-metadata-service.git",
1800 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246"
1801 },
1802 "dist": {
1803 "type": "zip",
1804 "url": "https://api.github.com/repos/web-auth/webauthn-metadata-service/zipball/ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1805 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1806 "shasum": ""
1807 },
1808 "require": {
1809 "beberlei/assert": "^3.2",
1810 "ext-json": "*",
1811 "league/uri": "^6.0",
1812 "php": ">=7.2",
1813 "psr/http-client": "^1.0",
1814 "psr/http-factory": "^1.0",
1815 "psr/log": "^1.1"
1816 },
1817 "suggest": {
1818 "web-token/jwt-key-mgmt": "Mandatory for fetching Metadata Statement from distant sources",
1819 "web-token/jwt-signature-algorithm-ecdsa": "Mandatory for fetching Metadata Statement from distant sources"
1820 },
1821 "time": "2021-11-21T11:14:31+00:00",
1822 "type": "library",
1823 "installation-source": "dist",
1824 "autoload": {
1825 "psr-4": {
1826 "Webauthn\\MetadataService\\": "src/"
1827 }
1828 },
1829 "notification-url": "https://packagist.org/downloads/",
1830 "license": [
1831 "MIT"
1832 ],
1833 "authors": [
1834 {
1835 "name": "Florent Morselli",
1836 "homepage": "https://github.com/Spomky"
1837 },
1838 {
1839 "name": "All contributors",
1840 "homepage": "https://github.com/web-auth/metadata-service/contributors"
1841 }
1842 ],
1843 "description": "Metadata Service for FIDO2/Webauthn",
1844 "homepage": "https://github.com/web-auth",
1845 "keywords": [
1846 "FIDO2",
1847 "fido",
1848 "webauthn"
1849 ],
1850 "support": {
1851 "source": "https://github.com/web-auth/webauthn-metadata-service/tree/v3.3.12"
1852 },
1853 "funding": [
1854 {
1855 "url": "https://github.com/Spomky",
1856 "type": "github"
1857 },
1858 {
1859 "url": "https://www.patreon.com/FlorentMorselli",
1860 "type": "patreon"
1861 }
1862 ],
1863 "abandoned": "web-auth/webauthn-lib",
1864 "install-path": "../web-auth/metadata-service"
1865 },
1866 {
1867 "name": "web-auth/webauthn-lib",
1868 "version": "v3.3.12",
1869 "version_normalized": "3.3.12.0",
1870 "source": {
1871 "type": "git",
1872 "url": "https://github.com/web-auth/webauthn-lib.git",
1873 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33"
1874 },
1875 "dist": {
1876 "type": "zip",
1877 "url": "https://api.github.com/repos/web-auth/webauthn-lib/zipball/5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
1878 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
1879 "shasum": ""
1880 },
1881 "require": {
1882 "beberlei/assert": "^3.2",
1883 "ext-json": "*",
1884 "ext-mbstring": "*",
1885 "ext-openssl": "*",
1886 "fgrosse/phpasn1": "^2.1",
1887 "php": ">=7.2",
1888 "psr/http-client": "^1.0",
1889 "psr/http-factory": "^1.0",
1890 "psr/http-message": "^1.0",
1891 "psr/log": "^1.1",
1892 "ramsey/uuid": "^3.8|^4.0",
1893 "spomky-labs/base64url": "^2.0",
1894 "spomky-labs/cbor-php": "^1.0|^2.0",
1895 "symfony/process": "^3.0|^4.0|^5.0",
1896 "thecodingmachine/safe": "^1.1",
1897 "web-auth/cose-lib": "self.version",
1898 "web-auth/metadata-service": "self.version"
1899 },
1900 "suggest": {
1901 "psr/log-implementation": "Recommended to receive logs from the library",
1902 "web-token/jwt-key-mgmt": "Mandatory for the AndroidSafetyNet Attestation Statement support",
1903 "web-token/jwt-signature-algorithm-ecdsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
1904 "web-token/jwt-signature-algorithm-eddsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
1905 "web-token/jwt-signature-algorithm-rsa": "Mandatory for the AndroidSafetyNet Attestation Statement support"
1906 },
1907 "time": "2022-02-18T07:13:44+00:00",
1908 "type": "library",
1909 "installation-source": "dist",
1910 "autoload": {
1911 "psr-4": {
1912 "Webauthn\\": "src/"
1913 }
1914 },
1915 "notification-url": "https://packagist.org/downloads/",
1916 "license": [
1917 "MIT"
1918 ],
1919 "authors": [
1920 {
1921 "name": "Florent Morselli",
1922 "homepage": "https://github.com/Spomky"
1923 },
1924 {
1925 "name": "All contributors",
1926 "homepage": "https://github.com/web-auth/webauthn-library/contributors"
1927 }
1928 ],
1929 "description": "FIDO2/Webauthn Support For PHP",
1930 "homepage": "https://github.com/web-auth",
1931 "keywords": [
1932 "FIDO2",
1933 "fido",
1934 "webauthn"
1935 ],
1936 "support": {
1937 "source": "https://github.com/web-auth/webauthn-lib/tree/v3.3.12"
1938 },
1939 "funding": [
1940 {
1941 "url": "https://github.com/Spomky",
1942 "type": "github"
1943 },
1944 {
1945 "url": "https://www.patreon.com/FlorentMorselli",
1946 "type": "patreon"
1947 }
1948 ],
1949 "install-path": "../web-auth/webauthn-lib"
1950 },
1951 {
1952 "name": "web-token/jwt-core",
1953 "version": "v2.2.11",
1954 "version_normalized": "2.2.11.0",
1955 "source": {
1956 "type": "git",
1957 "url": "https://github.com/web-token/jwt-core.git",
1958 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678"
1959 },
1960 "dist": {
1961 "type": "zip",
1962 "url": "https://api.github.com/repos/web-token/jwt-core/zipball/53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
1963 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
1964 "shasum": ""
1965 },
1966 "require": {
1967 "brick/math": "^0.8.17|^0.9",
1968 "ext-json": "*",
1969 "ext-mbstring": "*",
1970 "fgrosse/phpasn1": "^2.0",
1971 "php": ">=7.2",
1972 "spomky-labs/base64url": "^1.0|^2.0"
1973 },
1974 "conflict": {
1975 "spomky-labs/jose": "*"
1976 },
1977 "time": "2021-03-17T14:55:52+00:00",
1978 "type": "library",
1979 "installation-source": "dist",
1980 "autoload": {
1981 "psr-4": {
1982 "Jose\\Component\\Core\\": ""
1983 }
1984 },
1985 "notification-url": "https://packagist.org/downloads/",
1986 "license": [
1987 "MIT"
1988 ],
1989 "authors": [
1990 {
1991 "name": "Florent Morselli",
1992 "homepage": "https://github.com/Spomky"
1993 },
1994 {
1995 "name": "All contributors",
1996 "homepage": "https://github.com/web-token/jwt-framework/contributors"
1997 }
1998 ],
1999 "description": "Core component of the JWT Framework.",
2000 "homepage": "https://github.com/web-token",
2001 "keywords": [
2002 "JOSE",
2003 "JWE",
2004 "JWK",
2005 "JWKSet",
2006 "JWS",
2007 "Jot",
2008 "RFC7515",
2009 "RFC7516",
2010 "RFC7517",
2011 "RFC7518",
2012 "RFC7519",
2013 "RFC7520",
2014 "bundle",
2015 "jwa",
2016 "jwt",
2017 "symfony"
2018 ],
2019 "support": {
2020 "source": "https://github.com/web-token/jwt-core/tree/v2.2.11"
2021 },
2022 "funding": [
2023 {
2024 "url": "https://www.patreon.com/FlorentMorselli",
2025 "type": "patreon"
2026 }
2027 ],
2028 "abandoned": "web-token/jwt-library",
2029 "install-path": "../web-token/jwt-core"
2030 },
2031 {
2032 "name": "web-token/jwt-key-mgmt",
2033 "version": "v2.2.11",
2034 "version_normalized": "2.2.11.0",
2035 "source": {
2036 "type": "git",
2037 "url": "https://github.com/web-token/jwt-key-mgmt.git",
2038 "reference": "0b116379515700d237b4e5de86879078ccb09d8a"
2039 },
2040 "dist": {
2041 "type": "zip",
2042 "url": "https://api.github.com/repos/web-token/jwt-key-mgmt/zipball/0b116379515700d237b4e5de86879078ccb09d8a",
2043 "reference": "0b116379515700d237b4e5de86879078ccb09d8a",
2044 "shasum": ""
2045 },
2046 "require": {
2047 "ext-openssl": "*",
2048 "psr/http-client": "^1.0",
2049 "psr/http-factory": "^1.0",
2050 "web-token/jwt-core": "^2.0"
2051 },
2052 "suggest": {
2053 "ext-sodium": "Sodium is required for OKP key creation, EdDSA signature algorithm and ECDH-ES key encryption with OKP keys",
2054 "php-http/httplug": "To enable JKU/X5U support.",
2055 "php-http/message-factory": "To enable JKU/X5U support.",
2056 "web-token/jwt-util-ecc": "To use EC key analyzers."
2057 },
2058 "time": "2021-03-17T14:55:52+00:00",
2059 "type": "library",
2060 "installation-source": "dist",
2061 "autoload": {
2062 "psr-4": {
2063 "Jose\\Component\\KeyManagement\\": ""
2064 }
2065 },
2066 "notification-url": "https://packagist.org/downloads/",
2067 "license": [
2068 "MIT"
2069 ],
2070 "authors": [
2071 {
2072 "name": "Florent Morselli",
2073 "homepage": "https://github.com/Spomky"
2074 },
2075 {
2076 "name": "All contributors",
2077 "homepage": "https://github.com/web-token/jwt-key-mgmt/contributors"
2078 }
2079 ],
2080 "description": "Key Management component of the JWT Framework.",
2081 "homepage": "https://github.com/web-token",
2082 "keywords": [
2083 "JOSE",
2084 "JWE",
2085 "JWK",
2086 "JWKSet",
2087 "JWS",
2088 "Jot",
2089 "RFC7515",
2090 "RFC7516",
2091 "RFC7517",
2092 "RFC7518",
2093 "RFC7519",
2094 "RFC7520",
2095 "bundle",
2096 "jwa",
2097 "jwt",
2098 "symfony"
2099 ],
2100 "support": {
2101 "source": "https://github.com/web-token/jwt-key-mgmt/tree/v2.2.11"
2102 },
2103 "funding": [
2104 {
2105 "url": "https://www.patreon.com/FlorentMorselli",
2106 "type": "patreon"
2107 }
2108 ],
2109 "abandoned": "web-token/jwt-library",
2110 "install-path": "../web-token/jwt-key-mgmt"
2111 },
2112 {
2113 "name": "web-token/jwt-signature",
2114 "version": "v2.2.11",
2115 "version_normalized": "2.2.11.0",
2116 "source": {
2117 "type": "git",
2118 "url": "https://github.com/web-token/jwt-signature.git",
2119 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103"
2120 },
2121 "dist": {
2122 "type": "zip",
2123 "url": "https://api.github.com/repos/web-token/jwt-signature/zipball/015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2124 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2125 "shasum": ""
2126 },
2127 "require": {
2128 "web-token/jwt-core": "^2.1"
2129 },
2130 "suggest": {
2131 "web-token/jwt-signature-algorithm-ecdsa": "ECDSA Based Signature Algorithms",
2132 "web-token/jwt-signature-algorithm-eddsa": "EdDSA Based Signature Algorithms",
2133 "web-token/jwt-signature-algorithm-experimental": "Experimental Signature Algorithms",
2134 "web-token/jwt-signature-algorithm-hmac": "HMAC Based Signature Algorithms",
2135 "web-token/jwt-signature-algorithm-none": "None Signature Algorithm",
2136 "web-token/jwt-signature-algorithm-rsa": "RSA Based Signature Algorithms"
2137 },
2138 "time": "2021-03-01T19:55:28+00:00",
2139 "type": "library",
2140 "installation-source": "dist",
2141 "autoload": {
2142 "psr-4": {
2143 "Jose\\Component\\Signature\\": ""
2144 }
2145 },
2146 "notification-url": "https://packagist.org/downloads/",
2147 "license": [
2148 "MIT"
2149 ],
2150 "authors": [
2151 {
2152 "name": "Florent Morselli",
2153 "homepage": "https://github.com/Spomky"
2154 },
2155 {
2156 "name": "All contributors",
2157 "homepage": "https://github.com/web-token/jwt-signature/contributors"
2158 }
2159 ],
2160 "description": "Signature component of the JWT Framework.",
2161 "homepage": "https://github.com/web-token",
2162 "keywords": [
2163 "JOSE",
2164 "JWE",
2165 "JWK",
2166 "JWKSet",
2167 "JWS",
2168 "Jot",
2169 "RFC7515",
2170 "RFC7516",
2171 "RFC7517",
2172 "RFC7518",
2173 "RFC7519",
2174 "RFC7520",
2175 "bundle",
2176 "jwa",
2177 "jwt",
2178 "symfony"
2179 ],
2180 "support": {
2181 "source": "https://github.com/web-token/jwt-signature/tree/v2.2.11"
2182 },
2183 "funding": [
2184 {
2185 "url": "https://www.patreon.com/FlorentMorselli",
2186 "type": "patreon"
2187 }
2188 ],
2189 "abandoned": "web-token/jwt-library",
2190 "install-path": "../web-token/jwt-signature"
2191 },
2192 {
2193 "name": "web-token/jwt-signature-algorithm-ecdsa",
2194 "version": "v2.2.11",
2195 "version_normalized": "2.2.11.0",
2196 "source": {
2197 "type": "git",
2198 "url": "https://github.com/web-token/jwt-signature-algorithm-ecdsa.git",
2199 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591"
2200 },
2201 "dist": {
2202 "type": "zip",
2203 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-ecdsa/zipball/44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2204 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2205 "shasum": ""
2206 },
2207 "require": {
2208 "ext-openssl": "*",
2209 "web-token/jwt-signature": "^2.0"
2210 },
2211 "time": "2021-01-21T19:18:03+00:00",
2212 "type": "library",
2213 "installation-source": "dist",
2214 "autoload": {
2215 "psr-4": {
2216 "Jose\\Component\\Signature\\Algorithm\\": ""
2217 }
2218 },
2219 "notification-url": "https://packagist.org/downloads/",
2220 "license": [
2221 "MIT"
2222 ],
2223 "authors": [
2224 {
2225 "name": "Florent Morselli",
2226 "homepage": "https://github.com/Spomky"
2227 },
2228 {
2229 "name": "All contributors",
2230 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2231 }
2232 ],
2233 "description": "ECDSA Based Signature Algorithms the JWT Framework.",
2234 "homepage": "https://github.com/web-token",
2235 "keywords": [
2236 "JOSE",
2237 "JWE",
2238 "JWK",
2239 "JWKSet",
2240 "JWS",
2241 "Jot",
2242 "RFC7515",
2243 "RFC7516",
2244 "RFC7517",
2245 "RFC7518",
2246 "RFC7519",
2247 "RFC7520",
2248 "bundle",
2249 "jwa",
2250 "jwt",
2251 "symfony"
2252 ],
2253 "support": {
2254 "source": "https://github.com/web-token/jwt-signature-algorithm-ecdsa/tree/v2.2.11"
2255 },
2256 "funding": [
2257 {
2258 "url": "https://www.patreon.com/FlorentMorselli",
2259 "type": "patreon"
2260 }
2261 ],
2262 "abandoned": "web-token/jwt-library",
2263 "install-path": "../web-token/jwt-signature-algorithm-ecdsa"
2264 },
2265 {
2266 "name": "web-token/jwt-signature-algorithm-eddsa",
2267 "version": "v2.2.11",
2268 "version_normalized": "2.2.11.0",
2269 "source": {
2270 "type": "git",
2271 "url": "https://github.com/web-token/jwt-signature-algorithm-eddsa.git",
2272 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6"
2273 },
2274 "dist": {
2275 "type": "zip",
2276 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-eddsa/zipball/b805ecca593c56e60e0463bd2cacc9b1341910f6",
2277 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6",
2278 "shasum": ""
2279 },
2280 "require": {
2281 "ext-sodium": "*",
2282 "web-token/jwt-signature": "^2.1"
2283 },
2284 "time": "2021-01-21T19:18:03+00:00",
2285 "type": "library",
2286 "installation-source": "dist",
2287 "autoload": {
2288 "psr-4": {
2289 "Jose\\Component\\Signature\\Algorithm\\": ""
2290 }
2291 },
2292 "notification-url": "https://packagist.org/downloads/",
2293 "license": [
2294 "MIT"
2295 ],
2296 "authors": [
2297 {
2298 "name": "Florent Morselli",
2299 "homepage": "https://github.com/Spomky"
2300 },
2301 {
2302 "name": "All contributors",
2303 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2304 }
2305 ],
2306 "description": "EdDSA Signature Algorithm the JWT Framework.",
2307 "homepage": "https://github.com/web-token",
2308 "keywords": [
2309 "JOSE",
2310 "JWE",
2311 "JWK",
2312 "JWKSet",
2313 "JWS",
2314 "Jot",
2315 "RFC7515",
2316 "RFC7516",
2317 "RFC7517",
2318 "RFC7518",
2319 "RFC7519",
2320 "RFC7520",
2321 "bundle",
2322 "jwa",
2323 "jwt",
2324 "symfony"
2325 ],
2326 "support": {
2327 "source": "https://github.com/web-token/jwt-signature-algorithm-eddsa/tree/v2.2.11"
2328 },
2329 "funding": [
2330 {
2331 "url": "https://www.patreon.com/FlorentMorselli",
2332 "type": "patreon"
2333 }
2334 ],
2335 "abandoned": "web-token/jwt-library",
2336 "install-path": "../web-token/jwt-signature-algorithm-eddsa"
2337 },
2338 {
2339 "name": "web-token/jwt-signature-algorithm-rsa",
2340 "version": "v2.2.11",
2341 "version_normalized": "2.2.11.0",
2342 "source": {
2343 "type": "git",
2344 "url": "https://github.com/web-token/jwt-signature-algorithm-rsa.git",
2345 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0"
2346 },
2347 "dist": {
2348 "type": "zip",
2349 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-rsa/zipball/513ad90eb5ef1886ff176727a769bda4618141b0",
2350 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0",
2351 "shasum": ""
2352 },
2353 "require": {
2354 "brick/math": "^0.8.17|^0.9",
2355 "ext-openssl": "*",
2356 "web-token/jwt-signature": "^2.1"
2357 },
2358 "suggest": {
2359 "ext-bcmath": "GMP or BCMath is highly recommended to improve the library performance",
2360 "ext-gmp": "GMP or BCMath is highly recommended to improve the library performance"
2361 },
2362 "time": "2021-01-21T19:18:03+00:00",
2363 "type": "library",
2364 "installation-source": "dist",
2365 "autoload": {
2366 "psr-4": {
2367 "Jose\\Component\\Signature\\Algorithm\\": ""
2368 }
2369 },
2370 "notification-url": "https://packagist.org/downloads/",
2371 "license": [
2372 "MIT"
2373 ],
2374 "authors": [
2375 {
2376 "name": "Florent Morselli",
2377 "homepage": "https://github.com/Spomky"
2378 },
2379 {
2380 "name": "All contributors",
2381 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2382 }
2383 ],
2384 "description": "RSA Based Signature Algorithms the JWT Framework.",
2385 "homepage": "https://github.com/web-token",
2386 "keywords": [
2387 "JOSE",
2388 "JWE",
2389 "JWK",
2390 "JWKSet",
2391 "JWS",
2392 "Jot",
2393 "RFC7515",
2394 "RFC7516",
2395 "RFC7517",
2396 "RFC7518",
2397 "RFC7519",
2398 "RFC7520",
2399 "bundle",
2400 "jwa",
2401 "jwt",
2402 "symfony"
2403 ],
2404 "support": {
2405 "source": "https://github.com/web-token/jwt-signature-algorithm-rsa/tree/v2.2.11"
2406 },
2407 "funding": [
2408 {
2409 "url": "https://www.patreon.com/FlorentMorselli",
2410 "type": "patreon"
2411 }
2412 ],
2413 "abandoned": "web-token/jwt-library",
2414 "install-path": "../web-token/jwt-signature-algorithm-rsa"
2415 },
2416 {
2417 "name": "woocommerce/action-scheduler",
2418 "version": "3.9.2",
2419 "version_normalized": "3.9.2.0",
2420 "source": {
2421 "type": "git",
2422 "url": "https://github.com/woocommerce/action-scheduler.git",
2423 "reference": "efbb7953f72a433086335b249292f280dd43ddfe"
2424 },
2425 "dist": {
2426 "type": "zip",
2427 "url": "https://api.github.com/repos/woocommerce/action-scheduler/zipball/efbb7953f72a433086335b249292f280dd43ddfe",
2428 "reference": "efbb7953f72a433086335b249292f280dd43ddfe",
2429 "shasum": ""
2430 },
2431 "require": {
2432 "php": ">=7.1"
2433 },
2434 "require-dev": {
2435 "phpunit/phpunit": "^7.5",
2436 "woocommerce/woocommerce-sniffs": "0.1.0",
2437 "wp-cli/wp-cli": "~2.5.0",
2438 "yoast/phpunit-polyfills": "^2.0"
2439 },
2440 "time": "2025-02-03T09:09:30+00:00",
2441 "type": "wordpress-plugin",
2442 "extra": {
2443 "scripts-description": {
2444 "test": "Run unit tests",
2445 "phpcs": "Analyze code against the WordPress coding standards with PHP_CodeSniffer",
2446 "phpcbf": "Fix coding standards warnings/errors automatically with PHP Code Beautifier"
2447 }
2448 },
2449 "installation-source": "dist",
2450 "notification-url": "https://packagist.org/downloads/",
2451 "license": [
2452 "GPL-3.0-or-later"
2453 ],
2454 "description": "Action Scheduler for WordPress and WooCommerce",
2455 "homepage": "https://actionscheduler.org/",
2456 "support": {
2457 "issues": "https://github.com/woocommerce/action-scheduler/issues",
2458 "source": "https://github.com/woocommerce/action-scheduler/tree/3.9.2"
2459 },
2460 "install-path": "../woocommerce/action-scheduler"
2461 }
2462 ],
2463 "dev": false,
2464 "dev-package-names": []
2465 }
2466