PluginProbe
Defender Security – Malware Scanner, Login Security & Firewall / 5.8.0
Defender Security – Malware Scanner, Login Security & Firewall v5.8.0
6.3.0 6.2.3 6.2.4 6.2.0 6.2.1 6.2.2 6.1.0 5.3.1 5.4.0 5.4.1 5.5.0 5.5.1 5.6.0 5.6.1 5.6.2 5.7.0 5.7.1 5.7.2 5.8.0 5.8.1 5.9.0 6.0.0 6.0.1 3.0.1 3.1.0 All 141 releases
defender-security / vendor / composer / installed.json

installed.json in Defender Security – Malware Scanner, Login Security & Firewall 5.8.0, at vendor/composer/installed.json

2,595 lines 94.3 KB
No matching file
Up and down to move Enter to open Esc to close
Raw Download Zip
1 {
2 "packages": [
3 {
4 "name": "altcha-org/altcha",
5 "version": "v0.1.4",
6 "version_normalized": "0.1.4.0",
7 "source": {
8 "type": "git",
9 "url": "https://github.com/altcha-org/altcha-lib-php.git",
10 "reference": "0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6"
11 },
12 "dist": {
13 "type": "zip",
14 "url": "https://api.github.com/repos/altcha-org/altcha-lib-php/zipball/0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6",
15 "reference": "0371b6bd6ac1e7e4b78e47a884e5fa3d062720e6",
16 "shasum": ""
17 },
18 "require": {
19 "php": ">=7.4"
20 },
21 "require-dev": {
22 "phpunit/phpunit": "^11.5"
23 },
24 "time": "2025-02-28T05:17:34+00:00",
25 "type": "library",
26 "installation-source": "dist",
27 "autoload": {
28 "psr-4": {
29 "AltchaOrg\\Altcha\\": "src/"
30 }
31 },
32 "notification-url": "https://packagist.org/downloads/",
33 "license": [
34 "MIT"
35 ],
36 "authors": [
37 {
38 "name": "Daniel Regeci",
39 "email": "[email protected]"
40 }
41 ],
42 "support": {
43 "issues": "https://github.com/altcha-org/altcha-lib-php/issues",
44 "source": "https://github.com/altcha-org/altcha-lib-php/tree/v0.1.4"
45 },
46 "install-path": "../altcha-org/altcha"
47 },
48 {
49 "name": "beberlei/assert",
50 "version": "v3.3.3",
51 "version_normalized": "3.3.3.0",
52 "source": {
53 "type": "git",
54 "url": "https://github.com/beberlei/assert.git",
55 "reference": "b5fd8eacd8915a1b627b8bfc027803f1939734dd"
56 },
57 "dist": {
58 "type": "zip",
59 "url": "https://api.github.com/repos/beberlei/assert/zipball/b5fd8eacd8915a1b627b8bfc027803f1939734dd",
60 "reference": "b5fd8eacd8915a1b627b8bfc027803f1939734dd",
61 "shasum": ""
62 },
63 "require": {
64 "ext-ctype": "*",
65 "ext-json": "*",
66 "ext-mbstring": "*",
67 "ext-simplexml": "*",
68 "php": "^7.1 || ^8.0"
69 },
70 "require-dev": {
71 "friendsofphp/php-cs-fixer": "*",
72 "phpstan/phpstan": "*",
73 "phpunit/phpunit": ">=6.0.0",
74 "yoast/phpunit-polyfills": "^0.1.0"
75 },
76 "suggest": {
77 "ext-intl": "Needed to allow Assertion::count(), Assertion::isCountable(), Assertion::minCount(), and Assertion::maxCount() to operate on ResourceBundles"
78 },
79 "time": "2024-07-15T13:18:35+00:00",
80 "type": "library",
81 "installation-source": "dist",
82 "autoload": {
83 "files": [
84 "lib/Assert/functions.php"
85 ],
86 "psr-4": {
87 "Assert\\": "lib/Assert"
88 }
89 },
90 "notification-url": "https://packagist.org/downloads/",
91 "license": [
92 "BSD-2-Clause"
93 ],
94 "authors": [
95 {
96 "name": "Benjamin Eberlei",
97 "email": "[email protected]",
98 "role": "Lead Developer"
99 },
100 {
101 "name": "Richard Quadling",
102 "email": "[email protected]",
103 "role": "Collaborator"
104 }
105 ],
106 "description": "Thin assertion library for input validation in business models.",
107 "keywords": [
108 "assert",
109 "assertion",
110 "validation"
111 ],
112 "support": {
113 "issues": "https://github.com/beberlei/assert/issues",
114 "source": "https://github.com/beberlei/assert/tree/v3.3.3"
115 },
116 "install-path": "../beberlei/assert"
117 },
118 {
119 "name": "brick/math",
120 "version": "0.9.3",
121 "version_normalized": "0.9.3.0",
122 "source": {
123 "type": "git",
124 "url": "https://github.com/brick/math.git",
125 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae"
126 },
127 "dist": {
128 "type": "zip",
129 "url": "https://api.github.com/repos/brick/math/zipball/ca57d18f028f84f777b2168cd1911b0dee2343ae",
130 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae",
131 "shasum": ""
132 },
133 "require": {
134 "ext-json": "*",
135 "php": "^7.1 || ^8.0"
136 },
137 "require-dev": {
138 "php-coveralls/php-coveralls": "^2.2",
139 "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
140 "vimeo/psalm": "4.9.2"
141 },
142 "time": "2021-08-15T20:50:18+00:00",
143 "type": "library",
144 "installation-source": "dist",
145 "autoload": {
146 "psr-4": {
147 "Brick\\Math\\": "src/"
148 }
149 },
150 "notification-url": "https://packagist.org/downloads/",
151 "license": [
152 "MIT"
153 ],
154 "description": "Arbitrary-precision arithmetic library",
155 "keywords": [
156 "Arbitrary-precision",
157 "BigInteger",
158 "BigRational",
159 "arithmetic",
160 "bigdecimal",
161 "bignum",
162 "brick",
163 "math"
164 ],
165 "support": {
166 "issues": "https://github.com/brick/math/issues",
167 "source": "https://github.com/brick/math/tree/0.9.3"
168 },
169 "funding": [
170 {
171 "url": "https://github.com/BenMorel",
172 "type": "github"
173 },
174 {
175 "url": "https://tidelift.com/funding/github/packagist/brick/math",
176 "type": "tidelift"
177 }
178 ],
179 "install-path": "../brick/math"
180 },
181 {
182 "name": "cweagans/composer-configurable-plugin",
183 "version": "2.0.0",
184 "version_normalized": "2.0.0.0",
185 "source": {
186 "type": "git",
187 "url": "https://github.com/cweagans/composer-configurable-plugin.git",
188 "reference": "15433906511a108a1806710e988629fd24b89974"
189 },
190 "dist": {
191 "type": "zip",
192 "url": "https://api.github.com/repos/cweagans/composer-configurable-plugin/zipball/15433906511a108a1806710e988629fd24b89974",
193 "reference": "15433906511a108a1806710e988629fd24b89974",
194 "shasum": ""
195 },
196 "require": {
197 "php": ">=8.0.0"
198 },
199 "require-dev": {
200 "codeception/codeception": "~4.0",
201 "codeception/module-asserts": "^2.0",
202 "composer/composer": "~2.0",
203 "php-coveralls/php-coveralls": "~2.0",
204 "php-parallel-lint/php-parallel-lint": "^1.0.0",
205 "phpro/grumphp": "^1.8.0",
206 "sebastian/phpcpd": "^6.0",
207 "squizlabs/php_codesniffer": "^3.0"
208 },
209 "time": "2023-02-12T04:58:58+00:00",
210 "type": "library",
211 "installation-source": "dist",
212 "autoload": {
213 "psr-4": {
214 "cweagans\\Composer\\": "src"
215 }
216 },
217 "notification-url": "https://packagist.org/downloads/",
218 "license": [
219 "BSD-3-Clause"
220 ],
221 "authors": [
222 {
223 "name": "Cameron Eagans",
224 "email": "[email protected]"
225 }
226 ],
227 "description": "Provides a lightweight configuration system for Composer plugins.",
228 "support": {
229 "issues": "https://github.com/cweagans/composer-configurable-plugin/issues",
230 "source": "https://github.com/cweagans/composer-configurable-plugin/tree/2.0.0"
231 },
232 "funding": [
233 {
234 "url": "https://github.com/cweagans",
235 "type": "github"
236 }
237 ],
238 "install-path": "../cweagans/composer-configurable-plugin"
239 },
240 {
241 "name": "cweagans/composer-patches",
242 "version": "2.0.0",
243 "version_normalized": "2.0.0.0",
244 "source": {
245 "type": "git",
246 "url": "https://github.com/cweagans/composer-patches.git",
247 "reference": "bfa6018a5f864653d9ed899b902ea72f858a2cf7"
248 },
249 "dist": {
250 "type": "zip",
251 "url": "https://api.github.com/repos/cweagans/composer-patches/zipball/bfa6018a5f864653d9ed899b902ea72f858a2cf7",
252 "reference": "bfa6018a5f864653d9ed899b902ea72f858a2cf7",
253 "shasum": ""
254 },
255 "require": {
256 "composer-plugin-api": "^2.0",
257 "cweagans/composer-configurable-plugin": "^2.0",
258 "ext-json": "*",
259 "php": ">=8.0.0"
260 },
261 "require-dev": {
262 "codeception/codeception": "~4.0",
263 "codeception/module-asserts": "^2.0",
264 "codeception/module-cli": "^2.0",
265 "codeception/module-filesystem": "^2.0",
266 "composer/composer": "~2.0",
267 "php-coveralls/php-coveralls": "~2.0",
268 "php-parallel-lint/php-parallel-lint": "^1.0.0",
269 "phpro/grumphp": "^1.8.0",
270 "sebastian/phpcpd": "^6.0",
271 "squizlabs/php_codesniffer": "^4.0"
272 },
273 "time": "2025-10-30T23:44:22+00:00",
274 "type": "composer-plugin",
275 "extra": {
276 "_": "The following two lines ensure that composer-patches is loaded as early as possible.",
277 "class": "cweagans\\Composer\\Plugin\\Patches",
278 "plugin-modifies-downloads": true,
279 "plugin-modifies-install-path": true
280 },
281 "installation-source": "dist",
282 "autoload": {
283 "psr-4": {
284 "cweagans\\Composer\\": "src"
285 }
286 },
287 "notification-url": "https://packagist.org/downloads/",
288 "license": [
289 "BSD-3-Clause"
290 ],
291 "authors": [
292 {
293 "name": "Cameron Eagans",
294 "email": "[email protected]"
295 }
296 ],
297 "description": "Provides a way to patch Composer packages.",
298 "support": {
299 "issues": "https://github.com/cweagans/composer-patches/issues",
300 "source": "https://github.com/cweagans/composer-patches/tree/2.0.0"
301 },
302 "funding": [
303 {
304 "url": "https://github.com/cweagans",
305 "type": "github"
306 }
307 ],
308 "install-path": "../cweagans/composer-patches"
309 },
310 {
311 "name": "fgrosse/phpasn1",
312 "version": "v2.5.0",
313 "version_normalized": "2.5.0.0",
314 "source": {
315 "type": "git",
316 "url": "https://github.com/fgrosse/PHPASN1.git",
317 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b"
318 },
319 "dist": {
320 "type": "zip",
321 "url": "https://api.github.com/repos/fgrosse/PHPASN1/zipball/42060ed45344789fb9f21f9f1864fc47b9e3507b",
322 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b",
323 "shasum": ""
324 },
325 "require": {
326 "php": "^7.1 || ^8.0"
327 },
328 "require-dev": {
329 "php-coveralls/php-coveralls": "~2.0",
330 "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
331 },
332 "suggest": {
333 "ext-bcmath": "BCmath is the fallback extension for big integer calculations",
334 "ext-curl": "For loading OID information from the web if they have not bee defined statically",
335 "ext-gmp": "GMP is the preferred extension for big integer calculations",
336 "phpseclib/bcmath_compat": "BCmath polyfill for servers where neither GMP nor BCmath is available"
337 },
338 "time": "2022-12-19T11:08:26+00:00",
339 "type": "library",
340 "extra": {
341 "branch-alias": {
342 "dev-master": "2.0.x-dev"
343 }
344 },
345 "installation-source": "dist",
346 "autoload": {
347 "psr-4": {
348 "FG\\": "lib/"
349 }
350 },
351 "notification-url": "https://packagist.org/downloads/",
352 "license": [
353 "MIT"
354 ],
355 "authors": [
356 {
357 "name": "Friedrich Große",
358 "email": "[email protected]",
359 "homepage": "https://github.com/FGrosse",
360 "role": "Author"
361 },
362 {
363 "name": "All contributors",
364 "homepage": "https://github.com/FGrosse/PHPASN1/contributors"
365 }
366 ],
367 "description": "A PHP Framework that allows you to encode and decode arbitrary ASN.1 structures using the ITU-T X.690 Encoding Rules.",
368 "homepage": "https://github.com/FGrosse/PHPASN1",
369 "keywords": [
370 "DER",
371 "asn.1",
372 "asn1",
373 "ber",
374 "binary",
375 "decoding",
376 "encoding",
377 "x.509",
378 "x.690",
379 "x509",
380 "x690"
381 ],
382 "support": {
383 "issues": "https://github.com/fgrosse/PHPASN1/issues",
384 "source": "https://github.com/fgrosse/PHPASN1/tree/v2.5.0"
385 },
386 "abandoned": true,
387 "install-path": "../fgrosse/phpasn1"
388 },
389 {
390 "name": "gettext/gettext",
391 "version": "v5.7.3",
392 "version_normalized": "5.7.3.0",
393 "source": {
394 "type": "git",
395 "url": "https://github.com/php-gettext/Gettext.git",
396 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1"
397 },
398 "dist": {
399 "type": "zip",
400 "url": "https://api.github.com/repos/php-gettext/Gettext/zipball/95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
401 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
402 "shasum": ""
403 },
404 "require": {
405 "gettext/languages": "^2.3",
406 "php": "^7.2|^8.0"
407 },
408 "require-dev": {
409 "brick/varexporter": "^0.3.5",
410 "friendsofphp/php-cs-fixer": "^3.2",
411 "oscarotero/php-cs-fixer-config": "^2.0",
412 "phpunit/phpunit": "^8.0|^9.0",
413 "squizlabs/php_codesniffer": "^3.0"
414 },
415 "time": "2024-12-01T10:18:08+00:00",
416 "type": "library",
417 "installation-source": "dist",
418 "autoload": {
419 "psr-4": {
420 "Gettext\\": "src"
421 }
422 },
423 "notification-url": "https://packagist.org/downloads/",
424 "license": [
425 "MIT"
426 ],
427 "authors": [
428 {
429 "name": "Oscar Otero",
430 "email": "[email protected]",
431 "homepage": "http://oscarotero.com",
432 "role": "Developer"
433 }
434 ],
435 "description": "PHP gettext manager",
436 "homepage": "https://github.com/php-gettext/Gettext",
437 "keywords": [
438 "JS",
439 "gettext",
440 "i18n",
441 "mo",
442 "po",
443 "translation"
444 ],
445 "support": {
446 "email": "[email protected]",
447 "issues": "https://github.com/php-gettext/Gettext/issues",
448 "source": "https://github.com/php-gettext/Gettext/tree/v5.7.3"
449 },
450 "funding": [
451 {
452 "url": "https://paypal.me/oscarotero",
453 "type": "custom"
454 },
455 {
456 "url": "https://github.com/oscarotero",
457 "type": "github"
458 },
459 {
460 "url": "https://www.patreon.com/misteroom",
461 "type": "patreon"
462 }
463 ],
464 "install-path": "../gettext/gettext"
465 },
466 {
467 "name": "gettext/languages",
468 "version": "2.12.1",
469 "version_normalized": "2.12.1.0",
470 "source": {
471 "type": "git",
472 "url": "https://github.com/php-gettext/Languages.git",
473 "reference": "0b0b0851c55168e1dfb14305735c64019732b5f1"
474 },
475 "dist": {
476 "type": "zip",
477 "url": "https://api.github.com/repos/php-gettext/Languages/zipball/0b0b0851c55168e1dfb14305735c64019732b5f1",
478 "reference": "0b0b0851c55168e1dfb14305735c64019732b5f1",
479 "shasum": ""
480 },
481 "require": {
482 "php": ">=5.3"
483 },
484 "require-dev": {
485 "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.5 || ^8.4"
486 },
487 "time": "2025-03-19T11:14:02+00:00",
488 "bin": [
489 "bin/export-plural-rules",
490 "bin/import-cldr-data"
491 ],
492 "type": "library",
493 "installation-source": "dist",
494 "autoload": {
495 "psr-4": {
496 "Gettext\\Languages\\": "src/"
497 }
498 },
499 "notification-url": "https://packagist.org/downloads/",
500 "license": [
501 "MIT"
502 ],
503 "authors": [
504 {
505 "name": "Michele Locati",
506 "email": "[email protected]",
507 "role": "Developer"
508 }
509 ],
510 "description": "gettext languages with plural rules",
511 "homepage": "https://github.com/php-gettext/Languages",
512 "keywords": [
513 "cldr",
514 "i18n",
515 "internationalization",
516 "l10n",
517 "language",
518 "languages",
519 "localization",
520 "php",
521 "plural",
522 "plural rules",
523 "plurals",
524 "translate",
525 "translations",
526 "unicode"
527 ],
528 "support": {
529 "issues": "https://github.com/php-gettext/Languages/issues",
530 "source": "https://github.com/php-gettext/Languages/tree/2.12.1"
531 },
532 "funding": [
533 {
534 "url": "https://paypal.me/mlocati",
535 "type": "custom"
536 },
537 {
538 "url": "https://github.com/mlocati",
539 "type": "github"
540 }
541 ],
542 "install-path": "../gettext/languages"
543 },
544 {
545 "name": "league/uri",
546 "version": "6.7.2",
547 "version_normalized": "6.7.2.0",
548 "source": {
549 "type": "git",
550 "url": "https://github.com/thephpleague/uri.git",
551 "reference": "d3b50812dd51f3fbf176344cc2981db03d10fe06"
552 },
553 "dist": {
554 "type": "zip",
555 "url": "https://api.github.com/repos/thephpleague/uri/zipball/d3b50812dd51f3fbf176344cc2981db03d10fe06",
556 "reference": "d3b50812dd51f3fbf176344cc2981db03d10fe06",
557 "shasum": ""
558 },
559 "require": {
560 "ext-json": "*",
561 "league/uri-interfaces": "^2.3",
562 "php": "^7.4 || ^8.0",
563 "psr/http-message": "^1.0"
564 },
565 "conflict": {
566 "league/uri-schemes": "^1.0"
567 },
568 "require-dev": {
569 "friendsofphp/php-cs-fixer": "^v3.3.2",
570 "nyholm/psr7": "^1.5",
571 "php-http/psr7-integration-tests": "^1.1",
572 "phpstan/phpstan": "^1.2.0",
573 "phpstan/phpstan-deprecation-rules": "^1.0",
574 "phpstan/phpstan-phpunit": "^1.0.0",
575 "phpstan/phpstan-strict-rules": "^1.1.0",
576 "phpunit/phpunit": "^9.5.10",
577 "psr/http-factory": "^1.0"
578 },
579 "suggest": {
580 "ext-fileinfo": "Needed to create Data URI from a filepath",
581 "ext-intl": "Needed to improve host validation",
582 "league/uri-components": "Needed to easily manipulate URI objects",
583 "psr/http-factory": "Needed to use the URI factory"
584 },
585 "time": "2022-09-13T19:50:42+00:00",
586 "type": "library",
587 "extra": {
588 "branch-alias": {
589 "dev-master": "6.x-dev"
590 }
591 },
592 "installation-source": "dist",
593 "autoload": {
594 "psr-4": {
595 "League\\Uri\\": "src"
596 }
597 },
598 "notification-url": "https://packagist.org/downloads/",
599 "license": [
600 "MIT"
601 ],
602 "authors": [
603 {
604 "name": "Ignace Nyamagana Butera",
605 "email": "[email protected]",
606 "homepage": "https://nyamsprod.com"
607 }
608 ],
609 "description": "URI manipulation library",
610 "homepage": "https://uri.thephpleague.com",
611 "keywords": [
612 "data-uri",
613 "file-uri",
614 "ftp",
615 "hostname",
616 "http",
617 "https",
618 "middleware",
619 "parse_str",
620 "parse_url",
621 "psr-7",
622 "query-string",
623 "querystring",
624 "rfc3986",
625 "rfc3987",
626 "rfc6570",
627 "uri",
628 "uri-template",
629 "url",
630 "ws"
631 ],
632 "support": {
633 "docs": "https://uri.thephpleague.com",
634 "forum": "https://thephpleague.slack.com",
635 "issues": "https://github.com/thephpleague/uri/issues",
636 "source": "https://github.com/thephpleague/uri/tree/6.7.2"
637 },
638 "funding": [
639 {
640 "url": "https://github.com/sponsors/nyamsprod",
641 "type": "github"
642 }
643 ],
644 "install-path": "../league/uri"
645 },
646 {
647 "name": "league/uri-interfaces",
648 "version": "2.3.0",
649 "version_normalized": "2.3.0.0",
650 "source": {
651 "type": "git",
652 "url": "https://github.com/thephpleague/uri-interfaces.git",
653 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383"
654 },
655 "dist": {
656 "type": "zip",
657 "url": "https://api.github.com/repos/thephpleague/uri-interfaces/zipball/00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
658 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
659 "shasum": ""
660 },
661 "require": {
662 "ext-json": "*",
663 "php": "^7.2 || ^8.0"
664 },
665 "require-dev": {
666 "friendsofphp/php-cs-fixer": "^2.19",
667 "phpstan/phpstan": "^0.12.90",
668 "phpstan/phpstan-phpunit": "^0.12.19",
669 "phpstan/phpstan-strict-rules": "^0.12.9",
670 "phpunit/phpunit": "^8.5.15 || ^9.5"
671 },
672 "suggest": {
673 "ext-intl": "to use the IDNA feature",
674 "symfony/intl": "to use the IDNA feature via Symfony Polyfill"
675 },
676 "time": "2021-06-28T04:27:21+00:00",
677 "type": "library",
678 "extra": {
679 "branch-alias": {
680 "dev-master": "2.x-dev"
681 }
682 },
683 "installation-source": "dist",
684 "autoload": {
685 "psr-4": {
686 "League\\Uri\\": "src/"
687 }
688 },
689 "notification-url": "https://packagist.org/downloads/",
690 "license": [
691 "MIT"
692 ],
693 "authors": [
694 {
695 "name": "Ignace Nyamagana Butera",
696 "email": "[email protected]",
697 "homepage": "https://nyamsprod.com"
698 }
699 ],
700 "description": "Common interface for URI representation",
701 "homepage": "http://github.com/thephpleague/uri-interfaces",
702 "keywords": [
703 "rfc3986",
704 "rfc3987",
705 "uri",
706 "url"
707 ],
708 "support": {
709 "issues": "https://github.com/thephpleague/uri-interfaces/issues",
710 "source": "https://github.com/thephpleague/uri-interfaces/tree/2.3.0"
711 },
712 "funding": [
713 {
714 "url": "https://github.com/sponsors/nyamsprod",
715 "type": "github"
716 }
717 ],
718 "install-path": "../league/uri-interfaces"
719 },
720 {
721 "name": "nyholm/psr7",
722 "version": "1.8.2",
723 "version_normalized": "1.8.2.0",
724 "source": {
725 "type": "git",
726 "url": "https://github.com/Nyholm/psr7.git",
727 "reference": "a71f2b11690f4b24d099d6b16690a90ae14fc6f3"
728 },
729 "dist": {
730 "type": "zip",
731 "url": "https://api.github.com/repos/Nyholm/psr7/zipball/a71f2b11690f4b24d099d6b16690a90ae14fc6f3",
732 "reference": "a71f2b11690f4b24d099d6b16690a90ae14fc6f3",
733 "shasum": ""
734 },
735 "require": {
736 "php": ">=7.2",
737 "psr/http-factory": "^1.0",
738 "psr/http-message": "^1.1 || ^2.0"
739 },
740 "provide": {
741 "php-http/message-factory-implementation": "1.0",
742 "psr/http-factory-implementation": "1.0",
743 "psr/http-message-implementation": "1.0"
744 },
745 "require-dev": {
746 "http-interop/http-factory-tests": "^0.9",
747 "php-http/message-factory": "^1.0",
748 "php-http/psr7-integration-tests": "^1.0",
749 "phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
750 "symfony/error-handler": "^4.4"
751 },
752 "time": "2024-09-09T07:06:30+00:00",
753 "type": "library",
754 "extra": {
755 "branch-alias": {
756 "dev-master": "1.8-dev"
757 }
758 },
759 "installation-source": "dist",
760 "autoload": {
761 "psr-4": {
762 "Nyholm\\Psr7\\": "src/"
763 }
764 },
765 "notification-url": "https://packagist.org/downloads/",
766 "license": [
767 "MIT"
768 ],
769 "authors": [
770 {
771 "name": "Tobias Nyholm",
772 "email": "[email protected]"
773 },
774 {
775 "name": "Martijn van der Ven",
776 "email": "[email protected]"
777 }
778 ],
779 "description": "A fast PHP7 implementation of PSR-7",
780 "homepage": "https://tnyholm.se",
781 "keywords": [
782 "psr-17",
783 "psr-7"
784 ],
785 "support": {
786 "issues": "https://github.com/Nyholm/psr7/issues",
787 "source": "https://github.com/Nyholm/psr7/tree/1.8.2"
788 },
789 "funding": [
790 {
791 "url": "https://github.com/Zegnat",
792 "type": "github"
793 },
794 {
795 "url": "https://github.com/nyholm",
796 "type": "github"
797 }
798 ],
799 "install-path": "../nyholm/psr7"
800 },
801 {
802 "name": "nyholm/psr7-server",
803 "version": "1.1.0",
804 "version_normalized": "1.1.0.0",
805 "source": {
806 "type": "git",
807 "url": "https://github.com/Nyholm/psr7-server.git",
808 "reference": "4335801d851f554ca43fa6e7d2602141538854dc"
809 },
810 "dist": {
811 "type": "zip",
812 "url": "https://api.github.com/repos/Nyholm/psr7-server/zipball/4335801d851f554ca43fa6e7d2602141538854dc",
813 "reference": "4335801d851f554ca43fa6e7d2602141538854dc",
814 "shasum": ""
815 },
816 "require": {
817 "php": "^7.1 || ^8.0",
818 "psr/http-factory": "^1.0",
819 "psr/http-message": "^1.0 || ^2.0"
820 },
821 "require-dev": {
822 "nyholm/nsa": "^1.1",
823 "nyholm/psr7": "^1.3",
824 "phpunit/phpunit": "^7.0 || ^8.5 || ^9.3"
825 },
826 "time": "2023-11-08T09:30:43+00:00",
827 "type": "library",
828 "installation-source": "dist",
829 "autoload": {
830 "psr-4": {
831 "Nyholm\\Psr7Server\\": "src/"
832 }
833 },
834 "notification-url": "https://packagist.org/downloads/",
835 "license": [
836 "MIT"
837 ],
838 "authors": [
839 {
840 "name": "Tobias Nyholm",
841 "email": "[email protected]"
842 },
843 {
844 "name": "Martijn van der Ven",
845 "email": "[email protected]"
846 }
847 ],
848 "description": "Helper classes to handle PSR-7 server requests",
849 "homepage": "http://tnyholm.se",
850 "keywords": [
851 "psr-17",
852 "psr-7"
853 ],
854 "support": {
855 "issues": "https://github.com/Nyholm/psr7-server/issues",
856 "source": "https://github.com/Nyholm/psr7-server/tree/1.1.0"
857 },
858 "funding": [
859 {
860 "url": "https://github.com/Zegnat",
861 "type": "github"
862 },
863 {
864 "url": "https://github.com/nyholm",
865 "type": "github"
866 }
867 ],
868 "install-path": "../nyholm/psr7-server"
869 },
870 {
871 "name": "psr/http-client",
872 "version": "1.0.3",
873 "version_normalized": "1.0.3.0",
874 "source": {
875 "type": "git",
876 "url": "https://github.com/php-fig/http-client.git",
877 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90"
878 },
879 "dist": {
880 "type": "zip",
881 "url": "https://api.github.com/repos/php-fig/http-client/zipball/bb5906edc1c324c9a05aa0873d40117941e5fa90",
882 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90",
883 "shasum": ""
884 },
885 "require": {
886 "php": "^7.0 || ^8.0",
887 "psr/http-message": "^1.0 || ^2.0"
888 },
889 "time": "2023-09-23T14:17:50+00:00",
890 "type": "library",
891 "extra": {
892 "branch-alias": {
893 "dev-master": "1.0.x-dev"
894 }
895 },
896 "installation-source": "dist",
897 "autoload": {
898 "psr-4": {
899 "Psr\\Http\\Client\\": "src/"
900 }
901 },
902 "notification-url": "https://packagist.org/downloads/",
903 "license": [
904 "MIT"
905 ],
906 "authors": [
907 {
908 "name": "PHP-FIG",
909 "homepage": "https://www.php-fig.org/"
910 }
911 ],
912 "description": "Common interface for HTTP clients",
913 "homepage": "https://github.com/php-fig/http-client",
914 "keywords": [
915 "http",
916 "http-client",
917 "psr",
918 "psr-18"
919 ],
920 "support": {
921 "source": "https://github.com/php-fig/http-client"
922 },
923 "install-path": "../psr/http-client"
924 },
925 {
926 "name": "psr/http-factory",
927 "version": "1.1.0",
928 "version_normalized": "1.1.0.0",
929 "source": {
930 "type": "git",
931 "url": "https://github.com/php-fig/http-factory.git",
932 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a"
933 },
934 "dist": {
935 "type": "zip",
936 "url": "https://api.github.com/repos/php-fig/http-factory/zipball/2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
937 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
938 "shasum": ""
939 },
940 "require": {
941 "php": ">=7.1",
942 "psr/http-message": "^1.0 || ^2.0"
943 },
944 "time": "2024-04-15T12:06:14+00:00",
945 "type": "library",
946 "extra": {
947 "branch-alias": {
948 "dev-master": "1.0.x-dev"
949 }
950 },
951 "installation-source": "dist",
952 "autoload": {
953 "psr-4": {
954 "Psr\\Http\\Message\\": "src/"
955 }
956 },
957 "notification-url": "https://packagist.org/downloads/",
958 "license": [
959 "MIT"
960 ],
961 "authors": [
962 {
963 "name": "PHP-FIG",
964 "homepage": "https://www.php-fig.org/"
965 }
966 ],
967 "description": "PSR-17: Common interfaces for PSR-7 HTTP message factories",
968 "keywords": [
969 "factory",
970 "http",
971 "message",
972 "psr",
973 "psr-17",
974 "psr-7",
975 "request",
976 "response"
977 ],
978 "support": {
979 "source": "https://github.com/php-fig/http-factory"
980 },
981 "install-path": "../psr/http-factory"
982 },
983 {
984 "name": "psr/http-message",
985 "version": "1.1",
986 "version_normalized": "1.1.0.0",
987 "source": {
988 "type": "git",
989 "url": "https://github.com/php-fig/http-message.git",
990 "reference": "cb6ce4845ce34a8ad9e68117c10ee90a29919eba"
991 },
992 "dist": {
993 "type": "zip",
994 "url": "https://api.github.com/repos/php-fig/http-message/zipball/cb6ce4845ce34a8ad9e68117c10ee90a29919eba",
995 "reference": "cb6ce4845ce34a8ad9e68117c10ee90a29919eba",
996 "shasum": ""
997 },
998 "require": {
999 "php": "^7.2 || ^8.0"
1000 },
1001 "time": "2023-04-04T09:50:52+00:00",
1002 "type": "library",
1003 "extra": {
1004 "branch-alias": {
1005 "dev-master": "1.1.x-dev"
1006 }
1007 },
1008 "installation-source": "dist",
1009 "autoload": {
1010 "psr-4": {
1011 "Psr\\Http\\Message\\": "src/"
1012 }
1013 },
1014 "notification-url": "https://packagist.org/downloads/",
1015 "license": [
1016 "MIT"
1017 ],
1018 "authors": [
1019 {
1020 "name": "PHP-FIG",
1021 "homepage": "http://www.php-fig.org/"
1022 }
1023 ],
1024 "description": "Common interface for HTTP messages",
1025 "homepage": "https://github.com/php-fig/http-message",
1026 "keywords": [
1027 "http",
1028 "http-message",
1029 "psr",
1030 "psr-7",
1031 "request",
1032 "response"
1033 ],
1034 "support": {
1035 "source": "https://github.com/php-fig/http-message/tree/1.1"
1036 },
1037 "install-path": "../psr/http-message"
1038 },
1039 {
1040 "name": "psr/log",
1041 "version": "1.1.4",
1042 "version_normalized": "1.1.4.0",
1043 "source": {
1044 "type": "git",
1045 "url": "https://github.com/php-fig/log.git",
1046 "reference": "d49695b909c3b7628b6289db5479a1c204601f11"
1047 },
1048 "dist": {
1049 "type": "zip",
1050 "url": "https://api.github.com/repos/php-fig/log/zipball/d49695b909c3b7628b6289db5479a1c204601f11",
1051 "reference": "d49695b909c3b7628b6289db5479a1c204601f11",
1052 "shasum": ""
1053 },
1054 "require": {
1055 "php": ">=5.3.0"
1056 },
1057 "time": "2021-05-03T11:20:27+00:00",
1058 "type": "library",
1059 "extra": {
1060 "branch-alias": {
1061 "dev-master": "1.1.x-dev"
1062 }
1063 },
1064 "installation-source": "dist",
1065 "autoload": {
1066 "psr-4": {
1067 "Psr\\Log\\": "Psr/Log/"
1068 }
1069 },
1070 "notification-url": "https://packagist.org/downloads/",
1071 "license": [
1072 "MIT"
1073 ],
1074 "authors": [
1075 {
1076 "name": "PHP-FIG",
1077 "homepage": "https://www.php-fig.org/"
1078 }
1079 ],
1080 "description": "Common interface for logging libraries",
1081 "homepage": "https://github.com/php-fig/log",
1082 "keywords": [
1083 "log",
1084 "psr",
1085 "psr-3"
1086 ],
1087 "support": {
1088 "source": "https://github.com/php-fig/log/tree/1.1.4"
1089 },
1090 "install-path": "../psr/log"
1091 },
1092 {
1093 "name": "ramsey/collection",
1094 "version": "1.3.0",
1095 "version_normalized": "1.3.0.0",
1096 "source": {
1097 "type": "git",
1098 "url": "https://github.com/ramsey/collection.git",
1099 "reference": "ad7475d1c9e70b190ecffc58f2d989416af339b4"
1100 },
1101 "dist": {
1102 "type": "zip",
1103 "url": "https://api.github.com/repos/ramsey/collection/zipball/ad7475d1c9e70b190ecffc58f2d989416af339b4",
1104 "reference": "ad7475d1c9e70b190ecffc58f2d989416af339b4",
1105 "shasum": ""
1106 },
1107 "require": {
1108 "php": "^7.4 || ^8.0",
1109 "symfony/polyfill-php81": "^1.23"
1110 },
1111 "require-dev": {
1112 "captainhook/plugin-composer": "^5.3",
1113 "ergebnis/composer-normalize": "^2.28.3",
1114 "fakerphp/faker": "^1.21",
1115 "hamcrest/hamcrest-php": "^2.0",
1116 "jangregor/phpstan-prophecy": "^1.0",
1117 "mockery/mockery": "^1.5",
1118 "php-parallel-lint/php-console-highlighter": "^1.0",
1119 "php-parallel-lint/php-parallel-lint": "^1.3",
1120 "phpcsstandards/phpcsutils": "^1.0.0-rc1",
1121 "phpspec/prophecy-phpunit": "^2.0",
1122 "phpstan/extension-installer": "^1.2",
1123 "phpstan/phpstan": "^1.9",
1124 "phpstan/phpstan-mockery": "^1.1",
1125 "phpstan/phpstan-phpunit": "^1.3",
1126 "phpunit/phpunit": "^9.5",
1127 "psalm/plugin-mockery": "^1.1",
1128 "psalm/plugin-phpunit": "^0.18.4",
1129 "ramsey/coding-standard": "^2.0.3",
1130 "ramsey/conventional-commits": "^1.3",
1131 "vimeo/psalm": "^5.4"
1132 },
1133 "time": "2022-12-27T19:12:24+00:00",
1134 "type": "library",
1135 "extra": {
1136 "captainhook": {
1137 "force-install": true
1138 },
1139 "ramsey/conventional-commits": {
1140 "configFile": "conventional-commits.json"
1141 }
1142 },
1143 "installation-source": "dist",
1144 "autoload": {
1145 "psr-4": {
1146 "Ramsey\\Collection\\": "src/"
1147 }
1148 },
1149 "notification-url": "https://packagist.org/downloads/",
1150 "license": [
1151 "MIT"
1152 ],
1153 "authors": [
1154 {
1155 "name": "Ben Ramsey",
1156 "email": "[email protected]",
1157 "homepage": "https://benramsey.com"
1158 }
1159 ],
1160 "description": "A PHP library for representing and manipulating collections.",
1161 "keywords": [
1162 "array",
1163 "collection",
1164 "hash",
1165 "map",
1166 "queue",
1167 "set"
1168 ],
1169 "support": {
1170 "issues": "https://github.com/ramsey/collection/issues",
1171 "source": "https://github.com/ramsey/collection/tree/1.3.0"
1172 },
1173 "funding": [
1174 {
1175 "url": "https://github.com/ramsey",
1176 "type": "github"
1177 },
1178 {
1179 "url": "https://tidelift.com/funding/github/packagist/ramsey/collection",
1180 "type": "tidelift"
1181 }
1182 ],
1183 "install-path": "../ramsey/collection"
1184 },
1185 {
1186 "name": "ramsey/uuid",
1187 "version": "4.9.1",
1188 "version_normalized": "4.9.1.0",
1189 "source": {
1190 "type": "git",
1191 "url": "https://github.com/ramsey/uuid.git",
1192 "reference": "81f941f6f729b1e3ceea61d9d014f8b6c6800440"
1193 },
1194 "dist": {
1195 "type": "zip",
1196 "url": "https://api.github.com/repos/ramsey/uuid/zipball/81f941f6f729b1e3ceea61d9d014f8b6c6800440",
1197 "reference": "81f941f6f729b1e3ceea61d9d014f8b6c6800440",
1198 "shasum": ""
1199 },
1200 "require": {
1201 "brick/math": "^0.8.8 || ^0.9 || ^0.10 || ^0.11 || ^0.12 || ^0.13 || ^0.14",
1202 "php": "^8.0",
1203 "ramsey/collection": "^1.2 || ^2.0"
1204 },
1205 "replace": {
1206 "rhumsaa/uuid": "self.version"
1207 },
1208 "require-dev": {
1209 "captainhook/captainhook": "^5.25",
1210 "captainhook/plugin-composer": "^5.3",
1211 "dealerdirect/phpcodesniffer-composer-installer": "^1.0",
1212 "ergebnis/composer-normalize": "^2.47",
1213 "mockery/mockery": "^1.6",
1214 "paragonie/random-lib": "^2",
1215 "php-mock/php-mock": "^2.6",
1216 "php-mock/php-mock-mockery": "^1.5",
1217 "php-parallel-lint/php-parallel-lint": "^1.4.0",
1218 "phpbench/phpbench": "^1.2.14",
1219 "phpstan/extension-installer": "^1.4",
1220 "phpstan/phpstan": "^2.1",
1221 "phpstan/phpstan-mockery": "^2.0",
1222 "phpstan/phpstan-phpunit": "^2.0",
1223 "phpunit/phpunit": "^9.6",
1224 "slevomat/coding-standard": "^8.18",
1225 "squizlabs/php_codesniffer": "^3.13"
1226 },
1227 "suggest": {
1228 "ext-bcmath": "Enables faster math with arbitrary-precision integers using BCMath.",
1229 "ext-gmp": "Enables faster math with arbitrary-precision integers using GMP.",
1230 "ext-uuid": "Enables the use of PeclUuidTimeGenerator and PeclUuidRandomGenerator.",
1231 "paragonie/random-lib": "Provides RandomLib for use with the RandomLibAdapter",
1232 "ramsey/uuid-doctrine": "Allows the use of Ramsey\\Uuid\\Uuid as Doctrine field type."
1233 },
1234 "time": "2025-09-04T20:59:21+00:00",
1235 "type": "library",
1236 "extra": {
1237 "captainhook": {
1238 "force-install": true
1239 }
1240 },
1241 "installation-source": "dist",
1242 "autoload": {
1243 "files": [
1244 "src/functions.php"
1245 ],
1246 "psr-4": {
1247 "Ramsey\\Uuid\\": "src/"
1248 }
1249 },
1250 "notification-url": "https://packagist.org/downloads/",
1251 "license": [
1252 "MIT"
1253 ],
1254 "description": "A PHP library for generating and working with universally unique identifiers (UUIDs).",
1255 "keywords": [
1256 "guid",
1257 "identifier",
1258 "uuid"
1259 ],
1260 "support": {
1261 "issues": "https://github.com/ramsey/uuid/issues",
1262 "source": "https://github.com/ramsey/uuid/tree/4.9.1"
1263 },
1264 "install-path": "../ramsey/uuid"
1265 },
1266 {
1267 "name": "spomky-labs/base64url",
1268 "version": "v2.0.4",
1269 "version_normalized": "2.0.4.0",
1270 "source": {
1271 "type": "git",
1272 "url": "https://github.com/Spomky-Labs/base64url.git",
1273 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d"
1274 },
1275 "dist": {
1276 "type": "zip",
1277 "url": "https://api.github.com/repos/Spomky-Labs/base64url/zipball/7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1278 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1279 "shasum": ""
1280 },
1281 "require": {
1282 "php": ">=7.1"
1283 },
1284 "require-dev": {
1285 "phpstan/extension-installer": "^1.0",
1286 "phpstan/phpstan": "^0.11|^0.12",
1287 "phpstan/phpstan-beberlei-assert": "^0.11|^0.12",
1288 "phpstan/phpstan-deprecation-rules": "^0.11|^0.12",
1289 "phpstan/phpstan-phpunit": "^0.11|^0.12",
1290 "phpstan/phpstan-strict-rules": "^0.11|^0.12"
1291 },
1292 "time": "2020-11-03T09:10:25+00:00",
1293 "type": "library",
1294 "installation-source": "dist",
1295 "autoload": {
1296 "psr-4": {
1297 "Base64Url\\": "src/"
1298 }
1299 },
1300 "notification-url": "https://packagist.org/downloads/",
1301 "license": [
1302 "MIT"
1303 ],
1304 "authors": [
1305 {
1306 "name": "Florent Morselli",
1307 "homepage": "https://github.com/Spomky-Labs/base64url/contributors"
1308 }
1309 ],
1310 "description": "Base 64 URL Safe Encoding/Decoding PHP Library",
1311 "homepage": "https://github.com/Spomky-Labs/base64url",
1312 "keywords": [
1313 "base64",
1314 "rfc4648",
1315 "safe",
1316 "url"
1317 ],
1318 "support": {
1319 "issues": "https://github.com/Spomky-Labs/base64url/issues",
1320 "source": "https://github.com/Spomky-Labs/base64url/tree/v2.0.4"
1321 },
1322 "funding": [
1323 {
1324 "url": "https://github.com/Spomky",
1325 "type": "github"
1326 },
1327 {
1328 "url": "https://www.patreon.com/FlorentMorselli",
1329 "type": "patreon"
1330 }
1331 ],
1332 "install-path": "../spomky-labs/base64url"
1333 },
1334 {
1335 "name": "spomky-labs/cbor-php",
1336 "version": "v2.1.0",
1337 "version_normalized": "2.1.0.0",
1338 "source": {
1339 "type": "git",
1340 "url": "https://github.com/Spomky-Labs/cbor-php.git",
1341 "reference": "28e2712cfc0b48fae661a48ffc6896d7abe83684"
1342 },
1343 "dist": {
1344 "type": "zip",
1345 "url": "https://api.github.com/repos/Spomky-Labs/cbor-php/zipball/28e2712cfc0b48fae661a48ffc6896d7abe83684",
1346 "reference": "28e2712cfc0b48fae661a48ffc6896d7abe83684",
1347 "shasum": ""
1348 },
1349 "require": {
1350 "brick/math": "^0.8.15|^0.9.0",
1351 "ext-mbstring": "*",
1352 "php": ">=7.3"
1353 },
1354 "require-dev": {
1355 "ekino/phpstan-banned-code": "^1.0",
1356 "ext-json": "*",
1357 "infection/infection": "^0.18|^0.25",
1358 "phpstan/extension-installer": "^1.1",
1359 "phpstan/phpstan": "^1.0",
1360 "phpstan/phpstan-beberlei-assert": "^1.0",
1361 "phpstan/phpstan-deprecation-rules": "^1.0",
1362 "phpstan/phpstan-phpunit": "^1.0",
1363 "phpstan/phpstan-strict-rules": "^1.0",
1364 "phpunit/phpunit": "^9.5",
1365 "rector/rector": "^0.12",
1366 "roave/security-advisories": "dev-latest",
1367 "symplify/easy-coding-standard": "^10.0"
1368 },
1369 "suggest": {
1370 "ext-bcmath": "GMP or BCMath extensions will drastically improve the library performance. BCMath extension needed to handle the Big Float and Decimal Fraction Tags",
1371 "ext-gmp": "GMP or BCMath extensions will drastically improve the library performance"
1372 },
1373 "time": "2021-12-13T12:46:26+00:00",
1374 "type": "library",
1375 "installation-source": "dist",
1376 "autoload": {
1377 "psr-4": {
1378 "CBOR\\": "src/"
1379 }
1380 },
1381 "notification-url": "https://packagist.org/downloads/",
1382 "license": [
1383 "MIT"
1384 ],
1385 "authors": [
1386 {
1387 "name": "Florent Morselli",
1388 "homepage": "https://github.com/Spomky"
1389 },
1390 {
1391 "name": "All contributors",
1392 "homepage": "https://github.com/Spomky-Labs/cbor-php/contributors"
1393 }
1394 ],
1395 "description": "CBOR Encoder/Decoder for PHP",
1396 "keywords": [
1397 "Concise Binary Object Representation",
1398 "RFC7049",
1399 "cbor"
1400 ],
1401 "support": {
1402 "issues": "https://github.com/Spomky-Labs/cbor-php/issues",
1403 "source": "https://github.com/Spomky-Labs/cbor-php/tree/v2.1.0"
1404 },
1405 "funding": [
1406 {
1407 "url": "https://github.com/Spomky",
1408 "type": "github"
1409 },
1410 {
1411 "url": "https://www.patreon.com/FlorentMorselli",
1412 "type": "patreon"
1413 }
1414 ],
1415 "install-path": "../spomky-labs/cbor-php"
1416 },
1417 {
1418 "name": "symfony/polyfill-php80",
1419 "version": "v1.33.0",
1420 "version_normalized": "1.33.0.0",
1421 "source": {
1422 "type": "git",
1423 "url": "https://github.com/symfony/polyfill-php80.git",
1424 "reference": "0cc9dd0f17f61d8131e7df6b84bd344899fe2608"
1425 },
1426 "dist": {
1427 "type": "zip",
1428 "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/0cc9dd0f17f61d8131e7df6b84bd344899fe2608",
1429 "reference": "0cc9dd0f17f61d8131e7df6b84bd344899fe2608",
1430 "shasum": ""
1431 },
1432 "require": {
1433 "php": ">=7.2"
1434 },
1435 "time": "2025-01-02T08:10:11+00:00",
1436 "type": "library",
1437 "extra": {
1438 "thanks": {
1439 "url": "https://github.com/symfony/polyfill",
1440 "name": "symfony/polyfill"
1441 }
1442 },
1443 "installation-source": "dist",
1444 "autoload": {
1445 "files": [
1446 "bootstrap.php"
1447 ],
1448 "psr-4": {
1449 "Symfony\\Polyfill\\Php80\\": ""
1450 },
1451 "classmap": [
1452 "Resources/stubs"
1453 ]
1454 },
1455 "notification-url": "https://packagist.org/downloads/",
1456 "license": [
1457 "MIT"
1458 ],
1459 "authors": [
1460 {
1461 "name": "Ion Bazan",
1462 "email": "[email protected]"
1463 },
1464 {
1465 "name": "Nicolas Grekas",
1466 "email": "[email protected]"
1467 },
1468 {
1469 "name": "Symfony Community",
1470 "homepage": "https://symfony.com/contributors"
1471 }
1472 ],
1473 "description": "Symfony polyfill backporting some PHP 8.0+ features to lower PHP versions",
1474 "homepage": "https://symfony.com",
1475 "keywords": [
1476 "compatibility",
1477 "polyfill",
1478 "portable",
1479 "shim"
1480 ],
1481 "support": {
1482 "source": "https://github.com/symfony/polyfill-php80/tree/v1.33.0"
1483 },
1484 "funding": [
1485 {
1486 "url": "https://symfony.com/sponsor",
1487 "type": "custom"
1488 },
1489 {
1490 "url": "https://github.com/fabpot",
1491 "type": "github"
1492 },
1493 {
1494 "url": "https://github.com/nicolas-grekas",
1495 "type": "github"
1496 },
1497 {
1498 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1499 "type": "tidelift"
1500 }
1501 ],
1502 "install-path": "../symfony/polyfill-php80"
1503 },
1504 {
1505 "name": "symfony/polyfill-php81",
1506 "version": "v1.33.0",
1507 "version_normalized": "1.33.0.0",
1508 "source": {
1509 "type": "git",
1510 "url": "https://github.com/symfony/polyfill-php81.git",
1511 "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c"
1512 },
1513 "dist": {
1514 "type": "zip",
1515 "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
1516 "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
1517 "shasum": ""
1518 },
1519 "require": {
1520 "php": ">=7.2"
1521 },
1522 "time": "2024-09-09T11:45:10+00:00",
1523 "type": "library",
1524 "extra": {
1525 "thanks": {
1526 "url": "https://github.com/symfony/polyfill",
1527 "name": "symfony/polyfill"
1528 }
1529 },
1530 "installation-source": "dist",
1531 "autoload": {
1532 "files": [
1533 "bootstrap.php"
1534 ],
1535 "psr-4": {
1536 "Symfony\\Polyfill\\Php81\\": ""
1537 },
1538 "classmap": [
1539 "Resources/stubs"
1540 ]
1541 },
1542 "notification-url": "https://packagist.org/downloads/",
1543 "license": [
1544 "MIT"
1545 ],
1546 "authors": [
1547 {
1548 "name": "Nicolas Grekas",
1549 "email": "[email protected]"
1550 },
1551 {
1552 "name": "Symfony Community",
1553 "homepage": "https://symfony.com/contributors"
1554 }
1555 ],
1556 "description": "Symfony polyfill backporting some PHP 8.1+ features to lower PHP versions",
1557 "homepage": "https://symfony.com",
1558 "keywords": [
1559 "compatibility",
1560 "polyfill",
1561 "portable",
1562 "shim"
1563 ],
1564 "support": {
1565 "source": "https://github.com/symfony/polyfill-php81/tree/v1.33.0"
1566 },
1567 "funding": [
1568 {
1569 "url": "https://symfony.com/sponsor",
1570 "type": "custom"
1571 },
1572 {
1573 "url": "https://github.com/fabpot",
1574 "type": "github"
1575 },
1576 {
1577 "url": "https://github.com/nicolas-grekas",
1578 "type": "github"
1579 },
1580 {
1581 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1582 "type": "tidelift"
1583 }
1584 ],
1585 "install-path": "../symfony/polyfill-php81"
1586 },
1587 {
1588 "name": "symfony/process",
1589 "version": "v5.4.47",
1590 "version_normalized": "5.4.47.0",
1591 "source": {
1592 "type": "git",
1593 "url": "https://github.com/symfony/process.git",
1594 "reference": "5d1662fb32ebc94f17ddb8d635454a776066733d"
1595 },
1596 "dist": {
1597 "type": "zip",
1598 "url": "https://api.github.com/repos/symfony/process/zipball/5d1662fb32ebc94f17ddb8d635454a776066733d",
1599 "reference": "5d1662fb32ebc94f17ddb8d635454a776066733d",
1600 "shasum": ""
1601 },
1602 "require": {
1603 "php": ">=7.2.5",
1604 "symfony/polyfill-php80": "^1.16"
1605 },
1606 "time": "2024-11-06T11:36:42+00:00",
1607 "type": "library",
1608 "installation-source": "dist",
1609 "autoload": {
1610 "psr-4": {
1611 "Symfony\\Component\\Process\\": ""
1612 },
1613 "exclude-from-classmap": [
1614 "/Tests/"
1615 ]
1616 },
1617 "notification-url": "https://packagist.org/downloads/",
1618 "license": [
1619 "MIT"
1620 ],
1621 "authors": [
1622 {
1623 "name": "Fabien Potencier",
1624 "email": "[email protected]"
1625 },
1626 {
1627 "name": "Symfony Community",
1628 "homepage": "https://symfony.com/contributors"
1629 }
1630 ],
1631 "description": "Executes commands in sub-processes",
1632 "homepage": "https://symfony.com",
1633 "support": {
1634 "source": "https://github.com/symfony/process/tree/v5.4.47"
1635 },
1636 "funding": [
1637 {
1638 "url": "https://symfony.com/sponsor",
1639 "type": "custom"
1640 },
1641 {
1642 "url": "https://github.com/fabpot",
1643 "type": "github"
1644 },
1645 {
1646 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1647 "type": "tidelift"
1648 }
1649 ],
1650 "install-path": "../symfony/process"
1651 },
1652 {
1653 "name": "thecodingmachine/safe",
1654 "version": "v1.3.3",
1655 "version_normalized": "1.3.3.0",
1656 "source": {
1657 "type": "git",
1658 "url": "https://github.com/thecodingmachine/safe.git",
1659 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc"
1660 },
1661 "dist": {
1662 "type": "zip",
1663 "url": "https://api.github.com/repos/thecodingmachine/safe/zipball/a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1664 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1665 "shasum": ""
1666 },
1667 "require": {
1668 "php": ">=7.2"
1669 },
1670 "require-dev": {
1671 "phpstan/phpstan": "^0.12",
1672 "squizlabs/php_codesniffer": "^3.2",
1673 "thecodingmachine/phpstan-strict-rules": "^0.12"
1674 },
1675 "time": "2020-10-28T17:51:34+00:00",
1676 "type": "library",
1677 "extra": {
1678 "branch-alias": {
1679 "dev-master": "0.1-dev"
1680 }
1681 },
1682 "installation-source": "dist",
1683 "autoload": {
1684 "files": [
1685 "deprecated/apc.php",
1686 "deprecated/libevent.php",
1687 "deprecated/mssql.php",
1688 "deprecated/stats.php",
1689 "lib/special_cases.php",
1690 "generated/apache.php",
1691 "generated/apcu.php",
1692 "generated/array.php",
1693 "generated/bzip2.php",
1694 "generated/calendar.php",
1695 "generated/classobj.php",
1696 "generated/com.php",
1697 "generated/cubrid.php",
1698 "generated/curl.php",
1699 "generated/datetime.php",
1700 "generated/dir.php",
1701 "generated/eio.php",
1702 "generated/errorfunc.php",
1703 "generated/exec.php",
1704 "generated/fileinfo.php",
1705 "generated/filesystem.php",
1706 "generated/filter.php",
1707 "generated/fpm.php",
1708 "generated/ftp.php",
1709 "generated/funchand.php",
1710 "generated/gmp.php",
1711 "generated/gnupg.php",
1712 "generated/hash.php",
1713 "generated/ibase.php",
1714 "generated/ibmDb2.php",
1715 "generated/iconv.php",
1716 "generated/image.php",
1717 "generated/imap.php",
1718 "generated/info.php",
1719 "generated/ingres-ii.php",
1720 "generated/inotify.php",
1721 "generated/json.php",
1722 "generated/ldap.php",
1723 "generated/libxml.php",
1724 "generated/lzf.php",
1725 "generated/mailparse.php",
1726 "generated/mbstring.php",
1727 "generated/misc.php",
1728 "generated/msql.php",
1729 "generated/mysql.php",
1730 "generated/mysqli.php",
1731 "generated/mysqlndMs.php",
1732 "generated/mysqlndQc.php",
1733 "generated/network.php",
1734 "generated/oci8.php",
1735 "generated/opcache.php",
1736 "generated/openssl.php",
1737 "generated/outcontrol.php",
1738 "generated/password.php",
1739 "generated/pcntl.php",
1740 "generated/pcre.php",
1741 "generated/pdf.php",
1742 "generated/pgsql.php",
1743 "generated/posix.php",
1744 "generated/ps.php",
1745 "generated/pspell.php",
1746 "generated/readline.php",
1747 "generated/rpminfo.php",
1748 "generated/rrd.php",
1749 "generated/sem.php",
1750 "generated/session.php",
1751 "generated/shmop.php",
1752 "generated/simplexml.php",
1753 "generated/sockets.php",
1754 "generated/sodium.php",
1755 "generated/solr.php",
1756 "generated/spl.php",
1757 "generated/sqlsrv.php",
1758 "generated/ssdeep.php",
1759 "generated/ssh2.php",
1760 "generated/stream.php",
1761 "generated/strings.php",
1762 "generated/swoole.php",
1763 "generated/uodbc.php",
1764 "generated/uopz.php",
1765 "generated/url.php",
1766 "generated/var.php",
1767 "generated/xdiff.php",
1768 "generated/xml.php",
1769 "generated/xmlrpc.php",
1770 "generated/yaml.php",
1771 "generated/yaz.php",
1772 "generated/zip.php",
1773 "generated/zlib.php"
1774 ],
1775 "psr-4": {
1776 "Safe\\": [
1777 "lib/",
1778 "deprecated/",
1779 "generated/"
1780 ]
1781 }
1782 },
1783 "notification-url": "https://packagist.org/downloads/",
1784 "license": [
1785 "MIT"
1786 ],
1787 "description": "PHP core functions that throw exceptions instead of returning FALSE on error",
1788 "support": {
1789 "issues": "https://github.com/thecodingmachine/safe/issues",
1790 "source": "https://github.com/thecodingmachine/safe/tree/v1.3.3"
1791 },
1792 "install-path": "../thecodingmachine/safe"
1793 },
1794 {
1795 "name": "vlucas/valitron",
1796 "version": "v1.4.11",
1797 "version_normalized": "1.4.11.0",
1798 "source": {
1799 "type": "git",
1800 "url": "https://github.com/vlucas/valitron.git",
1801 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f"
1802 },
1803 "dist": {
1804 "type": "zip",
1805 "url": "https://api.github.com/repos/vlucas/valitron/zipball/fadce39f5f235755bb9794b2573af2d5bfcba85f",
1806 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f",
1807 "shasum": ""
1808 },
1809 "require": {
1810 "php": ">=5.3.2"
1811 },
1812 "require-dev": {
1813 "phpunit/phpunit": ">=4.8.35"
1814 },
1815 "suggest": {
1816 "ext-mbstring": "It can support the multiple bytes string length."
1817 },
1818 "time": "2022-10-14T11:54:24+00:00",
1819 "type": "library",
1820 "installation-source": "dist",
1821 "autoload": {
1822 "psr-4": {
1823 "Valitron\\": "src/Valitron"
1824 }
1825 },
1826 "notification-url": "https://packagist.org/downloads/",
1827 "license": [
1828 "BSD-3-Clause"
1829 ],
1830 "authors": [
1831 {
1832 "name": "Vance Lucas",
1833 "email": "[email protected]",
1834 "homepage": "https://www.vancelucas.com"
1835 }
1836 ],
1837 "description": "Simple, elegant, stand-alone validation library with NO dependencies",
1838 "homepage": "https://github.com/vlucas/valitron",
1839 "keywords": [
1840 "valid",
1841 "validation",
1842 "validator"
1843 ],
1844 "support": {
1845 "issues": "https://github.com/vlucas/valitron/issues",
1846 "source": "https://github.com/vlucas/valitron/tree/v1.4.11"
1847 },
1848 "funding": [
1849 {
1850 "url": "https://tidelift.com/funding/github/packagist/vlucas/valitron",
1851 "type": "tidelift"
1852 }
1853 ],
1854 "install-path": "../vlucas/valitron"
1855 },
1856 {
1857 "name": "web-auth/cose-lib",
1858 "version": "v3.3.12",
1859 "version_normalized": "3.3.12.0",
1860 "source": {
1861 "type": "git",
1862 "url": "https://github.com/web-auth/cose-lib.git",
1863 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb"
1864 },
1865 "dist": {
1866 "type": "zip",
1867 "url": "https://api.github.com/repos/web-auth/cose-lib/zipball/efa6ec2ba4e840bc1316a493973c9916028afeeb",
1868 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb",
1869 "shasum": ""
1870 },
1871 "require": {
1872 "beberlei/assert": "^3.2",
1873 "ext-json": "*",
1874 "ext-mbstring": "*",
1875 "ext-openssl": "*",
1876 "fgrosse/phpasn1": "^2.1",
1877 "php": ">=7.2"
1878 },
1879 "time": "2021-12-04T12:13:35+00:00",
1880 "type": "library",
1881 "installation-source": "dist",
1882 "autoload": {
1883 "psr-4": {
1884 "Cose\\": "src/"
1885 }
1886 },
1887 "notification-url": "https://packagist.org/downloads/",
1888 "license": [
1889 "MIT"
1890 ],
1891 "authors": [
1892 {
1893 "name": "Florent Morselli",
1894 "homepage": "https://github.com/Spomky"
1895 },
1896 {
1897 "name": "All contributors",
1898 "homepage": "https://github.com/web-auth/cose/contributors"
1899 }
1900 ],
1901 "description": "CBOR Object Signing and Encryption (COSE) For PHP",
1902 "homepage": "https://github.com/web-auth",
1903 "keywords": [
1904 "COSE",
1905 "RFC8152"
1906 ],
1907 "support": {
1908 "source": "https://github.com/web-auth/cose-lib/tree/v3.3.12"
1909 },
1910 "funding": [
1911 {
1912 "url": "https://github.com/Spomky",
1913 "type": "github"
1914 },
1915 {
1916 "url": "https://www.patreon.com/FlorentMorselli",
1917 "type": "patreon"
1918 }
1919 ],
1920 "install-path": "../web-auth/cose-lib"
1921 },
1922 {
1923 "name": "web-auth/metadata-service",
1924 "version": "v3.3.12",
1925 "version_normalized": "3.3.12.0",
1926 "source": {
1927 "type": "git",
1928 "url": "https://github.com/web-auth/webauthn-metadata-service.git",
1929 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246"
1930 },
1931 "dist": {
1932 "type": "zip",
1933 "url": "https://api.github.com/repos/web-auth/webauthn-metadata-service/zipball/ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1934 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1935 "shasum": ""
1936 },
1937 "require": {
1938 "beberlei/assert": "^3.2",
1939 "ext-json": "*",
1940 "league/uri": "^6.0",
1941 "php": ">=7.2",
1942 "psr/http-client": "^1.0",
1943 "psr/http-factory": "^1.0",
1944 "psr/log": "^1.1"
1945 },
1946 "suggest": {
1947 "web-token/jwt-key-mgmt": "Mandatory for fetching Metadata Statement from distant sources",
1948 "web-token/jwt-signature-algorithm-ecdsa": "Mandatory for fetching Metadata Statement from distant sources"
1949 },
1950 "time": "2021-11-21T11:14:31+00:00",
1951 "type": "library",
1952 "installation-source": "dist",
1953 "autoload": {
1954 "psr-4": {
1955 "Webauthn\\MetadataService\\": "src/"
1956 }
1957 },
1958 "notification-url": "https://packagist.org/downloads/",
1959 "license": [
1960 "MIT"
1961 ],
1962 "authors": [
1963 {
1964 "name": "Florent Morselli",
1965 "homepage": "https://github.com/Spomky"
1966 },
1967 {
1968 "name": "All contributors",
1969 "homepage": "https://github.com/web-auth/metadata-service/contributors"
1970 }
1971 ],
1972 "description": "Metadata Service for FIDO2/Webauthn",
1973 "homepage": "https://github.com/web-auth",
1974 "keywords": [
1975 "FIDO2",
1976 "fido",
1977 "webauthn"
1978 ],
1979 "support": {
1980 "source": "https://github.com/web-auth/webauthn-metadata-service/tree/v3.3.12"
1981 },
1982 "funding": [
1983 {
1984 "url": "https://github.com/Spomky",
1985 "type": "github"
1986 },
1987 {
1988 "url": "https://www.patreon.com/FlorentMorselli",
1989 "type": "patreon"
1990 }
1991 ],
1992 "abandoned": "web-auth/webauthn-lib",
1993 "install-path": "../web-auth/metadata-service"
1994 },
1995 {
1996 "name": "web-auth/webauthn-lib",
1997 "version": "v3.3.12",
1998 "version_normalized": "3.3.12.0",
1999 "source": {
2000 "type": "git",
2001 "url": "https://github.com/web-auth/webauthn-lib.git",
2002 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33"
2003 },
2004 "dist": {
2005 "type": "zip",
2006 "url": "https://api.github.com/repos/web-auth/webauthn-lib/zipball/5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
2007 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
2008 "shasum": ""
2009 },
2010 "require": {
2011 "beberlei/assert": "^3.2",
2012 "ext-json": "*",
2013 "ext-mbstring": "*",
2014 "ext-openssl": "*",
2015 "fgrosse/phpasn1": "^2.1",
2016 "php": ">=7.2",
2017 "psr/http-client": "^1.0",
2018 "psr/http-factory": "^1.0",
2019 "psr/http-message": "^1.0",
2020 "psr/log": "^1.1",
2021 "ramsey/uuid": "^3.8|^4.0",
2022 "spomky-labs/base64url": "^2.0",
2023 "spomky-labs/cbor-php": "^1.0|^2.0",
2024 "symfony/process": "^3.0|^4.0|^5.0",
2025 "thecodingmachine/safe": "^1.1",
2026 "web-auth/cose-lib": "self.version",
2027 "web-auth/metadata-service": "self.version"
2028 },
2029 "suggest": {
2030 "psr/log-implementation": "Recommended to receive logs from the library",
2031 "web-token/jwt-key-mgmt": "Mandatory for the AndroidSafetyNet Attestation Statement support",
2032 "web-token/jwt-signature-algorithm-ecdsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
2033 "web-token/jwt-signature-algorithm-eddsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
2034 "web-token/jwt-signature-algorithm-rsa": "Mandatory for the AndroidSafetyNet Attestation Statement support"
2035 },
2036 "time": "2022-02-18T07:13:44+00:00",
2037 "type": "library",
2038 "installation-source": "dist",
2039 "autoload": {
2040 "psr-4": {
2041 "Webauthn\\": "src/"
2042 }
2043 },
2044 "notification-url": "https://packagist.org/downloads/",
2045 "license": [
2046 "MIT"
2047 ],
2048 "authors": [
2049 {
2050 "name": "Florent Morselli",
2051 "homepage": "https://github.com/Spomky"
2052 },
2053 {
2054 "name": "All contributors",
2055 "homepage": "https://github.com/web-auth/webauthn-library/contributors"
2056 }
2057 ],
2058 "description": "FIDO2/Webauthn Support For PHP",
2059 "homepage": "https://github.com/web-auth",
2060 "keywords": [
2061 "FIDO2",
2062 "fido",
2063 "webauthn"
2064 ],
2065 "support": {
2066 "source": "https://github.com/web-auth/webauthn-lib/tree/v3.3.12"
2067 },
2068 "funding": [
2069 {
2070 "url": "https://github.com/Spomky",
2071 "type": "github"
2072 },
2073 {
2074 "url": "https://www.patreon.com/FlorentMorselli",
2075 "type": "patreon"
2076 }
2077 ],
2078 "install-path": "../web-auth/webauthn-lib"
2079 },
2080 {
2081 "name": "web-token/jwt-core",
2082 "version": "v2.2.11",
2083 "version_normalized": "2.2.11.0",
2084 "source": {
2085 "type": "git",
2086 "url": "https://github.com/web-token/jwt-core.git",
2087 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678"
2088 },
2089 "dist": {
2090 "type": "zip",
2091 "url": "https://api.github.com/repos/web-token/jwt-core/zipball/53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
2092 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
2093 "shasum": ""
2094 },
2095 "require": {
2096 "brick/math": "^0.8.17|^0.9",
2097 "ext-json": "*",
2098 "ext-mbstring": "*",
2099 "fgrosse/phpasn1": "^2.0",
2100 "php": ">=7.2",
2101 "spomky-labs/base64url": "^1.0|^2.0"
2102 },
2103 "conflict": {
2104 "spomky-labs/jose": "*"
2105 },
2106 "time": "2021-03-17T14:55:52+00:00",
2107 "type": "library",
2108 "installation-source": "dist",
2109 "autoload": {
2110 "psr-4": {
2111 "Jose\\Component\\Core\\": ""
2112 }
2113 },
2114 "notification-url": "https://packagist.org/downloads/",
2115 "license": [
2116 "MIT"
2117 ],
2118 "authors": [
2119 {
2120 "name": "Florent Morselli",
2121 "homepage": "https://github.com/Spomky"
2122 },
2123 {
2124 "name": "All contributors",
2125 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2126 }
2127 ],
2128 "description": "Core component of the JWT Framework.",
2129 "homepage": "https://github.com/web-token",
2130 "keywords": [
2131 "JOSE",
2132 "JWE",
2133 "JWK",
2134 "JWKSet",
2135 "JWS",
2136 "Jot",
2137 "RFC7515",
2138 "RFC7516",
2139 "RFC7517",
2140 "RFC7518",
2141 "RFC7519",
2142 "RFC7520",
2143 "bundle",
2144 "jwa",
2145 "jwt",
2146 "symfony"
2147 ],
2148 "support": {
2149 "source": "https://github.com/web-token/jwt-core/tree/v2.2.11"
2150 },
2151 "funding": [
2152 {
2153 "url": "https://www.patreon.com/FlorentMorselli",
2154 "type": "patreon"
2155 }
2156 ],
2157 "abandoned": "web-token/jwt-library",
2158 "install-path": "../web-token/jwt-core"
2159 },
2160 {
2161 "name": "web-token/jwt-key-mgmt",
2162 "version": "v2.2.11",
2163 "version_normalized": "2.2.11.0",
2164 "source": {
2165 "type": "git",
2166 "url": "https://github.com/web-token/jwt-key-mgmt.git",
2167 "reference": "0b116379515700d237b4e5de86879078ccb09d8a"
2168 },
2169 "dist": {
2170 "type": "zip",
2171 "url": "https://api.github.com/repos/web-token/jwt-key-mgmt/zipball/0b116379515700d237b4e5de86879078ccb09d8a",
2172 "reference": "0b116379515700d237b4e5de86879078ccb09d8a",
2173 "shasum": ""
2174 },
2175 "require": {
2176 "ext-openssl": "*",
2177 "psr/http-client": "^1.0",
2178 "psr/http-factory": "^1.0",
2179 "web-token/jwt-core": "^2.0"
2180 },
2181 "suggest": {
2182 "ext-sodium": "Sodium is required for OKP key creation, EdDSA signature algorithm and ECDH-ES key encryption with OKP keys",
2183 "php-http/httplug": "To enable JKU/X5U support.",
2184 "php-http/message-factory": "To enable JKU/X5U support.",
2185 "web-token/jwt-util-ecc": "To use EC key analyzers."
2186 },
2187 "time": "2021-03-17T14:55:52+00:00",
2188 "type": "library",
2189 "installation-source": "dist",
2190 "autoload": {
2191 "psr-4": {
2192 "Jose\\Component\\KeyManagement\\": ""
2193 }
2194 },
2195 "notification-url": "https://packagist.org/downloads/",
2196 "license": [
2197 "MIT"
2198 ],
2199 "authors": [
2200 {
2201 "name": "Florent Morselli",
2202 "homepage": "https://github.com/Spomky"
2203 },
2204 {
2205 "name": "All contributors",
2206 "homepage": "https://github.com/web-token/jwt-key-mgmt/contributors"
2207 }
2208 ],
2209 "description": "Key Management component of the JWT Framework.",
2210 "homepage": "https://github.com/web-token",
2211 "keywords": [
2212 "JOSE",
2213 "JWE",
2214 "JWK",
2215 "JWKSet",
2216 "JWS",
2217 "Jot",
2218 "RFC7515",
2219 "RFC7516",
2220 "RFC7517",
2221 "RFC7518",
2222 "RFC7519",
2223 "RFC7520",
2224 "bundle",
2225 "jwa",
2226 "jwt",
2227 "symfony"
2228 ],
2229 "support": {
2230 "source": "https://github.com/web-token/jwt-key-mgmt/tree/v2.2.11"
2231 },
2232 "funding": [
2233 {
2234 "url": "https://www.patreon.com/FlorentMorselli",
2235 "type": "patreon"
2236 }
2237 ],
2238 "abandoned": "web-token/jwt-library",
2239 "install-path": "../web-token/jwt-key-mgmt"
2240 },
2241 {
2242 "name": "web-token/jwt-signature",
2243 "version": "v2.2.11",
2244 "version_normalized": "2.2.11.0",
2245 "source": {
2246 "type": "git",
2247 "url": "https://github.com/web-token/jwt-signature.git",
2248 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103"
2249 },
2250 "dist": {
2251 "type": "zip",
2252 "url": "https://api.github.com/repos/web-token/jwt-signature/zipball/015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2253 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2254 "shasum": ""
2255 },
2256 "require": {
2257 "web-token/jwt-core": "^2.1"
2258 },
2259 "suggest": {
2260 "web-token/jwt-signature-algorithm-ecdsa": "ECDSA Based Signature Algorithms",
2261 "web-token/jwt-signature-algorithm-eddsa": "EdDSA Based Signature Algorithms",
2262 "web-token/jwt-signature-algorithm-experimental": "Experimental Signature Algorithms",
2263 "web-token/jwt-signature-algorithm-hmac": "HMAC Based Signature Algorithms",
2264 "web-token/jwt-signature-algorithm-none": "None Signature Algorithm",
2265 "web-token/jwt-signature-algorithm-rsa": "RSA Based Signature Algorithms"
2266 },
2267 "time": "2021-03-01T19:55:28+00:00",
2268 "type": "library",
2269 "installation-source": "dist",
2270 "autoload": {
2271 "psr-4": {
2272 "Jose\\Component\\Signature\\": ""
2273 }
2274 },
2275 "notification-url": "https://packagist.org/downloads/",
2276 "license": [
2277 "MIT"
2278 ],
2279 "authors": [
2280 {
2281 "name": "Florent Morselli",
2282 "homepage": "https://github.com/Spomky"
2283 },
2284 {
2285 "name": "All contributors",
2286 "homepage": "https://github.com/web-token/jwt-signature/contributors"
2287 }
2288 ],
2289 "description": "Signature component of the JWT Framework.",
2290 "homepage": "https://github.com/web-token",
2291 "keywords": [
2292 "JOSE",
2293 "JWE",
2294 "JWK",
2295 "JWKSet",
2296 "JWS",
2297 "Jot",
2298 "RFC7515",
2299 "RFC7516",
2300 "RFC7517",
2301 "RFC7518",
2302 "RFC7519",
2303 "RFC7520",
2304 "bundle",
2305 "jwa",
2306 "jwt",
2307 "symfony"
2308 ],
2309 "support": {
2310 "source": "https://github.com/web-token/jwt-signature/tree/v2.2.11"
2311 },
2312 "funding": [
2313 {
2314 "url": "https://www.patreon.com/FlorentMorselli",
2315 "type": "patreon"
2316 }
2317 ],
2318 "abandoned": "web-token/jwt-library",
2319 "install-path": "../web-token/jwt-signature"
2320 },
2321 {
2322 "name": "web-token/jwt-signature-algorithm-ecdsa",
2323 "version": "v2.2.11",
2324 "version_normalized": "2.2.11.0",
2325 "source": {
2326 "type": "git",
2327 "url": "https://github.com/web-token/jwt-signature-algorithm-ecdsa.git",
2328 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591"
2329 },
2330 "dist": {
2331 "type": "zip",
2332 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-ecdsa/zipball/44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2333 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2334 "shasum": ""
2335 },
2336 "require": {
2337 "ext-openssl": "*",
2338 "web-token/jwt-signature": "^2.0"
2339 },
2340 "time": "2021-01-21T19:18:03+00:00",
2341 "type": "library",
2342 "installation-source": "dist",
2343 "autoload": {
2344 "psr-4": {
2345 "Jose\\Component\\Signature\\Algorithm\\": ""
2346 }
2347 },
2348 "notification-url": "https://packagist.org/downloads/",
2349 "license": [
2350 "MIT"
2351 ],
2352 "authors": [
2353 {
2354 "name": "Florent Morselli",
2355 "homepage": "https://github.com/Spomky"
2356 },
2357 {
2358 "name": "All contributors",
2359 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2360 }
2361 ],
2362 "description": "ECDSA Based Signature Algorithms the JWT Framework.",
2363 "homepage": "https://github.com/web-token",
2364 "keywords": [
2365 "JOSE",
2366 "JWE",
2367 "JWK",
2368 "JWKSet",
2369 "JWS",
2370 "Jot",
2371 "RFC7515",
2372 "RFC7516",
2373 "RFC7517",
2374 "RFC7518",
2375 "RFC7519",
2376 "RFC7520",
2377 "bundle",
2378 "jwa",
2379 "jwt",
2380 "symfony"
2381 ],
2382 "support": {
2383 "source": "https://github.com/web-token/jwt-signature-algorithm-ecdsa/tree/v2.2.11"
2384 },
2385 "funding": [
2386 {
2387 "url": "https://www.patreon.com/FlorentMorselli",
2388 "type": "patreon"
2389 }
2390 ],
2391 "abandoned": "web-token/jwt-library",
2392 "install-path": "../web-token/jwt-signature-algorithm-ecdsa"
2393 },
2394 {
2395 "name": "web-token/jwt-signature-algorithm-eddsa",
2396 "version": "v2.2.11",
2397 "version_normalized": "2.2.11.0",
2398 "source": {
2399 "type": "git",
2400 "url": "https://github.com/web-token/jwt-signature-algorithm-eddsa.git",
2401 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6"
2402 },
2403 "dist": {
2404 "type": "zip",
2405 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-eddsa/zipball/b805ecca593c56e60e0463bd2cacc9b1341910f6",
2406 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6",
2407 "shasum": ""
2408 },
2409 "require": {
2410 "ext-sodium": "*",
2411 "web-token/jwt-signature": "^2.1"
2412 },
2413 "time": "2021-01-21T19:18:03+00:00",
2414 "type": "library",
2415 "installation-source": "dist",
2416 "autoload": {
2417 "psr-4": {
2418 "Jose\\Component\\Signature\\Algorithm\\": ""
2419 }
2420 },
2421 "notification-url": "https://packagist.org/downloads/",
2422 "license": [
2423 "MIT"
2424 ],
2425 "authors": [
2426 {
2427 "name": "Florent Morselli",
2428 "homepage": "https://github.com/Spomky"
2429 },
2430 {
2431 "name": "All contributors",
2432 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2433 }
2434 ],
2435 "description": "EdDSA Signature Algorithm the JWT Framework.",
2436 "homepage": "https://github.com/web-token",
2437 "keywords": [
2438 "JOSE",
2439 "JWE",
2440 "JWK",
2441 "JWKSet",
2442 "JWS",
2443 "Jot",
2444 "RFC7515",
2445 "RFC7516",
2446 "RFC7517",
2447 "RFC7518",
2448 "RFC7519",
2449 "RFC7520",
2450 "bundle",
2451 "jwa",
2452 "jwt",
2453 "symfony"
2454 ],
2455 "support": {
2456 "source": "https://github.com/web-token/jwt-signature-algorithm-eddsa/tree/v2.2.11"
2457 },
2458 "funding": [
2459 {
2460 "url": "https://www.patreon.com/FlorentMorselli",
2461 "type": "patreon"
2462 }
2463 ],
2464 "abandoned": "web-token/jwt-library",
2465 "install-path": "../web-token/jwt-signature-algorithm-eddsa"
2466 },
2467 {
2468 "name": "web-token/jwt-signature-algorithm-rsa",
2469 "version": "v2.2.11",
2470 "version_normalized": "2.2.11.0",
2471 "source": {
2472 "type": "git",
2473 "url": "https://github.com/web-token/jwt-signature-algorithm-rsa.git",
2474 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0"
2475 },
2476 "dist": {
2477 "type": "zip",
2478 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-rsa/zipball/513ad90eb5ef1886ff176727a769bda4618141b0",
2479 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0",
2480 "shasum": ""
2481 },
2482 "require": {
2483 "brick/math": "^0.8.17|^0.9",
2484 "ext-openssl": "*",
2485 "web-token/jwt-signature": "^2.1"
2486 },
2487 "suggest": {
2488 "ext-bcmath": "GMP or BCMath is highly recommended to improve the library performance",
2489 "ext-gmp": "GMP or BCMath is highly recommended to improve the library performance"
2490 },
2491 "time": "2021-01-21T19:18:03+00:00",
2492 "type": "library",
2493 "installation-source": "dist",
2494 "autoload": {
2495 "psr-4": {
2496 "Jose\\Component\\Signature\\Algorithm\\": ""
2497 }
2498 },
2499 "notification-url": "https://packagist.org/downloads/",
2500 "license": [
2501 "MIT"
2502 ],
2503 "authors": [
2504 {
2505 "name": "Florent Morselli",
2506 "homepage": "https://github.com/Spomky"
2507 },
2508 {
2509 "name": "All contributors",
2510 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2511 }
2512 ],
2513 "description": "RSA Based Signature Algorithms the JWT Framework.",
2514 "homepage": "https://github.com/web-token",
2515 "keywords": [
2516 "JOSE",
2517 "JWE",
2518 "JWK",
2519 "JWKSet",
2520 "JWS",
2521 "Jot",
2522 "RFC7515",
2523 "RFC7516",
2524 "RFC7517",
2525 "RFC7518",
2526 "RFC7519",
2527 "RFC7520",
2528 "bundle",
2529 "jwa",
2530 "jwt",
2531 "symfony"
2532 ],
2533 "support": {
2534 "source": "https://github.com/web-token/jwt-signature-algorithm-rsa/tree/v2.2.11"
2535 },
2536 "funding": [
2537 {
2538 "url": "https://www.patreon.com/FlorentMorselli",
2539 "type": "patreon"
2540 }
2541 ],
2542 "abandoned": "web-token/jwt-library",
2543 "install-path": "../web-token/jwt-signature-algorithm-rsa"
2544 },
2545 {
2546 "name": "woocommerce/action-scheduler",
2547 "version": "3.9.2",
2548 "version_normalized": "3.9.2.0",
2549 "source": {
2550 "type": "git",
2551 "url": "https://github.com/woocommerce/action-scheduler.git",
2552 "reference": "efbb7953f72a433086335b249292f280dd43ddfe"
2553 },
2554 "dist": {
2555 "type": "zip",
2556 "url": "https://api.github.com/repos/woocommerce/action-scheduler/zipball/efbb7953f72a433086335b249292f280dd43ddfe",
2557 "reference": "efbb7953f72a433086335b249292f280dd43ddfe",
2558 "shasum": ""
2559 },
2560 "require": {
2561 "php": ">=7.1"
2562 },
2563 "require-dev": {
2564 "phpunit/phpunit": "^7.5",
2565 "woocommerce/woocommerce-sniffs": "0.1.0",
2566 "wp-cli/wp-cli": "~2.5.0",
2567 "yoast/phpunit-polyfills": "^2.0"
2568 },
2569 "time": "2025-02-03T09:09:30+00:00",
2570 "type": "wordpress-plugin",
2571 "extra": {
2572 "scripts-description": {
2573 "test": "Run unit tests",
2574 "phpcs": "Analyze code against the WordPress coding standards with PHP_CodeSniffer",
2575 "phpcbf": "Fix coding standards warnings/errors automatically with PHP Code Beautifier"
2576 }
2577 },
2578 "installation-source": "dist",
2579 "notification-url": "https://packagist.org/downloads/",
2580 "license": [
2581 "GPL-3.0-or-later"
2582 ],
2583 "description": "Action Scheduler for WordPress and WooCommerce",
2584 "homepage": "https://actionscheduler.org/",
2585 "support": {
2586 "issues": "https://github.com/woocommerce/action-scheduler/issues",
2587 "source": "https://github.com/woocommerce/action-scheduler/tree/3.9.2"
2588 },
2589 "install-path": "../woocommerce/action-scheduler"
2590 }
2591 ],
2592 "dev": false,
2593 "dev-package-names": []
2594 }
2595