PluginProbe
Defender Security – Malware Scanner, Login Security & Firewall / 6.0.0
Defender Security – Malware Scanner, Login Security & Firewall v6.0.0
6.3.0 6.2.3 6.2.4 6.2.0 6.2.1 6.2.2 6.1.0 5.3.1 5.4.0 5.4.1 5.5.0 5.5.1 5.6.0 5.6.1 5.6.2 5.7.0 5.7.1 5.7.2 5.8.0 5.8.1 5.9.0 6.0.0 6.0.1 3.0.1 3.1.0 All 141 releases
defender-security / vendor / composer / installed.json

installed.json in Defender Security – Malware Scanner, Login Security & Firewall 6.0.0, at vendor/composer/installed.json

2,550 lines 92.7 KB
No matching file
Up and down to move Enter to open Esc to close
Raw Download Zip
1 {
2 "packages": [
3 {
4 "name": "beberlei/assert",
5 "version": "v3.3.3",
6 "version_normalized": "3.3.3.0",
7 "source": {
8 "type": "git",
9 "url": "https://github.com/beberlei/assert.git",
10 "reference": "b5fd8eacd8915a1b627b8bfc027803f1939734dd"
11 },
12 "dist": {
13 "type": "zip",
14 "url": "https://api.github.com/repos/beberlei/assert/zipball/b5fd8eacd8915a1b627b8bfc027803f1939734dd",
15 "reference": "b5fd8eacd8915a1b627b8bfc027803f1939734dd",
16 "shasum": ""
17 },
18 "require": {
19 "ext-ctype": "*",
20 "ext-json": "*",
21 "ext-mbstring": "*",
22 "ext-simplexml": "*",
23 "php": "^7.1 || ^8.0"
24 },
25 "require-dev": {
26 "friendsofphp/php-cs-fixer": "*",
27 "phpstan/phpstan": "*",
28 "phpunit/phpunit": ">=6.0.0",
29 "yoast/phpunit-polyfills": "^0.1.0"
30 },
31 "suggest": {
32 "ext-intl": "Needed to allow Assertion::count(), Assertion::isCountable(), Assertion::minCount(), and Assertion::maxCount() to operate on ResourceBundles"
33 },
34 "time": "2024-07-15T13:18:35+00:00",
35 "type": "library",
36 "installation-source": "dist",
37 "autoload": {
38 "files": [
39 "lib/Assert/functions.php"
40 ],
41 "psr-4": {
42 "Assert\\": "lib/Assert"
43 }
44 },
45 "notification-url": "https://packagist.org/downloads/",
46 "license": [
47 "BSD-2-Clause"
48 ],
49 "authors": [
50 {
51 "name": "Benjamin Eberlei",
52 "email": "[email protected]",
53 "role": "Lead Developer"
54 },
55 {
56 "name": "Richard Quadling",
57 "email": "[email protected]",
58 "role": "Collaborator"
59 }
60 ],
61 "description": "Thin assertion library for input validation in business models.",
62 "keywords": [
63 "assert",
64 "assertion",
65 "validation"
66 ],
67 "support": {
68 "issues": "https://github.com/beberlei/assert/issues",
69 "source": "https://github.com/beberlei/assert/tree/v3.3.3"
70 },
71 "install-path": "../beberlei/assert"
72 },
73 {
74 "name": "brick/math",
75 "version": "0.9.3",
76 "version_normalized": "0.9.3.0",
77 "source": {
78 "type": "git",
79 "url": "https://github.com/brick/math.git",
80 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae"
81 },
82 "dist": {
83 "type": "zip",
84 "url": "https://api.github.com/repos/brick/math/zipball/ca57d18f028f84f777b2168cd1911b0dee2343ae",
85 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae",
86 "shasum": ""
87 },
88 "require": {
89 "ext-json": "*",
90 "php": "^7.1 || ^8.0"
91 },
92 "require-dev": {
93 "php-coveralls/php-coveralls": "^2.2",
94 "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
95 "vimeo/psalm": "4.9.2"
96 },
97 "time": "2021-08-15T20:50:18+00:00",
98 "type": "library",
99 "installation-source": "dist",
100 "autoload": {
101 "psr-4": {
102 "Brick\\Math\\": "src/"
103 }
104 },
105 "notification-url": "https://packagist.org/downloads/",
106 "license": [
107 "MIT"
108 ],
109 "description": "Arbitrary-precision arithmetic library",
110 "keywords": [
111 "Arbitrary-precision",
112 "BigInteger",
113 "BigRational",
114 "arithmetic",
115 "bigdecimal",
116 "bignum",
117 "brick",
118 "math"
119 ],
120 "support": {
121 "issues": "https://github.com/brick/math/issues",
122 "source": "https://github.com/brick/math/tree/0.9.3"
123 },
124 "funding": [
125 {
126 "url": "https://github.com/BenMorel",
127 "type": "github"
128 },
129 {
130 "url": "https://tidelift.com/funding/github/packagist/brick/math",
131 "type": "tidelift"
132 }
133 ],
134 "install-path": "../brick/math"
135 },
136 {
137 "name": "cweagans/composer-configurable-plugin",
138 "version": "2.0.0",
139 "version_normalized": "2.0.0.0",
140 "source": {
141 "type": "git",
142 "url": "https://github.com/cweagans/composer-configurable-plugin.git",
143 "reference": "15433906511a108a1806710e988629fd24b89974"
144 },
145 "dist": {
146 "type": "zip",
147 "url": "https://api.github.com/repos/cweagans/composer-configurable-plugin/zipball/15433906511a108a1806710e988629fd24b89974",
148 "reference": "15433906511a108a1806710e988629fd24b89974",
149 "shasum": ""
150 },
151 "require": {
152 "php": ">=8.0.0"
153 },
154 "require-dev": {
155 "codeception/codeception": "~4.0",
156 "codeception/module-asserts": "^2.0",
157 "composer/composer": "~2.0",
158 "php-coveralls/php-coveralls": "~2.0",
159 "php-parallel-lint/php-parallel-lint": "^1.0.0",
160 "phpro/grumphp": "^1.8.0",
161 "sebastian/phpcpd": "^6.0",
162 "squizlabs/php_codesniffer": "^3.0"
163 },
164 "time": "2023-02-12T04:58:58+00:00",
165 "type": "library",
166 "installation-source": "dist",
167 "autoload": {
168 "psr-4": {
169 "cweagans\\Composer\\": "src"
170 }
171 },
172 "notification-url": "https://packagist.org/downloads/",
173 "license": [
174 "BSD-3-Clause"
175 ],
176 "authors": [
177 {
178 "name": "Cameron Eagans",
179 "email": "[email protected]"
180 }
181 ],
182 "description": "Provides a lightweight configuration system for Composer plugins.",
183 "support": {
184 "issues": "https://github.com/cweagans/composer-configurable-plugin/issues",
185 "source": "https://github.com/cweagans/composer-configurable-plugin/tree/2.0.0"
186 },
187 "funding": [
188 {
189 "url": "https://github.com/cweagans",
190 "type": "github"
191 }
192 ],
193 "install-path": "../cweagans/composer-configurable-plugin"
194 },
195 {
196 "name": "cweagans/composer-patches",
197 "version": "2.0.0",
198 "version_normalized": "2.0.0.0",
199 "source": {
200 "type": "git",
201 "url": "https://github.com/cweagans/composer-patches.git",
202 "reference": "bfa6018a5f864653d9ed899b902ea72f858a2cf7"
203 },
204 "dist": {
205 "type": "zip",
206 "url": "https://api.github.com/repos/cweagans/composer-patches/zipball/bfa6018a5f864653d9ed899b902ea72f858a2cf7",
207 "reference": "bfa6018a5f864653d9ed899b902ea72f858a2cf7",
208 "shasum": ""
209 },
210 "require": {
211 "composer-plugin-api": "^2.0",
212 "cweagans/composer-configurable-plugin": "^2.0",
213 "ext-json": "*",
214 "php": ">=8.0.0"
215 },
216 "require-dev": {
217 "codeception/codeception": "~4.0",
218 "codeception/module-asserts": "^2.0",
219 "codeception/module-cli": "^2.0",
220 "codeception/module-filesystem": "^2.0",
221 "composer/composer": "~2.0",
222 "php-coveralls/php-coveralls": "~2.0",
223 "php-parallel-lint/php-parallel-lint": "^1.0.0",
224 "phpro/grumphp": "^1.8.0",
225 "sebastian/phpcpd": "^6.0",
226 "squizlabs/php_codesniffer": "^4.0"
227 },
228 "time": "2025-10-30T23:44:22+00:00",
229 "type": "composer-plugin",
230 "extra": {
231 "_": "The following two lines ensure that composer-patches is loaded as early as possible.",
232 "class": "cweagans\\Composer\\Plugin\\Patches",
233 "plugin-modifies-downloads": true,
234 "plugin-modifies-install-path": true
235 },
236 "installation-source": "dist",
237 "autoload": {
238 "psr-4": {
239 "cweagans\\Composer\\": "src"
240 }
241 },
242 "notification-url": "https://packagist.org/downloads/",
243 "license": [
244 "BSD-3-Clause"
245 ],
246 "authors": [
247 {
248 "name": "Cameron Eagans",
249 "email": "[email protected]"
250 }
251 ],
252 "description": "Provides a way to patch Composer packages.",
253 "support": {
254 "issues": "https://github.com/cweagans/composer-patches/issues",
255 "source": "https://github.com/cweagans/composer-patches/tree/2.0.0"
256 },
257 "funding": [
258 {
259 "url": "https://github.com/cweagans",
260 "type": "github"
261 }
262 ],
263 "install-path": "../cweagans/composer-patches"
264 },
265 {
266 "name": "fgrosse/phpasn1",
267 "version": "v2.5.0",
268 "version_normalized": "2.5.0.0",
269 "source": {
270 "type": "git",
271 "url": "https://github.com/fgrosse/PHPASN1.git",
272 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b"
273 },
274 "dist": {
275 "type": "zip",
276 "url": "https://api.github.com/repos/fgrosse/PHPASN1/zipball/42060ed45344789fb9f21f9f1864fc47b9e3507b",
277 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b",
278 "shasum": ""
279 },
280 "require": {
281 "php": "^7.1 || ^8.0"
282 },
283 "require-dev": {
284 "php-coveralls/php-coveralls": "~2.0",
285 "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
286 },
287 "suggest": {
288 "ext-bcmath": "BCmath is the fallback extension for big integer calculations",
289 "ext-curl": "For loading OID information from the web if they have not bee defined statically",
290 "ext-gmp": "GMP is the preferred extension for big integer calculations",
291 "phpseclib/bcmath_compat": "BCmath polyfill for servers where neither GMP nor BCmath is available"
292 },
293 "time": "2022-12-19T11:08:26+00:00",
294 "type": "library",
295 "extra": {
296 "branch-alias": {
297 "dev-master": "2.0.x-dev"
298 }
299 },
300 "installation-source": "dist",
301 "autoload": {
302 "psr-4": {
303 "FG\\": "lib/"
304 }
305 },
306 "notification-url": "https://packagist.org/downloads/",
307 "license": [
308 "MIT"
309 ],
310 "authors": [
311 {
312 "name": "Friedrich Große",
313 "email": "[email protected]",
314 "homepage": "https://github.com/FGrosse",
315 "role": "Author"
316 },
317 {
318 "name": "All contributors",
319 "homepage": "https://github.com/FGrosse/PHPASN1/contributors"
320 }
321 ],
322 "description": "A PHP Framework that allows you to encode and decode arbitrary ASN.1 structures using the ITU-T X.690 Encoding Rules.",
323 "homepage": "https://github.com/FGrosse/PHPASN1",
324 "keywords": [
325 "DER",
326 "asn.1",
327 "asn1",
328 "ber",
329 "binary",
330 "decoding",
331 "encoding",
332 "x.509",
333 "x.690",
334 "x509",
335 "x690"
336 ],
337 "support": {
338 "issues": "https://github.com/fgrosse/PHPASN1/issues",
339 "source": "https://github.com/fgrosse/PHPASN1/tree/v2.5.0"
340 },
341 "abandoned": true,
342 "install-path": "../fgrosse/phpasn1"
343 },
344 {
345 "name": "gettext/gettext",
346 "version": "v5.7.3",
347 "version_normalized": "5.7.3.0",
348 "source": {
349 "type": "git",
350 "url": "https://github.com/php-gettext/Gettext.git",
351 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1"
352 },
353 "dist": {
354 "type": "zip",
355 "url": "https://api.github.com/repos/php-gettext/Gettext/zipball/95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
356 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
357 "shasum": ""
358 },
359 "require": {
360 "gettext/languages": "^2.3",
361 "php": "^7.2|^8.0"
362 },
363 "require-dev": {
364 "brick/varexporter": "^0.3.5",
365 "friendsofphp/php-cs-fixer": "^3.2",
366 "oscarotero/php-cs-fixer-config": "^2.0",
367 "phpunit/phpunit": "^8.0|^9.0",
368 "squizlabs/php_codesniffer": "^3.0"
369 },
370 "time": "2024-12-01T10:18:08+00:00",
371 "type": "library",
372 "installation-source": "dist",
373 "autoload": {
374 "psr-4": {
375 "Gettext\\": "src"
376 }
377 },
378 "notification-url": "https://packagist.org/downloads/",
379 "license": [
380 "MIT"
381 ],
382 "authors": [
383 {
384 "name": "Oscar Otero",
385 "email": "[email protected]",
386 "homepage": "http://oscarotero.com",
387 "role": "Developer"
388 }
389 ],
390 "description": "PHP gettext manager",
391 "homepage": "https://github.com/php-gettext/Gettext",
392 "keywords": [
393 "JS",
394 "gettext",
395 "i18n",
396 "mo",
397 "po",
398 "translation"
399 ],
400 "support": {
401 "email": "[email protected]",
402 "issues": "https://github.com/php-gettext/Gettext/issues",
403 "source": "https://github.com/php-gettext/Gettext/tree/v5.7.3"
404 },
405 "funding": [
406 {
407 "url": "https://paypal.me/oscarotero",
408 "type": "custom"
409 },
410 {
411 "url": "https://github.com/oscarotero",
412 "type": "github"
413 },
414 {
415 "url": "https://www.patreon.com/misteroom",
416 "type": "patreon"
417 }
418 ],
419 "install-path": "../gettext/gettext"
420 },
421 {
422 "name": "gettext/languages",
423 "version": "2.12.1",
424 "version_normalized": "2.12.1.0",
425 "source": {
426 "type": "git",
427 "url": "https://github.com/php-gettext/Languages.git",
428 "reference": "0b0b0851c55168e1dfb14305735c64019732b5f1"
429 },
430 "dist": {
431 "type": "zip",
432 "url": "https://api.github.com/repos/php-gettext/Languages/zipball/0b0b0851c55168e1dfb14305735c64019732b5f1",
433 "reference": "0b0b0851c55168e1dfb14305735c64019732b5f1",
434 "shasum": ""
435 },
436 "require": {
437 "php": ">=5.3"
438 },
439 "require-dev": {
440 "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.5 || ^8.4"
441 },
442 "time": "2025-03-19T11:14:02+00:00",
443 "bin": [
444 "bin/export-plural-rules",
445 "bin/import-cldr-data"
446 ],
447 "type": "library",
448 "installation-source": "dist",
449 "autoload": {
450 "psr-4": {
451 "Gettext\\Languages\\": "src/"
452 }
453 },
454 "notification-url": "https://packagist.org/downloads/",
455 "license": [
456 "MIT"
457 ],
458 "authors": [
459 {
460 "name": "Michele Locati",
461 "email": "[email protected]",
462 "role": "Developer"
463 }
464 ],
465 "description": "gettext languages with plural rules",
466 "homepage": "https://github.com/php-gettext/Languages",
467 "keywords": [
468 "cldr",
469 "i18n",
470 "internationalization",
471 "l10n",
472 "language",
473 "languages",
474 "localization",
475 "php",
476 "plural",
477 "plural rules",
478 "plurals",
479 "translate",
480 "translations",
481 "unicode"
482 ],
483 "support": {
484 "issues": "https://github.com/php-gettext/Languages/issues",
485 "source": "https://github.com/php-gettext/Languages/tree/2.12.1"
486 },
487 "funding": [
488 {
489 "url": "https://paypal.me/mlocati",
490 "type": "custom"
491 },
492 {
493 "url": "https://github.com/mlocati",
494 "type": "github"
495 }
496 ],
497 "install-path": "../gettext/languages"
498 },
499 {
500 "name": "league/uri",
501 "version": "6.7.2",
502 "version_normalized": "6.7.2.0",
503 "source": {
504 "type": "git",
505 "url": "https://github.com/thephpleague/uri.git",
506 "reference": "d3b50812dd51f3fbf176344cc2981db03d10fe06"
507 },
508 "dist": {
509 "type": "zip",
510 "url": "https://api.github.com/repos/thephpleague/uri/zipball/d3b50812dd51f3fbf176344cc2981db03d10fe06",
511 "reference": "d3b50812dd51f3fbf176344cc2981db03d10fe06",
512 "shasum": ""
513 },
514 "require": {
515 "ext-json": "*",
516 "league/uri-interfaces": "^2.3",
517 "php": "^7.4 || ^8.0",
518 "psr/http-message": "^1.0"
519 },
520 "conflict": {
521 "league/uri-schemes": "^1.0"
522 },
523 "require-dev": {
524 "friendsofphp/php-cs-fixer": "^v3.3.2",
525 "nyholm/psr7": "^1.5",
526 "php-http/psr7-integration-tests": "^1.1",
527 "phpstan/phpstan": "^1.2.0",
528 "phpstan/phpstan-deprecation-rules": "^1.0",
529 "phpstan/phpstan-phpunit": "^1.0.0",
530 "phpstan/phpstan-strict-rules": "^1.1.0",
531 "phpunit/phpunit": "^9.5.10",
532 "psr/http-factory": "^1.0"
533 },
534 "suggest": {
535 "ext-fileinfo": "Needed to create Data URI from a filepath",
536 "ext-intl": "Needed to improve host validation",
537 "league/uri-components": "Needed to easily manipulate URI objects",
538 "psr/http-factory": "Needed to use the URI factory"
539 },
540 "time": "2022-09-13T19:50:42+00:00",
541 "type": "library",
542 "extra": {
543 "branch-alias": {
544 "dev-master": "6.x-dev"
545 }
546 },
547 "installation-source": "dist",
548 "autoload": {
549 "psr-4": {
550 "League\\Uri\\": "src"
551 }
552 },
553 "notification-url": "https://packagist.org/downloads/",
554 "license": [
555 "MIT"
556 ],
557 "authors": [
558 {
559 "name": "Ignace Nyamagana Butera",
560 "email": "[email protected]",
561 "homepage": "https://nyamsprod.com"
562 }
563 ],
564 "description": "URI manipulation library",
565 "homepage": "https://uri.thephpleague.com",
566 "keywords": [
567 "data-uri",
568 "file-uri",
569 "ftp",
570 "hostname",
571 "http",
572 "https",
573 "middleware",
574 "parse_str",
575 "parse_url",
576 "psr-7",
577 "query-string",
578 "querystring",
579 "rfc3986",
580 "rfc3987",
581 "rfc6570",
582 "uri",
583 "uri-template",
584 "url",
585 "ws"
586 ],
587 "support": {
588 "docs": "https://uri.thephpleague.com",
589 "forum": "https://thephpleague.slack.com",
590 "issues": "https://github.com/thephpleague/uri/issues",
591 "source": "https://github.com/thephpleague/uri/tree/6.7.2"
592 },
593 "funding": [
594 {
595 "url": "https://github.com/sponsors/nyamsprod",
596 "type": "github"
597 }
598 ],
599 "install-path": "../league/uri"
600 },
601 {
602 "name": "league/uri-interfaces",
603 "version": "2.3.0",
604 "version_normalized": "2.3.0.0",
605 "source": {
606 "type": "git",
607 "url": "https://github.com/thephpleague/uri-interfaces.git",
608 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383"
609 },
610 "dist": {
611 "type": "zip",
612 "url": "https://api.github.com/repos/thephpleague/uri-interfaces/zipball/00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
613 "reference": "00e7e2943f76d8cb50c7dfdc2f6dee356e15e383",
614 "shasum": ""
615 },
616 "require": {
617 "ext-json": "*",
618 "php": "^7.2 || ^8.0"
619 },
620 "require-dev": {
621 "friendsofphp/php-cs-fixer": "^2.19",
622 "phpstan/phpstan": "^0.12.90",
623 "phpstan/phpstan-phpunit": "^0.12.19",
624 "phpstan/phpstan-strict-rules": "^0.12.9",
625 "phpunit/phpunit": "^8.5.15 || ^9.5"
626 },
627 "suggest": {
628 "ext-intl": "to use the IDNA feature",
629 "symfony/intl": "to use the IDNA feature via Symfony Polyfill"
630 },
631 "time": "2021-06-28T04:27:21+00:00",
632 "type": "library",
633 "extra": {
634 "branch-alias": {
635 "dev-master": "2.x-dev"
636 }
637 },
638 "installation-source": "dist",
639 "autoload": {
640 "psr-4": {
641 "League\\Uri\\": "src/"
642 }
643 },
644 "notification-url": "https://packagist.org/downloads/",
645 "license": [
646 "MIT"
647 ],
648 "authors": [
649 {
650 "name": "Ignace Nyamagana Butera",
651 "email": "[email protected]",
652 "homepage": "https://nyamsprod.com"
653 }
654 ],
655 "description": "Common interface for URI representation",
656 "homepage": "http://github.com/thephpleague/uri-interfaces",
657 "keywords": [
658 "rfc3986",
659 "rfc3987",
660 "uri",
661 "url"
662 ],
663 "support": {
664 "issues": "https://github.com/thephpleague/uri-interfaces/issues",
665 "source": "https://github.com/thephpleague/uri-interfaces/tree/2.3.0"
666 },
667 "funding": [
668 {
669 "url": "https://github.com/sponsors/nyamsprod",
670 "type": "github"
671 }
672 ],
673 "install-path": "../league/uri-interfaces"
674 },
675 {
676 "name": "nyholm/psr7",
677 "version": "1.8.2",
678 "version_normalized": "1.8.2.0",
679 "source": {
680 "type": "git",
681 "url": "https://github.com/Nyholm/psr7.git",
682 "reference": "a71f2b11690f4b24d099d6b16690a90ae14fc6f3"
683 },
684 "dist": {
685 "type": "zip",
686 "url": "https://api.github.com/repos/Nyholm/psr7/zipball/a71f2b11690f4b24d099d6b16690a90ae14fc6f3",
687 "reference": "a71f2b11690f4b24d099d6b16690a90ae14fc6f3",
688 "shasum": ""
689 },
690 "require": {
691 "php": ">=7.2",
692 "psr/http-factory": "^1.0",
693 "psr/http-message": "^1.1 || ^2.0"
694 },
695 "provide": {
696 "php-http/message-factory-implementation": "1.0",
697 "psr/http-factory-implementation": "1.0",
698 "psr/http-message-implementation": "1.0"
699 },
700 "require-dev": {
701 "http-interop/http-factory-tests": "^0.9",
702 "php-http/message-factory": "^1.0",
703 "php-http/psr7-integration-tests": "^1.0",
704 "phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
705 "symfony/error-handler": "^4.4"
706 },
707 "time": "2024-09-09T07:06:30+00:00",
708 "type": "library",
709 "extra": {
710 "branch-alias": {
711 "dev-master": "1.8-dev"
712 }
713 },
714 "installation-source": "dist",
715 "autoload": {
716 "psr-4": {
717 "Nyholm\\Psr7\\": "src/"
718 }
719 },
720 "notification-url": "https://packagist.org/downloads/",
721 "license": [
722 "MIT"
723 ],
724 "authors": [
725 {
726 "name": "Tobias Nyholm",
727 "email": "[email protected]"
728 },
729 {
730 "name": "Martijn van der Ven",
731 "email": "[email protected]"
732 }
733 ],
734 "description": "A fast PHP7 implementation of PSR-7",
735 "homepage": "https://tnyholm.se",
736 "keywords": [
737 "psr-17",
738 "psr-7"
739 ],
740 "support": {
741 "issues": "https://github.com/Nyholm/psr7/issues",
742 "source": "https://github.com/Nyholm/psr7/tree/1.8.2"
743 },
744 "funding": [
745 {
746 "url": "https://github.com/Zegnat",
747 "type": "github"
748 },
749 {
750 "url": "https://github.com/nyholm",
751 "type": "github"
752 }
753 ],
754 "install-path": "../nyholm/psr7"
755 },
756 {
757 "name": "nyholm/psr7-server",
758 "version": "1.1.0",
759 "version_normalized": "1.1.0.0",
760 "source": {
761 "type": "git",
762 "url": "https://github.com/Nyholm/psr7-server.git",
763 "reference": "4335801d851f554ca43fa6e7d2602141538854dc"
764 },
765 "dist": {
766 "type": "zip",
767 "url": "https://api.github.com/repos/Nyholm/psr7-server/zipball/4335801d851f554ca43fa6e7d2602141538854dc",
768 "reference": "4335801d851f554ca43fa6e7d2602141538854dc",
769 "shasum": ""
770 },
771 "require": {
772 "php": "^7.1 || ^8.0",
773 "psr/http-factory": "^1.0",
774 "psr/http-message": "^1.0 || ^2.0"
775 },
776 "require-dev": {
777 "nyholm/nsa": "^1.1",
778 "nyholm/psr7": "^1.3",
779 "phpunit/phpunit": "^7.0 || ^8.5 || ^9.3"
780 },
781 "time": "2023-11-08T09:30:43+00:00",
782 "type": "library",
783 "installation-source": "dist",
784 "autoload": {
785 "psr-4": {
786 "Nyholm\\Psr7Server\\": "src/"
787 }
788 },
789 "notification-url": "https://packagist.org/downloads/",
790 "license": [
791 "MIT"
792 ],
793 "authors": [
794 {
795 "name": "Tobias Nyholm",
796 "email": "[email protected]"
797 },
798 {
799 "name": "Martijn van der Ven",
800 "email": "[email protected]"
801 }
802 ],
803 "description": "Helper classes to handle PSR-7 server requests",
804 "homepage": "http://tnyholm.se",
805 "keywords": [
806 "psr-17",
807 "psr-7"
808 ],
809 "support": {
810 "issues": "https://github.com/Nyholm/psr7-server/issues",
811 "source": "https://github.com/Nyholm/psr7-server/tree/1.1.0"
812 },
813 "funding": [
814 {
815 "url": "https://github.com/Zegnat",
816 "type": "github"
817 },
818 {
819 "url": "https://github.com/nyholm",
820 "type": "github"
821 }
822 ],
823 "install-path": "../nyholm/psr7-server"
824 },
825 {
826 "name": "psr/http-client",
827 "version": "1.0.3",
828 "version_normalized": "1.0.3.0",
829 "source": {
830 "type": "git",
831 "url": "https://github.com/php-fig/http-client.git",
832 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90"
833 },
834 "dist": {
835 "type": "zip",
836 "url": "https://api.github.com/repos/php-fig/http-client/zipball/bb5906edc1c324c9a05aa0873d40117941e5fa90",
837 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90",
838 "shasum": ""
839 },
840 "require": {
841 "php": "^7.0 || ^8.0",
842 "psr/http-message": "^1.0 || ^2.0"
843 },
844 "time": "2023-09-23T14:17:50+00:00",
845 "type": "library",
846 "extra": {
847 "branch-alias": {
848 "dev-master": "1.0.x-dev"
849 }
850 },
851 "installation-source": "dist",
852 "autoload": {
853 "psr-4": {
854 "Psr\\Http\\Client\\": "src/"
855 }
856 },
857 "notification-url": "https://packagist.org/downloads/",
858 "license": [
859 "MIT"
860 ],
861 "authors": [
862 {
863 "name": "PHP-FIG",
864 "homepage": "https://www.php-fig.org/"
865 }
866 ],
867 "description": "Common interface for HTTP clients",
868 "homepage": "https://github.com/php-fig/http-client",
869 "keywords": [
870 "http",
871 "http-client",
872 "psr",
873 "psr-18"
874 ],
875 "support": {
876 "source": "https://github.com/php-fig/http-client"
877 },
878 "install-path": "../psr/http-client"
879 },
880 {
881 "name": "psr/http-factory",
882 "version": "1.1.0",
883 "version_normalized": "1.1.0.0",
884 "source": {
885 "type": "git",
886 "url": "https://github.com/php-fig/http-factory.git",
887 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a"
888 },
889 "dist": {
890 "type": "zip",
891 "url": "https://api.github.com/repos/php-fig/http-factory/zipball/2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
892 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
893 "shasum": ""
894 },
895 "require": {
896 "php": ">=7.1",
897 "psr/http-message": "^1.0 || ^2.0"
898 },
899 "time": "2024-04-15T12:06:14+00:00",
900 "type": "library",
901 "extra": {
902 "branch-alias": {
903 "dev-master": "1.0.x-dev"
904 }
905 },
906 "installation-source": "dist",
907 "autoload": {
908 "psr-4": {
909 "Psr\\Http\\Message\\": "src/"
910 }
911 },
912 "notification-url": "https://packagist.org/downloads/",
913 "license": [
914 "MIT"
915 ],
916 "authors": [
917 {
918 "name": "PHP-FIG",
919 "homepage": "https://www.php-fig.org/"
920 }
921 ],
922 "description": "PSR-17: Common interfaces for PSR-7 HTTP message factories",
923 "keywords": [
924 "factory",
925 "http",
926 "message",
927 "psr",
928 "psr-17",
929 "psr-7",
930 "request",
931 "response"
932 ],
933 "support": {
934 "source": "https://github.com/php-fig/http-factory"
935 },
936 "install-path": "../psr/http-factory"
937 },
938 {
939 "name": "psr/http-message",
940 "version": "1.1",
941 "version_normalized": "1.1.0.0",
942 "source": {
943 "type": "git",
944 "url": "https://github.com/php-fig/http-message.git",
945 "reference": "cb6ce4845ce34a8ad9e68117c10ee90a29919eba"
946 },
947 "dist": {
948 "type": "zip",
949 "url": "https://api.github.com/repos/php-fig/http-message/zipball/cb6ce4845ce34a8ad9e68117c10ee90a29919eba",
950 "reference": "cb6ce4845ce34a8ad9e68117c10ee90a29919eba",
951 "shasum": ""
952 },
953 "require": {
954 "php": "^7.2 || ^8.0"
955 },
956 "time": "2023-04-04T09:50:52+00:00",
957 "type": "library",
958 "extra": {
959 "branch-alias": {
960 "dev-master": "1.1.x-dev"
961 }
962 },
963 "installation-source": "dist",
964 "autoload": {
965 "psr-4": {
966 "Psr\\Http\\Message\\": "src/"
967 }
968 },
969 "notification-url": "https://packagist.org/downloads/",
970 "license": [
971 "MIT"
972 ],
973 "authors": [
974 {
975 "name": "PHP-FIG",
976 "homepage": "http://www.php-fig.org/"
977 }
978 ],
979 "description": "Common interface for HTTP messages",
980 "homepage": "https://github.com/php-fig/http-message",
981 "keywords": [
982 "http",
983 "http-message",
984 "psr",
985 "psr-7",
986 "request",
987 "response"
988 ],
989 "support": {
990 "source": "https://github.com/php-fig/http-message/tree/1.1"
991 },
992 "install-path": "../psr/http-message"
993 },
994 {
995 "name": "psr/log",
996 "version": "1.1.4",
997 "version_normalized": "1.1.4.0",
998 "source": {
999 "type": "git",
1000 "url": "https://github.com/php-fig/log.git",
1001 "reference": "d49695b909c3b7628b6289db5479a1c204601f11"
1002 },
1003 "dist": {
1004 "type": "zip",
1005 "url": "https://api.github.com/repos/php-fig/log/zipball/d49695b909c3b7628b6289db5479a1c204601f11",
1006 "reference": "d49695b909c3b7628b6289db5479a1c204601f11",
1007 "shasum": ""
1008 },
1009 "require": {
1010 "php": ">=5.3.0"
1011 },
1012 "time": "2021-05-03T11:20:27+00:00",
1013 "type": "library",
1014 "extra": {
1015 "branch-alias": {
1016 "dev-master": "1.1.x-dev"
1017 }
1018 },
1019 "installation-source": "dist",
1020 "autoload": {
1021 "psr-4": {
1022 "Psr\\Log\\": "Psr/Log/"
1023 }
1024 },
1025 "notification-url": "https://packagist.org/downloads/",
1026 "license": [
1027 "MIT"
1028 ],
1029 "authors": [
1030 {
1031 "name": "PHP-FIG",
1032 "homepage": "https://www.php-fig.org/"
1033 }
1034 ],
1035 "description": "Common interface for logging libraries",
1036 "homepage": "https://github.com/php-fig/log",
1037 "keywords": [
1038 "log",
1039 "psr",
1040 "psr-3"
1041 ],
1042 "support": {
1043 "source": "https://github.com/php-fig/log/tree/1.1.4"
1044 },
1045 "install-path": "../psr/log"
1046 },
1047 {
1048 "name": "ramsey/collection",
1049 "version": "1.3.0",
1050 "version_normalized": "1.3.0.0",
1051 "source": {
1052 "type": "git",
1053 "url": "https://github.com/ramsey/collection.git",
1054 "reference": "ad7475d1c9e70b190ecffc58f2d989416af339b4"
1055 },
1056 "dist": {
1057 "type": "zip",
1058 "url": "https://api.github.com/repos/ramsey/collection/zipball/ad7475d1c9e70b190ecffc58f2d989416af339b4",
1059 "reference": "ad7475d1c9e70b190ecffc58f2d989416af339b4",
1060 "shasum": ""
1061 },
1062 "require": {
1063 "php": "^7.4 || ^8.0",
1064 "symfony/polyfill-php81": "^1.23"
1065 },
1066 "require-dev": {
1067 "captainhook/plugin-composer": "^5.3",
1068 "ergebnis/composer-normalize": "^2.28.3",
1069 "fakerphp/faker": "^1.21",
1070 "hamcrest/hamcrest-php": "^2.0",
1071 "jangregor/phpstan-prophecy": "^1.0",
1072 "mockery/mockery": "^1.5",
1073 "php-parallel-lint/php-console-highlighter": "^1.0",
1074 "php-parallel-lint/php-parallel-lint": "^1.3",
1075 "phpcsstandards/phpcsutils": "^1.0.0-rc1",
1076 "phpspec/prophecy-phpunit": "^2.0",
1077 "phpstan/extension-installer": "^1.2",
1078 "phpstan/phpstan": "^1.9",
1079 "phpstan/phpstan-mockery": "^1.1",
1080 "phpstan/phpstan-phpunit": "^1.3",
1081 "phpunit/phpunit": "^9.5",
1082 "psalm/plugin-mockery": "^1.1",
1083 "psalm/plugin-phpunit": "^0.18.4",
1084 "ramsey/coding-standard": "^2.0.3",
1085 "ramsey/conventional-commits": "^1.3",
1086 "vimeo/psalm": "^5.4"
1087 },
1088 "time": "2022-12-27T19:12:24+00:00",
1089 "type": "library",
1090 "extra": {
1091 "captainhook": {
1092 "force-install": true
1093 },
1094 "ramsey/conventional-commits": {
1095 "configFile": "conventional-commits.json"
1096 }
1097 },
1098 "installation-source": "dist",
1099 "autoload": {
1100 "psr-4": {
1101 "Ramsey\\Collection\\": "src/"
1102 }
1103 },
1104 "notification-url": "https://packagist.org/downloads/",
1105 "license": [
1106 "MIT"
1107 ],
1108 "authors": [
1109 {
1110 "name": "Ben Ramsey",
1111 "email": "[email protected]",
1112 "homepage": "https://benramsey.com"
1113 }
1114 ],
1115 "description": "A PHP library for representing and manipulating collections.",
1116 "keywords": [
1117 "array",
1118 "collection",
1119 "hash",
1120 "map",
1121 "queue",
1122 "set"
1123 ],
1124 "support": {
1125 "issues": "https://github.com/ramsey/collection/issues",
1126 "source": "https://github.com/ramsey/collection/tree/1.3.0"
1127 },
1128 "funding": [
1129 {
1130 "url": "https://github.com/ramsey",
1131 "type": "github"
1132 },
1133 {
1134 "url": "https://tidelift.com/funding/github/packagist/ramsey/collection",
1135 "type": "tidelift"
1136 }
1137 ],
1138 "install-path": "../ramsey/collection"
1139 },
1140 {
1141 "name": "ramsey/uuid",
1142 "version": "4.9.2",
1143 "version_normalized": "4.9.2.0",
1144 "source": {
1145 "type": "git",
1146 "url": "https://github.com/ramsey/uuid.git",
1147 "reference": "8429c78ca35a09f27565311b98101e2826affde0"
1148 },
1149 "dist": {
1150 "type": "zip",
1151 "url": "https://api.github.com/repos/ramsey/uuid/zipball/8429c78ca35a09f27565311b98101e2826affde0",
1152 "reference": "8429c78ca35a09f27565311b98101e2826affde0",
1153 "shasum": ""
1154 },
1155 "require": {
1156 "brick/math": "^0.8.16 || ^0.9 || ^0.10 || ^0.11 || ^0.12 || ^0.13 || ^0.14",
1157 "php": "^8.0",
1158 "ramsey/collection": "^1.2 || ^2.0"
1159 },
1160 "replace": {
1161 "rhumsaa/uuid": "self.version"
1162 },
1163 "require-dev": {
1164 "captainhook/captainhook": "^5.25",
1165 "captainhook/plugin-composer": "^5.3",
1166 "dealerdirect/phpcodesniffer-composer-installer": "^1.0",
1167 "ergebnis/composer-normalize": "^2.47",
1168 "mockery/mockery": "^1.6",
1169 "paragonie/random-lib": "^2",
1170 "php-mock/php-mock": "^2.6",
1171 "php-mock/php-mock-mockery": "^1.5",
1172 "php-parallel-lint/php-parallel-lint": "^1.4.0",
1173 "phpbench/phpbench": "^1.2.14",
1174 "phpstan/extension-installer": "^1.4",
1175 "phpstan/phpstan": "^2.1",
1176 "phpstan/phpstan-mockery": "^2.0",
1177 "phpstan/phpstan-phpunit": "^2.0",
1178 "phpunit/phpunit": "^9.6",
1179 "slevomat/coding-standard": "^8.18",
1180 "squizlabs/php_codesniffer": "^3.13"
1181 },
1182 "suggest": {
1183 "ext-bcmath": "Enables faster math with arbitrary-precision integers using BCMath.",
1184 "ext-gmp": "Enables faster math with arbitrary-precision integers using GMP.",
1185 "ext-uuid": "Enables the use of PeclUuidTimeGenerator and PeclUuidRandomGenerator.",
1186 "paragonie/random-lib": "Provides RandomLib for use with the RandomLibAdapter",
1187 "ramsey/uuid-doctrine": "Allows the use of Ramsey\\Uuid\\Uuid as Doctrine field type."
1188 },
1189 "time": "2025-12-14T04:43:48+00:00",
1190 "type": "library",
1191 "extra": {
1192 "captainhook": {
1193 "force-install": true
1194 }
1195 },
1196 "installation-source": "dist",
1197 "autoload": {
1198 "files": [
1199 "src/functions.php"
1200 ],
1201 "psr-4": {
1202 "Ramsey\\Uuid\\": "src/"
1203 }
1204 },
1205 "notification-url": "https://packagist.org/downloads/",
1206 "license": [
1207 "MIT"
1208 ],
1209 "description": "A PHP library for generating and working with universally unique identifiers (UUIDs).",
1210 "keywords": [
1211 "guid",
1212 "identifier",
1213 "uuid"
1214 ],
1215 "support": {
1216 "issues": "https://github.com/ramsey/uuid/issues",
1217 "source": "https://github.com/ramsey/uuid/tree/4.9.2"
1218 },
1219 "install-path": "../ramsey/uuid"
1220 },
1221 {
1222 "name": "spomky-labs/base64url",
1223 "version": "v2.0.4",
1224 "version_normalized": "2.0.4.0",
1225 "source": {
1226 "type": "git",
1227 "url": "https://github.com/Spomky-Labs/base64url.git",
1228 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d"
1229 },
1230 "dist": {
1231 "type": "zip",
1232 "url": "https://api.github.com/repos/Spomky-Labs/base64url/zipball/7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1233 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d",
1234 "shasum": ""
1235 },
1236 "require": {
1237 "php": ">=7.1"
1238 },
1239 "require-dev": {
1240 "phpstan/extension-installer": "^1.0",
1241 "phpstan/phpstan": "^0.11|^0.12",
1242 "phpstan/phpstan-beberlei-assert": "^0.11|^0.12",
1243 "phpstan/phpstan-deprecation-rules": "^0.11|^0.12",
1244 "phpstan/phpstan-phpunit": "^0.11|^0.12",
1245 "phpstan/phpstan-strict-rules": "^0.11|^0.12"
1246 },
1247 "time": "2020-11-03T09:10:25+00:00",
1248 "type": "library",
1249 "installation-source": "dist",
1250 "autoload": {
1251 "psr-4": {
1252 "Base64Url\\": "src/"
1253 }
1254 },
1255 "notification-url": "https://packagist.org/downloads/",
1256 "license": [
1257 "MIT"
1258 ],
1259 "authors": [
1260 {
1261 "name": "Florent Morselli",
1262 "homepage": "https://github.com/Spomky-Labs/base64url/contributors"
1263 }
1264 ],
1265 "description": "Base 64 URL Safe Encoding/Decoding PHP Library",
1266 "homepage": "https://github.com/Spomky-Labs/base64url",
1267 "keywords": [
1268 "base64",
1269 "rfc4648",
1270 "safe",
1271 "url"
1272 ],
1273 "support": {
1274 "issues": "https://github.com/Spomky-Labs/base64url/issues",
1275 "source": "https://github.com/Spomky-Labs/base64url/tree/v2.0.4"
1276 },
1277 "funding": [
1278 {
1279 "url": "https://github.com/Spomky",
1280 "type": "github"
1281 },
1282 {
1283 "url": "https://www.patreon.com/FlorentMorselli",
1284 "type": "patreon"
1285 }
1286 ],
1287 "install-path": "../spomky-labs/base64url"
1288 },
1289 {
1290 "name": "spomky-labs/cbor-php",
1291 "version": "v2.1.0",
1292 "version_normalized": "2.1.0.0",
1293 "source": {
1294 "type": "git",
1295 "url": "https://github.com/Spomky-Labs/cbor-php.git",
1296 "reference": "28e2712cfc0b48fae661a48ffc6896d7abe83684"
1297 },
1298 "dist": {
1299 "type": "zip",
1300 "url": "https://api.github.com/repos/Spomky-Labs/cbor-php/zipball/28e2712cfc0b48fae661a48ffc6896d7abe83684",
1301 "reference": "28e2712cfc0b48fae661a48ffc6896d7abe83684",
1302 "shasum": ""
1303 },
1304 "require": {
1305 "brick/math": "^0.8.15|^0.9.0",
1306 "ext-mbstring": "*",
1307 "php": ">=7.3"
1308 },
1309 "require-dev": {
1310 "ekino/phpstan-banned-code": "^1.0",
1311 "ext-json": "*",
1312 "infection/infection": "^0.18|^0.25",
1313 "phpstan/extension-installer": "^1.1",
1314 "phpstan/phpstan": "^1.0",
1315 "phpstan/phpstan-beberlei-assert": "^1.0",
1316 "phpstan/phpstan-deprecation-rules": "^1.0",
1317 "phpstan/phpstan-phpunit": "^1.0",
1318 "phpstan/phpstan-strict-rules": "^1.0",
1319 "phpunit/phpunit": "^9.5",
1320 "rector/rector": "^0.12",
1321 "roave/security-advisories": "dev-latest",
1322 "symplify/easy-coding-standard": "^10.0"
1323 },
1324 "suggest": {
1325 "ext-bcmath": "GMP or BCMath extensions will drastically improve the library performance. BCMath extension needed to handle the Big Float and Decimal Fraction Tags",
1326 "ext-gmp": "GMP or BCMath extensions will drastically improve the library performance"
1327 },
1328 "time": "2021-12-13T12:46:26+00:00",
1329 "type": "library",
1330 "installation-source": "dist",
1331 "autoload": {
1332 "psr-4": {
1333 "CBOR\\": "src/"
1334 }
1335 },
1336 "notification-url": "https://packagist.org/downloads/",
1337 "license": [
1338 "MIT"
1339 ],
1340 "authors": [
1341 {
1342 "name": "Florent Morselli",
1343 "homepage": "https://github.com/Spomky"
1344 },
1345 {
1346 "name": "All contributors",
1347 "homepage": "https://github.com/Spomky-Labs/cbor-php/contributors"
1348 }
1349 ],
1350 "description": "CBOR Encoder/Decoder for PHP",
1351 "keywords": [
1352 "Concise Binary Object Representation",
1353 "RFC7049",
1354 "cbor"
1355 ],
1356 "support": {
1357 "issues": "https://github.com/Spomky-Labs/cbor-php/issues",
1358 "source": "https://github.com/Spomky-Labs/cbor-php/tree/v2.1.0"
1359 },
1360 "funding": [
1361 {
1362 "url": "https://github.com/Spomky",
1363 "type": "github"
1364 },
1365 {
1366 "url": "https://www.patreon.com/FlorentMorselli",
1367 "type": "patreon"
1368 }
1369 ],
1370 "install-path": "../spomky-labs/cbor-php"
1371 },
1372 {
1373 "name": "symfony/polyfill-php80",
1374 "version": "v1.33.0",
1375 "version_normalized": "1.33.0.0",
1376 "source": {
1377 "type": "git",
1378 "url": "https://github.com/symfony/polyfill-php80.git",
1379 "reference": "0cc9dd0f17f61d8131e7df6b84bd344899fe2608"
1380 },
1381 "dist": {
1382 "type": "zip",
1383 "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/0cc9dd0f17f61d8131e7df6b84bd344899fe2608",
1384 "reference": "0cc9dd0f17f61d8131e7df6b84bd344899fe2608",
1385 "shasum": ""
1386 },
1387 "require": {
1388 "php": ">=7.2"
1389 },
1390 "time": "2025-01-02T08:10:11+00:00",
1391 "type": "library",
1392 "extra": {
1393 "thanks": {
1394 "url": "https://github.com/symfony/polyfill",
1395 "name": "symfony/polyfill"
1396 }
1397 },
1398 "installation-source": "dist",
1399 "autoload": {
1400 "files": [
1401 "bootstrap.php"
1402 ],
1403 "psr-4": {
1404 "Symfony\\Polyfill\\Php80\\": ""
1405 },
1406 "classmap": [
1407 "Resources/stubs"
1408 ]
1409 },
1410 "notification-url": "https://packagist.org/downloads/",
1411 "license": [
1412 "MIT"
1413 ],
1414 "authors": [
1415 {
1416 "name": "Ion Bazan",
1417 "email": "[email protected]"
1418 },
1419 {
1420 "name": "Nicolas Grekas",
1421 "email": "[email protected]"
1422 },
1423 {
1424 "name": "Symfony Community",
1425 "homepage": "https://symfony.com/contributors"
1426 }
1427 ],
1428 "description": "Symfony polyfill backporting some PHP 8.0+ features to lower PHP versions",
1429 "homepage": "https://symfony.com",
1430 "keywords": [
1431 "compatibility",
1432 "polyfill",
1433 "portable",
1434 "shim"
1435 ],
1436 "support": {
1437 "source": "https://github.com/symfony/polyfill-php80/tree/v1.33.0"
1438 },
1439 "funding": [
1440 {
1441 "url": "https://symfony.com/sponsor",
1442 "type": "custom"
1443 },
1444 {
1445 "url": "https://github.com/fabpot",
1446 "type": "github"
1447 },
1448 {
1449 "url": "https://github.com/nicolas-grekas",
1450 "type": "github"
1451 },
1452 {
1453 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1454 "type": "tidelift"
1455 }
1456 ],
1457 "install-path": "../symfony/polyfill-php80"
1458 },
1459 {
1460 "name": "symfony/polyfill-php81",
1461 "version": "v1.33.0",
1462 "version_normalized": "1.33.0.0",
1463 "source": {
1464 "type": "git",
1465 "url": "https://github.com/symfony/polyfill-php81.git",
1466 "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c"
1467 },
1468 "dist": {
1469 "type": "zip",
1470 "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
1471 "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
1472 "shasum": ""
1473 },
1474 "require": {
1475 "php": ">=7.2"
1476 },
1477 "time": "2024-09-09T11:45:10+00:00",
1478 "type": "library",
1479 "extra": {
1480 "thanks": {
1481 "url": "https://github.com/symfony/polyfill",
1482 "name": "symfony/polyfill"
1483 }
1484 },
1485 "installation-source": "dist",
1486 "autoload": {
1487 "files": [
1488 "bootstrap.php"
1489 ],
1490 "psr-4": {
1491 "Symfony\\Polyfill\\Php81\\": ""
1492 },
1493 "classmap": [
1494 "Resources/stubs"
1495 ]
1496 },
1497 "notification-url": "https://packagist.org/downloads/",
1498 "license": [
1499 "MIT"
1500 ],
1501 "authors": [
1502 {
1503 "name": "Nicolas Grekas",
1504 "email": "[email protected]"
1505 },
1506 {
1507 "name": "Symfony Community",
1508 "homepage": "https://symfony.com/contributors"
1509 }
1510 ],
1511 "description": "Symfony polyfill backporting some PHP 8.1+ features to lower PHP versions",
1512 "homepage": "https://symfony.com",
1513 "keywords": [
1514 "compatibility",
1515 "polyfill",
1516 "portable",
1517 "shim"
1518 ],
1519 "support": {
1520 "source": "https://github.com/symfony/polyfill-php81/tree/v1.33.0"
1521 },
1522 "funding": [
1523 {
1524 "url": "https://symfony.com/sponsor",
1525 "type": "custom"
1526 },
1527 {
1528 "url": "https://github.com/fabpot",
1529 "type": "github"
1530 },
1531 {
1532 "url": "https://github.com/nicolas-grekas",
1533 "type": "github"
1534 },
1535 {
1536 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1537 "type": "tidelift"
1538 }
1539 ],
1540 "install-path": "../symfony/polyfill-php81"
1541 },
1542 {
1543 "name": "symfony/process",
1544 "version": "v5.4.47",
1545 "version_normalized": "5.4.47.0",
1546 "source": {
1547 "type": "git",
1548 "url": "https://github.com/symfony/process.git",
1549 "reference": "5d1662fb32ebc94f17ddb8d635454a776066733d"
1550 },
1551 "dist": {
1552 "type": "zip",
1553 "url": "https://api.github.com/repos/symfony/process/zipball/5d1662fb32ebc94f17ddb8d635454a776066733d",
1554 "reference": "5d1662fb32ebc94f17ddb8d635454a776066733d",
1555 "shasum": ""
1556 },
1557 "require": {
1558 "php": ">=7.2.5",
1559 "symfony/polyfill-php80": "^1.16"
1560 },
1561 "time": "2024-11-06T11:36:42+00:00",
1562 "type": "library",
1563 "installation-source": "dist",
1564 "autoload": {
1565 "psr-4": {
1566 "Symfony\\Component\\Process\\": ""
1567 },
1568 "exclude-from-classmap": [
1569 "/Tests/"
1570 ]
1571 },
1572 "notification-url": "https://packagist.org/downloads/",
1573 "license": [
1574 "MIT"
1575 ],
1576 "authors": [
1577 {
1578 "name": "Fabien Potencier",
1579 "email": "[email protected]"
1580 },
1581 {
1582 "name": "Symfony Community",
1583 "homepage": "https://symfony.com/contributors"
1584 }
1585 ],
1586 "description": "Executes commands in sub-processes",
1587 "homepage": "https://symfony.com",
1588 "support": {
1589 "source": "https://github.com/symfony/process/tree/v5.4.47"
1590 },
1591 "funding": [
1592 {
1593 "url": "https://symfony.com/sponsor",
1594 "type": "custom"
1595 },
1596 {
1597 "url": "https://github.com/fabpot",
1598 "type": "github"
1599 },
1600 {
1601 "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
1602 "type": "tidelift"
1603 }
1604 ],
1605 "install-path": "../symfony/process"
1606 },
1607 {
1608 "name": "thecodingmachine/safe",
1609 "version": "v1.3.3",
1610 "version_normalized": "1.3.3.0",
1611 "source": {
1612 "type": "git",
1613 "url": "https://github.com/thecodingmachine/safe.git",
1614 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc"
1615 },
1616 "dist": {
1617 "type": "zip",
1618 "url": "https://api.github.com/repos/thecodingmachine/safe/zipball/a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1619 "reference": "a8ab0876305a4cdaef31b2350fcb9811b5608dbc",
1620 "shasum": ""
1621 },
1622 "require": {
1623 "php": ">=7.2"
1624 },
1625 "require-dev": {
1626 "phpstan/phpstan": "^0.12",
1627 "squizlabs/php_codesniffer": "^3.2",
1628 "thecodingmachine/phpstan-strict-rules": "^0.12"
1629 },
1630 "time": "2020-10-28T17:51:34+00:00",
1631 "type": "library",
1632 "extra": {
1633 "branch-alias": {
1634 "dev-master": "0.1-dev"
1635 }
1636 },
1637 "installation-source": "dist",
1638 "autoload": {
1639 "files": [
1640 "deprecated/apc.php",
1641 "deprecated/libevent.php",
1642 "deprecated/mssql.php",
1643 "deprecated/stats.php",
1644 "lib/special_cases.php",
1645 "generated/apache.php",
1646 "generated/apcu.php",
1647 "generated/array.php",
1648 "generated/bzip2.php",
1649 "generated/calendar.php",
1650 "generated/classobj.php",
1651 "generated/com.php",
1652 "generated/cubrid.php",
1653 "generated/curl.php",
1654 "generated/datetime.php",
1655 "generated/dir.php",
1656 "generated/eio.php",
1657 "generated/errorfunc.php",
1658 "generated/exec.php",
1659 "generated/fileinfo.php",
1660 "generated/filesystem.php",
1661 "generated/filter.php",
1662 "generated/fpm.php",
1663 "generated/ftp.php",
1664 "generated/funchand.php",
1665 "generated/gmp.php",
1666 "generated/gnupg.php",
1667 "generated/hash.php",
1668 "generated/ibase.php",
1669 "generated/ibmDb2.php",
1670 "generated/iconv.php",
1671 "generated/image.php",
1672 "generated/imap.php",
1673 "generated/info.php",
1674 "generated/ingres-ii.php",
1675 "generated/inotify.php",
1676 "generated/json.php",
1677 "generated/ldap.php",
1678 "generated/libxml.php",
1679 "generated/lzf.php",
1680 "generated/mailparse.php",
1681 "generated/mbstring.php",
1682 "generated/misc.php",
1683 "generated/msql.php",
1684 "generated/mysql.php",
1685 "generated/mysqli.php",
1686 "generated/mysqlndMs.php",
1687 "generated/mysqlndQc.php",
1688 "generated/network.php",
1689 "generated/oci8.php",
1690 "generated/opcache.php",
1691 "generated/openssl.php",
1692 "generated/outcontrol.php",
1693 "generated/password.php",
1694 "generated/pcntl.php",
1695 "generated/pcre.php",
1696 "generated/pdf.php",
1697 "generated/pgsql.php",
1698 "generated/posix.php",
1699 "generated/ps.php",
1700 "generated/pspell.php",
1701 "generated/readline.php",
1702 "generated/rpminfo.php",
1703 "generated/rrd.php",
1704 "generated/sem.php",
1705 "generated/session.php",
1706 "generated/shmop.php",
1707 "generated/simplexml.php",
1708 "generated/sockets.php",
1709 "generated/sodium.php",
1710 "generated/solr.php",
1711 "generated/spl.php",
1712 "generated/sqlsrv.php",
1713 "generated/ssdeep.php",
1714 "generated/ssh2.php",
1715 "generated/stream.php",
1716 "generated/strings.php",
1717 "generated/swoole.php",
1718 "generated/uodbc.php",
1719 "generated/uopz.php",
1720 "generated/url.php",
1721 "generated/var.php",
1722 "generated/xdiff.php",
1723 "generated/xml.php",
1724 "generated/xmlrpc.php",
1725 "generated/yaml.php",
1726 "generated/yaz.php",
1727 "generated/zip.php",
1728 "generated/zlib.php"
1729 ],
1730 "psr-4": {
1731 "Safe\\": [
1732 "lib/",
1733 "deprecated/",
1734 "generated/"
1735 ]
1736 }
1737 },
1738 "notification-url": "https://packagist.org/downloads/",
1739 "license": [
1740 "MIT"
1741 ],
1742 "description": "PHP core functions that throw exceptions instead of returning FALSE on error",
1743 "support": {
1744 "issues": "https://github.com/thecodingmachine/safe/issues",
1745 "source": "https://github.com/thecodingmachine/safe/tree/v1.3.3"
1746 },
1747 "install-path": "../thecodingmachine/safe"
1748 },
1749 {
1750 "name": "vlucas/valitron",
1751 "version": "v1.4.11",
1752 "version_normalized": "1.4.11.0",
1753 "source": {
1754 "type": "git",
1755 "url": "https://github.com/vlucas/valitron.git",
1756 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f"
1757 },
1758 "dist": {
1759 "type": "zip",
1760 "url": "https://api.github.com/repos/vlucas/valitron/zipball/fadce39f5f235755bb9794b2573af2d5bfcba85f",
1761 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f",
1762 "shasum": ""
1763 },
1764 "require": {
1765 "php": ">=5.3.2"
1766 },
1767 "require-dev": {
1768 "phpunit/phpunit": ">=4.8.35"
1769 },
1770 "suggest": {
1771 "ext-mbstring": "It can support the multiple bytes string length."
1772 },
1773 "time": "2022-10-14T11:54:24+00:00",
1774 "type": "library",
1775 "installation-source": "dist",
1776 "autoload": {
1777 "psr-4": {
1778 "Valitron\\": "src/Valitron"
1779 }
1780 },
1781 "notification-url": "https://packagist.org/downloads/",
1782 "license": [
1783 "BSD-3-Clause"
1784 ],
1785 "authors": [
1786 {
1787 "name": "Vance Lucas",
1788 "email": "[email protected]",
1789 "homepage": "https://www.vancelucas.com"
1790 }
1791 ],
1792 "description": "Simple, elegant, stand-alone validation library with NO dependencies",
1793 "homepage": "https://github.com/vlucas/valitron",
1794 "keywords": [
1795 "valid",
1796 "validation",
1797 "validator"
1798 ],
1799 "support": {
1800 "issues": "https://github.com/vlucas/valitron/issues",
1801 "source": "https://github.com/vlucas/valitron/tree/v1.4.11"
1802 },
1803 "funding": [
1804 {
1805 "url": "https://tidelift.com/funding/github/packagist/vlucas/valitron",
1806 "type": "tidelift"
1807 }
1808 ],
1809 "install-path": "../vlucas/valitron"
1810 },
1811 {
1812 "name": "web-auth/cose-lib",
1813 "version": "v3.3.12",
1814 "version_normalized": "3.3.12.0",
1815 "source": {
1816 "type": "git",
1817 "url": "https://github.com/web-auth/cose-lib.git",
1818 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb"
1819 },
1820 "dist": {
1821 "type": "zip",
1822 "url": "https://api.github.com/repos/web-auth/cose-lib/zipball/efa6ec2ba4e840bc1316a493973c9916028afeeb",
1823 "reference": "efa6ec2ba4e840bc1316a493973c9916028afeeb",
1824 "shasum": ""
1825 },
1826 "require": {
1827 "beberlei/assert": "^3.2",
1828 "ext-json": "*",
1829 "ext-mbstring": "*",
1830 "ext-openssl": "*",
1831 "fgrosse/phpasn1": "^2.1",
1832 "php": ">=7.2"
1833 },
1834 "time": "2021-12-04T12:13:35+00:00",
1835 "type": "library",
1836 "installation-source": "dist",
1837 "autoload": {
1838 "psr-4": {
1839 "Cose\\": "src/"
1840 }
1841 },
1842 "notification-url": "https://packagist.org/downloads/",
1843 "license": [
1844 "MIT"
1845 ],
1846 "authors": [
1847 {
1848 "name": "Florent Morselli",
1849 "homepage": "https://github.com/Spomky"
1850 },
1851 {
1852 "name": "All contributors",
1853 "homepage": "https://github.com/web-auth/cose/contributors"
1854 }
1855 ],
1856 "description": "CBOR Object Signing and Encryption (COSE) For PHP",
1857 "homepage": "https://github.com/web-auth",
1858 "keywords": [
1859 "COSE",
1860 "RFC8152"
1861 ],
1862 "support": {
1863 "source": "https://github.com/web-auth/cose-lib/tree/v3.3.12"
1864 },
1865 "funding": [
1866 {
1867 "url": "https://github.com/Spomky",
1868 "type": "github"
1869 },
1870 {
1871 "url": "https://www.patreon.com/FlorentMorselli",
1872 "type": "patreon"
1873 }
1874 ],
1875 "install-path": "../web-auth/cose-lib"
1876 },
1877 {
1878 "name": "web-auth/metadata-service",
1879 "version": "v3.3.12",
1880 "version_normalized": "3.3.12.0",
1881 "source": {
1882 "type": "git",
1883 "url": "https://github.com/web-auth/webauthn-metadata-service.git",
1884 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246"
1885 },
1886 "dist": {
1887 "type": "zip",
1888 "url": "https://api.github.com/repos/web-auth/webauthn-metadata-service/zipball/ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1889 "reference": "ef40d2b7b68c4964247d13fab52e2fa8dbd65246",
1890 "shasum": ""
1891 },
1892 "require": {
1893 "beberlei/assert": "^3.2",
1894 "ext-json": "*",
1895 "league/uri": "^6.0",
1896 "php": ">=7.2",
1897 "psr/http-client": "^1.0",
1898 "psr/http-factory": "^1.0",
1899 "psr/log": "^1.1"
1900 },
1901 "suggest": {
1902 "web-token/jwt-key-mgmt": "Mandatory for fetching Metadata Statement from distant sources",
1903 "web-token/jwt-signature-algorithm-ecdsa": "Mandatory for fetching Metadata Statement from distant sources"
1904 },
1905 "time": "2021-11-21T11:14:31+00:00",
1906 "type": "library",
1907 "installation-source": "dist",
1908 "autoload": {
1909 "psr-4": {
1910 "Webauthn\\MetadataService\\": "src/"
1911 }
1912 },
1913 "notification-url": "https://packagist.org/downloads/",
1914 "license": [
1915 "MIT"
1916 ],
1917 "authors": [
1918 {
1919 "name": "Florent Morselli",
1920 "homepage": "https://github.com/Spomky"
1921 },
1922 {
1923 "name": "All contributors",
1924 "homepage": "https://github.com/web-auth/metadata-service/contributors"
1925 }
1926 ],
1927 "description": "Metadata Service for FIDO2/Webauthn",
1928 "homepage": "https://github.com/web-auth",
1929 "keywords": [
1930 "FIDO2",
1931 "fido",
1932 "webauthn"
1933 ],
1934 "support": {
1935 "source": "https://github.com/web-auth/webauthn-metadata-service/tree/v3.3.12"
1936 },
1937 "funding": [
1938 {
1939 "url": "https://github.com/Spomky",
1940 "type": "github"
1941 },
1942 {
1943 "url": "https://www.patreon.com/FlorentMorselli",
1944 "type": "patreon"
1945 }
1946 ],
1947 "abandoned": "web-auth/webauthn-lib",
1948 "install-path": "../web-auth/metadata-service"
1949 },
1950 {
1951 "name": "web-auth/webauthn-lib",
1952 "version": "v3.3.12",
1953 "version_normalized": "3.3.12.0",
1954 "source": {
1955 "type": "git",
1956 "url": "https://github.com/web-auth/webauthn-lib.git",
1957 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33"
1958 },
1959 "dist": {
1960 "type": "zip",
1961 "url": "https://api.github.com/repos/web-auth/webauthn-lib/zipball/5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
1962 "reference": "5ef9b21c8e9f8a817e524ac93290d08a9f065b33",
1963 "shasum": ""
1964 },
1965 "require": {
1966 "beberlei/assert": "^3.2",
1967 "ext-json": "*",
1968 "ext-mbstring": "*",
1969 "ext-openssl": "*",
1970 "fgrosse/phpasn1": "^2.1",
1971 "php": ">=7.2",
1972 "psr/http-client": "^1.0",
1973 "psr/http-factory": "^1.0",
1974 "psr/http-message": "^1.0",
1975 "psr/log": "^1.1",
1976 "ramsey/uuid": "^3.8|^4.0",
1977 "spomky-labs/base64url": "^2.0",
1978 "spomky-labs/cbor-php": "^1.0|^2.0",
1979 "symfony/process": "^3.0|^4.0|^5.0",
1980 "thecodingmachine/safe": "^1.1",
1981 "web-auth/cose-lib": "self.version",
1982 "web-auth/metadata-service": "self.version"
1983 },
1984 "suggest": {
1985 "psr/log-implementation": "Recommended to receive logs from the library",
1986 "web-token/jwt-key-mgmt": "Mandatory for the AndroidSafetyNet Attestation Statement support",
1987 "web-token/jwt-signature-algorithm-ecdsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
1988 "web-token/jwt-signature-algorithm-eddsa": "Recommended for the AndroidSafetyNet Attestation Statement support",
1989 "web-token/jwt-signature-algorithm-rsa": "Mandatory for the AndroidSafetyNet Attestation Statement support"
1990 },
1991 "time": "2022-02-18T07:13:44+00:00",
1992 "type": "library",
1993 "installation-source": "dist",
1994 "autoload": {
1995 "psr-4": {
1996 "Webauthn\\": "src/"
1997 }
1998 },
1999 "notification-url": "https://packagist.org/downloads/",
2000 "license": [
2001 "MIT"
2002 ],
2003 "authors": [
2004 {
2005 "name": "Florent Morselli",
2006 "homepage": "https://github.com/Spomky"
2007 },
2008 {
2009 "name": "All contributors",
2010 "homepage": "https://github.com/web-auth/webauthn-library/contributors"
2011 }
2012 ],
2013 "description": "FIDO2/Webauthn Support For PHP",
2014 "homepage": "https://github.com/web-auth",
2015 "keywords": [
2016 "FIDO2",
2017 "fido",
2018 "webauthn"
2019 ],
2020 "support": {
2021 "source": "https://github.com/web-auth/webauthn-lib/tree/v3.3.12"
2022 },
2023 "funding": [
2024 {
2025 "url": "https://github.com/Spomky",
2026 "type": "github"
2027 },
2028 {
2029 "url": "https://www.patreon.com/FlorentMorselli",
2030 "type": "patreon"
2031 }
2032 ],
2033 "install-path": "../web-auth/webauthn-lib"
2034 },
2035 {
2036 "name": "web-token/jwt-core",
2037 "version": "v2.2.11",
2038 "version_normalized": "2.2.11.0",
2039 "source": {
2040 "type": "git",
2041 "url": "https://github.com/web-token/jwt-core.git",
2042 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678"
2043 },
2044 "dist": {
2045 "type": "zip",
2046 "url": "https://api.github.com/repos/web-token/jwt-core/zipball/53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
2047 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
2048 "shasum": ""
2049 },
2050 "require": {
2051 "brick/math": "^0.8.17|^0.9",
2052 "ext-json": "*",
2053 "ext-mbstring": "*",
2054 "fgrosse/phpasn1": "^2.0",
2055 "php": ">=7.2",
2056 "spomky-labs/base64url": "^1.0|^2.0"
2057 },
2058 "conflict": {
2059 "spomky-labs/jose": "*"
2060 },
2061 "time": "2021-03-17T14:55:52+00:00",
2062 "type": "library",
2063 "installation-source": "dist",
2064 "autoload": {
2065 "psr-4": {
2066 "Jose\\Component\\Core\\": ""
2067 }
2068 },
2069 "notification-url": "https://packagist.org/downloads/",
2070 "license": [
2071 "MIT"
2072 ],
2073 "authors": [
2074 {
2075 "name": "Florent Morselli",
2076 "homepage": "https://github.com/Spomky"
2077 },
2078 {
2079 "name": "All contributors",
2080 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2081 }
2082 ],
2083 "description": "Core component of the JWT Framework.",
2084 "homepage": "https://github.com/web-token",
2085 "keywords": [
2086 "JOSE",
2087 "JWE",
2088 "JWK",
2089 "JWKSet",
2090 "JWS",
2091 "Jot",
2092 "RFC7515",
2093 "RFC7516",
2094 "RFC7517",
2095 "RFC7518",
2096 "RFC7519",
2097 "RFC7520",
2098 "bundle",
2099 "jwa",
2100 "jwt",
2101 "symfony"
2102 ],
2103 "support": {
2104 "source": "https://github.com/web-token/jwt-core/tree/v2.2.11"
2105 },
2106 "funding": [
2107 {
2108 "url": "https://www.patreon.com/FlorentMorselli",
2109 "type": "patreon"
2110 }
2111 ],
2112 "abandoned": "web-token/jwt-library",
2113 "install-path": "../web-token/jwt-core"
2114 },
2115 {
2116 "name": "web-token/jwt-key-mgmt",
2117 "version": "v2.2.11",
2118 "version_normalized": "2.2.11.0",
2119 "source": {
2120 "type": "git",
2121 "url": "https://github.com/web-token/jwt-key-mgmt.git",
2122 "reference": "0b116379515700d237b4e5de86879078ccb09d8a"
2123 },
2124 "dist": {
2125 "type": "zip",
2126 "url": "https://api.github.com/repos/web-token/jwt-key-mgmt/zipball/0b116379515700d237b4e5de86879078ccb09d8a",
2127 "reference": "0b116379515700d237b4e5de86879078ccb09d8a",
2128 "shasum": ""
2129 },
2130 "require": {
2131 "ext-openssl": "*",
2132 "psr/http-client": "^1.0",
2133 "psr/http-factory": "^1.0",
2134 "web-token/jwt-core": "^2.0"
2135 },
2136 "suggest": {
2137 "ext-sodium": "Sodium is required for OKP key creation, EdDSA signature algorithm and ECDH-ES key encryption with OKP keys",
2138 "php-http/httplug": "To enable JKU/X5U support.",
2139 "php-http/message-factory": "To enable JKU/X5U support.",
2140 "web-token/jwt-util-ecc": "To use EC key analyzers."
2141 },
2142 "time": "2021-03-17T14:55:52+00:00",
2143 "type": "library",
2144 "installation-source": "dist",
2145 "autoload": {
2146 "psr-4": {
2147 "Jose\\Component\\KeyManagement\\": ""
2148 }
2149 },
2150 "notification-url": "https://packagist.org/downloads/",
2151 "license": [
2152 "MIT"
2153 ],
2154 "authors": [
2155 {
2156 "name": "Florent Morselli",
2157 "homepage": "https://github.com/Spomky"
2158 },
2159 {
2160 "name": "All contributors",
2161 "homepage": "https://github.com/web-token/jwt-key-mgmt/contributors"
2162 }
2163 ],
2164 "description": "Key Management component of the JWT Framework.",
2165 "homepage": "https://github.com/web-token",
2166 "keywords": [
2167 "JOSE",
2168 "JWE",
2169 "JWK",
2170 "JWKSet",
2171 "JWS",
2172 "Jot",
2173 "RFC7515",
2174 "RFC7516",
2175 "RFC7517",
2176 "RFC7518",
2177 "RFC7519",
2178 "RFC7520",
2179 "bundle",
2180 "jwa",
2181 "jwt",
2182 "symfony"
2183 ],
2184 "support": {
2185 "source": "https://github.com/web-token/jwt-key-mgmt/tree/v2.2.11"
2186 },
2187 "funding": [
2188 {
2189 "url": "https://www.patreon.com/FlorentMorselli",
2190 "type": "patreon"
2191 }
2192 ],
2193 "abandoned": "web-token/jwt-library",
2194 "install-path": "../web-token/jwt-key-mgmt"
2195 },
2196 {
2197 "name": "web-token/jwt-signature",
2198 "version": "v2.2.11",
2199 "version_normalized": "2.2.11.0",
2200 "source": {
2201 "type": "git",
2202 "url": "https://github.com/web-token/jwt-signature.git",
2203 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103"
2204 },
2205 "dist": {
2206 "type": "zip",
2207 "url": "https://api.github.com/repos/web-token/jwt-signature/zipball/015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2208 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
2209 "shasum": ""
2210 },
2211 "require": {
2212 "web-token/jwt-core": "^2.1"
2213 },
2214 "suggest": {
2215 "web-token/jwt-signature-algorithm-ecdsa": "ECDSA Based Signature Algorithms",
2216 "web-token/jwt-signature-algorithm-eddsa": "EdDSA Based Signature Algorithms",
2217 "web-token/jwt-signature-algorithm-experimental": "Experimental Signature Algorithms",
2218 "web-token/jwt-signature-algorithm-hmac": "HMAC Based Signature Algorithms",
2219 "web-token/jwt-signature-algorithm-none": "None Signature Algorithm",
2220 "web-token/jwt-signature-algorithm-rsa": "RSA Based Signature Algorithms"
2221 },
2222 "time": "2021-03-01T19:55:28+00:00",
2223 "type": "library",
2224 "installation-source": "dist",
2225 "autoload": {
2226 "psr-4": {
2227 "Jose\\Component\\Signature\\": ""
2228 }
2229 },
2230 "notification-url": "https://packagist.org/downloads/",
2231 "license": [
2232 "MIT"
2233 ],
2234 "authors": [
2235 {
2236 "name": "Florent Morselli",
2237 "homepage": "https://github.com/Spomky"
2238 },
2239 {
2240 "name": "All contributors",
2241 "homepage": "https://github.com/web-token/jwt-signature/contributors"
2242 }
2243 ],
2244 "description": "Signature component of the JWT Framework.",
2245 "homepage": "https://github.com/web-token",
2246 "keywords": [
2247 "JOSE",
2248 "JWE",
2249 "JWK",
2250 "JWKSet",
2251 "JWS",
2252 "Jot",
2253 "RFC7515",
2254 "RFC7516",
2255 "RFC7517",
2256 "RFC7518",
2257 "RFC7519",
2258 "RFC7520",
2259 "bundle",
2260 "jwa",
2261 "jwt",
2262 "symfony"
2263 ],
2264 "support": {
2265 "source": "https://github.com/web-token/jwt-signature/tree/v2.2.11"
2266 },
2267 "funding": [
2268 {
2269 "url": "https://www.patreon.com/FlorentMorselli",
2270 "type": "patreon"
2271 }
2272 ],
2273 "abandoned": "web-token/jwt-library",
2274 "install-path": "../web-token/jwt-signature"
2275 },
2276 {
2277 "name": "web-token/jwt-signature-algorithm-ecdsa",
2278 "version": "v2.2.11",
2279 "version_normalized": "2.2.11.0",
2280 "source": {
2281 "type": "git",
2282 "url": "https://github.com/web-token/jwt-signature-algorithm-ecdsa.git",
2283 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591"
2284 },
2285 "dist": {
2286 "type": "zip",
2287 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-ecdsa/zipball/44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2288 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
2289 "shasum": ""
2290 },
2291 "require": {
2292 "ext-openssl": "*",
2293 "web-token/jwt-signature": "^2.0"
2294 },
2295 "time": "2021-01-21T19:18:03+00:00",
2296 "type": "library",
2297 "installation-source": "dist",
2298 "autoload": {
2299 "psr-4": {
2300 "Jose\\Component\\Signature\\Algorithm\\": ""
2301 }
2302 },
2303 "notification-url": "https://packagist.org/downloads/",
2304 "license": [
2305 "MIT"
2306 ],
2307 "authors": [
2308 {
2309 "name": "Florent Morselli",
2310 "homepage": "https://github.com/Spomky"
2311 },
2312 {
2313 "name": "All contributors",
2314 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2315 }
2316 ],
2317 "description": "ECDSA Based Signature Algorithms the JWT Framework.",
2318 "homepage": "https://github.com/web-token",
2319 "keywords": [
2320 "JOSE",
2321 "JWE",
2322 "JWK",
2323 "JWKSet",
2324 "JWS",
2325 "Jot",
2326 "RFC7515",
2327 "RFC7516",
2328 "RFC7517",
2329 "RFC7518",
2330 "RFC7519",
2331 "RFC7520",
2332 "bundle",
2333 "jwa",
2334 "jwt",
2335 "symfony"
2336 ],
2337 "support": {
2338 "source": "https://github.com/web-token/jwt-signature-algorithm-ecdsa/tree/v2.2.11"
2339 },
2340 "funding": [
2341 {
2342 "url": "https://www.patreon.com/FlorentMorselli",
2343 "type": "patreon"
2344 }
2345 ],
2346 "abandoned": "web-token/jwt-library",
2347 "install-path": "../web-token/jwt-signature-algorithm-ecdsa"
2348 },
2349 {
2350 "name": "web-token/jwt-signature-algorithm-eddsa",
2351 "version": "v2.2.11",
2352 "version_normalized": "2.2.11.0",
2353 "source": {
2354 "type": "git",
2355 "url": "https://github.com/web-token/jwt-signature-algorithm-eddsa.git",
2356 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6"
2357 },
2358 "dist": {
2359 "type": "zip",
2360 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-eddsa/zipball/b805ecca593c56e60e0463bd2cacc9b1341910f6",
2361 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6",
2362 "shasum": ""
2363 },
2364 "require": {
2365 "ext-sodium": "*",
2366 "web-token/jwt-signature": "^2.1"
2367 },
2368 "time": "2021-01-21T19:18:03+00:00",
2369 "type": "library",
2370 "installation-source": "dist",
2371 "autoload": {
2372 "psr-4": {
2373 "Jose\\Component\\Signature\\Algorithm\\": ""
2374 }
2375 },
2376 "notification-url": "https://packagist.org/downloads/",
2377 "license": [
2378 "MIT"
2379 ],
2380 "authors": [
2381 {
2382 "name": "Florent Morselli",
2383 "homepage": "https://github.com/Spomky"
2384 },
2385 {
2386 "name": "All contributors",
2387 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2388 }
2389 ],
2390 "description": "EdDSA Signature Algorithm the JWT Framework.",
2391 "homepage": "https://github.com/web-token",
2392 "keywords": [
2393 "JOSE",
2394 "JWE",
2395 "JWK",
2396 "JWKSet",
2397 "JWS",
2398 "Jot",
2399 "RFC7515",
2400 "RFC7516",
2401 "RFC7517",
2402 "RFC7518",
2403 "RFC7519",
2404 "RFC7520",
2405 "bundle",
2406 "jwa",
2407 "jwt",
2408 "symfony"
2409 ],
2410 "support": {
2411 "source": "https://github.com/web-token/jwt-signature-algorithm-eddsa/tree/v2.2.11"
2412 },
2413 "funding": [
2414 {
2415 "url": "https://www.patreon.com/FlorentMorselli",
2416 "type": "patreon"
2417 }
2418 ],
2419 "abandoned": "web-token/jwt-library",
2420 "install-path": "../web-token/jwt-signature-algorithm-eddsa"
2421 },
2422 {
2423 "name": "web-token/jwt-signature-algorithm-rsa",
2424 "version": "v2.2.11",
2425 "version_normalized": "2.2.11.0",
2426 "source": {
2427 "type": "git",
2428 "url": "https://github.com/web-token/jwt-signature-algorithm-rsa.git",
2429 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0"
2430 },
2431 "dist": {
2432 "type": "zip",
2433 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-rsa/zipball/513ad90eb5ef1886ff176727a769bda4618141b0",
2434 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0",
2435 "shasum": ""
2436 },
2437 "require": {
2438 "brick/math": "^0.8.17|^0.9",
2439 "ext-openssl": "*",
2440 "web-token/jwt-signature": "^2.1"
2441 },
2442 "suggest": {
2443 "ext-bcmath": "GMP or BCMath is highly recommended to improve the library performance",
2444 "ext-gmp": "GMP or BCMath is highly recommended to improve the library performance"
2445 },
2446 "time": "2021-01-21T19:18:03+00:00",
2447 "type": "library",
2448 "installation-source": "dist",
2449 "autoload": {
2450 "psr-4": {
2451 "Jose\\Component\\Signature\\Algorithm\\": ""
2452 }
2453 },
2454 "notification-url": "https://packagist.org/downloads/",
2455 "license": [
2456 "MIT"
2457 ],
2458 "authors": [
2459 {
2460 "name": "Florent Morselli",
2461 "homepage": "https://github.com/Spomky"
2462 },
2463 {
2464 "name": "All contributors",
2465 "homepage": "https://github.com/web-token/jwt-framework/contributors"
2466 }
2467 ],
2468 "description": "RSA Based Signature Algorithms the JWT Framework.",
2469 "homepage": "https://github.com/web-token",
2470 "keywords": [
2471 "JOSE",
2472 "JWE",
2473 "JWK",
2474 "JWKSet",
2475 "JWS",
2476 "Jot",
2477 "RFC7515",
2478 "RFC7516",
2479 "RFC7517",
2480 "RFC7518",
2481 "RFC7519",
2482 "RFC7520",
2483 "bundle",
2484 "jwa",
2485 "jwt",
2486 "symfony"
2487 ],
2488 "support": {
2489 "source": "https://github.com/web-token/jwt-signature-algorithm-rsa/tree/v2.2.11"
2490 },
2491 "funding": [
2492 {
2493 "url": "https://www.patreon.com/FlorentMorselli",
2494 "type": "patreon"
2495 }
2496 ],
2497 "abandoned": "web-token/jwt-library",
2498 "install-path": "../web-token/jwt-signature-algorithm-rsa"
2499 },
2500 {
2501 "name": "woocommerce/action-scheduler",
2502 "version": "3.9.2",
2503 "version_normalized": "3.9.2.0",
2504 "source": {
2505 "type": "git",
2506 "url": "https://github.com/woocommerce/action-scheduler.git",
2507 "reference": "efbb7953f72a433086335b249292f280dd43ddfe"
2508 },
2509 "dist": {
2510 "type": "zip",
2511 "url": "https://api.github.com/repos/woocommerce/action-scheduler/zipball/efbb7953f72a433086335b249292f280dd43ddfe",
2512 "reference": "efbb7953f72a433086335b249292f280dd43ddfe",
2513 "shasum": ""
2514 },
2515 "require": {
2516 "php": ">=7.1"
2517 },
2518 "require-dev": {
2519 "phpunit/phpunit": "^7.5",
2520 "woocommerce/woocommerce-sniffs": "0.1.0",
2521 "wp-cli/wp-cli": "~2.5.0",
2522 "yoast/phpunit-polyfills": "^2.0"
2523 },
2524 "time": "2025-02-03T09:09:30+00:00",
2525 "type": "wordpress-plugin",
2526 "extra": {
2527 "scripts-description": {
2528 "test": "Run unit tests",
2529 "phpcs": "Analyze code against the WordPress coding standards with PHP_CodeSniffer",
2530 "phpcbf": "Fix coding standards warnings/errors automatically with PHP Code Beautifier"
2531 }
2532 },
2533 "installation-source": "dist",
2534 "notification-url": "https://packagist.org/downloads/",
2535 "license": [
2536 "GPL-3.0-or-later"
2537 ],
2538 "description": "Action Scheduler for WordPress and WooCommerce",
2539 "homepage": "https://actionscheduler.org/",
2540 "support": {
2541 "issues": "https://github.com/woocommerce/action-scheduler/issues",
2542 "source": "https://github.com/woocommerce/action-scheduler/tree/3.9.2"
2543 },
2544 "install-path": "../woocommerce/action-scheduler"
2545 }
2546 ],
2547 "dev": false,
2548 "dev-package-names": []
2549 }
2550