PluginProbe
Defender Security – Malware Scanner, Login Security & Firewall / 6.3.0
Defender Security – Malware Scanner, Login Security & Firewall v6.3.0
6.3.0 6.2.3 6.2.4 6.2.0 6.2.1 6.2.2 6.1.0 5.3.1 5.4.0 5.4.1 5.5.0 5.5.1 5.6.0 5.6.1 5.6.2 5.7.0 5.7.1 5.7.2 5.8.0 5.8.1 5.9.0 6.0.0 6.0.1 3.0.1 3.1.0 All 141 releases
defender-security / vendor / composer / installed.json

installed.json in Defender Security – Malware Scanner, Login Security & Firewall 6.3.0, at vendor/composer/installed.json

1,114 lines 39.5 KB
No matching file
Up and down to move Enter to open Esc to close
Raw Download Zip
1 {
2 "packages": [
3 {
4 "name": "brick/math",
5 "version": "0.9.3",
6 "version_normalized": "0.9.3.0",
7 "source": {
8 "type": "git",
9 "url": "https://github.com/brick/math.git",
10 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae"
11 },
12 "dist": {
13 "type": "zip",
14 "url": "https://api.github.com/repos/brick/math/zipball/ca57d18f028f84f777b2168cd1911b0dee2343ae",
15 "reference": "ca57d18f028f84f777b2168cd1911b0dee2343ae",
16 "shasum": ""
17 },
18 "require": {
19 "ext-json": "*",
20 "php": "^7.1 || ^8.0"
21 },
22 "require-dev": {
23 "php-coveralls/php-coveralls": "^2.2",
24 "phpunit/phpunit": "^7.5.15 || ^8.5 || ^9.0",
25 "vimeo/psalm": "4.9.2"
26 },
27 "time": "2021-08-15T20:50:18+00:00",
28 "type": "library",
29 "installation-source": "dist",
30 "autoload": {
31 "psr-4": {
32 "Brick\\Math\\": "src/"
33 }
34 },
35 "notification-url": "https://packagist.org/downloads/",
36 "license": [
37 "MIT"
38 ],
39 "description": "Arbitrary-precision arithmetic library",
40 "keywords": [
41 "Arbitrary-precision",
42 "BigInteger",
43 "BigRational",
44 "arithmetic",
45 "bigdecimal",
46 "bignum",
47 "brick",
48 "math"
49 ],
50 "support": {
51 "issues": "https://github.com/brick/math/issues",
52 "source": "https://github.com/brick/math/tree/0.9.3"
53 },
54 "funding": [
55 {
56 "url": "https://github.com/BenMorel",
57 "type": "github"
58 },
59 {
60 "url": "https://tidelift.com/funding/github/packagist/brick/math",
61 "type": "tidelift"
62 }
63 ],
64 "install-path": "../brick/math"
65 },
66 {
67 "name": "fgrosse/phpasn1",
68 "version": "v2.5.0",
69 "version_normalized": "2.5.0.0",
70 "source": {
71 "type": "git",
72 "url": "https://github.com/fgrosse/PHPASN1.git",
73 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b"
74 },
75 "dist": {
76 "type": "zip",
77 "url": "https://api.github.com/repos/fgrosse/PHPASN1/zipball/42060ed45344789fb9f21f9f1864fc47b9e3507b",
78 "reference": "42060ed45344789fb9f21f9f1864fc47b9e3507b",
79 "shasum": ""
80 },
81 "require": {
82 "php": "^7.1 || ^8.0"
83 },
84 "require-dev": {
85 "php-coveralls/php-coveralls": "~2.0",
86 "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0"
87 },
88 "suggest": {
89 "ext-bcmath": "BCmath is the fallback extension for big integer calculations",
90 "ext-curl": "For loading OID information from the web if they have not bee defined statically",
91 "ext-gmp": "GMP is the preferred extension for big integer calculations",
92 "phpseclib/bcmath_compat": "BCmath polyfill for servers where neither GMP nor BCmath is available"
93 },
94 "time": "2022-12-19T11:08:26+00:00",
95 "type": "library",
96 "extra": {
97 "branch-alias": {
98 "dev-master": "2.0.x-dev"
99 }
100 },
101 "installation-source": "dist",
102 "autoload": {
103 "psr-4": {
104 "FG\\": "lib/"
105 }
106 },
107 "notification-url": "https://packagist.org/downloads/",
108 "license": [
109 "MIT"
110 ],
111 "authors": [
112 {
113 "name": "Friedrich Große",
114 "email": "[email protected]",
115 "homepage": "https://github.com/FGrosse",
116 "role": "Author"
117 },
118 {
119 "name": "All contributors",
120 "homepage": "https://github.com/FGrosse/PHPASN1/contributors"
121 }
122 ],
123 "description": "A PHP Framework that allows you to encode and decode arbitrary ASN.1 structures using the ITU-T X.690 Encoding Rules.",
124 "homepage": "https://github.com/FGrosse/PHPASN1",
125 "keywords": [
126 "DER",
127 "asn.1",
128 "asn1",
129 "ber",
130 "binary",
131 "decoding",
132 "encoding",
133 "x.509",
134 "x.690",
135 "x509",
136 "x690"
137 ],
138 "support": {
139 "issues": "https://github.com/fgrosse/PHPASN1/issues",
140 "source": "https://github.com/fgrosse/PHPASN1/tree/v2.5.0"
141 },
142 "abandoned": true,
143 "install-path": "../fgrosse/phpasn1"
144 },
145 {
146 "name": "gettext/gettext",
147 "version": "v5.7.3",
148 "version_normalized": "5.7.3.0",
149 "source": {
150 "type": "git",
151 "url": "https://github.com/php-gettext/Gettext.git",
152 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1"
153 },
154 "dist": {
155 "type": "zip",
156 "url": "https://api.github.com/repos/php-gettext/Gettext/zipball/95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
157 "reference": "95820f020e4f2f05e0bbaa5603e4c6ec3edc50f1",
158 "shasum": ""
159 },
160 "require": {
161 "gettext/languages": "^2.3",
162 "php": "^7.2|^8.0"
163 },
164 "require-dev": {
165 "brick/varexporter": "^0.3.5",
166 "friendsofphp/php-cs-fixer": "^3.2",
167 "oscarotero/php-cs-fixer-config": "^2.0",
168 "phpunit/phpunit": "^8.0|^9.0",
169 "squizlabs/php_codesniffer": "^3.0"
170 },
171 "time": "2024-12-01T10:18:08+00:00",
172 "type": "library",
173 "installation-source": "dist",
174 "autoload": {
175 "psr-4": {
176 "Gettext\\": "src"
177 }
178 },
179 "notification-url": "https://packagist.org/downloads/",
180 "license": [
181 "MIT"
182 ],
183 "authors": [
184 {
185 "name": "Oscar Otero",
186 "email": "[email protected]",
187 "homepage": "http://oscarotero.com",
188 "role": "Developer"
189 }
190 ],
191 "description": "PHP gettext manager",
192 "homepage": "https://github.com/php-gettext/Gettext",
193 "keywords": [
194 "JS",
195 "gettext",
196 "i18n",
197 "mo",
198 "po",
199 "translation"
200 ],
201 "support": {
202 "email": "[email protected]",
203 "issues": "https://github.com/php-gettext/Gettext/issues",
204 "source": "https://github.com/php-gettext/Gettext/tree/v5.7.3"
205 },
206 "funding": [
207 {
208 "url": "https://paypal.me/oscarotero",
209 "type": "custom"
210 },
211 {
212 "url": "https://github.com/oscarotero",
213 "type": "github"
214 },
215 {
216 "url": "https://www.patreon.com/misteroom",
217 "type": "patreon"
218 }
219 ],
220 "install-path": "../gettext/gettext"
221 },
222 {
223 "name": "gettext/languages",
224 "version": "2.12.2",
225 "version_normalized": "2.12.2.0",
226 "source": {
227 "type": "git",
228 "url": "https://github.com/php-gettext/Languages.git",
229 "reference": "079d6f4842cbcbf5673a70d8e93169a684e7aadd"
230 },
231 "dist": {
232 "type": "zip",
233 "url": "https://api.github.com/repos/php-gettext/Languages/zipball/079d6f4842cbcbf5673a70d8e93169a684e7aadd",
234 "reference": "079d6f4842cbcbf5673a70d8e93169a684e7aadd",
235 "shasum": ""
236 },
237 "require": {
238 "php": ">=5.3"
239 },
240 "require-dev": {
241 "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.5 || ^8.4"
242 },
243 "time": "2026-02-23T14:05:50+00:00",
244 "bin": [
245 "bin/export-plural-rules",
246 "bin/import-cldr-data"
247 ],
248 "type": "library",
249 "installation-source": "dist",
250 "autoload": {
251 "psr-4": {
252 "Gettext\\Languages\\": "src/"
253 }
254 },
255 "notification-url": "https://packagist.org/downloads/",
256 "license": [
257 "MIT"
258 ],
259 "authors": [
260 {
261 "name": "Michele Locati",
262 "email": "[email protected]",
263 "role": "Developer"
264 }
265 ],
266 "description": "gettext languages with plural rules",
267 "homepage": "https://github.com/php-gettext/Languages",
268 "keywords": [
269 "cldr",
270 "i18n",
271 "internationalization",
272 "l10n",
273 "language",
274 "languages",
275 "localization",
276 "php",
277 "plural",
278 "plural rules",
279 "plurals",
280 "translate",
281 "translations",
282 "unicode"
283 ],
284 "support": {
285 "issues": "https://github.com/php-gettext/Languages/issues",
286 "source": "https://github.com/php-gettext/Languages/tree/2.12.2"
287 },
288 "funding": [
289 {
290 "url": "https://paypal.me/mlocati",
291 "type": "custom"
292 },
293 {
294 "url": "https://github.com/mlocati",
295 "type": "github"
296 }
297 ],
298 "install-path": "../gettext/languages"
299 },
300 {
301 "name": "psr/http-client",
302 "version": "1.0.3",
303 "version_normalized": "1.0.3.0",
304 "source": {
305 "type": "git",
306 "url": "https://github.com/php-fig/http-client.git",
307 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90"
308 },
309 "dist": {
310 "type": "zip",
311 "url": "https://api.github.com/repos/php-fig/http-client/zipball/bb5906edc1c324c9a05aa0873d40117941e5fa90",
312 "reference": "bb5906edc1c324c9a05aa0873d40117941e5fa90",
313 "shasum": ""
314 },
315 "require": {
316 "php": "^7.0 || ^8.0",
317 "psr/http-message": "^1.0 || ^2.0"
318 },
319 "time": "2023-09-23T14:17:50+00:00",
320 "type": "library",
321 "extra": {
322 "branch-alias": {
323 "dev-master": "1.0.x-dev"
324 }
325 },
326 "installation-source": "dist",
327 "autoload": {
328 "psr-4": {
329 "Psr\\Http\\Client\\": "src/"
330 }
331 },
332 "notification-url": "https://packagist.org/downloads/",
333 "license": [
334 "MIT"
335 ],
336 "authors": [
337 {
338 "name": "PHP-FIG",
339 "homepage": "https://www.php-fig.org/"
340 }
341 ],
342 "description": "Common interface for HTTP clients",
343 "homepage": "https://github.com/php-fig/http-client",
344 "keywords": [
345 "http",
346 "http-client",
347 "psr",
348 "psr-18"
349 ],
350 "support": {
351 "source": "https://github.com/php-fig/http-client"
352 },
353 "install-path": "../psr/http-client"
354 },
355 {
356 "name": "psr/http-factory",
357 "version": "1.1.0",
358 "version_normalized": "1.1.0.0",
359 "source": {
360 "type": "git",
361 "url": "https://github.com/php-fig/http-factory.git",
362 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a"
363 },
364 "dist": {
365 "type": "zip",
366 "url": "https://api.github.com/repos/php-fig/http-factory/zipball/2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
367 "reference": "2b4765fddfe3b508ac62f829e852b1501d3f6e8a",
368 "shasum": ""
369 },
370 "require": {
371 "php": ">=7.1",
372 "psr/http-message": "^1.0 || ^2.0"
373 },
374 "time": "2024-04-15T12:06:14+00:00",
375 "type": "library",
376 "extra": {
377 "branch-alias": {
378 "dev-master": "1.0.x-dev"
379 }
380 },
381 "installation-source": "dist",
382 "autoload": {
383 "psr-4": {
384 "Psr\\Http\\Message\\": "src/"
385 }
386 },
387 "notification-url": "https://packagist.org/downloads/",
388 "license": [
389 "MIT"
390 ],
391 "authors": [
392 {
393 "name": "PHP-FIG",
394 "homepage": "https://www.php-fig.org/"
395 }
396 ],
397 "description": "PSR-17: Common interfaces for PSR-7 HTTP message factories",
398 "keywords": [
399 "factory",
400 "http",
401 "message",
402 "psr",
403 "psr-17",
404 "psr-7",
405 "request",
406 "response"
407 ],
408 "support": {
409 "source": "https://github.com/php-fig/http-factory"
410 },
411 "install-path": "../psr/http-factory"
412 },
413 {
414 "name": "psr/http-message",
415 "version": "2.0",
416 "version_normalized": "2.0.0.0",
417 "source": {
418 "type": "git",
419 "url": "https://github.com/php-fig/http-message.git",
420 "reference": "402d35bcb92c70c026d1a6a9883f06b2ead23d71"
421 },
422 "dist": {
423 "type": "zip",
424 "url": "https://api.github.com/repos/php-fig/http-message/zipball/402d35bcb92c70c026d1a6a9883f06b2ead23d71",
425 "reference": "402d35bcb92c70c026d1a6a9883f06b2ead23d71",
426 "shasum": ""
427 },
428 "require": {
429 "php": "^7.2 || ^8.0"
430 },
431 "time": "2023-04-04T09:54:51+00:00",
432 "type": "library",
433 "extra": {
434 "branch-alias": {
435 "dev-master": "2.0.x-dev"
436 }
437 },
438 "installation-source": "dist",
439 "autoload": {
440 "psr-4": {
441 "Psr\\Http\\Message\\": "src/"
442 }
443 },
444 "notification-url": "https://packagist.org/downloads/",
445 "license": [
446 "MIT"
447 ],
448 "authors": [
449 {
450 "name": "PHP-FIG",
451 "homepage": "https://www.php-fig.org/"
452 }
453 ],
454 "description": "Common interface for HTTP messages",
455 "homepage": "https://github.com/php-fig/http-message",
456 "keywords": [
457 "http",
458 "http-message",
459 "psr",
460 "psr-7",
461 "request",
462 "response"
463 ],
464 "support": {
465 "source": "https://github.com/php-fig/http-message/tree/2.0"
466 },
467 "install-path": "../psr/http-message"
468 },
469 {
470 "name": "spomky-labs/base64url",
471 "version": "v2.0.4",
472 "version_normalized": "2.0.4.0",
473 "source": {
474 "type": "git",
475 "url": "https://github.com/Spomky-Labs/base64url.git",
476 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d"
477 },
478 "dist": {
479 "type": "zip",
480 "url": "https://api.github.com/repos/Spomky-Labs/base64url/zipball/7752ce931ec285da4ed1f4c5aa27e45e097be61d",
481 "reference": "7752ce931ec285da4ed1f4c5aa27e45e097be61d",
482 "shasum": ""
483 },
484 "require": {
485 "php": ">=7.1"
486 },
487 "require-dev": {
488 "phpstan/extension-installer": "^1.0",
489 "phpstan/phpstan": "^0.11|^0.12",
490 "phpstan/phpstan-beberlei-assert": "^0.11|^0.12",
491 "phpstan/phpstan-deprecation-rules": "^0.11|^0.12",
492 "phpstan/phpstan-phpunit": "^0.11|^0.12",
493 "phpstan/phpstan-strict-rules": "^0.11|^0.12"
494 },
495 "time": "2020-11-03T09:10:25+00:00",
496 "type": "library",
497 "installation-source": "dist",
498 "autoload": {
499 "psr-4": {
500 "Base64Url\\": "src/"
501 }
502 },
503 "notification-url": "https://packagist.org/downloads/",
504 "license": [
505 "MIT"
506 ],
507 "authors": [
508 {
509 "name": "Florent Morselli",
510 "homepage": "https://github.com/Spomky-Labs/base64url/contributors"
511 }
512 ],
513 "description": "Base 64 URL Safe Encoding/Decoding PHP Library",
514 "homepage": "https://github.com/Spomky-Labs/base64url",
515 "keywords": [
516 "base64",
517 "rfc4648",
518 "safe",
519 "url"
520 ],
521 "support": {
522 "issues": "https://github.com/Spomky-Labs/base64url/issues",
523 "source": "https://github.com/Spomky-Labs/base64url/tree/v2.0.4"
524 },
525 "funding": [
526 {
527 "url": "https://github.com/Spomky",
528 "type": "github"
529 },
530 {
531 "url": "https://www.patreon.com/FlorentMorselli",
532 "type": "patreon"
533 }
534 ],
535 "install-path": "../spomky-labs/base64url"
536 },
537 {
538 "name": "vlucas/valitron",
539 "version": "v1.4.11",
540 "version_normalized": "1.4.11.0",
541 "source": {
542 "type": "git",
543 "url": "https://github.com/vlucas/valitron.git",
544 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f"
545 },
546 "dist": {
547 "type": "zip",
548 "url": "https://api.github.com/repos/vlucas/valitron/zipball/fadce39f5f235755bb9794b2573af2d5bfcba85f",
549 "reference": "fadce39f5f235755bb9794b2573af2d5bfcba85f",
550 "shasum": ""
551 },
552 "require": {
553 "php": ">=5.3.2"
554 },
555 "require-dev": {
556 "phpunit/phpunit": ">=4.8.35"
557 },
558 "suggest": {
559 "ext-mbstring": "It can support the multiple bytes string length."
560 },
561 "time": "2022-10-14T11:54:24+00:00",
562 "type": "library",
563 "installation-source": "dist",
564 "autoload": {
565 "psr-4": {
566 "Valitron\\": "src/Valitron"
567 }
568 },
569 "notification-url": "https://packagist.org/downloads/",
570 "license": [
571 "BSD-3-Clause"
572 ],
573 "authors": [
574 {
575 "name": "Vance Lucas",
576 "email": "[email protected]",
577 "homepage": "https://www.vancelucas.com"
578 }
579 ],
580 "description": "Simple, elegant, stand-alone validation library with NO dependencies",
581 "homepage": "https://github.com/vlucas/valitron",
582 "keywords": [
583 "valid",
584 "validation",
585 "validator"
586 ],
587 "support": {
588 "issues": "https://github.com/vlucas/valitron/issues",
589 "source": "https://github.com/vlucas/valitron/tree/v1.4.11"
590 },
591 "funding": [
592 {
593 "url": "https://tidelift.com/funding/github/packagist/vlucas/valitron",
594 "type": "tidelift"
595 }
596 ],
597 "install-path": "../vlucas/valitron"
598 },
599 {
600 "name": "web-token/jwt-core",
601 "version": "v2.2.11",
602 "version_normalized": "2.2.11.0",
603 "source": {
604 "type": "git",
605 "url": "https://github.com/web-token/jwt-core.git",
606 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678"
607 },
608 "dist": {
609 "type": "zip",
610 "url": "https://api.github.com/repos/web-token/jwt-core/zipball/53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
611 "reference": "53beb6f6c1eec4fa93c1c3e5d9e5701e71fa1678",
612 "shasum": ""
613 },
614 "require": {
615 "brick/math": "^0.8.17|^0.9",
616 "ext-json": "*",
617 "ext-mbstring": "*",
618 "fgrosse/phpasn1": "^2.0",
619 "php": ">=7.2",
620 "spomky-labs/base64url": "^1.0|^2.0"
621 },
622 "conflict": {
623 "spomky-labs/jose": "*"
624 },
625 "time": "2021-03-17T14:55:52+00:00",
626 "type": "library",
627 "installation-source": "dist",
628 "autoload": {
629 "psr-4": {
630 "Jose\\Component\\Core\\": ""
631 }
632 },
633 "notification-url": "https://packagist.org/downloads/",
634 "license": [
635 "MIT"
636 ],
637 "authors": [
638 {
639 "name": "Florent Morselli",
640 "homepage": "https://github.com/Spomky"
641 },
642 {
643 "name": "All contributors",
644 "homepage": "https://github.com/web-token/jwt-framework/contributors"
645 }
646 ],
647 "description": "Core component of the JWT Framework.",
648 "homepage": "https://github.com/web-token",
649 "keywords": [
650 "JOSE",
651 "JWE",
652 "JWK",
653 "JWKSet",
654 "JWS",
655 "Jot",
656 "RFC7515",
657 "RFC7516",
658 "RFC7517",
659 "RFC7518",
660 "RFC7519",
661 "RFC7520",
662 "bundle",
663 "jwa",
664 "jwt",
665 "symfony"
666 ],
667 "support": {
668 "source": "https://github.com/web-token/jwt-core/tree/v2.2.11"
669 },
670 "funding": [
671 {
672 "url": "https://www.patreon.com/FlorentMorselli",
673 "type": "patreon"
674 }
675 ],
676 "abandoned": "web-token/jwt-library",
677 "install-path": "../web-token/jwt-core"
678 },
679 {
680 "name": "web-token/jwt-key-mgmt",
681 "version": "v2.2.11",
682 "version_normalized": "2.2.11.0",
683 "source": {
684 "type": "git",
685 "url": "https://github.com/web-token/jwt-key-mgmt.git",
686 "reference": "0b116379515700d237b4e5de86879078ccb09d8a"
687 },
688 "dist": {
689 "type": "zip",
690 "url": "https://api.github.com/repos/web-token/jwt-key-mgmt/zipball/0b116379515700d237b4e5de86879078ccb09d8a",
691 "reference": "0b116379515700d237b4e5de86879078ccb09d8a",
692 "shasum": ""
693 },
694 "require": {
695 "ext-openssl": "*",
696 "psr/http-client": "^1.0",
697 "psr/http-factory": "^1.0",
698 "web-token/jwt-core": "^2.0"
699 },
700 "suggest": {
701 "ext-sodium": "Sodium is required for OKP key creation, EdDSA signature algorithm and ECDH-ES key encryption with OKP keys",
702 "php-http/httplug": "To enable JKU/X5U support.",
703 "php-http/message-factory": "To enable JKU/X5U support.",
704 "web-token/jwt-util-ecc": "To use EC key analyzers."
705 },
706 "time": "2021-03-17T14:55:52+00:00",
707 "type": "library",
708 "installation-source": "dist",
709 "autoload": {
710 "psr-4": {
711 "Jose\\Component\\KeyManagement\\": ""
712 }
713 },
714 "notification-url": "https://packagist.org/downloads/",
715 "license": [
716 "MIT"
717 ],
718 "authors": [
719 {
720 "name": "Florent Morselli",
721 "homepage": "https://github.com/Spomky"
722 },
723 {
724 "name": "All contributors",
725 "homepage": "https://github.com/web-token/jwt-key-mgmt/contributors"
726 }
727 ],
728 "description": "Key Management component of the JWT Framework.",
729 "homepage": "https://github.com/web-token",
730 "keywords": [
731 "JOSE",
732 "JWE",
733 "JWK",
734 "JWKSet",
735 "JWS",
736 "Jot",
737 "RFC7515",
738 "RFC7516",
739 "RFC7517",
740 "RFC7518",
741 "RFC7519",
742 "RFC7520",
743 "bundle",
744 "jwa",
745 "jwt",
746 "symfony"
747 ],
748 "support": {
749 "source": "https://github.com/web-token/jwt-key-mgmt/tree/v2.2.11"
750 },
751 "funding": [
752 {
753 "url": "https://www.patreon.com/FlorentMorselli",
754 "type": "patreon"
755 }
756 ],
757 "abandoned": "web-token/jwt-library",
758 "install-path": "../web-token/jwt-key-mgmt"
759 },
760 {
761 "name": "web-token/jwt-signature",
762 "version": "v2.2.11",
763 "version_normalized": "2.2.11.0",
764 "source": {
765 "type": "git",
766 "url": "https://github.com/web-token/jwt-signature.git",
767 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103"
768 },
769 "dist": {
770 "type": "zip",
771 "url": "https://api.github.com/repos/web-token/jwt-signature/zipball/015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
772 "reference": "015b59aaf3b6e8fb9f5bd1338845b7464c7d8103",
773 "shasum": ""
774 },
775 "require": {
776 "web-token/jwt-core": "^2.1"
777 },
778 "suggest": {
779 "web-token/jwt-signature-algorithm-ecdsa": "ECDSA Based Signature Algorithms",
780 "web-token/jwt-signature-algorithm-eddsa": "EdDSA Based Signature Algorithms",
781 "web-token/jwt-signature-algorithm-experimental": "Experimental Signature Algorithms",
782 "web-token/jwt-signature-algorithm-hmac": "HMAC Based Signature Algorithms",
783 "web-token/jwt-signature-algorithm-none": "None Signature Algorithm",
784 "web-token/jwt-signature-algorithm-rsa": "RSA Based Signature Algorithms"
785 },
786 "time": "2021-03-01T19:55:28+00:00",
787 "type": "library",
788 "installation-source": "dist",
789 "autoload": {
790 "psr-4": {
791 "Jose\\Component\\Signature\\": ""
792 }
793 },
794 "notification-url": "https://packagist.org/downloads/",
795 "license": [
796 "MIT"
797 ],
798 "authors": [
799 {
800 "name": "Florent Morselli",
801 "homepage": "https://github.com/Spomky"
802 },
803 {
804 "name": "All contributors",
805 "homepage": "https://github.com/web-token/jwt-signature/contributors"
806 }
807 ],
808 "description": "Signature component of the JWT Framework.",
809 "homepage": "https://github.com/web-token",
810 "keywords": [
811 "JOSE",
812 "JWE",
813 "JWK",
814 "JWKSet",
815 "JWS",
816 "Jot",
817 "RFC7515",
818 "RFC7516",
819 "RFC7517",
820 "RFC7518",
821 "RFC7519",
822 "RFC7520",
823 "bundle",
824 "jwa",
825 "jwt",
826 "symfony"
827 ],
828 "support": {
829 "source": "https://github.com/web-token/jwt-signature/tree/v2.2.11"
830 },
831 "funding": [
832 {
833 "url": "https://www.patreon.com/FlorentMorselli",
834 "type": "patreon"
835 }
836 ],
837 "abandoned": "web-token/jwt-library",
838 "install-path": "../web-token/jwt-signature"
839 },
840 {
841 "name": "web-token/jwt-signature-algorithm-ecdsa",
842 "version": "v2.2.11",
843 "version_normalized": "2.2.11.0",
844 "source": {
845 "type": "git",
846 "url": "https://github.com/web-token/jwt-signature-algorithm-ecdsa.git",
847 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591"
848 },
849 "dist": {
850 "type": "zip",
851 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-ecdsa/zipball/44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
852 "reference": "44cbbb4374c51f1cf48b82ae761efbf24e1a8591",
853 "shasum": ""
854 },
855 "require": {
856 "ext-openssl": "*",
857 "web-token/jwt-signature": "^2.0"
858 },
859 "time": "2021-01-21T19:18:03+00:00",
860 "type": "library",
861 "installation-source": "dist",
862 "autoload": {
863 "psr-4": {
864 "Jose\\Component\\Signature\\Algorithm\\": ""
865 }
866 },
867 "notification-url": "https://packagist.org/downloads/",
868 "license": [
869 "MIT"
870 ],
871 "authors": [
872 {
873 "name": "Florent Morselli",
874 "homepage": "https://github.com/Spomky"
875 },
876 {
877 "name": "All contributors",
878 "homepage": "https://github.com/web-token/jwt-framework/contributors"
879 }
880 ],
881 "description": "ECDSA Based Signature Algorithms the JWT Framework.",
882 "homepage": "https://github.com/web-token",
883 "keywords": [
884 "JOSE",
885 "JWE",
886 "JWK",
887 "JWKSet",
888 "JWS",
889 "Jot",
890 "RFC7515",
891 "RFC7516",
892 "RFC7517",
893 "RFC7518",
894 "RFC7519",
895 "RFC7520",
896 "bundle",
897 "jwa",
898 "jwt",
899 "symfony"
900 ],
901 "support": {
902 "source": "https://github.com/web-token/jwt-signature-algorithm-ecdsa/tree/v2.2.11"
903 },
904 "funding": [
905 {
906 "url": "https://www.patreon.com/FlorentMorselli",
907 "type": "patreon"
908 }
909 ],
910 "abandoned": "web-token/jwt-library",
911 "install-path": "../web-token/jwt-signature-algorithm-ecdsa"
912 },
913 {
914 "name": "web-token/jwt-signature-algorithm-eddsa",
915 "version": "v2.2.11",
916 "version_normalized": "2.2.11.0",
917 "source": {
918 "type": "git",
919 "url": "https://github.com/web-token/jwt-signature-algorithm-eddsa.git",
920 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6"
921 },
922 "dist": {
923 "type": "zip",
924 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-eddsa/zipball/b805ecca593c56e60e0463bd2cacc9b1341910f6",
925 "reference": "b805ecca593c56e60e0463bd2cacc9b1341910f6",
926 "shasum": ""
927 },
928 "require": {
929 "ext-sodium": "*",
930 "web-token/jwt-signature": "^2.1"
931 },
932 "time": "2021-01-21T19:18:03+00:00",
933 "type": "library",
934 "installation-source": "dist",
935 "autoload": {
936 "psr-4": {
937 "Jose\\Component\\Signature\\Algorithm\\": ""
938 }
939 },
940 "notification-url": "https://packagist.org/downloads/",
941 "license": [
942 "MIT"
943 ],
944 "authors": [
945 {
946 "name": "Florent Morselli",
947 "homepage": "https://github.com/Spomky"
948 },
949 {
950 "name": "All contributors",
951 "homepage": "https://github.com/web-token/jwt-framework/contributors"
952 }
953 ],
954 "description": "EdDSA Signature Algorithm the JWT Framework.",
955 "homepage": "https://github.com/web-token",
956 "keywords": [
957 "JOSE",
958 "JWE",
959 "JWK",
960 "JWKSet",
961 "JWS",
962 "Jot",
963 "RFC7515",
964 "RFC7516",
965 "RFC7517",
966 "RFC7518",
967 "RFC7519",
968 "RFC7520",
969 "bundle",
970 "jwa",
971 "jwt",
972 "symfony"
973 ],
974 "support": {
975 "source": "https://github.com/web-token/jwt-signature-algorithm-eddsa/tree/v2.2.11"
976 },
977 "funding": [
978 {
979 "url": "https://www.patreon.com/FlorentMorselli",
980 "type": "patreon"
981 }
982 ],
983 "abandoned": "web-token/jwt-library",
984 "install-path": "../web-token/jwt-signature-algorithm-eddsa"
985 },
986 {
987 "name": "web-token/jwt-signature-algorithm-rsa",
988 "version": "v2.2.11",
989 "version_normalized": "2.2.11.0",
990 "source": {
991 "type": "git",
992 "url": "https://github.com/web-token/jwt-signature-algorithm-rsa.git",
993 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0"
994 },
995 "dist": {
996 "type": "zip",
997 "url": "https://api.github.com/repos/web-token/jwt-signature-algorithm-rsa/zipball/513ad90eb5ef1886ff176727a769bda4618141b0",
998 "reference": "513ad90eb5ef1886ff176727a769bda4618141b0",
999 "shasum": ""
1000 },
1001 "require": {
1002 "brick/math": "^0.8.17|^0.9",
1003 "ext-openssl": "*",
1004 "web-token/jwt-signature": "^2.1"
1005 },
1006 "suggest": {
1007 "ext-bcmath": "GMP or BCMath is highly recommended to improve the library performance",
1008 "ext-gmp": "GMP or BCMath is highly recommended to improve the library performance"
1009 },
1010 "time": "2021-01-21T19:18:03+00:00",
1011 "type": "library",
1012 "installation-source": "dist",
1013 "autoload": {
1014 "psr-4": {
1015 "Jose\\Component\\Signature\\Algorithm\\": ""
1016 }
1017 },
1018 "notification-url": "https://packagist.org/downloads/",
1019 "license": [
1020 "MIT"
1021 ],
1022 "authors": [
1023 {
1024 "name": "Florent Morselli",
1025 "homepage": "https://github.com/Spomky"
1026 },
1027 {
1028 "name": "All contributors",
1029 "homepage": "https://github.com/web-token/jwt-framework/contributors"
1030 }
1031 ],
1032 "description": "RSA Based Signature Algorithms the JWT Framework.",
1033 "homepage": "https://github.com/web-token",
1034 "keywords": [
1035 "JOSE",
1036 "JWE",
1037 "JWK",
1038 "JWKSet",
1039 "JWS",
1040 "Jot",
1041 "RFC7515",
1042 "RFC7516",
1043 "RFC7517",
1044 "RFC7518",
1045 "RFC7519",
1046 "RFC7520",
1047 "bundle",
1048 "jwa",
1049 "jwt",
1050 "symfony"
1051 ],
1052 "support": {
1053 "source": "https://github.com/web-token/jwt-signature-algorithm-rsa/tree/v2.2.11"
1054 },
1055 "funding": [
1056 {
1057 "url": "https://www.patreon.com/FlorentMorselli",
1058 "type": "patreon"
1059 }
1060 ],
1061 "abandoned": "web-token/jwt-library",
1062 "install-path": "../web-token/jwt-signature-algorithm-rsa"
1063 },
1064 {
1065 "name": "woocommerce/action-scheduler",
1066 "version": "3.9.2",
1067 "version_normalized": "3.9.2.0",
1068 "source": {
1069 "type": "git",
1070 "url": "https://github.com/woocommerce/action-scheduler.git",
1071 "reference": "efbb7953f72a433086335b249292f280dd43ddfe"
1072 },
1073 "dist": {
1074 "type": "zip",
1075 "url": "https://api.github.com/repos/woocommerce/action-scheduler/zipball/efbb7953f72a433086335b249292f280dd43ddfe",
1076 "reference": "efbb7953f72a433086335b249292f280dd43ddfe",
1077 "shasum": ""
1078 },
1079 "require": {
1080 "php": ">=7.1"
1081 },
1082 "require-dev": {
1083 "phpunit/phpunit": "^7.5",
1084 "woocommerce/woocommerce-sniffs": "0.1.0",
1085 "wp-cli/wp-cli": "~2.5.0",
1086 "yoast/phpunit-polyfills": "^2.0"
1087 },
1088 "time": "2025-02-03T09:09:30+00:00",
1089 "type": "wordpress-plugin",
1090 "extra": {
1091 "scripts-description": {
1092 "test": "Run unit tests",
1093 "phpcs": "Analyze code against the WordPress coding standards with PHP_CodeSniffer",
1094 "phpcbf": "Fix coding standards warnings/errors automatically with PHP Code Beautifier"
1095 }
1096 },
1097 "installation-source": "dist",
1098 "notification-url": "https://packagist.org/downloads/",
1099 "license": [
1100 "GPL-3.0-or-later"
1101 ],
1102 "description": "Action Scheduler for WordPress and WooCommerce",
1103 "homepage": "https://actionscheduler.org/",
1104 "support": {
1105 "issues": "https://github.com/woocommerce/action-scheduler/issues",
1106 "source": "https://github.com/woocommerce/action-scheduler/tree/3.9.2"
1107 },
1108 "install-path": "../woocommerce/action-scheduler"
1109 }
1110 ],
1111 "dev": false,
1112 "dev-package-names": []
1113 }
1114